Web Service Developer Guide

Web Service Developer Guide GBG Web Service Developers Guide
GBG Web Service Developers Guide

This document describes the GBG Web Service interface for performing identity and back ground checks of an individual. The full URL for the WSDL interface can be downloaded here:

https://pilot.id3global.com/ID3gWS/ID3global.svc

Below is a list of the supported countries.

  • Argentina
  • Australia
  • Austria
  • Belgium
  • Brazil
  • Canada
  • Denmark
  • Finland
  • France
  • Germany
  • Greenland
  • Ireland
  • Italy
  • Mexico
  • Netherlands
  • Norway
  • New Zealand
  • Portugal
  • South Africa
  • Singapore
  • Spain
  • Sweden
  • Switzerland
  • United Kingdom
  • United States

GBG Web Service Developers Guide, September 2014 r5.0 ©2014 GB Group plc

Send Feedback on this topic to Send Feedback.


Validation

Validation GBG Web Service Developers Guide
Input Validation
This document describes the regular expressions used for validating input within ID3global.
Name | Regular Expression
Username | ^(\w+([-+.]\w+)*){1,64}$
Domain | ^([a-zA-Z0-9]+([-.][a-zA-Z0-9]+)*){1,255}$
Email | ^((\w+([-+.]\w+)*@[a-zA-Z0-9]+([-.][a-zA-Z0-9]+)*)*){3,320}$
Password | ^(.){8,30}$
PIN | ^[0-9\ ]{1,1}$
EnteredPIN | ^[0-9\ ]{3,3}$
FullPIN | ^[0-9\ ]{4,4}$
CustomerReference | ^[\sa-zA-Z0-9&/`´'-.,;"!_ÀÁÂÃÄÅÆàáâãäåąæßÇçćčÐðÈÉÊËèéêëěğĞÌÍÎÏİıìíîïÒÓÔÕÖØøòóôõöŁłÑñńŞşšśÙÚÛÜùúûüÝŸýÿŻžżþÞ@]{0,40}$
Title | ^[\sa-zA-Z0-9&/`´'-.,;"!_ÀÁÂÃÄÅÆàáâãäåąæßÇçćčÐðÈÉÊËèéêëěğĞÌÍÎÏİıìíîïÒÓÔÕÖØøòóôõöŁłÑñńŞşšśÙÚÛÜùúûüÝŸýÿŻžżþÞ]{0,256}$
Forename | ^[\sa-zA-Z0-9&/`´'-.,;"!_ÀÁÂÃÄÅÆàáâãäåąæßÇçćčÐðÈÉÊËèéêëěğĞÌÍÎÏİıìíîïÒÓÔÕÖØøòóôõöŁłÑñńŞşšśÙÚÛÜùúûüÝŸýÿŻžżþÞ]{0,256}$
MiddleName | ^[\sa-zA-Z0-9&/`´'-.,;"!_ÀÁÂÃÄÅÆàáâãäåąæßÇçćčÐðÈÉÊËèéêëěğĞÌÍÎÏİıìíîïÒÓÔÕÖØøòóôõöŁłÑñńŞşšśÙÚÛÜùúûüÝŸýÿŻžżþÞ]{0,256}$
Surname | ^[\sa-zA-Z0-9&/`´'-.,;"!_ÀÁÂÃÄÅÆàáâãäåąæßÇçćčÐðÈÉÊËèéêëěğĞÌÍÎÏİıìíîïÒÓÔÕÖØøòóôõöŁłÑñńŞşšśÙÚÛÜùúûüÝŸýÿŻžżþÞ]{0,256}$
ElectricNumber | ^([0-9]{0,2})([0-9]{0,4})([0-9]{0,4})([0-9]{0,3})$
TelephoneNumber | ^[0-9\s\(\)+x-]{0,256}$
TelephoneAccountNumber | ^[\sa-zA-Z0-9&/`´'-.,;"!_ÀÁÂÃÄÅÆàáâãäåąæßÇçćčÐðÈÉÊËèéêëěğĞÌÍÎÏİıìíîïÒÓÔÕÖØøòóôõöŁłÑñńŞşšśÙÚÛÜùúûüÝŸýÿŻžżþÞ@]{0,10}$
TelephoneBillNumber | ^[\sa-zA-Z0-9&/`´'-.,;"!_ÀÁÂÃÄÅÆàáâãäåąæßÇçćčÐðÈÉÊËèéêëěğĞÌÍÎÏİıìíîïÒÓÔÕÖØøòóôõöŁłÑñńŞşšśÙÚÛÜùúûüÝŸýÿŻžżþÞ@]{0,6}$
TelephoneBillAmount | ^([0-9.,]){0,64}$
DriverNumber | ^([a-zA-Z0-9]{0,5})([a-zA-Z0-9]{0,6})([a-zA-Z0-9]{0,3})([a-zA-Z0-9]{0,2})$
DriverMicrofiche | ^[0-9]{0,12}$
CardNumber | ^[\s0-9]{0,19}$
CardIssueNumber | ^[a-zA-Z0-9-.]{0,2}$
CardVerificationCode | ^[\s0-9]{0,4}$
CardHolder | ^[\sa-zA-Z0-9&/`´'-.,;"!_ÀÁÂÃÄÅÆàáâãäåąæßÇçćčÐðÈÉÊËèéêëěğĞÌÍÎÏİıìíîïÒÓÔÕÖØøòóôõöŁłÑñńŞşšśÙÚÛÜùúûüÝŸýÿŻžżþÞ@]{0,256}$
InternationalPassportNumber | ^([a-zA-Z0-9<]{0,9})([0-9]{0,1})([a-zA-Z<]{0,3})([0-9]{0,7})([a-zA-Z<]{0,1})([0-9]{0,7})([a-zA-Z0-9<]{0,14})([0-9<]{0,1})([0-9]{0,1})$
PassportNumber | ^([a-zA-Z0-9<]{0,10})([a-zA-Z<]{0,3})([0-9]{0,7})([a-zA-Z<]{0,1})([0-9]{0,7})([0-9]{0,2})$
ShortPassportNumber | ^[a-zA-Z0-9<]{0,15}$
AddressLine | ^[\sa-zA-Z0-9&/`´'-.,;"!_ÀÁÂÃÄÅÆàáâãäåąæßÇçćčÐðÈÉÊËèéêëěğĞÌÍÎÏİıìíîïÒÓÔÕÖØøòóôõöŁłÑñńŞşšśÙÚÛÜùúûüÝŸýÿŻžżþÞ@]{0,256}$
IPAddress | ^((UNKNOWN)|(\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b)){0,15}$
Country | ^[\sa-zA-Z0-9&/`´'-.,;"!_ÀÁÂÃÄÅÆàáâãäåąæßÇçćčÐðÈÉÊËèéêëěğĞÌÍÎÏİıìíîïÒÓÔÕÖØøòóôõöŁłÑñńŞşšśÙÚÛÜùúûüÝŸýÿŻžżþÞ@]{0,256}$
State | ^[\sa-zA-Z0-9&/`´'-.,;"!_ÀÁÂÃÄÅÆàáâãäåąæßÇçćčÐðÈÉÊËèéêëěğĞÌÍÎÏİıìíîïÒÓÔÕÖØøòóôõöŁłÑñńŞşšśÙÚÛÜùúûüÝŸýÿŻžżþÞ@]{0,256}$
SocialSecurityNumber | ^[\sa-zA-Z0-9]{0,8}$
USDrivingLicenceNumber | ^[\sa-zA-Z0-9&/`´'-.,;"!_ÀÁÂÃÄÅÆàáâãäåąæßÇçćčÐðÈÉÊËèéêëěğĞÌÍÎÏİıìíîïÒÓÔÕÖØøòóôõöŁłÑñńŞşšśÙÚÛÜùúûüÝŸýÿŻžżþÞ@]{0,256}$
MailSort | ^[0-9]{0,5}$
Postcode | ^[\sa-zA-Z0-9-.]{0,8}$
Hour | ^((dd)|(DD)|( )|(0|00)|([1-9]|0[1-9]|[1][0-9]|2[0-3]))$
Day | ^((dd)|(DD)|( )|(0|00)|([1-9]|0[1-9]|[12][0-9]|3[01]))$
Month | ^((mm)|(MM)|( )|(0|00)|([1-9]|0[1-9]|1[012]))$
Year | ^((yyyy)|(YYYY)|( )|((00|18|19|20|21)\d\d)|(0\d\d)|(\d\d)|(\d))$
NationalInsuranceNumber | ^([a-zA-Z0-9]{0,2})([a-zA-Z0-9]{0,2})([a-zA-Z0-9]{0,2})([a-zA-Z0-9]{0,2})([a-zA-Z0-9\s]{0,1})$
Generic | ^[\sa-zA-Z0-9&/`´'-.,;"!_ÀÁÂÃÄÅÆàáâãäåąæßÇçćčÐðÈÉÊËèéêëěğĞÌÍÎÏİıìíîïÒÓÔÕÖØøòóôõöŁłÑñńŞşšśÙÚÛÜùúûüÝŸýÿŻžżþÞ@]{0,256}$
PartSortCode | ^[0-9]{2}$
SortCode | ^[0-9]{0,6}$
BankAccountNumber | ^[0-9]{0,10}$
MobileTelephoneNumber | ^[+0-9]{0,256}$
IdentityCardNumber | ^[a-zA-z0-9"<]{0,90}$
IDLine1 | ^([a-zA-Z<]{0,2})([a-zA-Z<]{0,3})([a-zA-Z0-9<]{0,9})([0-9]{0,1})([a-zA-Z0-9<]{0,15})$
IDLine2 | ^([0-9]{0,6})([0-9]{0,1})([MF<]{0,1})([0-9]{0,6})([0-9]{0,1})([a-zA-Z<]{0,3})([a-zA-Z0-9<]{0,11})([0-9]{0,1})$
IDLine3MachineReadableZone3 | ^[a-zA-z0-9<]{0,30}$
BlackBoxID | ^[a-zA-Z0-9/\+-;:/-/\"=]{0,4096}$
IndividualID | ^[\sa-zA-Z0-9&/`´'-.,;"!_ÀÁÂÃÄÅÆàáâãäåąæßÇçćčÐðÈÉÊËèéêëěğĞÌÍÎÏİıìíîïÒÓÔÕÖØøòóôõöŁłÑñńŞşšśÙÚÛÜùúûüÝŸýÿŻžżþÞ@]{0,50}$
UserAgent | ^([^/[:space:]]*)(/([^[:space:]]*))?([[:space:]]*\[[a-zA-Z][a-zA-Z]\])?[[:space:]]*(\\((([^()]|(\\([^()]*\\)))*)\\))?[[:space:]]{0,4096}$
ThreeDSecureResponse | ^[a-zA-Z0-9/\+-;:/-/\"=]{0,1024}$
MerchantData | ^[0-9]{0,38}$
RiskAssessmentID | ^[a-zA-Z0-9]{0,25}$
EventID | ^[a-zA-Z0-9]{0,25}$
NationalIDCardNumber | ^[0-9a-zA-z]{0,16}$
SouthAfricaIDCardNumber | ^[0-9]{0,13}$
DenmarkIDCardNumber1 | ^[0-9]{0,6}$
DenmarkIDCardNumber2 | ^[0-9]{0,4}$
DenmarkIDCardNumberFull | ^[0-9]{0,10}$
ItalyIDCardNumber | ^[0-9a-zA-z]{0,16}$
SwedenIDCardNumber1 | ^[0-9]{0,8}$
SwedenIDCardNumber2 | ^[+-]{0,1}$
SwedenIDCardNumber3 | ^[0-9]{0,4}$
SwedenIDCardNumberFull | ^[0-9]{0,13}$
CanadaIDCardNumber | ^[0-9]{0,9}$
AustraliaMedicareNumber1 | ^[0-9]{0,4}$
AustraliaMedicareNumber2 | ^[0-9]{0,5}$
AustraliaMedicareNumber3 | ^[0-9]{0,1}$
AustraliaMedicareFullNumber | ^[0-9]{0,10}$
AustraliaMedicareReferenceNumber | ^[0-9]{0,1}$
ArgentinaIDCardNumber1 | ^[0-9]{0,2}$
ArgentinaIDCardNumber2 | ^[0-9]{0,8}$
ArgentinaIDCardNumber3 | ^[0-9]{0,1}$
ArgentinaIDCardNumberFull | ^[0-9]{0,11}$


Web Services Background

Web Services Background GBG Web Service Developers Guide
Web Services
Introduction

The GBG system provides a Web browser interface for customers to allow them to perform identity checks on individuals without the need for the customer to carry out any development or integration work. The Web browser interface provides access to all the features of GBG and provides a degree of customisation through the use of Profiles, which allow customers to configure which Item Checks should be used and whether scoring should be applied to the result codes returned.

If the customer is currently using a manual or paper-based process for carrying out identification checks, the Web browser interface provides the simplest and quickest way to start using GBG. GBG offers a second option, whereby the GBG system can be directly integrated into a customer’s own application(s). This may be a new application developed by the customer specifically for GBG, or part of an existing system where performing an identity check may be only one part of a customer’s existing process.

The mechanism by which GBG allows integration with customers’ own applications or systems is through Web Services.

What are Web Services?

Web Services are an industry standard way of allowing computer applications to communicate with each other in a way that is platform and language agnostic. The most common use of this technology is to allow business logic objects to communicate with each other over the Internet to enable B2B (Business to Business) applications.

The main two standards that work together to enable Web Services are SOAP (Simple Object Access Protocol), which defines how messages in the communication between applications should be described, and WSDL (Web Service Description Language), which provides a means for business logic objects to describe their interface (i.e. what they do and how to call them) in a machine-readable way. SOAP messages are XML documents that are passed between business logic objects or applications via some kind of transport. The most commonly used transport for a SOAP message is the HTTP/S, the protocol used by the Internet for transferring web pages and other types of documents and files.

By using HTTP/S as the transport, Web Services are able to work with existing Firewalls, network infrastructure and security policies the customer may have in place. The HTTP/S protocol provides encryption of all communication allowing Web Services to be accessed securely even over insecure networks, such as the Internet.

By providing a machine-readable interface via WSDL, Web Services provide a greater degree of interoperability between Operating Systems (platforms), languages and development tools, than other client/server architectures have offered in the past.

For example, a Web Service developed using the C# language on a Microsoft .NET platform can interoperate with an application developed in Java on a UNIX platform. SOAP toolkits (both free and commercial) are available for most commonly used programming languages and platforms.

Benefits of Web Service Integration

By choosing to integrate GBG directly into their application, a customer has complete control of the user interface, how the data is entered and what actions to perform on the results, e.g. the input data may be manually typed by an operator or automatically processed by reading out of an existing database.

Customers can choose to implement their own security model, i.e. remove the need for operators to logon to GBG as a separate activity, by automating this process, if the operators have already identified themselves to the customer’s application.

By choosing to integrate GBG directly into an existing system, the results or score returned from an ID check could be automatically used to take the operator to the next process in the customer’s application. For example a score that indicates a positive ID check may pass the operator directly into setting up a new customer account process.


GlobalCheck.DataLib Namespace

GlobalCheck.DataLib Namespace GBG Web Service Developers Guide

[Missing <summary> documentation for "N:GlobalCheck.DataLib"]

Classes
 | Class | Description
Public class | AddressDetails | Address details
Public class | DocumentDetails | Document specific details
Public class | DocumentForgeryTests | Tests run against the supplied document image
Public class | ExtractedData | Data extracted from a document image
Public class | Fields | Container for the matching criteria for each field
Public class | Global3DSecureCheckResultCodes | Results data returned by the 3DSecure Item Check
Public class | GlobalAccount | Contains user account details
Public class | GlobalAccountDetails | Contains detailed information for an account
Public class | GlobalAccounts | Contains paged results from a request for summary details of Accounts
Public class | GlobalAddress | Contains fixed and free address information.
Public class | GlobalAddressDocuments | Contains address document information
Public class | GlobalAddresses | Contains full address details for current and 3 previous addresses.
Public class | GlobalAlternateName | Contains alternate details.
Public class | GlobalAustralia | Australian identity details.
Public class | GlobalAuthentication | Container for Authentication details
Public class | GlobalAuthenticationDetails | The GlobalAuthenticationFull data type contains the details of an authentication. This includes the input data and the results of the authentication.
Public class | GlobalBand | Profile Decision Band
Public class | GlobalBankAccount | Contains bank account details.
Public class | GlobalBankingDetails | Contains details of bank accounts and credit/debit cards
Public class | GlobalBrazil | Brazil identity details.
Public class | GlobalBrazilCPFNumber | Brazil CPF Number
Public class | GlobalBreakpoint | A breakpoint in a Profile allows exection to be halted and resumed as an Incremental Verification or Force Override operation.
Public class | GlobalCanada | Canadian identity details.
Public class | GlobalCanadaSocialInsuranceNumber | Canada Social Insurance Number
Public class | GlobalCase | Contains details of a Case
Public class | GlobalCaseChargingPoint | Contains details of a Case Charging Point
Public class | GlobalCaseConsent | Contains details of a Case Consent
Public class | GlobalCaseDetails | Contains details of a Case
Public class | GlobalCaseDispatchParameters | Class for passing dispatch parameters
Public class | GlobalCaseDispatchRecord | Contains details of the dispatch of a Case to a third party
Public class | GlobalCaseDocument | Contains details of a Document
Public class | GlobalCaseDocumentReport | Hold a report of case document based on a validation and an authentication result
Public class | GlobalCaseDocumentResult | Holds the result of a case document
Public class | GlobalCaseDocumentResultParameters | Class for passing document result parameters
Public class | GlobalCaseReference | Holds user defined references of a case
Public class | GlobalCaseReport | Hold a report of case based on an authentication result
Public class | GlobalCaseResultParameters | Class for passing result parameters
Public class | GlobalCases | Contains paged results from a request for summary details of Data Cases
Public class | GlobalCaseVerdict | Holds a summary of the verdicts of a case, extracted from the results
Public class | GlobalConditionDecision | Execution condition based on the Decision Band that is calculated from the current execution position, i.e. from the Item Checks that appear before the current Item Check in the execution order, that have already been processed.
Public class | GlobalConditionItemCheck | Execution condition based on whether the Match Threshold from an Item Checks that appear before the current Item Check in the execution order has been met
Public class | GlobalConditionResultCode | Execution Condition based on Result Code
Public class | GlobalConditionResultCodes | Execution conditions based on Result Codes returned from Item Checks that are included earlier in the Profile sequence.
Public class | GlobalConditionScore | Execution condition based on the Score that is calculated from the current execution position, i.e. from the Item Checks that appear before the current Item Check in the execution order, that have already been processed.
Public class | GlobalContact | Contact details for Organisation
Public class | GlobalContactDetails | Contains Contact details.
Public class | GlobalCountry | Contains the country codes and names for all the countries.
Public class | GlobalCreditDebitCard | Contains details of credit/debit card
Public class | GlobalCreditReportResultCodes | Results data returned by the CreditReport Item Check
Public class | GlobalCriminalRecordCheckDisclosure | Criminal Record Check disclosure report information.
Public class | GlobalCriminalRecordCheckDisclosureOffence | Criminal record check disclosure offense information.
Public class | GlobalDataExtract | Contains details of a DataExtract
Public class | GlobalDataExtractDownloadHistory | Contains details of a Data Extract Download History
Public class | GlobalDataExtracts | Contains paged results from a request for summary details of Data Extracts
Public class | GlobalDecisionBanding | Profile Decision Bands
Public class | GlobalDenmark | Denmark identity details.
Public class | GlobalDeviceIDResultCodes | Results data returned by the DeviceID Item Check
Public class | GlobalDispatchResult | Contains Dispatch result data
Public class | GlobalDIVData | Document Image Validation data class
Public class | GlobalDocumentCategorySubmissionType | Defines the different ways a document can be submitted by an applicant
Public class | GlobalDocumentCheckResultCodes | Results data returned by the Document Checking Item Check
Public class | GlobalDVLADrivingLicenceCategory | /// DVLA Driving Licence Category information.
Public class | GlobalDVLADrivingLicenceEndorsement | /// DVLA endorsement information.
Public class | GlobalDVLADrivingLicenceReport | /// DVLA driving licence report information.
Public class | GlobalDVLADrivingLicenceReportCategory | DVLA driving licence report category information.
Public class | GlobalDVLADrivingLicenceReportEndorsement | DVLA driving licence report endorsement information.
Public class | GlobalDVLADrivingLicenceRestriction | /// DVLA Driving Licence Restriction information.
Public class | GlobalElectricitySupplier | Contains the electricity supply number information.
Public class | GlobalEmployment | Contains employment information.
Public class | GlobalEuropeanIdentityCard | European identity card information.
Public class | GlobalGeneric | Generic information.
Public class | GlobalHome | Contains data returned for the home page of an Organisation
Public class | GlobalIdentityCard | International identity card details.
Public class | GlobalIdentityDocuments | Conatins identity document information.
Public class | GlobalImage | Type and Reference of identity document images
Public class | GlobalInputData | The GlobalInputData data type contains the details of an individual, used in performing an Authentication. The data type is a container for a number of other complex data types, which split an individuals details between them.
Public class | GlobalInternationalPassport | International passport information.
Public class | GlobalItem | Base class for a Profile Item (derived classes are GlobalItemCheck and GlobalBreakpoint)
Public class | GlobalItemCheck | Defines an Item Check instance within a Profile
Public class | GlobalItemCheckEvent | Contains Item Check Event - used for logging
Public class | GlobalItemCheckMatch | Container for the matching conditions for each item check
Public class | GlobalItemCheckResultCode | Result code details
Public class | GlobalItemCheckResultCodes | Container for result code information returned from an authentication.
Public class | GlobalLandTelephone | Contains land telephone information.
Public class | GlobalLicence | Global Licence
Public class | GlobalLicenceItem | A Licence Item
Public class | GlobalLocation | Location details.
Public class | GlobalMedicare | Medicare details.
Public class | GlobalMexico | Mexico identity details.
Public class | GlobalMexicoTaxIdentificationNumber | Mexico Tax Identification Number
Public class | GlobalMobileTelephone | Contains mobile phone information.
Public class | GlobalNewZealand | New Zealand identity details.
Public class | GlobalNewZealandDrivingLicence | NZ driving licence information.
Public class | GlobalOrganisation | Contains details of an Organisation
Public class | GlobalOrganisationDetails | Full details of an organisation that can be updated by an administrator of the parent organisation that manages the child organisation
Public class | GlobalOrganisations | Contains paged results from a request for summary details of child organisations
Public class | GlobalOverride | Details associated with an Item Check whose results have been forcibly overriden
Public class | GlobalPasswordPolicy | Password Policy
Public class | GlobalPEPIntelligenceData | Information about an entity from PEP Intelligence data
Public class | GlobalPersonal | Contains all the personal details for an individual including alternate details.
Public class | GlobalPersonalDetails | Contains all the personal details.
Public class | GlobalProfile | Contains details of a Profile
Public class | GlobalProfileDetails | Full Profile Details including Decision Bands, Item Checks, Properties, Scoring and Execution Conditions
Public class | GlobalProfileIDVersion | Profile ID and Version
Public class | GlobalProfileVersion | Profile Version details
Public class | GlobalProperty | An Item Check Property
Public class | GlobalProvince | Contains the code and name of provinces / states.
Public class | GlobalReportDetails | Describes an ID3global Report
Public class | GlobalReportParameter | Report Parameter class to store simple names and values
Public class | GlobalResource | ID3global Resource
Public class | GlobalResultData | Container for the results of an authentication.
Public class | GlobalRole | Contains details of a Role
Public class | GlobalRoleMember | Contains Role Member
Public class | GlobalRoleMembers | Contains paged results from a request for summary details of Role Members
Public class | GlobalRolePermission | Contains Permission for a Role.
Public class | GlobalRoles | Contains paged results from a request for summary details of Roles
Public class | GlobalSanctionsAddress | Address information about an entity from Sanctions & Enforcements data
Public class | GlobalSanctionsDate | Birth / Death information about an entity from Sanctions & Enforcements data
Public class | GlobalSanctionsEnforcementData | Information about an entity from Sanctions & Enforcements data
Public class | GlobalSanctionsIssuer | Contains the Issuer details for Sanctions.
Public class | GlobalSanctionsMatch | Data returned for a Sanctions match
Public class | GlobalSanctionsPosition | Information about an entity from Sanctions & Enforcements data
Public class | GlobalSanctionsResultCodes | Results data returned by the Sanctions Item Check
Public class | GlobalScoring | Scoring applied to an Item Check within a Profile
Public class | GlobalSharedFraudResultCodes | Shared Fraud Item Check Result data
Public class | GlobalShortPassport | Short passport number.
Public class | GlobalSpain | Spain identity details.
Public class | GlobalSpainTaxIDNumber | Spain TaxID Number
Public class | GlobalSupportContact | Organisation Support Contact Details
Public class | GlobalTelephoneResultCodes | Telephone Item Check Result data
Public class | GlobalUKAddressDocuments | Contains UK Address Document Information.
Public class | GlobalUKBirth | Birth details of an individual.
Public class | GlobalUKData | Contains UK identity documents.
Public class | GlobalUKDrivingLicence | UK driving licence information.
Public class | GlobalUKNationalInsuranceNumber | UK national insurance number details.
Public class | GlobalUKPassport | UK Passport information.
Public class | GlobalUS | US identity details.
Public class | GlobalUSDrivingLicense | US driving license
Public class | GlobalUSSocialSecurity | US social security number.
Public class | GlobalWeighting | Score Weighting applied to a Result Code on an Item Check in a Profile
Public class | GlobalWorkTelephone | Contains work telephone information.
Public class | ImageChecks | Checks run against the supplied image to check if the document is the valid quality
Public class | ImageData | Data relating to the image and the image in Byte[] format
Public class | ResultCode | Container for the list of result codes
Structures
 | Structure | Description
Public structure | GlobalKeyValuePair TKey, TValue | Serializable KeyValuePair
Enumerations
 | Enumeration | Description
Public enumeration | DataExtractVersion | Employment status information
Public enumeration | GlobalAddressFormat | Determines how the address fields are displayed
Public enumeration | GlobalCardType | Contains card types.
Public enumeration | GlobalCaseDispatchRecordStatus | Defines the different dispatch record status for external checks
Public enumeration | GlobalCaseDispatchServiceType | Defines the different service types and case can be dispatched to for external checks
Public enumeration | GlobalConsentVerdict |
Public enumeration | GlobalCriminalRecordCheckDisclosureOffenceType | Contains global criminal record check disclosure offense types.
Public enumeration | GlobalCurrentTime | Current time in employment
Public enumeration | GlobalDataExtractFormat | The format of the DataExtract
Public enumeration | GlobalDataExtractState | The state of the DataExtract
Public enumeration | GlobalDataExtractType | The DataExtract type
Public enumeration | GlobalDispatchReportStatus | Defines the GlobalDispatchReportStatus
Public enumeration | GlobalDIVData GlobalDocumentExtractedStatus | Extraction Status
Public enumeration | GlobalDocumentSubmissionType | The DataExtract type
Public enumeration | GlobalDocumentType | Document type
Public enumeration | GlobalDVLADrivingLicenceReportCategoryType | Defines the GlobalCaseDispatchLicenceCategoryStatus
Public enumeration | GlobalEmploymentStatus | Employment status information
Public enumeration | GlobalGender | Gender of an individual.
Public enumeration | GlobalMatch | Match value
Public enumeration | GlobalPermission | Contains Permissions.
Public enumeration | GlobalProfileState | Profile State
Public enumeration | GlobalResidenceType | Residence type information.
Public enumeration | GlobalSanctionsDateType | Sanctions Date Type
Public enumeration | GlobalUKBirthsIndexCountry | Country details for an individual.


AddressDetails Class

AddressDetails Class GBG Web Service Developers Guide
Address details
Inheritance Hierarchy
System Object
GlobalCheck.DataLib AddressDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AddressDetails
public class AddressDetails
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.AddressDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.AddressDetails');
GlobalCheck.DataLib.AddressDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.AddressDetails');
See Also
AddressDetails Members
GlobalCheck.DataLib Namespace


AddressDetails Members

AddressDetails Members GBG Web Service Developers Guide
The AddressDetails type exposes the following members.
Properties
 | Name | Description
Public property | AddressLines | Address lines
Public property | ZipPostcode | Plostcode of the address details
Back to Top
See Also
AddressDetails Class


AddressDetails Properties

AddressDetails Properties GBG Web Service Developers Guide
The AddressDetails type exposes the following members.
Properties
 | Name | Description
Public property | AddressLines | Address lines
Public property | ZipPostcode | Plostcode of the address details
Back to Top
See Also
AddressDetails Class


AddressDetails.AddressLines Property

AddressDetails AddressLines Property GBG Web Service Developers Guide
Address lines

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> AddressLines { get; set; }
public List<string> AddressLines { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressLines();
function set_AddressLines(value);
function get_AddressLines();
function set_AddressLines(value);
Property Value
Type: List String
See Also
AddressDetails Class
AddressDetails Members


AddressDetails.ZipPostcode Property

AddressDetails ZipPostcode Property GBG Web Service Developers Guide
Plostcode of the address details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ZipPostcode { get; set; }
public string ZipPostcode { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ZipPostcode();
function set_ZipPostcode(value);
function get_ZipPostcode();
function set_ZipPostcode(value);
Property Value
Type: String
See Also
AddressDetails Class
AddressDetails Members


DataExtractVersion Enumeration

DataExtractVersion Enumeration GBG Web Service Developers Guide
Employment status information

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum DataExtractVersion
[SerializableAttribute]
public enum DataExtractVersion
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.DataExtractVersion = function();
GlobalCheck.DataLib.DataExtractVersion.createEnum('GlobalCheck.DataLib.DataExtractVersion', false);
GlobalCheck.DataLib.DataExtractVersion = function();
GlobalCheck.DataLib.DataExtractVersion.createEnum('GlobalCheck.DataLib.DataExtractVersion', false);
Members
Member name | Value | Description
ID3g201304 | 0 | Default - ID3g201304
URU11a | 1 | URU 11a
URU10a | 2 | URU 10a
URU9a | 3 | URU 9a
URU8b | 4 | URU 8b
URU7c | 5 | URU 7c
URU6d | 6 | URU 6d
See Also


DocumentDetails Class

DocumentDetails Class GBG Web Service Developers Guide
Document specific details
Inheritance Hierarchy
System Object
GlobalCheck.DataLib DocumentDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DocumentDetails
public class DocumentDetails
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.DocumentDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.DocumentDetails');
GlobalCheck.DataLib.DocumentDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.DocumentDetails');
See Also
DocumentDetails Members


DocumentDetails Members

DocumentDetails Members GBG Web Service Developers Guide
The DocumentDetails type exposes the following members.
Properties
 | Name | Description
Public property | Country | Country Property
Public property | DocumentNumber | DocumentNumber Property
Public property | State | State Property
Public property | Type | Document Type Property
Public property | Version | Version Property
Back to Top
See Also
DocumentDetails Class


DocumentDetails Properties

DocumentDetails Properties GBG Web Service Developers Guide
The DocumentDetails type exposes the following members.
Properties
 | Name | Description
Public property | Country | Country Property
Public property | DocumentNumber | DocumentNumber Property
Public property | State | State Property
Public property | Type | Document Type Property
Public property | Version | Version Property
Back to Top
See Also
DocumentDetails Class


DocumentDetails.Country Property

DocumentDetails Country Property GBG Web Service Developers Guide
Country Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Country { get; set; }
public string Country { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Country();
function set_Country(value);
function get_Country();
function set_Country(value);
Property Value
Type: String

            Country of Issue

See Also
DocumentDetails Class
DocumentDetails Members


DocumentDetails.DocumentNumber Property

DocumentDetails DocumentNumber Property GBG Web Service Developers Guide
DocumentNumber Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DocumentNumber { get; set; }
public string DocumentNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DocumentNumber();
function set_DocumentNumber(value);
function get_DocumentNumber();
function set_DocumentNumber(value);
Property Value
Type: String

            Document specific number

See Also
DocumentDetails Class
DocumentDetails Members


DocumentDetails.State Property

DocumentDetails State Property GBG Web Service Developers Guide
State Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string State { get; set; }
public string State { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_State();
function set_State(value);
function get_State();
function set_State(value);
Property Value
Type: String

            Issuing State or Province if applicable

See Also
DocumentDetails Class
DocumentDetails Members


DocumentDetails.Type Property

DocumentDetails Type Property GBG Web Service Developers Guide
Document Type Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalDocumentType Type { get; set; }
public GlobalDocumentType Type { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Type();
function set_Type(value);
function get_Type();
function set_Type(value);
Property Value
Type: GlobalDocumentType

            Possible values are:
            Passport
            DrivingLicence
            IDCard
            Unknown

See Also
DocumentDetails Class
DocumentDetails Members


DocumentDetails.Version Property

DocumentDetails Version Property GBG Web Service Developers Guide
Version Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Version { get; set; }
public string Version { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Version();
function set_Version(value);
function get_Version();
function set_Version(value);
Property Value
Type: String

            Document version

See Also
DocumentDetails Class
DocumentDetails Members


DocumentForgeryTests Class

DocumentForgeryTests Class GBG Web Service Developers Guide
Tests run against the supplied document image
Inheritance Hierarchy
System Object
GlobalCheck.DataLib DocumentForgeryTests

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DocumentForgeryTests
public class DocumentForgeryTests
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.DocumentForgeryTests = function();

Type.createClass(
    'GlobalCheck.DataLib.DocumentForgeryTests');
GlobalCheck.DataLib.DocumentForgeryTests = function();

Type.createClass(
    'GlobalCheck.DataLib.DocumentForgeryTests');
See Also
DocumentForgeryTests Members


DocumentForgeryTests Members

DocumentForgeryTests Members GBG Web Service Developers Guide
The DocumentForgeryTests type exposes the following members.
Properties
 | Name | Description
Public property | Description | Description of the test
Public property | Result | Result of the test
Public property | Type | Type of test
Back to Top
See Also
DocumentForgeryTests Class


DocumentForgeryTests Properties

DocumentForgeryTests Properties GBG Web Service Developers Guide
The DocumentForgeryTests type exposes the following members.
Properties
 | Name | Description
Public property | Description | Description of the test
Public property | Result | Result of the test
Public property | Type | Type of test
Back to Top
See Also
DocumentForgeryTests Class


DocumentForgeryTests.Description Property

DocumentForgeryTests Description Property GBG Web Service Developers Guide
Description of the test

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Description();
function set_Description(value);
function get_Description();
function set_Description(value);
Property Value
Type: String
See Also
DocumentForgeryTests Class
DocumentForgeryTests Members


DocumentForgeryTests.Result Property

DocumentForgeryTests Result Property GBG Web Service Developers Guide
Result of the test

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Result { get; set; }
public string Result { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Result();
function set_Result(value);
function get_Result();
function set_Result(value);
Property Value
Type: String
See Also
DocumentForgeryTests Class
DocumentForgeryTests Members


DocumentForgeryTests.Type Property

DocumentForgeryTests Type Property GBG Web Service Developers Guide
Type of test

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Type { get; set; }
public string Type { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Type();
function set_Type(value);
function get_Type();
function set_Type(value);
Property Value
Type: String
See Also
DocumentForgeryTests Class
DocumentForgeryTests Members


ExtractedData Class

ExtractedData Class GBG Web Service Developers Guide
Data extracted from a document image
Inheritance Hierarchy
System Object
GlobalCheck.DataLib ExtractedData

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ExtractedData
public class ExtractedData
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.ExtractedData = function();

Type.createClass(
    'GlobalCheck.DataLib.ExtractedData');
GlobalCheck.DataLib.ExtractedData = function();

Type.createClass(
    'GlobalCheck.DataLib.ExtractedData');
See Also
ExtractedData Members


ExtractedData Members

ExtractedData Members GBG Web Service Developers Guide
The ExtractedData type exposes the following members.
Properties
 | Name | Description
Public property | AdditionalData | Additional Data extracted
Public property | Address | Address extracted from the document
Public property | DOB | DOB Property
Public property | Expiry | Expiry Property
Public property | Forename | Forename extracted from the document
Public property | FormattedAddress | Formatted address returned from the filtering engine
Public property | Gender | Gender extracted from the document
Public property | IssueDate | IssueDate Property
Public property | MRZ | MRZ extracted from the document
Public property | Nationality | Nationality extracted from the document
Public property | Surname | Surname extracted from the document
Back to Top
See Also
ExtractedData Class


ExtractedData Properties

ExtractedData Properties GBG Web Service Developers Guide
The ExtractedData type exposes the following members.
Properties
 | Name | Description
Public property | AdditionalData | Additional Data extracted
Public property | Address | Address extracted from the document
Public property | DOB | DOB Property
Public property | Expiry | Expiry Property
Public property | Forename | Forename extracted from the document
Public property | FormattedAddress | Formatted address returned from the filtering engine
Public property | Gender | Gender extracted from the document
Public property | IssueDate | IssueDate Property
Public property | MRZ | MRZ extracted from the document
Public property | Nationality | Nationality extracted from the document
Public property | Surname | Surname extracted from the document
Back to Top
See Also
ExtractedData Class


ExtractedData.AdditionalData Property

ExtractedData AdditionalData Property GBG Web Service Developers Guide
Additional Data extracted

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AdditionalData { get; set; }
public string AdditionalData { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AdditionalData();
function set_AdditionalData(value);
function get_AdditionalData();
function set_AdditionalData(value);
Property Value
Type: String
See Also
ExtractedData Class
ExtractedData Members


ExtractedData.Address Property

ExtractedData Address Property GBG Web Service Developers Guide
Address extracted from the document

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AddressDetails Address { get; set; }
public AddressDetails Address { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Address();
function set_Address(value);
function get_Address();
function set_Address(value);
Property Value
Type: AddressDetails
See Also
ExtractedData Class
ExtractedData Members


ExtractedData.DOB Property

ExtractedData DOB Property GBG Web Service Developers Guide
DOB Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> DOB { get; set; }
public Nullable<DateTime> DOB { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DOB();
function set_DOB(value);
function get_DOB();
function set_DOB(value);
Property Value
Type: Nullable DateTime

            Timestamp representing the DOB. This property may be omitted to indicate no value was supplied.

See Also
ExtractedData Class
ExtractedData Members


ExtractedData.Expiry Property

ExtractedData Expiry Property GBG Web Service Developers Guide
Expiry Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> Expiry { get; set; }
public Nullable<DateTime> Expiry { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Expiry();
function set_Expiry(value);
function get_Expiry();
function set_Expiry(value);
Property Value
Type: Nullable DateTime

            Timestamp representing the IssueDate. This property may be omitted or set to an empty string to indicate no value was supplied.

See Also
ExtractedData Class
ExtractedData Members


ExtractedData.Forename Property

ExtractedData Forename Property GBG Web Service Developers Guide
Forename extracted from the document

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Forename { get; set; }
public string Forename { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Forename();
function set_Forename(value);
function get_Forename();
function set_Forename(value);
Property Value
Type: String
See Also
ExtractedData Class
ExtractedData Members


ExtractedData.FormattedAddress Property

ExtractedData FormattedAddress Property GBG Web Service Developers Guide
Formatted address returned from the filtering engine

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalAddress FormattedAddress { get; set; }
public GlobalAddress FormattedAddress { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_FormattedAddress();
function set_FormattedAddress(value);
function get_FormattedAddress();
function set_FormattedAddress(value);
Property Value
Type: GlobalAddress
See Also
ExtractedData Class
ExtractedData Members


ExtractedData.Gender Property

ExtractedData Gender Property GBG Web Service Developers Guide
Gender extracted from the document

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalGender Gender { get; set; }
public GlobalGender Gender { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Gender();
function set_Gender(value);
function get_Gender();
function set_Gender(value);
Property Value
Type: GlobalGender
See Also
ExtractedData Class
ExtractedData Members


ExtractedData.IssueDate Property

ExtractedData IssueDate Property GBG Web Service Developers Guide
IssueDate Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> IssueDate { get; set; }
public Nullable<DateTime> IssueDate { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IssueDate();
function set_IssueDate(value);
function get_IssueDate();
function set_IssueDate(value);
Property Value
Type: Nullable DateTime

            Timestamp representing the IssueDate. This property may be omitted to indicate no value was supplied.

See Also
ExtractedData Class
ExtractedData Members


ExtractedData.MRZ Property

ExtractedData MRZ Property GBG Web Service Developers Guide
MRZ extracted from the document

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MRZ { get; set; }
public string MRZ { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MRZ();
function set_MRZ(value);
function get_MRZ();
function set_MRZ(value);
Property Value
Type: String
See Also
ExtractedData Class
ExtractedData Members


ExtractedData.Nationality Property

ExtractedData Nationality Property GBG Web Service Developers Guide
Nationality extracted from the document

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Nationality { get; set; }
public string Nationality { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Nationality();
function set_Nationality(value);
function get_Nationality();
function set_Nationality(value);
Property Value
Type: String
See Also
ExtractedData Class
ExtractedData Members


ExtractedData.Surname Property

ExtractedData Surname Property GBG Web Service Developers Guide
Surname extracted from the document

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Surname { get; set; }
public string Surname { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Surname();
function set_Surname(value);
function get_Surname();
function set_Surname(value);
Property Value
Type: String
See Also
ExtractedData Class
ExtractedData Members


Fields Class

Fields Class GBG Web Service Developers Guide
Container for the matching criteria for each field
Inheritance Hierarchy
System Object
GlobalCheck.DataLib Fields

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class Fields
[SerializableAttribute]
public class Fields
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.Fields = function();

Type.createClass(
    'GlobalCheck.DataLib.Fields');
GlobalCheck.DataLib.Fields = function();

Type.createClass(
    'GlobalCheck.DataLib.Fields');
See Also
Fields Members


Fields Members

Fields Members GBG Web Service Developers Guide
The Fields type exposes the following members.
Properties
 | Name | Description
Public property | Match | Match Property
Public property | MatchAll | MatchAll property
Public property | Mismatch | Mismatch Property
Back to Top
See Also
Fields Class


Fields Properties

Fields Properties GBG Web Service Developers Guide
The Fields type exposes the following members.
Properties
 | Name | Description
Public property | Match | Match Property
Public property | MatchAll | MatchAll property
Public property | Mismatch | Mismatch Property
Back to Top
See Also
Fields Class


Fields.Match Property

Fields Match Property GBG Web Service Developers Guide
Match Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResultCode Match { get; set; }
public ResultCode Match { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Match();
function set_Match(value);
function get_Match();
function set_Match(value);
Property Value
Type: ResultCode

            All the Match codes for the field

See Also
Fields Class
Fields Members


Fields.MatchAll Property

Fields MatchAll Property GBG Web Service Developers Guide
MatchAll property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MatchAll { get; set; }
public bool MatchAll { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MatchAll();
function set_MatchAll(value);
function get_MatchAll();
function set_MatchAll(value);
Property Value
Type: Boolean

            Property that determines if all the match codes must be returned in order for the field to return a match

See Also
Fields Class
Fields Members


Fields.Mismatch Property

Fields Mismatch Property GBG Web Service Developers Guide
Mismatch Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResultCode Mismatch { get; set; }
public ResultCode Mismatch { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Mismatch();
function set_Mismatch(value);
function get_Mismatch();
function set_Mismatch(value);
Property Value
Type: ResultCode

            All the mismatch codes for the field

See Also
Fields Class
Fields Members


Global3DSecureCheckResultCodes Class

Global3DSecureCheckResultCodes Class GBG Web Service Developers Guide
Results data returned by the 3DSecure Item Check
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalItemCheckResultCodes
GlobalCheck.DataLib Global3DSecureCheckResultCodes

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Global3DSecureCheckResultCodes : GlobalItemCheckResultCodes
public class Global3DSecureCheckResultCodes : GlobalItemCheckResultCodes
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.Global3DSecureCheckResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.Global3DSecureCheckResultCodes',
    GlobalCheck.DataLib.GlobalItemCheckResultCodes);
GlobalCheck.DataLib.Global3DSecureCheckResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.Global3DSecureCheckResultCodes',
    GlobalCheck.DataLib.GlobalItemCheckResultCodes);
See Also
Global3DSecureCheckResultCodes Members


Global3DSecureCheckResultCodes Members

Global3DSecureCheckResultCodes Members GBG Web Service Developers Guide
The Global3DSecureCheckResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | MerchantData | MerchantData Property
Public property | ThreeDSecureACSUrl | ThreeDSecureACSUrl Property
Public property | ThreeDSecureRequest | ThreeDSecureRequest Property
Back to Top
See Also
Global3DSecureCheckResultCodes Class


Global3DSecureCheckResultCodes Properties

Global3DSecureCheckResultCodes Properties GBG Web Service Developers Guide
The Global3DSecureCheckResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | MerchantData | MerchantData Property
Public property | ThreeDSecureACSUrl | ThreeDSecureACSUrl Property
Public property | ThreeDSecureRequest | ThreeDSecureRequest Property
Back to Top
See Also
Global3DSecureCheckResultCodes Class


Global3DSecureCheckResultCodes.MerchantData Property

Global3DSecureCheckResultCodes MerchantData Property GBG Web Service Developers Guide
MerchantData Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MerchantData { get; set; }
public string MerchantData { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MerchantData();
function set_MerchantData(value);
function get_MerchantData();
function set_MerchantData(value);
Property Value
Type: String
Merchant data generated by 3DSecure check
See Also
Global3DSecureCheckResultCodes Class
Global3DSecureCheckResultCodes Members


Global3DSecureCheckResultCodes.ThreeDSecureACSUrl Property

Global3DSecureCheckResultCodes ThreeDSecureACSUrl Property GBG Web Service Developers Guide
ThreeDSecureACSUrl Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ThreeDSecureACSUrl { get; set; }
public string ThreeDSecureACSUrl { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ThreeDSecureACSUrl();
function set_ThreeDSecureACSUrl(value);
function get_ThreeDSecureACSUrl();
function set_ThreeDSecureACSUrl(value);
Property Value
Type: String
3D Secure Url generated by 3DSecure check
See Also
Global3DSecureCheckResultCodes Class
Global3DSecureCheckResultCodes Members


Global3DSecureCheckResultCodes.ThreeDSecureRequest Property

Global3DSecureCheckResultCodes ThreeDSecureRequest Property GBG Web Service Developers Guide
ThreeDSecureRequest Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ThreeDSecureRequest { get; set; }
public string ThreeDSecureRequest { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ThreeDSecureRequest();
function set_ThreeDSecureRequest(value);
function get_ThreeDSecureRequest();
function set_ThreeDSecureRequest(value);
Property Value
Type: String
ThreeDSecureRequest request generate by 3DSecure check
See Also
Global3DSecureCheckResultCodes Class
Global3DSecureCheckResultCodes Members


GlobalAccount Class

GlobalAccount Class GBG Web Service Developers Guide
Contains user account details
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalAccount
GlobalCheck.DataLib GlobalAccountDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalAccount
public class GlobalAccount
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalAccount = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAccount');
GlobalCheck.DataLib.GlobalAccount = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAccount');
See Also
GlobalAccount Members


GlobalAccount Members

GlobalAccount Members GBG Web Service Developers Guide
The GlobalAccount type exposes the following members.
Properties
 | Name | Description
Public property | AccountID | AccountID Property
Public property | AccountName | AccountName Property
Public property | Active | Active Property
Public property | Created | Created Property
Public property | DomainName | DomainName Property
Public property | Email | Email Property
Public property | LastSignInFailed | LastSignInFailed Property
Public property | LastSignInSuccess | LastSignInSuccess Property
Public property | Locked | Locked Property
Public property | Name | Name Property
Public property | OrgID | OrgID Property
Public property | OrgName | OrgName Property
Public property | System | System Property
Public property | Username | Username Property
Back to Top
See Also
GlobalAccount Class


GlobalAccount Properties

GlobalAccount Properties GBG Web Service Developers Guide
The GlobalAccount type exposes the following members.
Properties
 | Name | Description
Public property | AccountID | AccountID Property
Public property | AccountName | AccountName Property
Public property | Active | Active Property
Public property | Created | Created Property
Public property | DomainName | DomainName Property
Public property | Email | Email Property
Public property | LastSignInFailed | LastSignInFailed Property
Public property | LastSignInSuccess | LastSignInSuccess Property
Public property | Locked | Locked Property
Public property | Name | Name Property
Public property | OrgID | OrgID Property
Public property | OrgName | OrgName Property
Public property | System | System Property
Public property | Username | Username Property
Back to Top
See Also
GlobalAccount Class


GlobalAccount.AccountID Property

GlobalAccount AccountID Property GBG Web Service Developers Guide
AccountID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid AccountID { get; set; }
public Guid AccountID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AccountID();
function set_AccountID(value);
function get_AccountID();
function set_AccountID(value);
Property Value
Type: Guid

            Unique identifier of the account

See Also
GlobalAccount Class
GlobalAccount Members


GlobalAccount.AccountName Property

GlobalAccount AccountName Property GBG Web Service Developers Guide
AccountName Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AccountName { get; }
public string AccountName { get; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AccountName();
function get_AccountName();
Property Value
Type: String

            username@domainname

See Also
GlobalAccount Class
GlobalAccount Members


GlobalAccount.Active Property

GlobalAccount Active Property GBG Web Service Developers Guide
Active Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Active { get; set; }
public bool Active { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Active();
function set_Active(value);
function get_Active();
function set_Active(value);
Property Value
Type: Boolean

            True if the account is active, false otherwise

See Also
GlobalAccount Class
GlobalAccount Members


GlobalAccount.Created Property

GlobalAccount Created Property GBG Web Service Developers Guide
Created Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Created { get; set; }
public DateTime Created { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Created();
function set_Created(value);
function get_Created();
function set_Created(value);
Property Value
Type: DateTime

            Timestamp of when the account was created

See Also
GlobalAccount Class
GlobalAccount Members


GlobalAccount.DomainName Property

GlobalAccount DomainName Property GBG Web Service Developers Guide
DomainName Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DomainName { get; set; }
public string DomainName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DomainName();
function set_DomainName(value);
function get_DomainName();
function set_DomainName(value);
Property Value
Type: String

            Domain name component of the full account name, i.e. 'domainname' from 'username@domainname'

See Also
GlobalAccount Class
GlobalAccount Members


GlobalAccount.Email Property

GlobalAccount Email Property GBG Web Service Developers Guide
Email Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Email { get; set; }
public string Email { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Email();
function set_Email(value);
function get_Email();
function set_Email(value);
Property Value
Type: String

            Contact email address of the account holder

See Also
GlobalAccount Class
GlobalAccount Members


GlobalAccount.LastSignInFailed Property

GlobalAccount LastSignInFailed Property GBG Web Service Developers Guide
LastSignInFailed Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LastSignInFailed { get; set; }
public DateTime LastSignInFailed { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_LastSignInFailed();
function set_LastSignInFailed(value);
function get_LastSignInFailed();
function set_LastSignInFailed(value);
Property Value
Type: DateTime

            Timestamp of the last failed sign in

See Also
GlobalAccount Class
GlobalAccount Members


GlobalAccount.LastSignInSuccess Property

GlobalAccount LastSignInSuccess Property GBG Web Service Developers Guide
LastSignInSuccess Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LastSignInSuccess { get; set; }
public DateTime LastSignInSuccess { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_LastSignInSuccess();
function set_LastSignInSuccess(value);
function get_LastSignInSuccess();
function set_LastSignInSuccess(value);
Property Value
Type: DateTime

            Timestamp of the last successful sign in

See Also
GlobalAccount Class
GlobalAccount Members


GlobalAccount.Locked Property

GlobalAccount Locked Property GBG Web Service Developers Guide
Locked Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Locked { get; set; }
public bool Locked { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Locked();
function set_Locked(value);
function get_Locked();
function set_Locked(value);
Property Value
Type: Boolean

            True if the account has been locked due to invalid access attempts

See Also
GlobalAccount Class
GlobalAccount Members


GlobalAccount.Name Property

GlobalAccount Name Property GBG Web Service Developers Guide
Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String

            Name of the account holder, e.g. 'John Smith'

See Also
GlobalAccount Class
GlobalAccount Members


GlobalAccount.OrgID Property

GlobalAccount OrgID Property GBG Web Service Developers Guide
OrgID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid OrgID { get; set; }
public Guid OrgID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OrgID();
function set_OrgID(value);
function get_OrgID();
function set_OrgID(value);
Property Value
Type: Guid

            Unique identifier of the organisation the account is a member of

See Also
GlobalAccount Class
GlobalAccount Members


GlobalAccount.OrgName Property

GlobalAccount OrgName Property GBG Web Service Developers Guide
OrgName Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OrgName { get; set; }
public string OrgName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OrgName();
function set_OrgName(value);
function get_OrgName();
function set_OrgName(value);
Property Value
Type: String

            Name of the organisation the account is a member of

See Also
GlobalAccount Class
GlobalAccount Members


GlobalAccount.System Property

GlobalAccount System Property GBG Web Service Developers Guide
System Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool System { get; set; }
public bool System { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_System();
function set_System(value);
function get_System();
function set_System(value);
Property Value
Type: Boolean

            True if the account is created and managed by the system

See Also
GlobalAccount Class
GlobalAccount Members


GlobalAccount.Username Property

GlobalAccount Username Property GBG Web Service Developers Guide
Username Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Username { get; set; }
public string Username { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Username();
function set_Username(value);
function get_Username();
function set_Username(value);
Property Value
Type: String

            Username component of the full account name, i.e. 'username' from 'username@domainname'

See Also
GlobalAccount Class
GlobalAccount Members


GlobalAccountDetails Class

GlobalAccountDetails Class GBG Web Service Developers Guide
Contains detailed information for an account
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalAccount
GlobalCheck.DataLib GlobalAccountDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalAccountDetails : GlobalAccount
public class GlobalAccountDetails : GlobalAccount
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalAccountDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAccountDetails',
    GlobalCheck.DataLib.GlobalAccount);
GlobalCheck.DataLib.GlobalAccountDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAccountDetails',
    GlobalCheck.DataLib.GlobalAccount);
See Also
GlobalAccountDetails Members


GlobalAccountDetails Members

GlobalAccountDetails Members GBG Web Service Developers Guide
The GlobalAccountDetails type exposes the following members.
Properties
 | Name | Description
Public property | DisabledByAdministrator | DisabledByAdministrator Property
Public property | DisabledByInactivity | DisabledByInactivity Property
Public property | FailedAttempts | FailedAttempts Property
Public property | IsAdminPolicy | IsAdminPolicy Property
Public property | PasswordNeverExpires | PasswordNeverExpires Property
Public property | PIN | PIN Property
Public property | RequireChangePassword | RequireChangePassword Property
Back to Top
See Also
GlobalAccountDetails Class


GlobalAccountDetails Properties

GlobalAccountDetails Properties GBG Web Service Developers Guide
The GlobalAccountDetails type exposes the following members.
Properties
 | Name | Description
Public property | DisabledByAdministrator | DisabledByAdministrator Property
Public property | DisabledByInactivity | DisabledByInactivity Property
Public property | FailedAttempts | FailedAttempts Property
Public property | IsAdminPolicy | IsAdminPolicy Property
Public property | PasswordNeverExpires | PasswordNeverExpires Property
Public property | PIN | PIN Property
Public property | RequireChangePassword | RequireChangePassword Property
Back to Top
See Also
GlobalAccountDetails Class


GlobalAccountDetails.DisabledByAdministrator Property

GlobalAccountDetails DisabledByAdministrator Property GBG Web Service Developers Guide
DisabledByAdministrator Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DisabledByAdministrator { get; set; }
public bool DisabledByAdministrator { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DisabledByAdministrator();
function set_DisabledByAdministrator(value);
function get_DisabledByAdministrator();
function set_DisabledByAdministrator(value);
Property Value
Type: Boolean

            True if the account has been disabled by an administrator

See Also
GlobalAccountDetails Class
GlobalAccountDetails Members


GlobalAccountDetails.DisabledByInactivity Property

GlobalAccountDetails DisabledByInactivity Property GBG Web Service Developers Guide
DisabledByInactivity Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DisabledByInactivity { get; set; }
public bool DisabledByInactivity { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DisabledByInactivity();
function set_DisabledByInactivity(value);
function get_DisabledByInactivity();
function set_DisabledByInactivity(value);
Property Value
Type: Boolean

            True if the account has been disabled due to inactivity

See Also
GlobalAccountDetails Class
GlobalAccountDetails Members


GlobalAccountDetails.FailedAttempts Property

GlobalAccountDetails FailedAttempts Property GBG Web Service Developers Guide
FailedAttempts Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint FailedAttempts { get; set; }
public uint FailedAttempts { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_FailedAttempts();
function set_FailedAttempts(value);
function get_FailedAttempts();
function set_FailedAttempts(value);
Property Value
Type: UInt32

            The number of failed sign in attempts since the last successful sign in

            This is a read-only property

See Also
GlobalAccountDetails Class
GlobalAccountDetails Members


GlobalAccountDetails.IsAdminPolicy Property

GlobalAccountDetails IsAdminPolicy Property GBG Web Service Developers Guide
IsAdminPolicy Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAdminPolicy { get; set; }
public bool IsAdminPolicy { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IsAdminPolicy();
function set_IsAdminPolicy(value);
function get_IsAdminPolicy();
function set_IsAdminPolicy(value);
Property Value
Type: Boolean

            True if the organisations Admin Password Policy should apply to this account,
            False if the organisations User Password Policy should apply to this account.
            Note: if a user is a member of multiple roles with different Policies then the
            Admin policy will apply

            This is a read-only property, automatically set by the system depending on the
            Role membership of the account

See Also
GlobalAccountDetails Class
GlobalAccountDetails Members


GlobalAccountDetails.PasswordNeverExpires Property

GlobalAccountDetails PasswordNeverExpires Property GBG Web Service Developers Guide
PasswordNeverExpires Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool PasswordNeverExpires { get; set; }
public bool PasswordNeverExpires { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PasswordNeverExpires();
function set_PasswordNeverExpires(value);
function get_PasswordNeverExpires();
function set_PasswordNeverExpires(value);
Property Value
Type: Boolean

            True if the accounts password should never expire, overriding the
            policy setting on the Password Policy that is applied to the account

See Also
GlobalAccountDetails Class
GlobalAccountDetails Members


GlobalAccountDetails.PIN Property

GlobalAccountDetails PIN Property GBG Web Service Developers Guide
PIN Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PIN { get; set; }
public string PIN { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PIN();
function set_PIN(value);
function get_PIN();
function set_PIN(value);
Property Value
Type: String

            PIN associated with the account

See Also
GlobalAccountDetails Class
GlobalAccountDetails Members


GlobalAccountDetails.RequireChangePassword Property

GlobalAccountDetails RequireChangePassword Property GBG Web Service Developers Guide
RequireChangePassword Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RequireChangePassword { get; set; }
public bool RequireChangePassword { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_RequireChangePassword();
function set_RequireChangePassword(value);
function get_RequireChangePassword();
function set_RequireChangePassword(value);
Property Value
Type: Boolean

            True if user must change their password

See Also
GlobalAccountDetails Class
GlobalAccountDetails Members


GlobalAccounts Class

GlobalAccounts Class GBG Web Service Developers Guide
Contains paged results from a request for summary details of Accounts
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalAccounts

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalAccounts
public class GlobalAccounts
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalAccounts = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAccounts');
GlobalCheck.DataLib.GlobalAccounts = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAccounts');
See Also
GlobalAccounts Members


GlobalAccounts Members

GlobalAccounts Members GBG Web Service Developers Guide
The GlobalAccounts type exposes the following members.
Properties
 | Name | Description
Public property | Accounts | Accounts Property
Public property | PageSize | PageSize Property
Public property | TotalAccounts | TotalAccounts Property
Public property | TotalActive | TotalActive Property
Public property | TotalExpired | TotalExpired Property
Public property | TotalPages | TotalPages Property
Back to Top
See Also
GlobalAccounts Class


GlobalAccounts Properties

GlobalAccounts Properties GBG Web Service Developers Guide
The GlobalAccounts type exposes the following members.
Properties
 | Name | Description
Public property | Accounts | Accounts Property
Public property | PageSize | PageSize Property
Public property | TotalAccounts | TotalAccounts Property
Public property | TotalActive | TotalActive Property
Public property | TotalExpired | TotalExpired Property
Public property | TotalPages | TotalPages Property
Back to Top
See Also
GlobalAccounts Class


GlobalAccounts.Accounts Property

GlobalAccounts Accounts Property GBG Web Service Developers Guide
Accounts Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalAccount> Accounts { get; set; }
public List<GlobalAccount> Accounts { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Accounts();
function set_Accounts(value);
function get_Accounts();
function set_Accounts(value);
Property Value
Type: List GlobalAccount

            Filtered list of Accounts

See Also
GlobalAccounts Class
GlobalAccounts Members


GlobalAccounts.PageSize Property

GlobalAccounts PageSize Property GBG Web Service Developers Guide
PageSize Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint PageSize { get; set; }
public uint PageSize { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PageSize();
function set_PageSize(value);
function get_PageSize();
function set_PageSize(value);
Property Value
Type: UInt32

            Maximum number of results returned from the paged request

See Also
GlobalAccounts Class
GlobalAccounts Members


GlobalAccounts.TotalAccounts Property

GlobalAccounts TotalAccounts Property GBG Web Service Developers Guide
TotalAccounts Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalAccounts { get; set; }
public uint TotalAccounts { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalAccounts();
function set_TotalAccounts(value);
function get_TotalAccounts();
function set_TotalAccounts(value);
Property Value
Type: UInt32

            Total number of accounts that matched the query

See Also
GlobalAccounts Class
GlobalAccounts Members


GlobalAccounts.TotalActive Property

GlobalAccounts TotalActive Property GBG Web Service Developers Guide
TotalActive Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalActive { get; set; }
public uint TotalActive { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalActive();
function set_TotalActive(value);
function get_TotalActive();
function set_TotalActive(value);
Property Value
Type: UInt32

            Total number of active accounts that matched the query

See Also
GlobalAccounts Class
GlobalAccounts Members


GlobalAccounts.TotalExpired Property

GlobalAccounts TotalExpired Property GBG Web Service Developers Guide
TotalExpired Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalExpired { get; set; }
public uint TotalExpired { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalExpired();
function set_TotalExpired(value);
function get_TotalExpired();
function set_TotalExpired(value);
Property Value
Type: UInt32

            Total number of expired accounts that matched the query

See Also
GlobalAccounts Class
GlobalAccounts Members


GlobalAccounts.TotalPages Property

GlobalAccounts TotalPages Property GBG Web Service Developers Guide
TotalPages Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalPages { get; set; }
public uint TotalPages { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalPages();
function set_TotalPages(value);
function get_TotalPages();
function set_TotalPages(value);
Property Value
Type: UInt32

            The total number of pages that would be required to return all the results, based on a page size of PageSize

See Also
GlobalAccounts Class
GlobalAccounts Members


GlobalAddress Class

GlobalAddress Class GBG Web Service Developers Guide
Contains fixed and free address information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalAddress

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalAddress
[SerializableAttribute]
public class GlobalAddress
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalAddress = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAddress');
GlobalCheck.DataLib.GlobalAddress = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAddress');
See Also
GlobalAddress Members


GlobalAddress Members

GlobalAddress Members GBG Web Service Developers Guide
The GlobalAddress type exposes the following members.
Properties
 | Name | Description
Public property | AddressLine1 | Address Line1 Property
Public property | AddressLine2 | Address Line2 Property
Public property | AddressLine3 | Address Line3 Property
Public property | AddressLine4 | Address Line4 Property
Public property | AddressLine5 | Address Line5 Property
Public property | AddressLine6 | Address Line6 Property
Public property | AddressLine7 | Address Line7 Property
Public property | AddressLine8 | Address Line8 Property
Public property | Building | Building Property
Public property | CedexMailsort | Cedex Mailsort Property
Public property | City | City Property
Public property | Company | Company Property
Public property | Country | Country Property
Public property | Department | Department Property
Public property | DpsZipPlus | Dps Zip Plus Property
Public property | FirstMonthOfResidence | First Month of Residence
Public property | FirstYearOfResidence | First Year of Residence
Public property | IsFreeFormat | True if contains a Free Format Address, False otherwise
Public property | LastMonthOfResidence | Last Month of Residence
Public property | LastYearOfResidence | Last Year of Residence
Public property | POBox | PO Box Property
Public property | Premise | Premise Property
Public property | Principality | Principality Property
Public property | Region | Region Property
Public property | StateDistrict | State or District Property
Public property | Street | Street Property
Public property | SubBuilding | Sub Building Property
Public property | SubCity | Sub City Property
Public property | SubStreet | Sub Street Property
Public property | ZipPostcode | ZipPostcode Property
Back to Top
See Also
GlobalAddress Class


GlobalAddress Properties

GlobalAddress Properties GBG Web Service Developers Guide
The GlobalAddress type exposes the following members.
Properties
 | Name | Description
Public property | AddressLine1 | Address Line1 Property
Public property | AddressLine2 | Address Line2 Property
Public property | AddressLine3 | Address Line3 Property
Public property | AddressLine4 | Address Line4 Property
Public property | AddressLine5 | Address Line5 Property
Public property | AddressLine6 | Address Line6 Property
Public property | AddressLine7 | Address Line7 Property
Public property | AddressLine8 | Address Line8 Property
Public property | Building | Building Property
Public property | CedexMailsort | Cedex Mailsort Property
Public property | City | City Property
Public property | Company | Company Property
Public property | Country | Country Property
Public property | Department | Department Property
Public property | DpsZipPlus | Dps Zip Plus Property
Public property | FirstMonthOfResidence | First Month of Residence
Public property | FirstYearOfResidence | First Year of Residence
Public property | IsFreeFormat | True if contains a Free Format Address, False otherwise
Public property | LastMonthOfResidence | Last Month of Residence
Public property | LastYearOfResidence | Last Year of Residence
Public property | POBox | PO Box Property
Public property | Premise | Premise Property
Public property | Principality | Principality Property
Public property | Region | Region Property
Public property | StateDistrict | State or District Property
Public property | Street | Street Property
Public property | SubBuilding | Sub Building Property
Public property | SubCity | Sub City Property
Public property | SubStreet | Sub Street Property
Public property | ZipPostcode | ZipPostcode Property
Back to Top
See Also
GlobalAddress Class


GlobalAddress.AddressLine1 Property

GlobalAddress AddressLine1 Property GBG Web Service Developers Guide
Address Line1 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AddressLine1 { get; set; }
public string AddressLine1 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressLine1();
function set_AddressLine1(value);
function get_AddressLine1();
function set_AddressLine1(value);
Property Value
Type: String

            The part 1 from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.AddressLine2 Property

GlobalAddress AddressLine2 Property GBG Web Service Developers Guide
Address Line2 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AddressLine2 { get; set; }
public string AddressLine2 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressLine2();
function set_AddressLine2(value);
function get_AddressLine2();
function set_AddressLine2(value);
Property Value
Type: String

            The part 2 from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.AddressLine3 Property

GlobalAddress AddressLine3 Property GBG Web Service Developers Guide
Address Line3 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AddressLine3 { get; set; }
public string AddressLine3 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressLine3();
function set_AddressLine3(value);
function get_AddressLine3();
function set_AddressLine3(value);
Property Value
Type: String

            The part 3 from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.AddressLine4 Property

GlobalAddress AddressLine4 Property GBG Web Service Developers Guide
Address Line4 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AddressLine4 { get; set; }
public string AddressLine4 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressLine4();
function set_AddressLine4(value);
function get_AddressLine4();
function set_AddressLine4(value);
Property Value
Type: String

            The part 4 from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.AddressLine5 Property

GlobalAddress AddressLine5 Property GBG Web Service Developers Guide
Address Line5 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AddressLine5 { get; set; }
public string AddressLine5 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressLine5();
function set_AddressLine5(value);
function get_AddressLine5();
function set_AddressLine5(value);
Property Value
Type: String

            The part 5 from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.AddressLine6 Property

GlobalAddress AddressLine6 Property GBG Web Service Developers Guide
Address Line6 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AddressLine6 { get; set; }
public string AddressLine6 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressLine6();
function set_AddressLine6(value);
function get_AddressLine6();
function set_AddressLine6(value);
Property Value
Type: String

            The part 6 from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.AddressLine7 Property

GlobalAddress AddressLine7 Property GBG Web Service Developers Guide
Address Line7 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AddressLine7 { get; set; }
public string AddressLine7 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressLine7();
function set_AddressLine7(value);
function get_AddressLine7();
function set_AddressLine7(value);
Property Value
Type: String

            The part 7 from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.AddressLine8 Property

GlobalAddress AddressLine8 Property GBG Web Service Developers Guide
Address Line8 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AddressLine8 { get; set; }
public string AddressLine8 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressLine8();
function set_AddressLine8(value);
function get_AddressLine8();
function set_AddressLine8(value);
Property Value
Type: String

            The part 8 from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.Building Property

GlobalAddress Building Property GBG Web Service Developers Guide
Building Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Building { get; set; }
public string Building { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Building();
function set_Building(value);
function get_Building();
function set_Building(value);
Property Value
Type: String

            The building from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.CedexMailsort Property

GlobalAddress CedexMailsort Property GBG Web Service Developers Guide
Cedex Mailsort Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CedexMailsort { get; set; }
public string CedexMailsort { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CedexMailsort();
function set_CedexMailsort(value);
function get_CedexMailsort();
function set_CedexMailsort(value);
Property Value
Type: String

            The cedex mailsort from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.City Property

GlobalAddress City Property GBG Web Service Developers Guide
City Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string City { get; set; }
public string City { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_City();
function set_City(value);
function get_City();
function set_City(value);
Property Value
Type: String

            The city from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.Company Property

GlobalAddress Company Property GBG Web Service Developers Guide
Company Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Company { get; set; }
public string Company { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Company();
function set_Company(value);
function get_Company();
function set_Company(value);
Property Value
Type: String

            The company or organisation name from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.Country Property

GlobalAddress Country Property GBG Web Service Developers Guide
Country Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Country { get; set; }
public string Country { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Country();
function set_Country(value);
function get_Country();
function set_Country(value);
Property Value
Type: String

            The country from an individuals current or previous address. This property must be supplied.
            This property will be validated against the following named regular expression: Country
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.Department Property

GlobalAddress Department Property GBG Web Service Developers Guide
Department Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Department { get; set; }
public string Department { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Department();
function set_Department(value);
function get_Department();
function set_Department(value);
Property Value
Type: String

            The department from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.DpsZipPlus Property

GlobalAddress DpsZipPlus Property GBG Web Service Developers Guide
Dps Zip Plus Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DpsZipPlus { get; set; }
public string DpsZipPlus { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DpsZipPlus();
function set_DpsZipPlus(value);
function get_DpsZipPlus();
function set_DpsZipPlus(value);
Property Value
Type: String

            The Dps Zip Plus from an individuals current or previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.FirstMonthOfResidence Property

GlobalAddress FirstMonthOfResidence Property GBG Web Service Developers Guide
First Month of Residence

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int FirstMonthOfResidence { get; set; }
public int FirstMonthOfResidence { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_FirstMonthOfResidence();
function set_FirstMonthOfResidence(value);
function get_FirstMonthOfResidence();
function set_FirstMonthOfResidence(value);
Property Value
Type: Int32

            Integer in the range 1-12 representing the calendar month of an individuals first month of residence of the address specified. This property may be omitted to indicate that this information is not available.
            This property will be validated against the following named regular expression: Month
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.FirstYearOfResidence Property

GlobalAddress FirstYearOfResidence Property GBG Web Service Developers Guide
First Year of Residence

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int FirstYearOfResidence { get; set; }
public int FirstYearOfResidence { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_FirstYearOfResidence();
function set_FirstYearOfResidence(value);
function get_FirstYearOfResidence();
function set_FirstYearOfResidence(value);
Property Value
Type: Int32

            Integer in the range 0-9999 representing the calendar year of an individuals first year of residence of the address specified. This property may be omitted to indicate that this information is not available.
            This property will be validated against the following named regular expression: Year
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.IsFreeFormat Property

GlobalAddress IsFreeFormat Property GBG Web Service Developers Guide
True if contains a Free Format Address, False otherwise

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsFreeFormat { get; }
public bool IsFreeFormat { get; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IsFreeFormat();
function get_IsFreeFormat();
Property Value
Type: Boolean
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.LastMonthOfResidence Property

GlobalAddress LastMonthOfResidence Property GBG Web Service Developers Guide
Last Month of Residence

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int LastMonthOfResidence { get; set; }
public int LastMonthOfResidence { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_LastMonthOfResidence();
function set_LastMonthOfResidence(value);
function get_LastMonthOfResidence();
function set_LastMonthOfResidence(value);
Property Value
Type: Int32

            Integer in the range 1-12 representing the calendar month of an individuals last month of residence of the address specified. This property may be omitted to indicate that this information is not available.
            This property will be validated against the following named regular expression: Month
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.LastYearOfResidence Property

GlobalAddress LastYearOfResidence Property GBG Web Service Developers Guide
Last Year of Residence

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int LastYearOfResidence { get; set; }
public int LastYearOfResidence { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_LastYearOfResidence();
function set_LastYearOfResidence(value);
function get_LastYearOfResidence();
function set_LastYearOfResidence(value);
Property Value
Type: Int32

            Integer in the range 0-9999 representing the calendar year of an individuals first year of residence of the address specified. This property may be omitted to indicate that this information is not available.
            This property will be validated against the following named regular expression: Year
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.POBox Property

GlobalAddress POBox Property GBG Web Service Developers Guide
PO Box Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string POBox { get; set; }
public string POBox { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_POBox();
function set_POBox(value);
function get_POBox();
function set_POBox(value);
Property Value
Type: String

            The PO Box from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.Premise Property

GlobalAddress Premise Property GBG Web Service Developers Guide
Premise Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Premise { get; set; }
public string Premise { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Premise();
function set_Premise(value);
function get_Premise();
function set_Premise(value);
Property Value
Type: String

            The premise from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.Principality Property

GlobalAddress Principality Property GBG Web Service Developers Guide
Principality Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Principality { get; set; }
public string Principality { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Principality();
function set_Principality(value);
function get_Principality();
function set_Principality(value);
Property Value
Type: String

            The principality from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.Region Property

GlobalAddress Region Property GBG Web Service Developers Guide
Region Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Region { get; set; }
public string Region { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Region();
function set_Region(value);
function get_Region();
function set_Region(value);
Property Value
Type: String

            The region from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.StateDistrict Property

GlobalAddress StateDistrict Property GBG Web Service Developers Guide
State or District Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string StateDistrict { get; set; }
public string StateDistrict { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_StateDistrict();
function set_StateDistrict(value);
function get_StateDistrict();
function set_StateDistrict(value);
Property Value
Type: String

            The state or district from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.Street Property

GlobalAddress Street Property GBG Web Service Developers Guide
Street Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Street { get; set; }
public string Street { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Street();
function set_Street(value);
function get_Street();
function set_Street(value);
Property Value
Type: String

            The street name from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.SubBuilding Property

GlobalAddress SubBuilding Property GBG Web Service Developers Guide
Sub Building Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SubBuilding { get; set; }
public string SubBuilding { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SubBuilding();
function set_SubBuilding(value);
function get_SubBuilding();
function set_SubBuilding(value);
Property Value
Type: String

            The sub building from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.SubCity Property

GlobalAddress SubCity Property GBG Web Service Developers Guide
Sub City Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SubCity { get; set; }
public string SubCity { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SubCity();
function set_SubCity(value);
function get_SubCity();
function set_SubCity(value);
Property Value
Type: String

            The sub city from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.SubStreet Property

GlobalAddress SubStreet Property GBG Web Service Developers Guide
Sub Street Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SubStreet { get; set; }
public string SubStreet { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SubStreet();
function set_SubStreet(value);
function get_SubStreet();
function set_SubStreet(value);
Property Value
Type: String

            The sub street name from an individuals current of previous address. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddress.ZipPostcode Property

GlobalAddress ZipPostcode Property GBG Web Service Developers Guide
ZipPostcode Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ZipPostcode { get; set; }
public string ZipPostcode { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ZipPostcode();
function set_ZipPostcode(value);
function get_ZipPostcode();
function set_ZipPostcode(value);
Property Value
Type: String

            The Zip or Postcode from an individuals current or previous address. Note: postcode may be supplied with or without a space, e.g. ‘AB1 1CD’ or ‘AB11CD’. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Postcode
See Also
GlobalAddress Class
GlobalAddress Members


GlobalAddressDocuments Class

GlobalAddressDocuments Class GBG Web Service Developers Guide
Contains address document information
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalAddressDocuments

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalAddressDocuments
[SerializableAttribute]
public class GlobalAddressDocuments
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalAddressDocuments = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAddressDocuments');
GlobalCheck.DataLib.GlobalAddressDocuments = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAddressDocuments');
See Also
GlobalAddressDocuments Members


GlobalAddressDocuments Members

GlobalAddressDocuments Members GBG Web Service Developers Guide
The GlobalAddressDocuments type exposes the following members.
Properties
 | Name | Description
Public property | UKAddressDocuments | UK Address Documents
Back to Top
See Also
GlobalAddressDocuments Class


GlobalAddressDocuments Properties

GlobalAddressDocuments Properties GBG Web Service Developers Guide
The GlobalAddressDocuments type exposes the following members.
Properties
 | Name | Description
Public property | UKAddressDocuments | UK Address Documents
Back to Top
See Also
GlobalAddressDocuments Class


GlobalAddressDocuments.UKAddressDocuments Property

GlobalAddressDocuments UKAddressDocuments Property GBG Web Service Developers Guide
UK Address Documents

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalUKAddressDocuments UKAddressDocuments { get; set; }
public GlobalUKAddressDocuments UKAddressDocuments { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_UKAddressDocuments();
function set_UKAddressDocuments(value);
function get_UKAddressDocuments();
function set_UKAddressDocuments(value);
Property Value
Type: GlobalUKAddressDocuments
See Also
GlobalAddressDocuments Class
GlobalAddressDocuments Members


GlobalAddresses Class

GlobalAddresses Class GBG Web Service Developers Guide
Contains full address details for current and 3 previous addresses.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalAddresses

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalAddresses
[SerializableAttribute]
public class GlobalAddresses
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalAddresses = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAddresses');
GlobalCheck.DataLib.GlobalAddresses = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAddresses');
See Also
GlobalAddresses Members


GlobalAddresses Members

GlobalAddresses Members GBG Web Service Developers Guide
The GlobalAddresses type exposes the following members.
Properties
 | Name | Description
Public property | CurrentAddress | Current Address
Public property | HistoricAddresses | HistoricAddresses Addresses - not supported for matching
Public property | PreviousAddress1 | Previous Address 1
Public property | PreviousAddress2 | Previous Address 2
Public property | PreviousAddress3 | Previous Address 3
Back to Top
See Also
GlobalAddresses Class


GlobalAddresses Properties

GlobalAddresses Properties GBG Web Service Developers Guide
The GlobalAddresses type exposes the following members.
Properties
 | Name | Description
Public property | CurrentAddress | Current Address
Public property | HistoricAddresses | HistoricAddresses Addresses - not supported for matching
Public property | PreviousAddress1 | Previous Address 1
Public property | PreviousAddress2 | Previous Address 2
Public property | PreviousAddress3 | Previous Address 3
Back to Top
See Also
GlobalAddresses Class


GlobalAddresses.CurrentAddress Property

GlobalAddresses CurrentAddress Property GBG Web Service Developers Guide
Current Address

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalAddress CurrentAddress { get; set; }
public GlobalAddress CurrentAddress { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CurrentAddress();
function set_CurrentAddress(value);
function get_CurrentAddress();
function set_CurrentAddress(value);
Property Value
Type: GlobalAddress
See Also
GlobalAddresses Class
GlobalAddresses Members


GlobalAddresses.HistoricAddresses Property

GlobalAddresses HistoricAddresses Property GBG Web Service Developers Guide
HistoricAddresses Addresses - not supported for matching

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalAddress> HistoricAddresses { get; set; }
public List<GlobalAddress> HistoricAddresses { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_HistoricAddresses();
function set_HistoricAddresses(value);
function get_HistoricAddresses();
function set_HistoricAddresses(value);
Property Value
Type: List GlobalAddress
See Also
GlobalAddresses Class
GlobalAddresses Members


GlobalAddresses.PreviousAddress1 Property

GlobalAddresses PreviousAddress1 Property GBG Web Service Developers Guide
Previous Address 1

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalAddress PreviousAddress1 { get; set; }
public GlobalAddress PreviousAddress1 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PreviousAddress1();
function set_PreviousAddress1(value);
function get_PreviousAddress1();
function set_PreviousAddress1(value);
Property Value
Type: GlobalAddress
See Also
GlobalAddresses Class
GlobalAddresses Members


GlobalAddresses.PreviousAddress2 Property

GlobalAddresses PreviousAddress2 Property GBG Web Service Developers Guide
Previous Address 2

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalAddress PreviousAddress2 { get; set; }
public GlobalAddress PreviousAddress2 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PreviousAddress2();
function set_PreviousAddress2(value);
function get_PreviousAddress2();
function set_PreviousAddress2(value);
Property Value
Type: GlobalAddress
See Also
GlobalAddresses Class
GlobalAddresses Members


GlobalAddresses.PreviousAddress3 Property

GlobalAddresses PreviousAddress3 Property GBG Web Service Developers Guide
Previous Address 3

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalAddress PreviousAddress3 { get; set; }
public GlobalAddress PreviousAddress3 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PreviousAddress3();
function set_PreviousAddress3(value);
function get_PreviousAddress3();
function set_PreviousAddress3(value);
Property Value
Type: GlobalAddress
See Also
GlobalAddresses Class
GlobalAddresses Members


GlobalAddressFormat Enumeration

GlobalAddressFormat Enumeration GBG Web Service Developers Guide
Determines how the address fields are displayed

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalAddressFormat
[SerializableAttribute]
public enum GlobalAddressFormat
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalAddressFormat = function();
GlobalCheck.DataLib.GlobalAddressFormat.createEnum('GlobalCheck.DataLib.GlobalAddressFormat', false);
GlobalCheck.DataLib.GlobalAddressFormat = function();
GlobalCheck.DataLib.GlobalAddressFormat.createEnum('GlobalCheck.DataLib.GlobalAddressFormat', false);
Members
Member name | Value | Description
FixedOnly | 0 | Fixed Format Only
FreeOnly | 1 | Free Format Only
FixedThenFree | 2 | Fixed Format as default. Then option for Free Format
FreeThenFixed | 3 | Free Format as default. Then option for Fixed Format
See Also


GlobalAlternateName Class

GlobalAlternateName Class GBG Web Service Developers Guide
Contains alternate details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalAlternateName

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalAlternateName
[SerializableAttribute]
public class GlobalAlternateName
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalAlternateName = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAlternateName');
GlobalCheck.DataLib.GlobalAlternateName = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAlternateName');
See Also
GlobalAlternateName Members


GlobalAlternateName Members

GlobalAlternateName Members GBG Web Service Developers Guide
The GlobalAlternateName type exposes the following members.
Methods
Name | Description
DelimitedHeader | Adds column headers for Data Extract to StringBuilder
GetDocumentTypes | Get a list of supported document types
Back to Top
Properties
 | Name | Description
Public property | DocumentType | Document Type property
Public property | Forename | Forename Property
Public property | Gender | Gender Property
Public property | GenderSpecified | Gender Specified Property
Public property | GenderX | Gender Property
Public property | MiddleName | Middle Name Property
Public property | PeriodInUseEndDay | PeriodInUseEndDay Property
Public property | PeriodInUseEndMonth | PeriodInUseEndMonth Property
Public property | PeriodInUseEndYear | PeriodInUseEndYear Property
Public property | PeriodInUseStartDay | PeriodInUseStartDay Property
Public property | PeriodInUseStartMonth | PeriodInUseStartMonth Property
Public property | PeriodInUseStartYear | PeriodInUseStartYear Property
Public property | Surname | Surname Property
Public property | Title | Title Property
Back to Top
See Also
GlobalAlternateName Class


GlobalAlternateName Methods

GlobalAlternateName Methods GBG Web Service Developers Guide
The GlobalAlternateName type exposes the following members.
Methods
Name | Description
DelimitedHeader | Adds column headers for Data Extract to StringBuilder
GetDocumentTypes | Get a list of supported document types
Back to Top
See Also
GlobalAlternateName Class


GlobalAlternateName.DelimitedHeader Method

GlobalAlternateName DelimitedHeader Method GBG Web Service Developers Guide
Adds column headers for Data Extract to StringBuilder

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void DelimitedHeader(
    ref StringBuilder StringB,
    string Delimiter
)
public static void DelimitedHeader(
    ref StringBuilder StringB,
    string Delimiter
)
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalAlternateName.DelimitedHeader = function(StringB, Delimiter);
GlobalCheck.DataLib.GlobalAlternateName.DelimitedHeader = function(StringB, Delimiter);
Parameters
StringB
Type: System.Text StringBuilder
[ref] StringBuilder object to append strings to
Delimiter
Type: System String
Delimiter to separate columns, e.g. '\t'
See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName.GetDocumentTypes Method

GlobalAlternateName GetDocumentTypes Method GBG Web Service Developers Guide
Get a list of supported document types

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<string> GetDocumentTypes()
public static List<string> GetDocumentTypes()
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalAlternateName.GetDocumentTypes = function();
GlobalCheck.DataLib.GlobalAlternateName.GetDocumentTypes = function();
Return Value
Type: List String
list of strings containing the supported types
See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName Properties

GlobalAlternateName Properties GBG Web Service Developers Guide
The GlobalAlternateName type exposes the following members.
Properties
 | Name | Description
Public property | DocumentType | Document Type property
Public property | Forename | Forename Property
Public property | Gender | Gender Property
Public property | GenderSpecified | Gender Specified Property
Public property | GenderX | Gender Property
Public property | MiddleName | Middle Name Property
Public property | PeriodInUseEndDay | PeriodInUseEndDay Property
Public property | PeriodInUseEndMonth | PeriodInUseEndMonth Property
Public property | PeriodInUseEndYear | PeriodInUseEndYear Property
Public property | PeriodInUseStartDay | PeriodInUseStartDay Property
Public property | PeriodInUseStartMonth | PeriodInUseStartMonth Property
Public property | PeriodInUseStartYear | PeriodInUseStartYear Property
Public property | Surname | Surname Property
Public property | Title | Title Property
Back to Top
See Also
GlobalAlternateName Class


GlobalAlternateName.DocumentType Property

GlobalAlternateName DocumentType Property GBG Web Service Developers Guide
Document Type property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DocumentType { get; set; }
public string DocumentType { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DocumentType();
function set_DocumentType(value);
function get_DocumentType();
function set_DocumentType(value);
Property Value
Type: String
See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName.Forename Property

GlobalAlternateName Forename Property GBG Web Service Developers Guide
Forename Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Forename { get; set; }
public string Forename { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Forename();
function set_Forename(value);
function get_Forename();
function set_Forename(value);
Property Value
Type: String

            The alternate forename of the individual. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Forename
See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName.Gender Property

GlobalAlternateName Gender Property GBG Web Service Developers Guide
Gender Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalGender Gender { get; set; }
public GlobalGender Gender { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Gender();
function set_Gender(value);
function get_Gender();
function set_Gender(value);
Property Value
Type: GlobalGender

            Individual’s gender. This property may be omitted indicate no value was supplied (alternatively the value of 'Unspecified' can be passed) for UK authentications. It must be supplied when performing an authentication against any other country.
            Possible values are:
            Male
            Female
            Unknown
            Unspecified

See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName.GenderSpecified Property

GlobalAlternateName GenderSpecified Property GBG Web Service Developers Guide
Gender Specified Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool GenderSpecified { get; set; }
public bool GenderSpecified { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_GenderSpecified();
function set_GenderSpecified(value);
function get_GenderSpecified();
function set_GenderSpecified(value);
Property Value
Type: Boolean

            This property is generated by a SOAP toolkit to indicate whether a value type was passed
            true if the Gender value was passed. false if the Gender value was not passed

See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName.GenderX Property

GlobalAlternateName GenderX Property GBG Web Service Developers Guide
Gender Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<GlobalGender> GenderX { get; set; }
public Nullable<GlobalGender> GenderX { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_GenderX();
function set_GenderX(value);
function get_GenderX();
function set_GenderX(value);
Property Value
Type: Nullable GlobalGender

            Individual’s gender. This property may be omitted indicate no value was supplied (alternatively the value of 'Unspecified' can be passed) for UK authentications. It must be supplied when performing an authentication against any other country.
            Possible values are:
            Male
            Female
            Unknown
            Unspecified

See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName.MiddleName Property

GlobalAlternateName MiddleName Property GBG Web Service Developers Guide
Middle Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MiddleName { get; set; }
public string MiddleName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MiddleName();
function set_MiddleName(value);
function get_MiddleName();
function set_MiddleName(value);
Property Value
Type: String

            The alternate middle name of the individual. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: MiddleName
See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName.PeriodInUseEndDay Property

GlobalAlternateName PeriodInUseEndDay Property GBG Web Service Developers Guide
PeriodInUseEndDay Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int PeriodInUseEndDay { get; set; }
public int PeriodInUseEndDay { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PeriodInUseEndDay();
function set_PeriodInUseEndDay(value);
function get_PeriodInUseEndDay();
function set_PeriodInUseEndDay(value);
Property Value
Type: Int32

            End day of the period the alternate name was in use

See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName.PeriodInUseEndMonth Property

GlobalAlternateName PeriodInUseEndMonth Property GBG Web Service Developers Guide
PeriodInUseEndMonth Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int PeriodInUseEndMonth { get; set; }
public int PeriodInUseEndMonth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PeriodInUseEndMonth();
function set_PeriodInUseEndMonth(value);
function get_PeriodInUseEndMonth();
function set_PeriodInUseEndMonth(value);
Property Value
Type: Int32

            End month of the period the alternate name was in use

See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName.PeriodInUseEndYear Property

GlobalAlternateName PeriodInUseEndYear Property GBG Web Service Developers Guide
PeriodInUseEndYear Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int PeriodInUseEndYear { get; set; }
public int PeriodInUseEndYear { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PeriodInUseEndYear();
function set_PeriodInUseEndYear(value);
function get_PeriodInUseEndYear();
function set_PeriodInUseEndYear(value);
Property Value
Type: Int32

            End year of the period the alternate name was in use

See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName.PeriodInUseStartDay Property

GlobalAlternateName PeriodInUseStartDay Property GBG Web Service Developers Guide
PeriodInUseStartDay Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int PeriodInUseStartDay { get; set; }
public int PeriodInUseStartDay { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PeriodInUseStartDay();
function set_PeriodInUseStartDay(value);
function get_PeriodInUseStartDay();
function set_PeriodInUseStartDay(value);
Property Value
Type: Int32

            Start day of the period the alternate name was in use

See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName.PeriodInUseStartMonth Property

GlobalAlternateName PeriodInUseStartMonth Property GBG Web Service Developers Guide
PeriodInUseStartMonth Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int PeriodInUseStartMonth { get; set; }
public int PeriodInUseStartMonth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PeriodInUseStartMonth();
function set_PeriodInUseStartMonth(value);
function get_PeriodInUseStartMonth();
function set_PeriodInUseStartMonth(value);
Property Value
Type: Int32

            Start month of the period the alternate name was in use

See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName.PeriodInUseStartYear Property

GlobalAlternateName PeriodInUseStartYear Property GBG Web Service Developers Guide
PeriodInUseStartYear Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int PeriodInUseStartYear { get; set; }
public int PeriodInUseStartYear { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PeriodInUseStartYear();
function set_PeriodInUseStartYear(value);
function get_PeriodInUseStartYear();
function set_PeriodInUseStartYear(value);
Property Value
Type: Int32

            Start year of the period the alternate name was in use

See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName.Surname Property

GlobalAlternateName Surname Property GBG Web Service Developers Guide
Surname Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Surname { get; set; }
public string Surname { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Surname();
function set_Surname(value);
function get_Surname();
function set_Surname(value);
Property Value
Type: String

            The alternate surname of the individual. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Surname
See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAlternateName.Title Property

GlobalAlternateName Title Property GBG Web Service Developers Guide
Title Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Title { get; set; }
public string Title { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Title();
function set_Title(value);
function get_Title();
function set_Title(value);
Property Value
Type: String

            The alternate title of the individual. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Title
See Also
GlobalAlternateName Class
GlobalAlternateName Members


GlobalAustralia Class

GlobalAustralia Class GBG Web Service Developers Guide
Australian identity details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalAustralia

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalAustralia
[SerializableAttribute]
public class GlobalAustralia
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalAustralia = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAustralia');
GlobalCheck.DataLib.GlobalAustralia = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAustralia');
See Also
GlobalAustralia Members


GlobalAustralia Members

GlobalAustralia Members GBG Web Service Developers Guide
The GlobalAustralia type exposes the following members.
Properties
 | Name | Description
Public property | Medicare | Medicare Details
Public property | ShortPassport | Short Passport Details
Back to Top
See Also
GlobalAustralia Class


GlobalAustralia Properties

GlobalAustralia Properties GBG Web Service Developers Guide
The GlobalAustralia type exposes the following members.
Properties
 | Name | Description
Public property | Medicare | Medicare Details
Public property | ShortPassport | Short Passport Details
Back to Top
See Also
GlobalAustralia Class


GlobalAustralia.Medicare Property

GlobalAustralia Medicare Property GBG Web Service Developers Guide
Medicare Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalMedicare Medicare { get; set; }
public GlobalMedicare Medicare { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Medicare();
function set_Medicare(value);
function get_Medicare();
function set_Medicare(value);
Property Value
Type: GlobalMedicare
See Also
GlobalAustralia Class
GlobalAustralia Members


GlobalAustralia.ShortPassport Property

GlobalAustralia ShortPassport Property GBG Web Service Developers Guide
Short Passport Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalShortPassport ShortPassport { get; set; }
public GlobalShortPassport ShortPassport { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ShortPassport();
function set_ShortPassport(value);
function get_ShortPassport();
function set_ShortPassport(value);
Property Value
Type: GlobalShortPassport
See Also
GlobalAustralia Class
GlobalAustralia Members


GlobalAuthentication Class

GlobalAuthentication Class GBG Web Service Developers Guide
Container for Authentication details
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalAuthentication
GlobalCheck.DataLib GlobalAuthenticationDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalAuthentication
public class GlobalAuthentication
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalAuthentication = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAuthentication');
GlobalCheck.DataLib.GlobalAuthentication = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAuthentication');
See Also
GlobalAuthentication Members


GlobalAuthentication Members

GlobalAuthentication Members GBG Web Service Developers Guide
The GlobalAuthentication type exposes the following members.
Properties
 | Name | Description
Public property | AccountID | Account ID Property
Public property | AuthenticationID | Authentication ID Property
Public property | BandText | Band Text Property
Public property | ChainID | Chain ID Property
Public property | CustomerRef | Customer Reference Property
Public property | HelpdeskAccess | HelpdeskAccess Property
Public property | IsMultipleProfile | Multiple Profile Property
Public property | OrgID | Organisation ID Property
Public property | ProfileID | Profile ID Property
Public property | ProfileName | Profile Name Property
Public property | ProfileRevision | Profile Revision Property
Public property | ProfileState | Profile State Property
Public property | ProfileVersion | Profile Version Property
Public property | Score | Score Property
Public property | Timestamp | Timestamp Property
Back to Top
See Also
GlobalAuthentication Class


GlobalAuthentication Properties

GlobalAuthentication Properties GBG Web Service Developers Guide
The GlobalAuthentication type exposes the following members.
Properties
 | Name | Description
Public property | AccountID | Account ID Property
Public property | AuthenticationID | Authentication ID Property
Public property | BandText | Band Text Property
Public property | ChainID | Chain ID Property
Public property | CustomerRef | Customer Reference Property
Public property | HelpdeskAccess | HelpdeskAccess Property
Public property | IsMultipleProfile | Multiple Profile Property
Public property | OrgID | Organisation ID Property
Public property | ProfileID | Profile ID Property
Public property | ProfileName | Profile Name Property
Public property | ProfileRevision | Profile Revision Property
Public property | ProfileState | Profile State Property
Public property | ProfileVersion | Profile Version Property
Public property | Score | Score Property
Public property | Timestamp | Timestamp Property
Back to Top
See Also
GlobalAuthentication Class


GlobalAuthentication.AccountID Property

GlobalAuthentication AccountID Property GBG Web Service Developers Guide
Account ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid AccountID { get; set; }
public Guid AccountID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AccountID();
function set_AccountID(value);
function get_AccountID();
function set_AccountID(value);
Property Value
Type: Guid
See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthentication.AuthenticationID Property

GlobalAuthentication AuthenticationID Property GBG Web Service Developers Guide
Authentication ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid AuthenticationID { get; set; }
public Guid AuthenticationID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AuthenticationID();
function set_AuthenticationID(value);
function get_AuthenticationID();
function set_AuthenticationID(value);
Property Value
Type: Guid
See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthentication.BandText Property

GlobalAuthentication BandText Property GBG Web Service Developers Guide
Band Text Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BandText { get; set; }
public string BandText { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_BandText();
function set_BandText(value);
function get_BandText();
function set_BandText(value);
Property Value
Type: String
See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthentication.ChainID Property

GlobalAuthentication ChainID Property GBG Web Service Developers Guide
Chain ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ChainID { get; set; }
public Guid ChainID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ChainID();
function set_ChainID(value);
function get_ChainID();
function set_ChainID(value);
Property Value
Type: Guid
See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthentication.CustomerRef Property

GlobalAuthentication CustomerRef Property GBG Web Service Developers Guide
Customer Reference Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CustomerRef { get; set; }
public string CustomerRef { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CustomerRef();
function set_CustomerRef(value);
function get_CustomerRef();
function set_CustomerRef(value);
Property Value
Type: String
See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthentication.HelpdeskAccess Property

GlobalAuthentication HelpdeskAccess Property GBG Web Service Developers Guide
HelpdeskAccess Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HelpdeskAccess { get; set; }
public bool HelpdeskAccess { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_HelpdeskAccess();
function set_HelpdeskAccess(value);
function get_HelpdeskAccess();
function set_HelpdeskAccess(value);
Property Value
Type: Boolean

            True if Helpdesk Access has been enabled on the Authentication Record

See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthentication.IsMultipleProfile Property

GlobalAuthentication IsMultipleProfile Property GBG Web Service Developers Guide
Multiple Profile Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsMultipleProfile { get; set; }
public bool IsMultipleProfile { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IsMultipleProfile();
function set_IsMultipleProfile(value);
function get_IsMultipleProfile();
function set_IsMultipleProfile(value);
Property Value
Type: Boolean

            True if the authentication was performed as part of a multiple profile

See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthentication.OrgID Property

GlobalAuthentication OrgID Property GBG Web Service Developers Guide
Organisation ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid OrgID { get; set; }
public Guid OrgID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OrgID();
function set_OrgID(value);
function get_OrgID();
function set_OrgID(value);
Property Value
Type: Guid
See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthentication.ProfileID Property

GlobalAuthentication ProfileID Property GBG Web Service Developers Guide
Profile ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ProfileID { get; set; }
public Guid ProfileID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProfileID();
function set_ProfileID(value);
function get_ProfileID();
function set_ProfileID(value);
Property Value
Type: Guid
See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthentication.ProfileName Property

GlobalAuthentication ProfileName Property GBG Web Service Developers Guide
Profile Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ProfileName { get; set; }
public string ProfileName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProfileName();
function set_ProfileName(value);
function get_ProfileName();
function set_ProfileName(value);
Property Value
Type: String
See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthentication.ProfileRevision Property

GlobalAuthentication ProfileRevision Property GBG Web Service Developers Guide
Profile Revision Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint ProfileRevision { get; set; }
public uint ProfileRevision { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProfileRevision();
function set_ProfileRevision(value);
function get_ProfileRevision();
function set_ProfileRevision(value);
Property Value
Type: UInt32
See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthentication.ProfileState Property

GlobalAuthentication ProfileState Property GBG Web Service Developers Guide
Profile State Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalProfileState ProfileState { get; set; }
public GlobalProfileState ProfileState { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProfileState();
function set_ProfileState(value);
function get_ProfileState();
function set_ProfileState(value);
Property Value
Type: GlobalProfileState
See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthentication.ProfileVersion Property

GlobalAuthentication ProfileVersion Property GBG Web Service Developers Guide
Profile Version Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint ProfileVersion { get; set; }
public uint ProfileVersion { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProfileVersion();
function set_ProfileVersion(value);
function get_ProfileVersion();
function set_ProfileVersion(value);
Property Value
Type: UInt32
See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthentication.Score Property

GlobalAuthentication Score Property GBG Web Service Developers Guide
Score Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Score { get; set; }
public int Score { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Score();
function set_Score(value);
function get_Score();
function set_Score(value);
Property Value
Type: Int32
See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthentication.Timestamp Property

GlobalAuthentication Timestamp Property GBG Web Service Developers Guide
Timestamp Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Timestamp { get; set; }
public DateTime Timestamp { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Timestamp();
function set_Timestamp(value);
function get_Timestamp();
function set_Timestamp(value);
Property Value
Type: DateTime
See Also
GlobalAuthentication Class
GlobalAuthentication Members


GlobalAuthenticationDetails Class

GlobalAuthenticationDetails Class GBG Web Service Developers Guide
The GlobalAuthenticationFull data type contains the details of an authentication. This includes the input data and the results of the authentication.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalAuthentication
GlobalCheck.DataLib GlobalAuthenticationDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalAuthenticationDetails : GlobalAuthentication
public class GlobalAuthenticationDetails : GlobalAuthentication
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalAuthenticationDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAuthenticationDetails',
    GlobalCheck.DataLib.GlobalAuthentication);
GlobalCheck.DataLib.GlobalAuthenticationDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalAuthenticationDetails',
    GlobalCheck.DataLib.GlobalAuthentication);
See Also
GlobalAuthenticationDetails Members


GlobalAuthenticationDetails Members

GlobalAuthenticationDetails Members GBG Web Service Developers Guide
The GlobalAuthenticationDetails type exposes the following members.
Properties
 | Name | Description
Public property | InputData | InputData property
Public property | Name | Name property
Public property | ResultCodes | ResultCodes Property
Public property | UserBreakpoint | User Breakpoint Property
Public property | Username | Username property
Back to Top
See Also
GlobalAuthenticationDetails Class


GlobalAuthenticationDetails Properties

GlobalAuthenticationDetails Properties GBG Web Service Developers Guide
The GlobalAuthenticationDetails type exposes the following members.
Properties
 | Name | Description
Public property | InputData | InputData property
Public property | Name | Name property
Public property | ResultCodes | ResultCodes Property
Public property | UserBreakpoint | User Breakpoint Property
Public property | Username | Username property
Back to Top
See Also
GlobalAuthenticationDetails Class


GlobalAuthenticationDetails.InputData Property

GlobalAuthenticationDetails InputData Property GBG Web Service Developers Guide
InputData property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalInputData InputData { get; set; }
public GlobalInputData InputData { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_InputData();
function set_InputData(value);
function get_InputData();
function set_InputData(value);
Property Value
Type: GlobalInputData

            The input data supplied for the authentication.

See Also
GlobalAuthenticationDetails Class
GlobalAuthenticationDetails Members


GlobalAuthenticationDetails.Name Property

GlobalAuthenticationDetails Name Property GBG Web Service Developers Guide
Name property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String

            Full name of the user

See Also
GlobalAuthenticationDetails Class
GlobalAuthenticationDetails Members


GlobalAuthenticationDetails.ResultCodes Property

GlobalAuthenticationDetails ResultCodes Property GBG Web Service Developers Guide
ResultCodes Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalItemCheckResultCodes> ResultCodes { get; set; }
public List<GlobalItemCheckResultCodes> ResultCodes { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ResultCodes();
function set_ResultCodes(value);
function get_ResultCodes();
function set_ResultCodes(value);
Property Value
Type: List GlobalItemCheckResultCodes

            Result codes returned by each Item Check.

See Also
GlobalAuthenticationDetails Class
GlobalAuthenticationDetails Members


GlobalAuthenticationDetails.UserBreakpoint Property

GlobalAuthenticationDetails UserBreakpoint Property GBG Web Service Developers Guide
User Breakpoint Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint UserBreakpoint { get; set; }
public uint UserBreakpoint { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_UserBreakpoint();
function set_UserBreakpoint(value);
function get_UserBreakpoint();
function set_UserBreakpoint(value);
Property Value
Type: UInt32

            Index of User Breakpoint that the Authentication halted on, or zero if no User Breakpoint was met

See Also
GlobalAuthenticationDetails Class
GlobalAuthenticationDetails Members


GlobalAuthenticationDetails.Username Property

GlobalAuthenticationDetails Username Property GBG Web Service Developers Guide
Username property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Username { get; set; }
public string Username { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Username();
function set_Username(value);
function get_Username();
function set_Username(value);
Property Value
Type: String

            The users username.

See Also
GlobalAuthenticationDetails Class
GlobalAuthenticationDetails Members


GlobalBand Class

GlobalBand Class GBG Web Service Developers Guide
Profile Decision Band
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalBand

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalBand
[SerializableAttribute]
public class GlobalBand
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalBand = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalBand');
GlobalCheck.DataLib.GlobalBand = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalBand');
See Also
GlobalBand Members


GlobalBand Members

GlobalBand Members GBG Web Service Developers Guide
The GlobalBand type exposes the following members.
Properties
 | Name | Description
Public property | BandText | BandText Property
Public property | EndValue | EndValue Property
Public property | StartValue | StartValue Property
Back to Top
See Also
GlobalBand Class


GlobalBand Properties

GlobalBand Properties GBG Web Service Developers Guide
The GlobalBand type exposes the following members.
Properties
 | Name | Description
Public property | BandText | BandText Property
Public property | EndValue | EndValue Property
Public property | StartValue | StartValue Property
Back to Top
See Also
GlobalBand Class


GlobalBand.BandText Property

GlobalBand BandText Property GBG Web Service Developers Guide
BandText Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BandText { get; set; }
public string BandText { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_BandText();
function set_BandText(value);
function get_BandText();
function set_BandText(value);
Property Value
Type: String

            Text to display for the Decision Band

See Also
GlobalBand Class
GlobalBand Members


GlobalBand.EndValue Property

GlobalBand EndValue Property GBG Web Service Developers Guide
EndValue Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long EndValue { get; set; }
public long EndValue { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_EndValue();
function set_EndValue(value);
function get_EndValue();
function set_EndValue(value);
Property Value
Type: Int64

            Score end value

See Also
GlobalBand Class
GlobalBand Members


GlobalBand.StartValue Property

GlobalBand StartValue Property GBG Web Service Developers Guide
StartValue Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long StartValue { get; set; }
public long StartValue { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_StartValue();
function set_StartValue(value);
function get_StartValue();
function set_StartValue(value);
Property Value
Type: Int64

            Score start value

See Also
GlobalBand Class
GlobalBand Members


GlobalBankAccount Class

GlobalBankAccount Class GBG Web Service Developers Guide
Contains bank account details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalBankAccount

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalBankAccount
[SerializableAttribute]
public class GlobalBankAccount
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalBankAccount = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalBankAccount');
GlobalCheck.DataLib.GlobalBankAccount = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalBankAccount');
See Also
GlobalBankAccount Members


GlobalBankAccount Members

GlobalBankAccount Members GBG Web Service Developers Guide
The GlobalBankAccount type exposes the following members.
Properties
 | Name | Description
Public property | AccountNumber | Account number Property
Public property | SortCode | Sortcode Property
Back to Top
See Also
GlobalBankAccount Class


GlobalBankAccount Properties

GlobalBankAccount Properties GBG Web Service Developers Guide
The GlobalBankAccount type exposes the following members.
Properties
 | Name | Description
Public property | AccountNumber | Account number Property
Public property | SortCode | Sortcode Property
Back to Top
See Also
GlobalBankAccount Class


GlobalBankAccount.AccountNumber Property

GlobalBankAccount AccountNumber Property GBG Web Service Developers Guide
Account number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AccountNumber { get; set; }
public string AccountNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AccountNumber();
function set_AccountNumber(value);
function get_AccountNumber();
function set_AccountNumber(value);
Property Value
Type: String

            Contains an individuals bank account number. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: BankAccountNumber
See Also
GlobalBankAccount Class
GlobalBankAccount Members


GlobalBankAccount.SortCode Property

GlobalBankAccount SortCode Property GBG Web Service Developers Guide
Sortcode Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SortCode { get; set; }
public string SortCode { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SortCode();
function set_SortCode(value);
function get_SortCode();
function set_SortCode(value);
Property Value
Type: String

            Contains an individuals bank sort code. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: SortCode
See Also
GlobalBankAccount Class
GlobalBankAccount Members


GlobalBankingDetails Class

GlobalBankingDetails Class GBG Web Service Developers Guide
Contains details of bank accounts and credit/debit cards
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalBankingDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalBankingDetails
[SerializableAttribute]
public class GlobalBankingDetails
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalBankingDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalBankingDetails');
GlobalCheck.DataLib.GlobalBankingDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalBankingDetails');
See Also
GlobalBankingDetails Members


GlobalBankingDetails Members

GlobalBankingDetails Members GBG Web Service Developers Guide
The GlobalBankingDetails type exposes the following members.
Properties
 | Name | Description
Public property | BankAccount | Bank Account
Public property | CreditDebitCard | Credit Debit Card
Back to Top
See Also
GlobalBankingDetails Class


GlobalBankingDetails Properties

GlobalBankingDetails Properties GBG Web Service Developers Guide
The GlobalBankingDetails type exposes the following members.
Properties
 | Name | Description
Public property | BankAccount | Bank Account
Public property | CreditDebitCard | Credit Debit Card
Back to Top
See Also
GlobalBankingDetails Class


GlobalBankingDetails.BankAccount Property

GlobalBankingDetails BankAccount Property GBG Web Service Developers Guide
Bank Account

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalBankAccount BankAccount { get; set; }
public GlobalBankAccount BankAccount { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_BankAccount();
function set_BankAccount(value);
function get_BankAccount();
function set_BankAccount(value);
Property Value
Type: GlobalBankAccount
See Also
GlobalBankingDetails Class
GlobalBankingDetails Members


GlobalBankingDetails.CreditDebitCard Property

GlobalBankingDetails CreditDebitCard Property GBG Web Service Developers Guide
Credit Debit Card

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalCreditDebitCard CreditDebitCard { get; set; }
public GlobalCreditDebitCard CreditDebitCard { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CreditDebitCard();
function set_CreditDebitCard(value);
function get_CreditDebitCard();
function set_CreditDebitCard(value);
Property Value
Type: GlobalCreditDebitCard
See Also
GlobalBankingDetails Class
GlobalBankingDetails Members


GlobalBrazil Class

GlobalBrazil Class GBG Web Service Developers Guide
Brazil identity details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalBrazil

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalBrazil
[SerializableAttribute]
public class GlobalBrazil
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalBrazil = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalBrazil');
GlobalCheck.DataLib.GlobalBrazil = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalBrazil');
See Also
GlobalBrazil Members


GlobalBrazil Members

GlobalBrazil Members GBG Web Service Developers Guide
The GlobalBrazil type exposes the following members.
Properties
 | Name | Description
Public property | CPFNumber | CPFNumber
Back to Top
See Also
GlobalBrazil Class


GlobalBrazil Properties

GlobalBrazil Properties GBG Web Service Developers Guide
The GlobalBrazil type exposes the following members.
Properties
 | Name | Description
Public property | CPFNumber | CPFNumber
Back to Top
See Also
GlobalBrazil Class


GlobalBrazil.CPFNumber Property

GlobalBrazil CPFNumber Property GBG Web Service Developers Guide
CPFNumber

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalBrazilCPFNumber CPFNumber { get; set; }
public GlobalBrazilCPFNumber CPFNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CPFNumber();
function set_CPFNumber(value);
function get_CPFNumber();
function set_CPFNumber(value);
Property Value
Type: GlobalBrazilCPFNumber

            This property will be validated against the following named regular expression: BrazilCPFNumber
See Also
GlobalBrazil Class
GlobalBrazil Members


GlobalBrazilCPFNumber Class

GlobalBrazilCPFNumber Class GBG Web Service Developers Guide
Brazil CPF Number
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalBrazilCPFNumber

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalBrazilCPFNumber
[SerializableAttribute]
public class GlobalBrazilCPFNumber
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalBrazilCPFNumber = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalBrazilCPFNumber');
GlobalCheck.DataLib.GlobalBrazilCPFNumber = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalBrazilCPFNumber');
See Also
GlobalBrazilCPFNumber Members


GlobalBrazilCPFNumber Members

GlobalBrazilCPFNumber Members GBG Web Service Developers Guide
The GlobalBrazilCPFNumber type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalBrazilCPFNumber Class


GlobalBrazilCPFNumber Properties

GlobalBrazilCPFNumber Properties GBG Web Service Developers Guide
The GlobalBrazilCPFNumber type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalBrazilCPFNumber Class


GlobalBrazilCPFNumber.Number Property

GlobalBrazilCPFNumber Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            Contains an individuals CPF Number.  This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: GlobalBrazilCPFNumber
See Also
GlobalBrazilCPFNumber Class
GlobalBrazilCPFNumber Members


GlobalBreakpoint Class

GlobalBreakpoint Class GBG Web Service Developers Guide
A breakpoint in a Profile allows exection to be halted and resumed as an Incremental Verification or Force Override operation.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalItem
GlobalCheck.DataLib GlobalBreakpoint

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalBreakpoint : GlobalItem
[SerializableAttribute]
public class GlobalBreakpoint : GlobalItem
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalBreakpoint = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalBreakpoint',
    GlobalCheck.DataLib.GlobalItem);
GlobalCheck.DataLib.GlobalBreakpoint = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalBreakpoint',
    GlobalCheck.DataLib.GlobalItem);
See Also
GlobalBreakpoint Members


GlobalBreakpoint Members

GlobalBreakpoint Members GBG Web Service Developers Guide
The GlobalBreakpoint type exposes the following members.
Properties
 | Name | Description
Public property | IsNoRetry | IsNoRetry Property
Back to Top
See Also
GlobalBreakpoint Class


GlobalBreakpoint Properties

GlobalBreakpoint Properties GBG Web Service Developers Guide
The GlobalBreakpoint type exposes the following members.
Properties
 | Name | Description
Public property | IsNoRetry | IsNoRetry Property
Back to Top
See Also
GlobalBreakpoint Class


GlobalBreakpoint.IsNoRetry Property

GlobalBreakpoint IsNoRetry Property GBG Web Service Developers Guide
IsNoRetry Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsNoRetry { get; set; }
public bool IsNoRetry { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IsNoRetry();
function set_IsNoRetry(value);
function get_IsNoRetry();
function set_IsNoRetry(value);
Property Value
Type: Boolean

            True if no further execution is permitted if this breakpoint is hit, false otherwise

See Also
GlobalBreakpoint Class
GlobalBreakpoint Members


GlobalCanada Class

GlobalCanada Class GBG Web Service Developers Guide
Canadian identity details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCanada

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCanada
[SerializableAttribute]
public class GlobalCanada
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCanada = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCanada');
GlobalCheck.DataLib.GlobalCanada = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCanada');
See Also
GlobalCanada Members


GlobalCanada Members

GlobalCanada Members GBG Web Service Developers Guide
The GlobalCanada type exposes the following members.
Properties
 | Name | Description
Public property | IdentityCard | Identity Card Details
Public property | SocialInsuranceNumber | Social Insurance Number
Back to Top
See Also
GlobalCanada Class


GlobalCanada Properties

GlobalCanada Properties GBG Web Service Developers Guide
The GlobalCanada type exposes the following members.
Properties
 | Name | Description
Public property | IdentityCard | Identity Card Details
Public property | SocialInsuranceNumber | Social Insurance Number
Back to Top
See Also
GlobalCanada Class


GlobalCanada.IdentityCard Property

GlobalCanada IdentityCard Property GBG Web Service Developers Guide
Identity Card Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalIdentityCard IdentityCard { get; set; }
public GlobalIdentityCard IdentityCard { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IdentityCard();
function set_IdentityCard(value);
function get_IdentityCard();
function set_IdentityCard(value);
Property Value
Type: GlobalIdentityCard

            This property will be validated against the following named regular expression: IdentityCardNumber
See Also
GlobalCanada Class
GlobalCanada Members


GlobalCanada.SocialInsuranceNumber Property

GlobalCanada SocialInsuranceNumber Property GBG Web Service Developers Guide
Social Insurance Number

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalCanadaSocialInsuranceNumber SocialInsuranceNumber { get; set; }
public GlobalCanadaSocialInsuranceNumber SocialInsuranceNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SocialInsuranceNumber();
function set_SocialInsuranceNumber(value);
function get_SocialInsuranceNumber();
function set_SocialInsuranceNumber(value);
Property Value
Type: GlobalCanadaSocialInsuranceNumber

            This property will be validated against the following named regular expression: CanadaSocialInsuranceNumber
See Also
GlobalCanada Class
GlobalCanada Members


GlobalCanadaSocialInsuranceNumber Class

GlobalCanadaSocialInsuranceNumber Class GBG Web Service Developers Guide
Canada Social Insurance Number
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCanadaSocialInsuranceNumber

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCanadaSocialInsuranceNumber
[SerializableAttribute]
public class GlobalCanadaSocialInsuranceNumber
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCanadaSocialInsuranceNumber = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCanadaSocialInsuranceNumber');
GlobalCheck.DataLib.GlobalCanadaSocialInsuranceNumber = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCanadaSocialInsuranceNumber');
See Also
GlobalCanadaSocialInsuranceNumber Members


GlobalCanadaSocialInsuranceNumber Members

GlobalCanadaSocialInsuranceNumber Members GBG Web Service Developers Guide
The GlobalCanadaSocialInsuranceNumber type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalCanadaSocialInsuranceNumber Class


GlobalCanadaSocialInsuranceNumber Properties

GlobalCanadaSocialInsuranceNumber Properties GBG Web Service Developers Guide
The GlobalCanadaSocialInsuranceNumber type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalCanadaSocialInsuranceNumber Class


GlobalCanadaSocialInsuranceNumber.Number Property

GlobalCanadaSocialInsuranceNumber Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            Contains an individuals Social Insurance Number.  This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: CanadaSocialInsuranceNumber
See Also
GlobalCanadaSocialInsuranceNumber Class
GlobalCanadaSocialInsuranceNumber Members


GlobalCardType Enumeration

GlobalCardType Enumeration GBG Web Service Developers Guide
Contains card types.

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalCardType
[SerializableAttribute]
public enum GlobalCardType
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCardType = function();
GlobalCheck.DataLib.GlobalCardType.createEnum('GlobalCheck.DataLib.GlobalCardType', false);
GlobalCheck.DataLib.GlobalCardType = function();
GlobalCheck.DataLib.GlobalCardType.createEnum('GlobalCheck.DataLib.GlobalCardType', false);
Members
Member name | Value | Description
VISA | 0 | VISA
MASTERCARD | 1 | MASTERCARD
DELTA | 2 | DELTA
SWITCH | 3 | SWITCH
AMEX | 4 | AMEX
JCB | 5 | JCB
MAESTRO | 6 | MAESTRO
DINERS | 7 | DINERS
ELECTRON | 8 | ELECTRON
SOLO | 9 | SOLO
CARTEBANCAIRE | 10 | Carte Bancaire
CARTEBLEUE | 11 | Carte Bleue
LASER | 12 | Laser Card
DISCOVER | 13 | Discover Card
DANKORT | 14 | Dankort
See Also


GlobalCase Class

GlobalCase Class GBG Web Service Developers Guide
Contains details of a Case
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCase
GlobalCheck.DataLib GlobalCaseDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCase
[SerializableAttribute]
public class GlobalCase
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCase = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCase');
GlobalCheck.DataLib.GlobalCase = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCase');
See Also
GlobalCase Members


GlobalCase Members

GlobalCase Members GBG Web Service Developers Guide
The GlobalCase type exposes the following members.
Properties
 | Name | Description
Public property | AuthorType | Author Property
Public property | CaseID | CaseID Property
Public property | ChargingPoints | The charging points
Public property | Created | Updated Property
Public property | DisclaimerAccepted | Indicates if the disclaimer has been accepted
Public property | LinkedAccountID | AccountID Property
Public property | Name | Name Property
Public property | OrgID | OrgID Property
Public property | ProductId | Product Property
Public property | Reference | Reference Property
Public property | State | State Property
Public property | Updated | Updated Property
Public property | UpdatedBy | UpdatedBy Property
Public property | UpdatedByAccount | UpdatedByAccount Property
Public property | Verdict | Verdict Property
Public property | Verdicts | The verdicts
Back to Top
See Also
GlobalCase Class


GlobalCase Properties

GlobalCase Properties GBG Web Service Developers Guide
The GlobalCase type exposes the following members.
Properties
 | Name | Description
Public property | AuthorType | Author Property
Public property | CaseID | CaseID Property
Public property | ChargingPoints | The charging points
Public property | Created | Updated Property
Public property | DisclaimerAccepted | Indicates if the disclaimer has been accepted
Public property | LinkedAccountID | AccountID Property
Public property | Name | Name Property
Public property | OrgID | OrgID Property
Public property | ProductId | Product Property
Public property | Reference | Reference Property
Public property | State | State Property
Public property | Updated | Updated Property
Public property | UpdatedBy | UpdatedBy Property
Public property | UpdatedByAccount | UpdatedByAccount Property
Public property | Verdict | Verdict Property
Public property | Verdicts | The verdicts
Back to Top
See Also
GlobalCase Class


GlobalCase.AuthorType Property

GlobalCase AuthorType Property GBG Web Service Developers Guide
Author Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint AuthorType { get; set; }
public uint AuthorType { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AuthorType();
function set_AuthorType(value);
function get_AuthorType();
function set_AuthorType(value);
Property Value
Type: UInt32

            The Author of a Case

See Also
GlobalCase Class
GlobalCase Members


GlobalCase.CaseID Property

GlobalCase CaseID Property GBG Web Service Developers Guide
CaseID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid CaseID { get; set; }
public Guid CaseID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CaseID();
function set_CaseID(value);
function get_CaseID();
function set_CaseID(value);
Property Value
Type: Guid

            Unique identifier for Case

See Also
GlobalCase Class
GlobalCase Members


GlobalCase.ChargingPoints Property

GlobalCase ChargingPoints Property GBG Web Service Developers Guide
The charging points

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalCaseChargingPoint> ChargingPoints { get; set; }
public List<GlobalCaseChargingPoint> ChargingPoints { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ChargingPoints();
function set_ChargingPoints(value);
function get_ChargingPoints();
function set_ChargingPoints(value);
Property Value
Type: List GlobalCaseChargingPoint
See Also
GlobalCase Class
GlobalCase Members


GlobalCase.Created Property

GlobalCase Created Property GBG Web Service Developers Guide
Updated Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Created { get; set; }
public DateTime Created { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Created();
function set_Created(value);
function get_Created();
function set_Created(value);
Property Value
Type: DateTime

            Date the last time the case was updated

See Also
GlobalCase Class
GlobalCase Members


GlobalCase.DisclaimerAccepted Property

GlobalCase DisclaimerAccepted Property GBG Web Service Developers Guide
Indicates if the disclaimer has been accepted

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DisclaimerAccepted { get; set; }
public bool DisclaimerAccepted { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DisclaimerAccepted();
function set_DisclaimerAccepted(value);
function get_DisclaimerAccepted();
function set_DisclaimerAccepted(value);
Property Value
Type: Boolean

            True if the disclaimer has been accepted

See Also
GlobalCase Class
GlobalCase Members


GlobalCase.LinkedAccountID Property

GlobalCase LinkedAccountID Property GBG Web Service Developers Guide
AccountID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> LinkedAccountID { get; set; }
public Nullable<Guid> LinkedAccountID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_LinkedAccountID();
function set_LinkedAccountID(value);
function get_LinkedAccountID();
function set_LinkedAccountID(value);
Property Value
Type: Nullable Guid

            Unique identifier for the Account that the case is about

See Also
GlobalCase Class
GlobalCase Members


GlobalCase.Name Property

GlobalCase Name Property GBG Web Service Developers Guide
Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String

            Case Name
            This property will be validated against the following named regular expression: Generic
See Also
GlobalCase Class
GlobalCase Members


GlobalCase.OrgID Property

GlobalCase OrgID Property GBG Web Service Developers Guide
OrgID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid OrgID { get; set; }
public Guid OrgID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OrgID();
function set_OrgID(value);
function get_OrgID();
function set_OrgID(value);
Property Value
Type: Guid

            Unique identifier for the Organisation the case belongs to

See Also
GlobalCase Class
GlobalCase Members


GlobalCase.ProductId Property

GlobalCase ProductId Property GBG Web Service Developers Guide
Product Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ProductId { get; set; }
public Guid ProductId { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProductId();
function set_ProductId(value);
function get_ProductId();
function set_ProductId(value);
Property Value
Type: Guid

            The Product that owns the case

See Also
GlobalCase Class
GlobalCase Members


GlobalCase.Reference Property

GlobalCase Reference Property GBG Web Service Developers Guide
Reference Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Reference { get; set; }
public string Reference { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Reference();
function set_Reference(value);
function get_Reference();
function set_Reference(value);
Property Value
Type: String

            Case Reference
            This property will be validated against the following named regular expression: Generic
See Also
GlobalCase Class
GlobalCase Members


GlobalCase.State Property

GlobalCase State Property GBG Web Service Developers Guide
State Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint State { get; set; }
public uint State { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_State();
function set_State(value);
function get_State();
function set_State(value);
Property Value
Type: UInt32

            The State of a Case

See Also
GlobalCase Class
GlobalCase Members


GlobalCase.Updated Property

GlobalCase Updated Property GBG Web Service Developers Guide
Updated Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Updated { get; set; }
public DateTime Updated { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Updated();
function set_Updated(value);
function get_Updated();
function set_Updated(value);
Property Value
Type: DateTime

            Date the last time the case was updated

See Also
GlobalCase Class
GlobalCase Members


GlobalCase.UpdatedBy Property

GlobalCase UpdatedBy Property GBG Web Service Developers Guide
UpdatedBy Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid UpdatedBy { get; set; }
public Guid UpdatedBy { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_UpdatedBy();
function set_UpdatedBy(value);
function get_UpdatedBy();
function set_UpdatedBy(value);
Property Value
Type: Guid

            Unique identifier user who updated the case

See Also
GlobalCase Class
GlobalCase Members


GlobalCase.UpdatedByAccount Property

GlobalCase UpdatedByAccount Property GBG Web Service Developers Guide
UpdatedByAccount Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UpdatedByAccount { get; set; }
public string UpdatedByAccount { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_UpdatedByAccount();
function set_UpdatedByAccount(value);
function get_UpdatedByAccount();
function set_UpdatedByAccount(value);
Property Value
Type: String

            Account name in the form user@domain of the user who updated the case
            This property will be validated against the following named regular expression: Generic
See Also
GlobalCase Class
GlobalCase Members


GlobalCase.Verdict Property

GlobalCase Verdict Property GBG Web Service Developers Guide
Verdict Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Verdict { get; set; }
public uint Verdict { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Verdict();
function set_Verdict(value);
function get_Verdict();
function set_Verdict(value);
Property Value
Type: UInt32

            The Verdict of a Case

See Also
GlobalCase Class
GlobalCase Members


GlobalCase.Verdicts Property

GlobalCase Verdicts Property GBG Web Service Developers Guide
The verdicts

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalCaseVerdict> Verdicts { get; set; }
public List<GlobalCaseVerdict> Verdicts { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Verdicts();
function set_Verdicts(value);
function get_Verdicts();
function set_Verdicts(value);
Property Value
Type: List GlobalCaseVerdict
See Also
GlobalCase Class
GlobalCase Members


GlobalCaseChargingPoint Class

GlobalCaseChargingPoint Class GBG Web Service Developers Guide
Contains details of a Case Charging Point
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCaseChargingPoint

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCaseChargingPoint
[SerializableAttribute]
public class GlobalCaseChargingPoint
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseChargingPoint = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseChargingPoint');
GlobalCheck.DataLib.GlobalCaseChargingPoint = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseChargingPoint');
See Also
GlobalCaseChargingPoint Members


GlobalCaseChargingPoint Members

GlobalCaseChargingPoint Members GBG Web Service Developers Guide
The GlobalCaseChargingPoint type exposes the following members.
Properties
 | Name | Description
Public property | AuthenticationID | The id of the authentication associated with the charging point
Public property | ChargingDate | The charging date
Public property | ProfileID | The id of the profile associated with the charging point
Back to Top
See Also
GlobalCaseChargingPoint Class


GlobalCaseChargingPoint Properties

GlobalCaseChargingPoint Properties GBG Web Service Developers Guide
The GlobalCaseChargingPoint type exposes the following members.
Properties
 | Name | Description
Public property | AuthenticationID | The id of the authentication associated with the charging point
Public property | ChargingDate | The charging date
Public property | ProfileID | The id of the profile associated with the charging point
Back to Top
See Also
GlobalCaseChargingPoint Class


GlobalCaseChargingPoint.AuthenticationID Property

GlobalCaseChargingPoint AuthenticationID Property GBG Web Service Developers Guide
The id of the authentication associated with the charging point

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid AuthenticationID { get; set; }
public Guid AuthenticationID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AuthenticationID();
function set_AuthenticationID(value);
function get_AuthenticationID();
function set_AuthenticationID(value);
Property Value
Type: Guid
See Also
GlobalCaseChargingPoint Class
GlobalCaseChargingPoint Members


GlobalCaseChargingPoint.ChargingDate Property

GlobalCaseChargingPoint ChargingDate Property GBG Web Service Developers Guide
The charging date

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ChargingDate { get; set; }
public DateTime ChargingDate { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ChargingDate();
function set_ChargingDate(value);
function get_ChargingDate();
function set_ChargingDate(value);
Property Value
Type: DateTime
See Also
GlobalCaseChargingPoint Class
GlobalCaseChargingPoint Members


GlobalCaseChargingPoint.ProfileID Property

GlobalCaseChargingPoint ProfileID Property GBG Web Service Developers Guide
The id of the profile associated with the charging point

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ProfileID { get; set; }
public Guid ProfileID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProfileID();
function set_ProfileID(value);
function get_ProfileID();
function set_ProfileID(value);
Property Value
Type: Guid
See Also
GlobalCaseChargingPoint Class
GlobalCaseChargingPoint Members


GlobalCaseConsent Class

GlobalCaseConsent Class GBG Web Service Developers Guide
Contains details of a Case Consent
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCaseConsent

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCaseConsent
[SerializableAttribute]
public class GlobalCaseConsent
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseConsent = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseConsent');
GlobalCheck.DataLib.GlobalCaseConsent = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseConsent');
See Also
GlobalCaseConsent Members


GlobalCaseConsent Members

GlobalCaseConsent Members GBG Web Service Developers Guide
The GlobalCaseConsent type exposes the following members.
Properties
 | Name | Description
Public property | Action | The consent action
Public property | ConsentedByAccountID | The consent action
Public property | Description | The description
Public property | Key | The consent key
Public property | Reasons | The consent reasons
Public property | Verdict | The consent verdict
Back to Top
See Also
GlobalCaseConsent Class


GlobalCaseConsent Properties

GlobalCaseConsent Properties GBG Web Service Developers Guide
The GlobalCaseConsent type exposes the following members.
Properties
 | Name | Description
Public property | Action | The consent action
Public property | ConsentedByAccountID | The consent action
Public property | Description | The description
Public property | Key | The consent key
Public property | Reasons | The consent reasons
Public property | Verdict | The consent verdict
Back to Top
See Also
GlobalCaseConsent Class


GlobalCaseConsent.Action Property

GlobalCaseConsent Action Property GBG Web Service Developers Guide
The consent action

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Action { get; set; }
public int Action { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Action();
function set_Action(value);
function get_Action();
function set_Action(value);
Property Value
Type: Int32
See Also
GlobalCaseConsent Class
GlobalCaseConsent Members


GlobalCaseConsent.ConsentedByAccountID Property

GlobalCaseConsent ConsentedByAccountID Property GBG Web Service Developers Guide
The consent action

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ConsentedByAccountID { get; set; }
public Guid ConsentedByAccountID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ConsentedByAccountID();
function set_ConsentedByAccountID(value);
function get_ConsentedByAccountID();
function set_ConsentedByAccountID(value);
Property Value
Type: Guid
See Also
GlobalCaseConsent Class
GlobalCaseConsent Members


GlobalCaseConsent.Description Property

GlobalCaseConsent Description Property GBG Web Service Developers Guide
The description

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Description();
function set_Description(value);
function get_Description();
function set_Description(value);
Property Value
Type: String

            This property will be validated against the following named regular expression: Generic
See Also
GlobalCaseConsent Class
GlobalCaseConsent Members


GlobalCaseConsent.Key Property

GlobalCaseConsent Key Property GBG Web Service Developers Guide
The consent key

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; set; }
public string Key { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Key();
function set_Key(value);
function get_Key();
function set_Key(value);
Property Value
Type: String

            This property will be validated against the following named regular expression: Generic
See Also
GlobalCaseConsent Class
GlobalCaseConsent Members


GlobalCaseConsent.Reasons Property

GlobalCaseConsent Reasons Property GBG Web Service Developers Guide
The consent reasons

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> Reasons { get; set; }
public List<string> Reasons { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Reasons();
function set_Reasons(value);
function get_Reasons();
function set_Reasons(value);
Property Value
Type: List String

            Each item in this property will be validated against the following named regular expression: Generic
See Also
GlobalCaseConsent Class
GlobalCaseConsent Members


GlobalCaseConsent.Verdict Property

GlobalCaseConsent Verdict Property GBG Web Service Developers Guide
The consent verdict

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalConsentVerdict Verdict { get; set; }
public GlobalConsentVerdict Verdict { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Verdict();
function set_Verdict(value);
function get_Verdict();
function set_Verdict(value);
Property Value
Type: GlobalConsentVerdict
See Also
GlobalCaseConsent Class
GlobalCaseConsent Members


GlobalCaseDetails Class

GlobalCaseDetails Class GBG Web Service Developers Guide
Contains details of a Case
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCase
GlobalCheck.DataLib GlobalCaseDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCaseDetails : GlobalCase
[SerializableAttribute]
public class GlobalCaseDetails : GlobalCase
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseDetails',
    GlobalCheck.DataLib.GlobalCase);
GlobalCheck.DataLib.GlobalCaseDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseDetails',
    GlobalCheck.DataLib.GlobalCase);
See Also
GlobalCaseDetails Members


GlobalCaseDetails Members

GlobalCaseDetails Members GBG Web Service Developers Guide
The GlobalCaseDetails type exposes the following members.
Properties
 | Name | Description
Public property | Consents | Consents Property
Public property | CreatedOrganisationID | CreatedOrganisationID Property
Public property | CustomerReferences | CustomerReferences Property
Public property | DispatchRecord | DispatchRecord Property
Public property | DispatchResult | DispatchResult Property
Public property | DocumentCategorySubmissionTypes | How a documents will be submitted
Public property | Documents | Documents Property
Public property | Properties | Properties
Public property | Reports | Reports Property
Back to Top
See Also
GlobalCaseDetails Class


GlobalCaseDetails Properties

GlobalCaseDetails Properties GBG Web Service Developers Guide
The GlobalCaseDetails type exposes the following members.
Properties
 | Name | Description
Public property | Consents | Consents Property
Public property | CreatedOrganisationID | CreatedOrganisationID Property
Public property | CustomerReferences | CustomerReferences Property
Public property | DispatchRecord | DispatchRecord Property
Public property | DispatchResult | DispatchResult Property
Public property | DocumentCategorySubmissionTypes | How a documents will be submitted
Public property | Documents | Documents Property
Public property | Properties | Properties
Public property | Reports | Reports Property
Back to Top
See Also
GlobalCaseDetails Class


GlobalCaseDetails.Consents Property

GlobalCaseDetails Consents Property GBG Web Service Developers Guide
Consents Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalCaseConsent> Consents { get; set; }
public List<GlobalCaseConsent> Consents { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Consents();
function set_Consents(value);
function get_Consents();
function set_Consents(value);
Property Value
Type: List GlobalCaseConsent

            The consents

See Also
GlobalCaseDetails Class
GlobalCaseDetails Members


GlobalCaseDetails.CreatedOrganisationID Property

GlobalCaseDetails CreatedOrganisationID Property GBG Web Service Developers Guide
CreatedOrganisationID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid CreatedOrganisationID { get; set; }
public Guid CreatedOrganisationID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CreatedOrganisationID();
function set_CreatedOrganisationID(value);
function get_CreatedOrganisationID();
function set_CreatedOrganisationID(value);
Property Value
Type: Guid

            The organisation that created the case

See Also
GlobalCaseDetails Class
GlobalCaseDetails Members


GlobalCaseDetails.CustomerReferences Property

GlobalCaseDetails CustomerReferences Property GBG Web Service Developers Guide
CustomerReferences Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalCaseReference> CustomerReferences { get; set; }
public List<GlobalCaseReference> CustomerReferences { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CustomerReferences();
function set_CustomerReferences(value);
function get_CustomerReferences();
function set_CustomerReferences(value);
Property Value
Type: List GlobalCaseReference

            Case CustomerReferences

See Also
GlobalCaseDetails Class
GlobalCaseDetails Members


GlobalCaseDetails.DispatchRecord Property

GlobalCaseDetails DispatchRecord Property GBG Web Service Developers Guide
DispatchRecord Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalCaseDispatchRecord> DispatchRecord { get; set; }
public List<GlobalCaseDispatchRecord> DispatchRecord { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DispatchRecord();
function set_DispatchRecord(value);
function get_DispatchRecord();
function set_DispatchRecord(value);
Property Value
Type: List GlobalCaseDispatchRecord

            The dispatch record of the case

See Also
GlobalCaseDetails Class
GlobalCaseDetails Members


GlobalCaseDetails.DispatchResult Property

GlobalCaseDetails DispatchResult Property GBG Web Service Developers Guide
DispatchResult Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalDispatchResult DispatchResult { get; set; }
public GlobalDispatchResult DispatchResult { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DispatchResult();
function set_DispatchResult(value);
function get_DispatchResult();
function set_DispatchResult(value);
Property Value
Type: GlobalDispatchResult

            The dispatch result of a case

See Also
GlobalCaseDetails Class
GlobalCaseDetails Members


GlobalCaseDetails.DocumentCategorySubmissionTypes Property

GlobalCaseDetails DocumentCategorySubmissionTypes Property GBG Web Service Developers Guide
How a documents will be submitted

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalDocumentCategorySubmissionType> DocumentCategorySubmissionTypes { get; set; }
public List<GlobalDocumentCategorySubmissionType> DocumentCategorySubmissionTypes { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DocumentCategorySubmissionTypes();
function set_DocumentCategorySubmissionTypes(value);
function get_DocumentCategorySubmissionTypes();
function set_DocumentCategorySubmissionTypes(value);
Property Value
Type: List GlobalDocumentCategorySubmissionType
See Also
GlobalCaseDetails Class
GlobalCaseDetails Members


GlobalCaseDetails.Documents Property

GlobalCaseDetails Documents Property GBG Web Service Developers Guide
Documents Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalCaseDocument> Documents { get; set; }
public List<GlobalCaseDocument> Documents { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Documents();
function set_Documents(value);
function get_Documents();
function set_Documents(value);
Property Value
Type: List GlobalCaseDocument

            A list of Documents associated with the case

See Also
GlobalCaseDetails Class
GlobalCaseDetails Members


GlobalCaseDetails.Properties Property

GlobalCaseDetails Properties Property GBG Web Service Developers Guide
Properties

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalKeyValuePair<string, string>> Properties { get; set; }
public List<GlobalKeyValuePair<string, string>> Properties { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Properties();
function set_Properties(value);
function get_Properties();
function set_Properties(value);
Property Value
Type: List GlobalKeyValuePair  String, String
See Also
GlobalCaseDetails Class
GlobalCaseDetails Members


GlobalCaseDetails.Reports Property

GlobalCaseDetails Reports Property GBG Web Service Developers Guide
Reports Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalCaseReport> Reports { get; set; }
public List<GlobalCaseReport> Reports { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Reports();
function set_Reports(value);
function get_Reports();
function set_Reports(value);
Property Value
Type: List GlobalCaseReport

            A list of associated Reports

See Also
GlobalCaseDetails Class
GlobalCaseDetails Members


GlobalCaseDispatchParameters Class

GlobalCaseDispatchParameters Class GBG Web Service Developers Guide
Class for passing dispatch parameters
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCaseResultParameters
GlobalCheck.DataLib GlobalCaseDispatchParameters

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCaseDispatchParameters : GlobalCaseResultParameters
[SerializableAttribute]
public class GlobalCaseDispatchParameters : GlobalCaseResultParameters
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseDispatchParameters = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseDispatchParameters',
    GlobalCheck.DataLib.GlobalCaseResultParameters);
GlobalCheck.DataLib.GlobalCaseDispatchParameters = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseDispatchParameters',
    GlobalCheck.DataLib.GlobalCaseResultParameters);
See Also
GlobalCaseDispatchParameters Members


GlobalCaseDispatchParameters Members

GlobalCaseDispatchParameters Members GBG Web Service Developers Guide
The GlobalCaseDispatchParameters type exposes the following members.
Properties
 | Name | Description
Public property | ConsentStatus | The status for requesting consent for resending a dispatch
Public property | RejectStatus | The status for rejecting the dispatch
Public property | ResendConsentRequired | Confirms if consent is required before resending the dispatch
Public property | ResendStatus | The status for resending a dispatch
Public property | ServiceAgreementID | The service agreement id
Public property | ServiceType | The dispatch service
Back to Top
See Also
GlobalCaseDispatchParameters Class


GlobalCaseDispatchParameters Properties

GlobalCaseDispatchParameters Properties GBG Web Service Developers Guide
The GlobalCaseDispatchParameters type exposes the following members.
Properties
 | Name | Description
Public property | ConsentStatus | The status for requesting consent for resending a dispatch
Public property | RejectStatus | The status for rejecting the dispatch
Public property | ResendConsentRequired | Confirms if consent is required before resending the dispatch
Public property | ResendStatus | The status for resending a dispatch
Public property | ServiceAgreementID | The service agreement id
Public property | ServiceType | The dispatch service
Back to Top
See Also
GlobalCaseDispatchParameters Class


GlobalCaseDispatchParameters.ConsentStatus Property

GlobalCaseDispatchParameters ConsentStatus Property GBG Web Service Developers Guide
The status for requesting consent for resending a dispatch

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<uint> ConsentStatus { get; set; }
public Nullable<uint> ConsentStatus { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ConsentStatus();
function set_ConsentStatus(value);
function get_ConsentStatus();
function set_ConsentStatus(value);
Property Value
Type: Nullable UInt32
See Also
GlobalCaseDispatchParameters Class
GlobalCaseDispatchParameters Members


GlobalCaseDispatchParameters.RejectStatus Property

GlobalCaseDispatchParameters RejectStatus Property GBG Web Service Developers Guide
The status for rejecting the dispatch

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<uint> RejectStatus { get; set; }
public Nullable<uint> RejectStatus { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_RejectStatus();
function set_RejectStatus(value);
function get_RejectStatus();
function set_RejectStatus(value);
Property Value
Type: Nullable UInt32
See Also
GlobalCaseDispatchParameters Class
GlobalCaseDispatchParameters Members


GlobalCaseDispatchParameters.ResendConsentRequired Property

GlobalCaseDispatchParameters ResendConsentRequired Property GBG Web Service Developers Guide
Confirms if consent is required before resending the dispatch

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ResendConsentRequired { get; set; }
public bool ResendConsentRequired { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ResendConsentRequired();
function set_ResendConsentRequired(value);
function get_ResendConsentRequired();
function set_ResendConsentRequired(value);
Property Value
Type: Boolean
See Also
GlobalCaseDispatchParameters Class
GlobalCaseDispatchParameters Members


GlobalCaseDispatchParameters.ResendStatus Property

GlobalCaseDispatchParameters ResendStatus Property GBG Web Service Developers Guide
The status for resending a dispatch

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<uint> ResendStatus { get; set; }
public Nullable<uint> ResendStatus { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ResendStatus();
function set_ResendStatus(value);
function get_ResendStatus();
function set_ResendStatus(value);
Property Value
Type: Nullable UInt32
See Also
GlobalCaseDispatchParameters Class
GlobalCaseDispatchParameters Members


GlobalCaseDispatchParameters.ServiceAgreementID Property

GlobalCaseDispatchParameters ServiceAgreementID Property GBG Web Service Developers Guide
The service agreement id

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ServiceAgreementID { get; set; }
public string ServiceAgreementID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ServiceAgreementID();
function set_ServiceAgreementID(value);
function get_ServiceAgreementID();
function set_ServiceAgreementID(value);
Property Value
Type: String
See Also
GlobalCaseDispatchParameters Class
GlobalCaseDispatchParameters Members


GlobalCaseDispatchParameters.ServiceType Property

GlobalCaseDispatchParameters ServiceType Property GBG Web Service Developers Guide
The dispatch service

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalCaseDispatchServiceType ServiceType { get; set; }
public GlobalCaseDispatchServiceType ServiceType { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ServiceType();
function set_ServiceType(value);
function get_ServiceType();
function set_ServiceType(value);
Property Value
Type: GlobalCaseDispatchServiceType
See Also
GlobalCaseDispatchParameters Class
GlobalCaseDispatchParameters Members


GlobalCaseDispatchRecord Class

GlobalCaseDispatchRecord Class GBG Web Service Developers Guide
Contains details of the dispatch of a Case to a third party
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCaseDispatchRecord

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCaseDispatchRecord
[SerializableAttribute]
public class GlobalCaseDispatchRecord
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseDispatchRecord = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseDispatchRecord');
GlobalCheck.DataLib.GlobalCaseDispatchRecord = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseDispatchRecord');
See Also
GlobalCaseDispatchRecord Members


GlobalCaseDispatchRecord Members

GlobalCaseDispatchRecord Members GBG Web Service Developers Guide
The GlobalCaseDispatchRecord type exposes the following members.
Properties
 | Name | Description
Public property | DispatchService | DispatchService Property
Public property | Message | ResendConsentRequired Property
Public property | ResendConsentRequired | ResendConsentRequired Property
Public property | Status | Status Property
Public property | Updated | Updated Property
Back to Top
See Also
GlobalCaseDispatchRecord Class


GlobalCaseDispatchRecord Properties

GlobalCaseDispatchRecord Properties GBG Web Service Developers Guide
The GlobalCaseDispatchRecord type exposes the following members.
Properties
 | Name | Description
Public property | DispatchService | DispatchService Property
Public property | Message | ResendConsentRequired Property
Public property | ResendConsentRequired | ResendConsentRequired Property
Public property | Status | Status Property
Public property | Updated | Updated Property
Back to Top
See Also
GlobalCaseDispatchRecord Class


GlobalCaseDispatchRecord.DispatchService Property

GlobalCaseDispatchRecord DispatchService Property GBG Web Service Developers Guide
DispatchService Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalCaseDispatchServiceType DispatchService { get; set; }
public GlobalCaseDispatchServiceType DispatchService { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DispatchService();
function set_DispatchService(value);
function get_DispatchService();
function set_DispatchService(value);
Property Value
Type: GlobalCaseDispatchServiceType

            The dispatch service

See Also
GlobalCaseDispatchRecord Class
GlobalCaseDispatchRecord Members


GlobalCaseDispatchRecord.Message Property

GlobalCaseDispatchRecord Message Property GBG Web Service Developers Guide
ResendConsentRequired Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Message { get; set; }
public string Message { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Message();
function set_Message(value);
function get_Message();
function set_Message(value);
Property Value
Type: String

            Message returned from the dispatch service

See Also
GlobalCaseDispatchRecord Class
GlobalCaseDispatchRecord Members


GlobalCaseDispatchRecord.ResendConsentRequired Property

GlobalCaseDispatchRecord ResendConsentRequired Property GBG Web Service Developers Guide
ResendConsentRequired Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ResendConsentRequired { get; set; }
public bool ResendConsentRequired { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ResendConsentRequired();
function set_ResendConsentRequired(value);
function get_ResendConsentRequired();
function set_ResendConsentRequired(value);
Property Value
Type: Boolean

            Confirms if a consent is required in order to resend the dispatch

See Also
GlobalCaseDispatchRecord Class
GlobalCaseDispatchRecord Members


GlobalCaseDispatchRecord.Status Property

GlobalCaseDispatchRecord Status Property GBG Web Service Developers Guide
Status Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalCaseDispatchRecordStatus Status { get; set; }
public GlobalCaseDispatchRecordStatus Status { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Status();
function set_Status(value);
function get_Status();
function set_Status(value);
Property Value
Type: GlobalCaseDispatchRecordStatus

            The dispatch status

See Also
GlobalCaseDispatchRecord Class
GlobalCaseDispatchRecord Members


GlobalCaseDispatchRecord.Updated Property

GlobalCaseDispatchRecord Updated Property GBG Web Service Developers Guide
Updated Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Updated { get; set; }
public DateTime Updated { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Updated();
function set_Updated(value);
function get_Updated();
function set_Updated(value);
Property Value
Type: DateTime

            The date the dispatch was updated

See Also
GlobalCaseDispatchRecord Class
GlobalCaseDispatchRecord Members


GlobalCaseDispatchRecordStatus Enumeration

GlobalCaseDispatchRecordStatus Enumeration GBG Web Service Developers Guide
Defines the different dispatch record status for external checks

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalCaseDispatchRecordStatus
[SerializableAttribute]
public enum GlobalCaseDispatchRecordStatus
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseDispatchRecordStatus = function();
GlobalCheck.DataLib.GlobalCaseDispatchRecordStatus.createEnum('GlobalCheck.DataLib.GlobalCaseDispatchRecordStatus', false);
GlobalCheck.DataLib.GlobalCaseDispatchRecordStatus = function();
GlobalCheck.DataLib.GlobalCaseDispatchRecordStatus.createEnum('GlobalCheck.DataLib.GlobalCaseDispatchRecordStatus', false);
Members
Member name | Value | Description
Sent | 0 | Dispatch sent
ResendConfirmationRequired | 1 | Resend confirmation required
ProcessResend | 2 | Print resend details
Resent | 3 | Dispatch has been resent
Complete | 4 | Dispatch completed, results received
Rejected | 5 | Dispatch rejected
See Also


GlobalCaseDispatchServiceType Enumeration

GlobalCaseDispatchServiceType Enumeration GBG Web Service Developers Guide
Defines the different service types and case can be dispatched to for external checks

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalCaseDispatchServiceType
[SerializableAttribute]
public enum GlobalCaseDispatchServiceType
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseDispatchServiceType = function();
GlobalCheck.DataLib.GlobalCaseDispatchServiceType.createEnum('GlobalCheck.DataLib.GlobalCaseDispatchServiceType', false);
GlobalCheck.DataLib.GlobalCaseDispatchServiceType = function();
GlobalCheck.DataLib.GlobalCaseDispatchServiceType.createEnum('GlobalCheck.DataLib.GlobalCaseDispatchServiceType', false);
Members
Member name | Value | Description
None | 0 | None
DVLA | 1 | DVLA
DisclosureScotland | 2 | Disclosure Scotland
See Also


GlobalCaseDocument Class

GlobalCaseDocument Class GBG Web Service Developers Guide
Contains details of a Document
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCaseDocument

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCaseDocument
[SerializableAttribute]
public class GlobalCaseDocument
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseDocument = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseDocument');
GlobalCheck.DataLib.GlobalCaseDocument = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseDocument');
See Also
GlobalCaseDocument Members


GlobalCaseDocument Members

GlobalCaseDocument Members GBG Web Service Developers Guide
The GlobalCaseDocument type exposes the following members.
Properties
 | Name | Description
Public property | Category | Category Property
Public property | Created | Created Property
Public property | Deleted | Deleted
Public property | DocumentID | DocumentID Property
Public property | DocumentImageID | DIVID Property
Public property | EncodedInputData | EncodedInputData property
Public property | Report | Report property
Public property | Selected | Selected property
Public property | Type | Type Property
Back to Top
See Also
GlobalCaseDocument Class


GlobalCaseDocument Properties

GlobalCaseDocument Properties GBG Web Service Developers Guide
The GlobalCaseDocument type exposes the following members.
Properties
 | Name | Description
Public property | Category | Category Property
Public property | Created | Created Property
Public property | Deleted | Deleted
Public property | DocumentID | DocumentID Property
Public property | DocumentImageID | DIVID Property
Public property | EncodedInputData | EncodedInputData property
Public property | Report | Report property
Public property | Selected | Selected property
Public property | Type | Type Property
Back to Top
See Also
GlobalCaseDocument Class


GlobalCaseDocument.Category Property

GlobalCaseDocument Category Property GBG Web Service Developers Guide
Category Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Category { get; set; }
public uint Category { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Category();
function set_Category(value);
function get_Category();
function set_Category(value);
Property Value
Type: UInt32

            Document Category

See Also
GlobalCaseDocument Class
GlobalCaseDocument Members


GlobalCaseDocument.Created Property

GlobalCaseDocument Created Property GBG Web Service Developers Guide
Created Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Created { get; set; }
public DateTime Created { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Created();
function set_Created(value);
function get_Created();
function set_Created(value);
Property Value
Type: DateTime

            Date for which a Document was created

See Also
GlobalCaseDocument Class
GlobalCaseDocument Members


GlobalCaseDocument.Deleted Property

GlobalCaseDocument Deleted Property GBG Web Service Developers Guide
Deleted

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> Deleted { get; set; }
public Nullable<DateTime> Deleted { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Deleted();
function set_Deleted(value);
function get_Deleted();
function set_Deleted(value);
Property Value
Type: Nullable DateTime

            Date the document was deleted

See Also
GlobalCaseDocument Class
GlobalCaseDocument Members


GlobalCaseDocument.DocumentID Property

GlobalCaseDocument DocumentID Property GBG Web Service Developers Guide
DocumentID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid DocumentID { get; set; }
public Guid DocumentID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DocumentID();
function set_DocumentID(value);
function get_DocumentID();
function set_DocumentID(value);
Property Value
Type: Guid

            Unique identifier for Document

See Also
GlobalCaseDocument Class
GlobalCaseDocument Members


GlobalCaseDocument.DocumentImageID Property

GlobalCaseDocument DocumentImageID Property GBG Web Service Developers Guide
DIVID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> DocumentImageID { get; set; }
public Nullable<Guid> DocumentImageID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DocumentImageID();
function set_DocumentImageID(value);
function get_DocumentImageID();
function set_DocumentImageID(value);
Property Value
Type: Nullable Guid

            Unique identifier for Document Image

See Also
GlobalCaseDocument Class
GlobalCaseDocument Members


GlobalCaseDocument.EncodedInputData Property

GlobalCaseDocument EncodedInputData Property GBG Web Service Developers Guide
EncodedInputData property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EncodedInputData { get; set; }
public string EncodedInputData { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_EncodedInputData();
function set_EncodedInputData(value);
function get_EncodedInputData();
function set_EncodedInputData(value);
Property Value
Type: String

            The encoded input data for the document

See Also
GlobalCaseDocument Class
GlobalCaseDocument Members


GlobalCaseDocument.Report Property

GlobalCaseDocument Report Property GBG Web Service Developers Guide
Report property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalCaseDocumentReport Report { get; set; }
public GlobalCaseDocumentReport Report { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Report();
function set_Report(value);
function get_Report();
function set_Report(value);
Property Value
Type: GlobalCaseDocumentReport

            The report of the document validation

See Also
GlobalCaseDocument Class
GlobalCaseDocument Members


GlobalCaseDocument.Selected Property

GlobalCaseDocument Selected Property GBG Web Service Developers Guide
Selected property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Selected { get; set; }
public bool Selected { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Selected();
function set_Selected(value);
function get_Selected();
function set_Selected(value);
Property Value
Type: Boolean

            Indicates if the document is selected

See Also
GlobalCaseDocument Class
GlobalCaseDocument Members


GlobalCaseDocument.Type Property

GlobalCaseDocument Type Property GBG Web Service Developers Guide
Type Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Type { get; set; }
public uint Type { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Type();
function set_Type(value);
function get_Type();
function set_Type(value);
Property Value
Type: UInt32

            Document Type

See Also
GlobalCaseDocument Class
GlobalCaseDocument Members


GlobalCaseDocumentReport Class

GlobalCaseDocumentReport Class GBG Web Service Developers Guide
Hold a report of case document based on a validation and an authentication result
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCaseDocumentReport

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCaseDocumentReport
[SerializableAttribute]
public class GlobalCaseDocumentReport
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseDocumentReport = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseDocumentReport');
GlobalCheck.DataLib.GlobalCaseDocumentReport = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseDocumentReport');
See Also
GlobalCaseDocumentReport Members


GlobalCaseDocumentReport Members

GlobalCaseDocumentReport Members GBG Web Service Developers Guide
The GlobalCaseDocumentReport type exposes the following members.
Properties
 | Name | Description
Public property | AuthenticationID | The authentication id
Public property | DocumentType | The document type
Public property | Profile | The profile used for the authentication
Public property | Result | The result generated by the configuration matrix
Public property | ValidationID | The validation id
Back to Top
See Also
GlobalCaseDocumentReport Class


GlobalCaseDocumentReport Properties

GlobalCaseDocumentReport Properties GBG Web Service Developers Guide
The GlobalCaseDocumentReport type exposes the following members.
Properties
 | Name | Description
Public property | AuthenticationID | The authentication id
Public property | DocumentType | The document type
Public property | Profile | The profile used for the authentication
Public property | Result | The result generated by the configuration matrix
Public property | ValidationID | The validation id
Back to Top
See Also
GlobalCaseDocumentReport Class


GlobalCaseDocumentReport.AuthenticationID Property

GlobalCaseDocumentReport AuthenticationID Property GBG Web Service Developers Guide
The authentication id

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> AuthenticationID { get; set; }
public Nullable<Guid> AuthenticationID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AuthenticationID();
function set_AuthenticationID(value);
function get_AuthenticationID();
function set_AuthenticationID(value);
Property Value
Type: Nullable Guid
See Also
GlobalCaseDocumentReport Class
GlobalCaseDocumentReport Members


GlobalCaseDocumentReport.DocumentType Property

GlobalCaseDocumentReport DocumentType Property GBG Web Service Developers Guide
The document type

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalDocumentType DocumentType { get; set; }
public GlobalDocumentType DocumentType { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DocumentType();
function set_DocumentType(value);
function get_DocumentType();
function set_DocumentType(value);
Property Value
Type: GlobalDocumentType
See Also
GlobalCaseDocumentReport Class
GlobalCaseDocumentReport Members


GlobalCaseDocumentReport.Profile Property

GlobalCaseDocumentReport Profile Property GBG Web Service Developers Guide
The profile used for the authentication

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalProfileIDVersion Profile { get; set; }
public GlobalProfileIDVersion Profile { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Profile();
function set_Profile(value);
function get_Profile();
function set_Profile(value);
Property Value
Type: GlobalProfileIDVersion
See Also
GlobalCaseDocumentReport Class
GlobalCaseDocumentReport Members


GlobalCaseDocumentReport.Result Property

GlobalCaseDocumentReport Result Property GBG Web Service Developers Guide
The result generated by the configuration matrix

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalMatrixResult Result { get; set; }
public GlobalMatrixResult Result { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Result();
function set_Result(value);
function get_Result();
function set_Result(value);
Property Value
Type: GlobalMatrixResult
See Also
GlobalCaseDocumentReport Class
GlobalCaseDocumentReport Members


GlobalCaseDocumentReport.ValidationID Property

GlobalCaseDocumentReport ValidationID Property GBG Web Service Developers Guide
The validation id

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ValidationID { get; set; }
public Guid ValidationID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ValidationID();
function set_ValidationID(value);
function get_ValidationID();
function set_ValidationID(value);
Property Value
Type: Guid
See Also
GlobalCaseDocumentReport Class
GlobalCaseDocumentReport Members


GlobalCaseDocumentResult Class

GlobalCaseDocumentResult Class GBG Web Service Developers Guide
Holds the result of a case document
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCaseDocumentResult

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCaseDocumentResult
[SerializableAttribute]
public class GlobalCaseDocumentResult
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseDocumentResult = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseDocumentResult');
GlobalCheck.DataLib.GlobalCaseDocumentResult = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseDocumentResult');
See Also
GlobalCaseDocumentResult Members


GlobalCaseDocumentResult Members

GlobalCaseDocumentResult Members GBG Web Service Developers Guide
The GlobalCaseDocumentResult type exposes the following members.
Properties
 | Name | Description
Public property | AuthDetails | The authentication result data. This value can be null
Public property | DIVData | The DIV result data
Public property | DocumentImageID | Unique identifier of the Document Image
Public property | EncodedInputData | EncodedInputData property
Back to Top
See Also
GlobalCaseDocumentResult Class


GlobalCaseDocumentResult Properties

GlobalCaseDocumentResult Properties GBG Web Service Developers Guide
The GlobalCaseDocumentResult type exposes the following members.
Properties
 | Name | Description
Public property | AuthDetails | The authentication result data. This value can be null
Public property | DIVData | The DIV result data
Public property | DocumentImageID | Unique identifier of the Document Image
Public property | EncodedInputData | EncodedInputData property
Back to Top
See Also
GlobalCaseDocumentResult Class


GlobalCaseDocumentResult.AuthDetails Property

GlobalCaseDocumentResult AuthDetails Property GBG Web Service Developers Guide
The authentication result data. This value can be null

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalAuthenticationDetails AuthDetails { get; set; }
public GlobalAuthenticationDetails AuthDetails { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AuthDetails();
function set_AuthDetails(value);
function get_AuthDetails();
function set_AuthDetails(value);
Property Value
Type: GlobalAuthenticationDetails
See Also
GlobalCaseDocumentResult Class
GlobalCaseDocumentResult Members


GlobalCaseDocumentResult.DIVData Property

GlobalCaseDocumentResult DIVData Property GBG Web Service Developers Guide
The DIV result data

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalDIVData DIVData { get; set; }
public GlobalDIVData DIVData { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DIVData();
function set_DIVData(value);
function get_DIVData();
function set_DIVData(value);
Property Value
Type: GlobalDIVData
See Also
GlobalCaseDocumentResult Class
GlobalCaseDocumentResult Members


GlobalCaseDocumentResult.DocumentImageID Property

GlobalCaseDocumentResult DocumentImageID Property GBG Web Service Developers Guide
Unique identifier of the Document Image

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid DocumentImageID { get; set; }
public Guid DocumentImageID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DocumentImageID();
function set_DocumentImageID(value);
function get_DocumentImageID();
function set_DocumentImageID(value);
Property Value
Type: Guid
See Also
GlobalCaseDocumentResult Class
GlobalCaseDocumentResult Members


GlobalCaseDocumentResult.EncodedInputData Property

GlobalCaseDocumentResult EncodedInputData Property GBG Web Service Developers Guide
EncodedInputData property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EncodedInputData { get; set; }
public string EncodedInputData { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_EncodedInputData();
function set_EncodedInputData(value);
function get_EncodedInputData();
function set_EncodedInputData(value);
Property Value
Type: String

            The encoded input data for the document

See Also
GlobalCaseDocumentResult Class
GlobalCaseDocumentResult Members


GlobalCaseDocumentResultParameters Class

GlobalCaseDocumentResultParameters Class GBG Web Service Developers Guide
Class for passing document result parameters
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCaseResultParameters
GlobalCheck.DataLib GlobalCaseDocumentResultParameters

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCaseDocumentResultParameters : GlobalCaseResultParameters
[SerializableAttribute]
public class GlobalCaseDocumentResultParameters : GlobalCaseResultParameters
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseDocumentResultParameters = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseDocumentResultParameters',
    GlobalCheck.DataLib.GlobalCaseResultParameters);
GlobalCheck.DataLib.GlobalCaseDocumentResultParameters = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseDocumentResultParameters',
    GlobalCheck.DataLib.GlobalCaseResultParameters);
See Also
GlobalCaseDocumentResultParameters Members


GlobalCaseDocumentResultParameters Members

GlobalCaseDocumentResultParameters Members GBG Web Service Developers Guide
The GlobalCaseDocumentResultParameters type exposes the following members.
Properties
 | Name | Description
Public property | MatchItemPassKey | The key for pass match item
Public property | MatchItemWarningKey | The key for warning match item
Public property | RequireValidationTypes | The document types that require validation
Back to Top
See Also
GlobalCaseDocumentResultParameters Class


GlobalCaseDocumentResultParameters Properties

GlobalCaseDocumentResultParameters Properties GBG Web Service Developers Guide
The GlobalCaseDocumentResultParameters type exposes the following members.
Properties
 | Name | Description
Public property | MatchItemPassKey | The key for pass match item
Public property | MatchItemWarningKey | The key for warning match item
Public property | RequireValidationTypes | The document types that require validation
Back to Top
See Also
GlobalCaseDocumentResultParameters Class


GlobalCaseDocumentResultParameters.MatchItemPassKey Property

GlobalCaseDocumentResultParameters MatchItemPassKey Property GBG Web Service Developers Guide
The key for pass match item

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MatchItemPassKey { get; set; }
public string MatchItemPassKey { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MatchItemPassKey();
function set_MatchItemPassKey(value);
function get_MatchItemPassKey();
function set_MatchItemPassKey(value);
Property Value
Type: String
See Also
GlobalCaseDocumentResultParameters Class
GlobalCaseDocumentResultParameters Members


GlobalCaseDocumentResultParameters.MatchItemWarningKey Property

GlobalCaseDocumentResultParameters MatchItemWarningKey Property GBG Web Service Developers Guide
The key for warning match item

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MatchItemWarningKey { get; set; }
public string MatchItemWarningKey { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MatchItemWarningKey();
function set_MatchItemWarningKey(value);
function get_MatchItemWarningKey();
function set_MatchItemWarningKey(value);
Property Value
Type: String
See Also
GlobalCaseDocumentResultParameters Class
GlobalCaseDocumentResultParameters Members


GlobalCaseDocumentResultParameters.RequireValidationTypes Property

GlobalCaseDocumentResultParameters RequireValidationTypes Property GBG Web Service Developers Guide
The document types that require validation

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<uint> RequireValidationTypes { get; set; }
public List<uint> RequireValidationTypes { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_RequireValidationTypes();
function set_RequireValidationTypes(value);
function get_RequireValidationTypes();
function set_RequireValidationTypes(value);
Property Value
Type: List UInt32
See Also
GlobalCaseDocumentResultParameters Class
GlobalCaseDocumentResultParameters Members


GlobalCaseReference Class

GlobalCaseReference Class GBG Web Service Developers Guide
Holds user defined references of a case
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCaseReference

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCaseReference
[SerializableAttribute]
public class GlobalCaseReference
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseReference = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseReference');
GlobalCheck.DataLib.GlobalCaseReference = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseReference');
See Also
GlobalCaseReference Members


GlobalCaseReference Members

GlobalCaseReference Members GBG Web Service Developers Guide
The GlobalCaseReference type exposes the following members.
Properties
 | Name | Description
Public property | Note | The description of the reference
Public property | Type | The type of reference
Back to Top
See Also
GlobalCaseReference Class


GlobalCaseReference Properties

GlobalCaseReference Properties GBG Web Service Developers Guide
The GlobalCaseReference type exposes the following members.
Properties
 | Name | Description
Public property | Note | The description of the reference
Public property | Type | The type of reference
Back to Top
See Also
GlobalCaseReference Class


GlobalCaseReference.Note Property

GlobalCaseReference Note Property GBG Web Service Developers Guide
The description of the reference

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Note { get; set; }
public string Note { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Note();
function set_Note(value);
function get_Note();
function set_Note(value);
Property Value
Type: String

            This property will be validated against the following named regular expression: ShortGeneric
See Also
GlobalCaseReference Class
GlobalCaseReference Members


GlobalCaseReference.Type Property

GlobalCaseReference Type Property GBG Web Service Developers Guide
The type of reference

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Type { get; set; }
public string Type { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Type();
function set_Type(value);
function get_Type();
function set_Type(value);
Property Value
Type: String

            This property will be validated against the following named regular expression: ShortGeneric
See Also
GlobalCaseReference Class
GlobalCaseReference Members


GlobalCaseReport Class

GlobalCaseReport Class GBG Web Service Developers Guide
Hold a report of case based on an authentication result
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCaseReport

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCaseReport
[SerializableAttribute]
public class GlobalCaseReport
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseReport = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseReport');
GlobalCheck.DataLib.GlobalCaseReport = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseReport');
See Also
GlobalCaseReport Members


GlobalCaseReport Members

GlobalCaseReport Members GBG Web Service Developers Guide
The GlobalCaseReport type exposes the following members.
Properties
 | Name | Description
Public property | AuthenticationID | The authentication id
Public property | Profile | The profile used for the authentication
Public property | Result | The result generated by the configuration matrix
Back to Top
See Also
GlobalCaseReport Class


GlobalCaseReport Properties

GlobalCaseReport Properties GBG Web Service Developers Guide
The GlobalCaseReport type exposes the following members.
Properties
 | Name | Description
Public property | AuthenticationID | The authentication id
Public property | Profile | The profile used for the authentication
Public property | Result | The result generated by the configuration matrix
Back to Top
See Also
GlobalCaseReport Class


GlobalCaseReport.AuthenticationID Property

GlobalCaseReport AuthenticationID Property GBG Web Service Developers Guide
The authentication id

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> AuthenticationID { get; set; }
public Nullable<Guid> AuthenticationID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AuthenticationID();
function set_AuthenticationID(value);
function get_AuthenticationID();
function set_AuthenticationID(value);
Property Value
Type: Nullable Guid
See Also
GlobalCaseReport Class
GlobalCaseReport Members


GlobalCaseReport.Profile Property

GlobalCaseReport Profile Property GBG Web Service Developers Guide
The profile used for the authentication

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalProfileIDVersion Profile { get; set; }
public GlobalProfileIDVersion Profile { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Profile();
function set_Profile(value);
function get_Profile();
function set_Profile(value);
Property Value
Type: GlobalProfileIDVersion
See Also
GlobalCaseReport Class
GlobalCaseReport Members


GlobalCaseReport.Result Property

GlobalCaseReport Result Property GBG Web Service Developers Guide
The result generated by the configuration matrix

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalMatrixResult Result { get; set; }
public GlobalMatrixResult Result { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Result();
function set_Result(value);
function get_Result();
function set_Result(value);
Property Value
Type: GlobalMatrixResult
See Also
GlobalCaseReport Class
GlobalCaseReport Members


GlobalCaseResultParameters Class

GlobalCaseResultParameters Class GBG Web Service Developers Guide
Class for passing result parameters
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCaseResultParameters
GlobalCheck.DataLib GlobalCaseDispatchParameters
GlobalCheck.DataLib GlobalCaseDocumentResultParameters

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCaseResultParameters
[SerializableAttribute]
public class GlobalCaseResultParameters
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseResultParameters = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseResultParameters');
GlobalCheck.DataLib.GlobalCaseResultParameters = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseResultParameters');
See Also
GlobalCaseResultParameters Members


GlobalCaseResultParameters Members

GlobalCaseResultParameters Members GBG Web Service Developers Guide
The GlobalCaseResultParameters type exposes the following members.
Properties
 | Name | Description
Public property | ChargingPointProfileIDs | List of ids of the profile associated with the charging point
Public property | CompleteStatus | The status for a completed dispatch
Public property | PendgingStatus | The status for pending results
Public property | ProfileID | The profileID
Public property | Source | The source e.g KYP
Back to Top
See Also
GlobalCaseResultParameters Class


GlobalCaseResultParameters Properties

GlobalCaseResultParameters Properties GBG Web Service Developers Guide
The GlobalCaseResultParameters type exposes the following members.
Properties
 | Name | Description
Public property | ChargingPointProfileIDs | List of ids of the profile associated with the charging point
Public property | CompleteStatus | The status for a completed dispatch
Public property | PendgingStatus | The status for pending results
Public property | ProfileID | The profileID
Public property | Source | The source e.g KYP
Back to Top
See Also
GlobalCaseResultParameters Class


GlobalCaseResultParameters.ChargingPointProfileIDs Property

GlobalCaseResultParameters ChargingPointProfileIDs Property GBG Web Service Developers Guide
List of ids of the profile associated with the charging point

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<Guid> ChargingPointProfileIDs { get; set; }
public List<Guid> ChargingPointProfileIDs { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ChargingPointProfileIDs();
function set_ChargingPointProfileIDs(value);
function get_ChargingPointProfileIDs();
function set_ChargingPointProfileIDs(value);
Property Value
Type: List Guid
See Also
GlobalCaseResultParameters Class
GlobalCaseResultParameters Members


GlobalCaseResultParameters.CompleteStatus Property

GlobalCaseResultParameters CompleteStatus Property GBG Web Service Developers Guide
The status for a completed dispatch

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<uint> CompleteStatus { get; set; }
public Nullable<uint> CompleteStatus { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CompleteStatus();
function set_CompleteStatus(value);
function get_CompleteStatus();
function set_CompleteStatus(value);
Property Value
Type: Nullable UInt32
See Also
GlobalCaseResultParameters Class
GlobalCaseResultParameters Members


GlobalCaseResultParameters.PendgingStatus Property

GlobalCaseResultParameters PendgingStatus Property GBG Web Service Developers Guide
The status for pending results

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<uint> PendgingStatus { get; set; }
public Nullable<uint> PendgingStatus { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PendgingStatus();
function set_PendgingStatus(value);
function get_PendgingStatus();
function set_PendgingStatus(value);
Property Value
Type: Nullable UInt32
See Also
GlobalCaseResultParameters Class
GlobalCaseResultParameters Members


GlobalCaseResultParameters.ProfileID Property

GlobalCaseResultParameters ProfileID Property GBG Web Service Developers Guide
The profileID

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ProfileID { get; set; }
public Guid ProfileID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProfileID();
function set_ProfileID(value);
function get_ProfileID();
function set_ProfileID(value);
Property Value
Type: Guid
See Also
GlobalCaseResultParameters Class
GlobalCaseResultParameters Members


GlobalCaseResultParameters.Source Property

GlobalCaseResultParameters Source Property GBG Web Service Developers Guide
The source e.g KYP

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Source { get; set; }
public string Source { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Source();
function set_Source(value);
function get_Source();
function set_Source(value);
Property Value
Type: String
See Also
GlobalCaseResultParameters Class
GlobalCaseResultParameters Members


GlobalCases Class

GlobalCases Class GBG Web Service Developers Guide
Contains paged results from a request for summary details of Data Cases
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCases

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalCases
public class GlobalCases
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCases = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCases');
GlobalCheck.DataLib.GlobalCases = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCases');
See Also
GlobalCases Members


GlobalCases Members

GlobalCases Members GBG Web Service Developers Guide
The GlobalCases type exposes the following members.
Properties
 | Name | Description
Public property | Cases | Cases Property
Public property | PageSize | PageSize Property
Public property | TotalCases | TotalCases Property
Public property | TotalPages | TotalPages Property
Back to Top
See Also
GlobalCases Class


GlobalCases Properties

GlobalCases Properties GBG Web Service Developers Guide
The GlobalCases type exposes the following members.
Properties
 | Name | Description
Public property | Cases | Cases Property
Public property | PageSize | PageSize Property
Public property | TotalCases | TotalCases Property
Public property | TotalPages | TotalPages Property
Back to Top
See Also
GlobalCases Class


GlobalCases.Cases Property

GlobalCases Cases Property GBG Web Service Developers Guide
Cases Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalCase> Cases { get; set; }
public List<GlobalCase> Cases { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Cases();
function set_Cases(value);
function get_Cases();
function set_Cases(value);
Property Value
Type: List GlobalCase

            Filtered list of Data Cases

See Also
GlobalCases Class
GlobalCases Members


GlobalCases.PageSize Property

GlobalCases PageSize Property GBG Web Service Developers Guide
PageSize Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint PageSize { get; set; }
public uint PageSize { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PageSize();
function set_PageSize(value);
function get_PageSize();
function set_PageSize(value);
Property Value
Type: UInt32

            Maximum number of results returned from the paged request

See Also
GlobalCases Class
GlobalCases Members


GlobalCases.TotalCases Property

GlobalCases TotalCases Property GBG Web Service Developers Guide
TotalCases Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalCases { get; set; }
public uint TotalCases { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalCases();
function set_TotalCases(value);
function get_TotalCases();
function set_TotalCases(value);
Property Value
Type: UInt32

            Total number of Cases matching the query

See Also
GlobalCases Class
GlobalCases Members


GlobalCases.TotalPages Property

GlobalCases TotalPages Property GBG Web Service Developers Guide
TotalPages Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalPages { get; set; }
public uint TotalPages { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalPages();
function set_TotalPages(value);
function get_TotalPages();
function set_TotalPages(value);
Property Value
Type: UInt32

            The total number of pages that would be required to return all the results, based on a page size of PageSize

See Also
GlobalCases Class
GlobalCases Members


GlobalCaseVerdict Class

GlobalCaseVerdict Class GBG Web Service Developers Guide
Holds a summary of the verdicts of a case, extracted from the results
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCaseVerdict

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCaseVerdict
[SerializableAttribute]
public class GlobalCaseVerdict
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCaseVerdict = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseVerdict');
GlobalCheck.DataLib.GlobalCaseVerdict = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCaseVerdict');
See Also
GlobalCaseVerdict Members


GlobalCaseVerdict Members

GlobalCaseVerdict Members GBG Web Service Developers Guide
The GlobalCaseVerdict type exposes the following members.
Properties
 | Name | Description
Public property | ProfileId | The id of the profile associated with the verdict
Public property | Verdict | The verdict indicator
Back to Top
See Also
GlobalCaseVerdict Class


GlobalCaseVerdict Properties

GlobalCaseVerdict Properties GBG Web Service Developers Guide
The GlobalCaseVerdict type exposes the following members.
Properties
 | Name | Description
Public property | ProfileId | The id of the profile associated with the verdict
Public property | Verdict | The verdict indicator
Back to Top
See Also
GlobalCaseVerdict Class


GlobalCaseVerdict.ProfileId Property

GlobalCaseVerdict ProfileId Property GBG Web Service Developers Guide
The id of the profile associated with the verdict

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ProfileId { get; set; }
public Guid ProfileId { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProfileId();
function set_ProfileId(value);
function get_ProfileId();
function set_ProfileId(value);
Property Value
Type: Guid
See Also
GlobalCaseVerdict Class
GlobalCaseVerdict Members


GlobalCaseVerdict.Verdict Property

GlobalCaseVerdict Verdict Property GBG Web Service Developers Guide
The verdict indicator

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Verdict { get; set; }
public int Verdict { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Verdict();
function set_Verdict(value);
function get_Verdict();
function set_Verdict(value);
Property Value
Type: Int32
See Also
GlobalCaseVerdict Class
GlobalCaseVerdict Members


GlobalConditionDecision Class

GlobalConditionDecision Class GBG Web Service Developers Guide
Execution condition based on the Decision Band that is calculated from the current execution position, i.e. from the Item Checks that appear before the current Item Check in the execution order, that have already been processed.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalConditionDecision

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalConditionDecision
[SerializableAttribute]
public class GlobalConditionDecision
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalConditionDecision = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalConditionDecision');
GlobalCheck.DataLib.GlobalConditionDecision = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalConditionDecision');
See Also
GlobalConditionDecision Members


GlobalConditionDecision Members

GlobalConditionDecision Members GBG Web Service Developers Guide
The GlobalConditionDecision type exposes the following members.
Properties
 | Name | Description
Public property | BandTargetText | BandTargetText Property
Public property | TrueIfMatched | TrueIfMatched Property
Back to Top
See Also
GlobalConditionDecision Class


GlobalConditionDecision Properties

GlobalConditionDecision Properties GBG Web Service Developers Guide
The GlobalConditionDecision type exposes the following members.
Properties
 | Name | Description
Public property | BandTargetText | BandTargetText Property
Public property | TrueIfMatched | TrueIfMatched Property
Back to Top
See Also
GlobalConditionDecision Class


GlobalConditionDecision.BandTargetText Property

GlobalConditionDecision BandTargetText Property GBG Web Service Developers Guide
BandTargetText Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BandTargetText { get; set; }
public string BandTargetText { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_BandTargetText();
function set_BandTargetText(value);
function get_BandTargetText();
function set_BandTargetText(value);
Property Value
Type: String

            Decision Band text to match condition on.

See Also
GlobalConditionDecision Class
GlobalConditionDecision Members


GlobalConditionDecision.TrueIfMatched Property

GlobalConditionDecision TrueIfMatched Property GBG Web Service Developers Guide
TrueIfMatched Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TrueIfMatched { get; set; }
public bool TrueIfMatched { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TrueIfMatched();
function set_TrueIfMatched(value);
function get_TrueIfMatched();
function set_TrueIfMatched(value);
Property Value
Type: Boolean

            If true then Execution condition will be met if BandTargetText equals the Decision Band

            If false then Execution condition will be met if BandTargetText does NOT equal the Decision Band

See Also
GlobalConditionDecision Class
GlobalConditionDecision Members


GlobalConditionItemCheck Class

GlobalConditionItemCheck Class GBG Web Service Developers Guide
Execution condition based on whether the Match Threshold from an Item Checks that appear before the current Item Check in the execution order has been met
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalConditionItemCheck

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalConditionItemCheck
[SerializableAttribute]
public class GlobalConditionItemCheck
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalConditionItemCheck = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalConditionItemCheck');
GlobalCheck.DataLib.GlobalConditionItemCheck = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalConditionItemCheck');
See Also
GlobalConditionItemCheck Members


GlobalConditionItemCheck Members

GlobalConditionItemCheck Members GBG Web Service Developers Guide
The GlobalConditionItemCheck type exposes the following members.
Properties
 | Name | Description
Public property | ID | ID Property
Public property | TrueIfMatched | TrueIfMatched Property
Back to Top
See Also
GlobalConditionItemCheck Class


GlobalConditionItemCheck Properties

GlobalConditionItemCheck Properties GBG Web Service Developers Guide
The GlobalConditionItemCheck type exposes the following members.
Properties
 | Name | Description
Public property | ID | ID Property
Public property | TrueIfMatched | TrueIfMatched Property
Back to Top
See Also
GlobalConditionItemCheck Class


GlobalConditionItemCheck.ID Property

GlobalConditionItemCheck ID Property GBG Web Service Developers Guide
ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint ID { get; set; }
public uint ID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ID();
function set_ID(value);
function get_ID();
function set_ID(value);
Property Value
Type: UInt32

            Item Check identifier for an Item Check that appears earlier in the Profile execution order

See Also
GlobalConditionItemCheck Class
GlobalConditionItemCheck Members


GlobalConditionItemCheck.TrueIfMatched Property

GlobalConditionItemCheck TrueIfMatched Property GBG Web Service Developers Guide
TrueIfMatched Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TrueIfMatched { get; set; }
public bool TrueIfMatched { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TrueIfMatched();
function set_TrueIfMatched(value);
function get_TrueIfMatched();
function set_TrueIfMatched(value);
Property Value
Type: Boolean

            If True the Execution condition will be met if the Item Check specified by ID has reached its Match Threshold

            If False the Execution condition will be met if the Item Check specified by ID has NOT reached its Match Threshold

See Also
GlobalConditionItemCheck Class
GlobalConditionItemCheck Members


GlobalConditionResultCode Class

GlobalConditionResultCode Class GBG Web Service Developers Guide
Execution Condition based on Result Code
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalConditionResultCode

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalConditionResultCode
[SerializableAttribute]
public class GlobalConditionResultCode
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalConditionResultCode = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalConditionResultCode');
GlobalCheck.DataLib.GlobalConditionResultCode = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalConditionResultCode');
See Also
GlobalConditionResultCode Members


GlobalConditionResultCode Members

GlobalConditionResultCode Members GBG Web Service Developers Guide
The GlobalConditionResultCode type exposes the following members.
Properties
 | Name | Description
Public property | Code | Code Property
Public property | TrueIfPresent | TrueIfPresent Property
Back to Top
See Also
GlobalConditionResultCode Class


GlobalConditionResultCode Properties

GlobalConditionResultCode Properties GBG Web Service Developers Guide
The GlobalConditionResultCode type exposes the following members.
Properties
 | Name | Description
Public property | Code | Code Property
Public property | TrueIfPresent | TrueIfPresent Property
Back to Top
See Also
GlobalConditionResultCode Class


GlobalConditionResultCode.Code Property

GlobalConditionResultCode Code Property GBG Web Service Developers Guide
Code Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Code { get; set; }
public uint Code { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Code();
function set_Code(value);
function get_Code();
function set_Code(value);
Property Value
Type: UInt32

            Result Code to match against

See Also
GlobalConditionResultCode Class
GlobalConditionResultCode Members


GlobalConditionResultCode.TrueIfPresent Property

GlobalConditionResultCode TrueIfPresent Property GBG Web Service Developers Guide
TrueIfPresent Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TrueIfPresent { get; set; }
public bool TrueIfPresent { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TrueIfPresent();
function set_TrueIfPresent(value);
function get_TrueIfPresent();
function set_TrueIfPresent(value);
Property Value
Type: Boolean

            If true then Execution condition will be met if Code is returned by the Item Check

            If false then Execution condition will be met if Code is NOT returned by the Item Check

See Also
GlobalConditionResultCode Class
GlobalConditionResultCode Members


GlobalConditionResultCodes Class

GlobalConditionResultCodes Class GBG Web Service Developers Guide
Execution conditions based on Result Codes returned from Item Checks that are included earlier in the Profile sequence.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalConditionResultCodes

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalConditionResultCodes
[SerializableAttribute]
public class GlobalConditionResultCodes
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalConditionResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalConditionResultCodes');
GlobalCheck.DataLib.GlobalConditionResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalConditionResultCodes');
See Also
GlobalConditionResultCodes Members


GlobalConditionResultCodes Members

GlobalConditionResultCodes Members GBG Web Service Developers Guide
The GlobalConditionResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | Comment | Comment Property
Public property | ID | ID Property
Public property | Match | Match Property
Public property | Mismatch | Mismatch Property
Public property | Warning | Warning Property
Back to Top
See Also
GlobalConditionResultCodes Class


GlobalConditionResultCodes Properties

GlobalConditionResultCodes Properties GBG Web Service Developers Guide
The GlobalConditionResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | Comment | Comment Property
Public property | ID | ID Property
Public property | Match | Match Property
Public property | Mismatch | Mismatch Property
Public property | Warning | Warning Property
Back to Top
See Also
GlobalConditionResultCodes Class


GlobalConditionResultCodes.Comment Property

GlobalConditionResultCodes Comment Property GBG Web Service Developers Guide
Comment Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalConditionResultCode> Comment { get; set; }
public List<GlobalConditionResultCode> Comment { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Comment();
function set_Comment(value);
function get_Comment();
function set_Comment(value);
Property Value
Type: List GlobalConditionResultCode

            Result Code conditions within the 'Comment' category range

See Also
GlobalConditionResultCodes Class
GlobalConditionResultCodes Members


GlobalConditionResultCodes.ID Property

GlobalConditionResultCodes ID Property GBG Web Service Developers Guide
ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint ID { get; set; }
public uint ID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ID();
function set_ID(value);
function get_ID();
function set_ID(value);
Property Value
Type: UInt32

            Item Check Identifier

See Also
GlobalConditionResultCodes Class
GlobalConditionResultCodes Members


GlobalConditionResultCodes.Match Property

GlobalConditionResultCodes Match Property GBG Web Service Developers Guide
Match Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalConditionResultCode> Match { get; set; }
public List<GlobalConditionResultCode> Match { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Match();
function set_Match(value);
function get_Match();
function set_Match(value);
Property Value
Type: List GlobalConditionResultCode

            Result Code conditions within the 'Match' category range

See Also
GlobalConditionResultCodes Class
GlobalConditionResultCodes Members


GlobalConditionResultCodes.Mismatch Property

GlobalConditionResultCodes Mismatch Property GBG Web Service Developers Guide
Mismatch Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalConditionResultCode> Mismatch { get; set; }
public List<GlobalConditionResultCode> Mismatch { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Mismatch();
function set_Mismatch(value);
function get_Mismatch();
function set_Mismatch(value);
Property Value
Type: List GlobalConditionResultCode

            Result Code conditions within the 'Mismatch' category range

See Also
GlobalConditionResultCodes Class
GlobalConditionResultCodes Members


GlobalConditionResultCodes.Warning Property

GlobalConditionResultCodes Warning Property GBG Web Service Developers Guide
Warning Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalConditionResultCode> Warning { get; set; }
public List<GlobalConditionResultCode> Warning { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Warning();
function set_Warning(value);
function get_Warning();
function set_Warning(value);
Property Value
Type: List GlobalConditionResultCode

            Result Code conditions within the 'Warning' category range

See Also
GlobalConditionResultCodes Class
GlobalConditionResultCodes Members


GlobalConditionScore Class

GlobalConditionScore Class GBG Web Service Developers Guide
Execution condition based on the Score that is calculated from the current execution position, i.e. from the Item Checks that appear before the current Item Check in the execution order, that have already been processed.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalConditionScore

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalConditionScore
[SerializableAttribute]
public class GlobalConditionScore
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalConditionScore = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalConditionScore');
GlobalCheck.DataLib.GlobalConditionScore = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalConditionScore');
See Also
GlobalConditionScore Members


GlobalConditionScore Members

GlobalConditionScore Members GBG Web Service Developers Guide
The GlobalConditionScore type exposes the following members.
Properties
 | Name | Description
Public property | ScoreTargetVal | ScoreTargetVal Property
Public property | TrueIfGTEQ | TrueIfGTEQ Property
Back to Top
See Also
GlobalConditionScore Class


GlobalConditionScore Properties

GlobalConditionScore Properties GBG Web Service Developers Guide
The GlobalConditionScore type exposes the following members.
Properties
 | Name | Description
Public property | ScoreTargetVal | ScoreTargetVal Property
Public property | TrueIfGTEQ | TrueIfGTEQ Property
Back to Top
See Also
GlobalConditionScore Class


GlobalConditionScore.ScoreTargetVal Property

GlobalConditionScore ScoreTargetVal Property GBG Web Service Developers Guide
ScoreTargetVal Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ScoreTargetVal { get; set; }
public int ScoreTargetVal { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ScoreTargetVal();
function set_ScoreTargetVal(value);
function get_ScoreTargetVal();
function set_ScoreTargetVal(value);
Property Value
Type: Int32

            Score Threshold

See Also
GlobalConditionScore Class
GlobalConditionScore Members


GlobalConditionScore.TrueIfGTEQ Property

GlobalConditionScore TrueIfGTEQ Property GBG Web Service Developers Guide
TrueIfGTEQ Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TrueIfGTEQ { get; set; }
public bool TrueIfGTEQ { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TrueIfGTEQ();
function set_TrueIfGTEQ(value);
function get_TrueIfGTEQ();
function set_TrueIfGTEQ(value);
Property Value
Type: Boolean

            If set to True the value of ScoreTargetVal must be met or exceeded by the score for the Execution condition to be met

            If set to False the score must be less than the value of ScoreTargetVal for the Execution condition to be met

See Also
GlobalConditionScore Class
GlobalConditionScore Members


GlobalConsentVerdict Enumeration

GlobalConsentVerdict Enumeration GBG Web Service Developers Guide

[Missing <summary> documentation for "T:GlobalCheck.DataLib.GlobalConsentVerdict"]

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalConsentVerdict
[SerializableAttribute]
public enum GlobalConsentVerdict
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalConsentVerdict = function();
GlobalCheck.DataLib.GlobalConsentVerdict.createEnum('GlobalCheck.DataLib.GlobalConsentVerdict', false);
GlobalCheck.DataLib.GlobalConsentVerdict = function();
GlobalCheck.DataLib.GlobalConsentVerdict.createEnum('GlobalCheck.DataLib.GlobalConsentVerdict', false);
Members
Member name | Value | Description
None | 0 | No verdict
Approved | 1 | Approved
Reject | 2 | Reject
RequestInfo | 3 | Reject
Cancel | 4 | Cancel
See Also


GlobalContact Class

GlobalContact Class GBG Web Service Developers Guide
Contact details for Organisation
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalContact

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalContact
public class GlobalContact
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalContact = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalContact');
GlobalCheck.DataLib.GlobalContact = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalContact');
See Also
GlobalContact Members


GlobalContact Members

GlobalContact Members GBG Web Service Developers Guide
The GlobalContact type exposes the following members.
Properties
 | Name | Description
Public property | Emails | Emails Property
Public property | Name | Name Property
Public property | Telephone | Telephone Property
Back to Top
See Also
GlobalContact Class


GlobalContact Properties

GlobalContact Properties GBG Web Service Developers Guide
The GlobalContact type exposes the following members.
Properties
 | Name | Description
Public property | Emails | Emails Property
Public property | Name | Name Property
Public property | Telephone | Telephone Property
Back to Top
See Also
GlobalContact Class


GlobalContact.Emails Property

GlobalContact Emails Property GBG Web Service Developers Guide
Emails Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> Emails { get; set; }
public List<string> Emails { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Emails();
function set_Emails(value);
function get_Emails();
function set_Emails(value);
Property Value
Type: List String

            List of contact email addresses

See Also
GlobalContact Class
GlobalContact Members


GlobalContact.Name Property

GlobalContact Name Property GBG Web Service Developers Guide
Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String

            Contact Name

See Also
GlobalContact Class
GlobalContact Members


GlobalContact.Telephone Property

GlobalContact Telephone Property GBG Web Service Developers Guide
Telephone Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Telephone { get; set; }
public string Telephone { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Telephone();
function set_Telephone(value);
function get_Telephone();
function set_Telephone(value);
Property Value
Type: String

            Contact Telephone Number

See Also
GlobalContact Class
GlobalContact Members


GlobalContactDetails Class

GlobalContactDetails Class GBG Web Service Developers Guide
Contains Contact details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalContactDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalContactDetails
[SerializableAttribute]
public class GlobalContactDetails
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalContactDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalContactDetails');
GlobalCheck.DataLib.GlobalContactDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalContactDetails');
See Also
GlobalContactDetails Members


GlobalContactDetails Members

GlobalContactDetails Members GBG Web Service Developers Guide
The GlobalContactDetails type exposes the following members.
Properties
 | Name | Description
Public property | Email | Email Property
Public property | LandTelephone | Land Telephone Property
Public property | MobileTelephone | Mobile Telephone Property
Public property | WorkTelephone | Work Telephone Property
Back to Top
See Also
GlobalContactDetails Class


GlobalContactDetails Properties

GlobalContactDetails Properties GBG Web Service Developers Guide
The GlobalContactDetails type exposes the following members.
Properties
 | Name | Description
Public property | Email | Email Property
Public property | LandTelephone | Land Telephone Property
Public property | MobileTelephone | Mobile Telephone Property
Public property | WorkTelephone | Work Telephone Property
Back to Top
See Also
GlobalContactDetails Class


GlobalContactDetails.Email Property

GlobalContactDetails Email Property GBG Web Service Developers Guide
Email Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Email { get; set; }
public string Email { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Email();
function set_Email(value);
function get_Email();
function set_Email(value);
Property Value
Type: String

            Contains an individuals email address.This property may be omitted or set to an empty string to indicate no value was supplied
            This property will be validated against the following named regular expression: Email
See Also
GlobalContactDetails Class
GlobalContactDetails Members


GlobalContactDetails.LandTelephone Property

GlobalContactDetails LandTelephone Property GBG Web Service Developers Guide
Land Telephone Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalLandTelephone LandTelephone { get; set; }
public GlobalLandTelephone LandTelephone { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_LandTelephone();
function set_LandTelephone(value);
function get_LandTelephone();
function set_LandTelephone(value);
Property Value
Type: GlobalLandTelephone
See Also
GlobalContactDetails Class
GlobalContactDetails Members


GlobalContactDetails.MobileTelephone Property

GlobalContactDetails MobileTelephone Property GBG Web Service Developers Guide
Mobile Telephone Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalMobileTelephone MobileTelephone { get; set; }
public GlobalMobileTelephone MobileTelephone { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MobileTelephone();
function set_MobileTelephone(value);
function get_MobileTelephone();
function set_MobileTelephone(value);
Property Value
Type: GlobalMobileTelephone
See Also
GlobalContactDetails Class
GlobalContactDetails Members


GlobalContactDetails.WorkTelephone Property

GlobalContactDetails WorkTelephone Property GBG Web Service Developers Guide
Work Telephone Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalWorkTelephone WorkTelephone { get; set; }
public GlobalWorkTelephone WorkTelephone { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_WorkTelephone();
function set_WorkTelephone(value);
function get_WorkTelephone();
function set_WorkTelephone(value);
Property Value
Type: GlobalWorkTelephone
See Also
GlobalContactDetails Class
GlobalContactDetails Members


GlobalCountry Class

GlobalCountry Class GBG Web Service Developers Guide
Contains the country codes and names for all the countries.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCountry

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCountry
[SerializableAttribute]
public class GlobalCountry
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCountry = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCountry');
GlobalCheck.DataLib.GlobalCountry = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCountry');
See Also
GlobalCountry Members


GlobalCountry Members

GlobalCountry Members GBG Web Service Developers Guide
The GlobalCountry type exposes the following members.
Properties
 | Name | Description
 | CardCountries | Issuing Countries Supported by GetCardCountries method
Public property | CountryCode | Country Code Property
 | IDCardIssuingCountries | Issuing Countries Supported by Identity Card Check
 | IDCardNationalityCountries | Countries Supported by Identity Card Check for the Country of Nationality
Public property | Name | Country Name Property
 | OnlineLocationCountries | Countries Supported by Online Location (IP Verification) Check
 | PassportCountries | Countries supported by International Passport Check
Back to Top
See Also
GlobalCountry Class


GlobalCountry Properties

GlobalCountry Properties GBG Web Service Developers Guide
The GlobalCountry type exposes the following members.
Properties
 | Name | Description
 | CardCountries | Issuing Countries Supported by GetCardCountries method
Public property | CountryCode | Country Code Property
 | IDCardIssuingCountries | Issuing Countries Supported by Identity Card Check
 | IDCardNationalityCountries | Countries Supported by Identity Card Check for the Country of Nationality
Public property | Name | Country Name Property
 | OnlineLocationCountries | Countries Supported by Online Location (IP Verification) Check
 | PassportCountries | Countries supported by International Passport Check
Back to Top
See Also
GlobalCountry Class


GlobalCountry.CardCountries Property

GlobalCountry CardCountries Property GBG Web Service Developers Guide
Issuing Countries Supported by GetCardCountries method

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<GlobalCountry> CardCountries { get; }
public static List<GlobalCountry> CardCountries { get; }
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCountry.get_CardCountries = function();
GlobalCheck.DataLib.GlobalCountry.get_CardCountries = function();
Property Value
Type: List GlobalCountry
See Also
GlobalCountry Class
GlobalCountry Members


GlobalCountry.CountryCode Property

GlobalCountry CountryCode Property GBG Web Service Developers Guide
Country Code Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CountryCode { get; set; }
public string CountryCode { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CountryCode();
function set_CountryCode(value);
function get_CountryCode();
function set_CountryCode(value);
Property Value
Type: String
See Also
GlobalCountry Class
GlobalCountry Members


GlobalCountry.IDCardIssuingCountries Property

GlobalCountry IDCardIssuingCountries Property GBG Web Service Developers Guide
Issuing Countries Supported by Identity Card Check

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<GlobalCountry> IDCardIssuingCountries { get; }
public static List<GlobalCountry> IDCardIssuingCountries { get; }
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCountry.get_IDCardIssuingCountries = function();
GlobalCheck.DataLib.GlobalCountry.get_IDCardIssuingCountries = function();
Property Value
Type: List GlobalCountry
See Also
GlobalCountry Class
GlobalCountry Members


GlobalCountry.IDCardNationalityCountries Property

GlobalCountry IDCardNationalityCountries Property GBG Web Service Developers Guide
Countries Supported by Identity Card Check for the Country of Nationality

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<GlobalCountry> IDCardNationalityCountries { get; }
public static List<GlobalCountry> IDCardNationalityCountries { get; }
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCountry.get_IDCardNationalityCountries = function();
GlobalCheck.DataLib.GlobalCountry.get_IDCardNationalityCountries = function();
Property Value
Type: List GlobalCountry
See Also
GlobalCountry Class
GlobalCountry Members


GlobalCountry.Name Property

GlobalCountry Name Property GBG Web Service Developers Guide
Country Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String
See Also
GlobalCountry Class
GlobalCountry Members


GlobalCountry.OnlineLocationCountries Property

GlobalCountry OnlineLocationCountries Property GBG Web Service Developers Guide
Countries Supported by Online Location (IP Verification) Check

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<GlobalCountry> OnlineLocationCountries { get; }
public static List<GlobalCountry> OnlineLocationCountries { get; }
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCountry.get_OnlineLocationCountries = function();
GlobalCheck.DataLib.GlobalCountry.get_OnlineLocationCountries = function();
Property Value
Type: List GlobalCountry
See Also
GlobalCountry Class
GlobalCountry Members


GlobalCountry.PassportCountries Property

GlobalCountry PassportCountries Property GBG Web Service Developers Guide
Countries supported by International Passport Check

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<GlobalCountry> PassportCountries { get; }
public static List<GlobalCountry> PassportCountries { get; }
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCountry.get_PassportCountries = function();
GlobalCheck.DataLib.GlobalCountry.get_PassportCountries = function();
Property Value
Type: List GlobalCountry
See Also
GlobalCountry Class
GlobalCountry Members


GlobalCreditDebitCard Class

GlobalCreditDebitCard Class GBG Web Service Developers Guide
Contains details of credit/debit card
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCreditDebitCard

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCreditDebitCard
[SerializableAttribute]
public class GlobalCreditDebitCard
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCreditDebitCard = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCreditDebitCard');
GlobalCheck.DataLib.GlobalCreditDebitCard = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCreditDebitCard');
See Also
GlobalCreditDebitCard Members


GlobalCreditDebitCard Members

GlobalCreditDebitCard Members GBG Web Service Developers Guide
The GlobalCreditDebitCard type exposes the following members.
Properties
 | Name | Description
Public property | CardHolderName | Card Holder Name Property
Public property | CardIssueNumber | Issue Number Property
Public property | CardNumber | Card Number Property
Public property | CardType | Card type Property
Public property | CardVerificationCode | Verification code Property
Public property | Country | Country Property
Public property | ExpiryMonth | Expiry Month Property
Public property | ExpiryYear | Expiry Year Property
Public property | MerchantData | Merchant data Property
Public property | StartMonth | Start Month Property
Public property | StartYear | Start Year Property
Public property | State | State Property
Public property | ThreeDSecureResponse | ThreeD Secure Response Property
Back to Top
See Also
GlobalCreditDebitCard Class


GlobalCreditDebitCard Properties

GlobalCreditDebitCard Properties GBG Web Service Developers Guide
The GlobalCreditDebitCard type exposes the following members.
Properties
 | Name | Description
Public property | CardHolderName | Card Holder Name Property
Public property | CardIssueNumber | Issue Number Property
Public property | CardNumber | Card Number Property
Public property | CardType | Card type Property
Public property | CardVerificationCode | Verification code Property
Public property | Country | Country Property
Public property | ExpiryMonth | Expiry Month Property
Public property | ExpiryYear | Expiry Year Property
Public property | MerchantData | Merchant data Property
Public property | StartMonth | Start Month Property
Public property | StartYear | Start Year Property
Public property | State | State Property
Public property | ThreeDSecureResponse | ThreeD Secure Response Property
Back to Top
See Also
GlobalCreditDebitCard Class


GlobalCreditDebitCard.CardHolderName Property

GlobalCreditDebitCard CardHolderName Property GBG Web Service Developers Guide
Card Holder Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CardHolderName { get; set; }
public string CardHolderName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CardHolderName();
function set_CardHolderName(value);
function get_CardHolderName();
function set_CardHolderName(value);
Property Value
Type: String

            Name of the card holder as printed on the card. This property is ignored if Buynet is used to perform the check.
            This property will be validated against the following named regular expression: CardHolder
See Also
GlobalCreditDebitCard Class
GlobalCreditDebitCard Members


GlobalCreditDebitCard.CardIssueNumber Property

GlobalCreditDebitCard CardIssueNumber Property GBG Web Service Developers Guide
Issue Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CardIssueNumber { get; set; }
public string CardIssueNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CardIssueNumber();
function set_CardIssueNumber(value);
function get_CardIssueNumber();
function set_CardIssueNumber(value);
Property Value
Type: String

            Issue number for SWITCH/MAESTRO cards. This property may be omitted or set to an empty string to indicate no value was supplied provided the card type is not SWITCH/MAESTRO.
            This property will be validated against the following named regular expression: CardIssueNumber
See Also
GlobalCreditDebitCard Class
GlobalCreditDebitCard Members


GlobalCreditDebitCard.CardNumber Property

GlobalCreditDebitCard CardNumber Property GBG Web Service Developers Guide
Card Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CardNumber { get; set; }
public string CardNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CardNumber();
function set_CardNumber(value);
function get_CardNumber();
function set_CardNumber(value);
Property Value
Type: String

            Card Number. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: CardNumber
See Also
GlobalCreditDebitCard Class
GlobalCreditDebitCard Members


GlobalCreditDebitCard.CardType Property

GlobalCreditDebitCard CardType Property GBG Web Service Developers Guide
Card type Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalCardType CardType { get; set; }
public GlobalCardType CardType { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CardType();
function set_CardType(value);
function get_CardType();
function set_CardType(value);
Property Value
Type: GlobalCardType

            This property may be omitted to indicate that this information is not available.
            Possible values are:
            VISA
            MASTERCARD
            DELTA
            SWITCH
            AMEX
            MAESTRO
            JCB
            DINERS
            ELECTRON
            SOLO
            CARTEBANCAIRE
            CARTEBLEUE
            LASER
            DISCOVER
            DANKORT

See Also
GlobalCreditDebitCard Class
GlobalCreditDebitCard Members


GlobalCreditDebitCard.CardVerificationCode Property

GlobalCreditDebitCard CardVerificationCode Property GBG Web Service Developers Guide
Verification code Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CardVerificationCode { get; set; }
public string CardVerificationCode { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CardVerificationCode();
function set_CardVerificationCode(value);
function get_CardVerificationCode();
function set_CardVerificationCode(value);
Property Value
Type: String

            4 digits for Amex card, 3 digits for all other card types. This property may be omitted or set to an empty string to indicate no value was supplied.
            Note. This value is not stored in the audit log.
            This property will be validated against the following named regular expression: CardVerificationCode
See Also
GlobalCreditDebitCard Class
GlobalCreditDebitCard Members


GlobalCreditDebitCard.Country Property

GlobalCreditDebitCard Country Property GBG Web Service Developers Guide
Country Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Country { get; set; }
public string Country { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Country();
function set_Country(value);
function get_Country();
function set_Country(value);
Property Value
Type: String

            The country where the card was issued .
            This property will be validated against the following named regular expression: Country
See Also
GlobalCreditDebitCard Class
GlobalCreditDebitCard Members


GlobalCreditDebitCard.ExpiryMonth Property

GlobalCreditDebitCard ExpiryMonth Property GBG Web Service Developers Guide
Expiry Month Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExpiryMonth { get; set; }
public int ExpiryMonth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryMonth();
function set_ExpiryMonth(value);
function get_ExpiryMonth();
function set_ExpiryMonth(value);
Property Value
Type: Int32

            Integer in the range 1-12 representing the calendar month of an individuals card expiry date.
            This property will be validated against the following named regular expression: Month
See Also
GlobalCreditDebitCard Class
GlobalCreditDebitCard Members


GlobalCreditDebitCard.ExpiryYear Property

GlobalCreditDebitCard ExpiryYear Property GBG Web Service Developers Guide
Expiry Year Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExpiryYear { get; set; }
public int ExpiryYear { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryYear();
function set_ExpiryYear(value);
function get_ExpiryYear();
function set_ExpiryYear(value);
Property Value
Type: Int32

            Integer in the range 1-12 representing the calendar month of an individuals card expiry date.
            This property will be validated against the following named regular expression: Year
See Also
GlobalCreditDebitCard Class
GlobalCreditDebitCard Members


GlobalCreditDebitCard.MerchantData Property

GlobalCreditDebitCard MerchantData Property GBG Web Service Developers Guide
Merchant data Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MerchantData { get; set; }
public string MerchantData { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MerchantData();
function set_MerchantData(value);
function get_MerchantData();
function set_MerchantData(value);
Property Value
Type: String

            MerchantData string for 3DSecure. This property must be supplied if a 3DSecure check is used to perform the check.
            This property will be validated against the following named regular expression: MerchantData
See Also
GlobalCreditDebitCard Class
GlobalCreditDebitCard Members


GlobalCreditDebitCard.StartMonth Property

GlobalCreditDebitCard StartMonth Property GBG Web Service Developers Guide
Start Month Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int StartMonth { get; set; }
public int StartMonth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_StartMonth();
function set_StartMonth(value);
function get_StartMonth();
function set_StartMonth(value);
Property Value
Type: Int32

            Integer in the range 1-12 representing the calendar month of an individuals card start date.
            This property will be validated against the following named regular expression: Month
See Also
GlobalCreditDebitCard Class
GlobalCreditDebitCard Members


GlobalCreditDebitCard.StartYear Property

GlobalCreditDebitCard StartYear Property GBG Web Service Developers Guide
Start Year Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int StartYear { get; set; }
public int StartYear { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_StartYear();
function set_StartYear(value);
function get_StartYear();
function set_StartYear(value);
Property Value
Type: Int32

            Integer in the range 1-12 representing the calendar month of an individuals card start date.
            This property will be validated against the following named regular expression: Year
See Also
GlobalCreditDebitCard Class
GlobalCreditDebitCard Members


GlobalCreditDebitCard.State Property

GlobalCreditDebitCard State Property GBG Web Service Developers Guide
State Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string State { get; set; }
public string State { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_State();
function set_State(value);
function get_State();
function set_State(value);
Property Value
Type: String

            The state/county of the registered address.
            This property will be validated against the following named regular expression: State
See Also
GlobalCreditDebitCard Class
GlobalCreditDebitCard Members


GlobalCreditDebitCard.ThreeDSecureResponse Property

GlobalCreditDebitCard ThreeDSecureResponse Property GBG Web Service Developers Guide
ThreeD Secure Response Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ThreeDSecureResponse { get; set; }
public string ThreeDSecureResponse { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ThreeDSecureResponse();
function set_ThreeDSecureResponse(value);
function get_ThreeDSecureResponse();
function set_ThreeDSecureResponse(value);
Property Value
Type: String

            3D Secure Response. This property must be supplied if a 3DSecure check is used to perform the check.
            This property will be validated against the following named regular expression: ThreeDSecureResponse
See Also
GlobalCreditDebitCard Class
GlobalCreditDebitCard Members


GlobalCreditReportResultCodes Class

GlobalCreditReportResultCodes Class GBG Web Service Developers Guide
Results data returned by the CreditReport Item Check
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalItemCheckResultCodes
GlobalCheck.DataLib GlobalCreditReportResultCodes

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCreditReportResultCodes : GlobalItemCheckResultCodes
[SerializableAttribute]
public class GlobalCreditReportResultCodes : GlobalItemCheckResultCodes
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCreditReportResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCreditReportResultCodes',
    GlobalCheck.DataLib.GlobalItemCheckResultCodes);
GlobalCheck.DataLib.GlobalCreditReportResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCreditReportResultCodes',
    GlobalCheck.DataLib.GlobalItemCheckResultCodes);
See Also
GlobalCreditReportResultCodes Members


GlobalCreditReportResultCodes Members

GlobalCreditReportResultCodes Members GBG Web Service Developers Guide
The GlobalCreditReportResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | CreditReportID | CreditReportID Property
Public property | Score | Score Property
Public property | SearchPurposeCode | SearchPurposeCode Property
Public property | SearchPurposeName | SearchPurposeName Property
Back to Top
See Also
GlobalCreditReportResultCodes Class


GlobalCreditReportResultCodes Properties

GlobalCreditReportResultCodes Properties GBG Web Service Developers Guide
The GlobalCreditReportResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | CreditReportID | CreditReportID Property
Public property | Score | Score Property
Public property | SearchPurposeCode | SearchPurposeCode Property
Public property | SearchPurposeName | SearchPurposeName Property
Back to Top
See Also
GlobalCreditReportResultCodes Class


GlobalCreditReportResultCodes.CreditReportID Property

GlobalCreditReportResultCodes CreditReportID Property GBG Web Service Developers Guide
CreditReportID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid CreditReportID { get; set; }
public Guid CreditReportID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CreditReportID();
function set_CreditReportID(value);
function get_CreditReportID();
function set_CreditReportID(value);
Property Value
Type: Guid
Credit Report Unique Identifier
See Also
GlobalCreditReportResultCodes Class
GlobalCreditReportResultCodes Members


GlobalCreditReportResultCodes.Score Property

GlobalCreditReportResultCodes Score Property GBG Web Service Developers Guide
Score Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Score { get; set; }
public int Score { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Score();
function set_Score(value);
function get_Score();
function set_Score(value);
Property Value
Type: Int32

            Legacy Creditlite score for historic URU transactions

See Also
GlobalCreditReportResultCodes Class
GlobalCreditReportResultCodes Members


GlobalCreditReportResultCodes.SearchPurposeCode Property

GlobalCreditReportResultCodes SearchPurposeCode Property GBG Web Service Developers Guide
SearchPurposeCode Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SearchPurposeCode { get; set; }
public string SearchPurposeCode { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SearchPurposeCode();
function set_SearchPurposeCode(value);
function get_SearchPurposeCode();
function set_SearchPurposeCode(value);
Property Value
Type: String
Search Purpose Code used for the Credit Report search
See Also
GlobalCreditReportResultCodes Class
GlobalCreditReportResultCodes Members


GlobalCreditReportResultCodes.SearchPurposeName Property

GlobalCreditReportResultCodes SearchPurposeName Property GBG Web Service Developers Guide
SearchPurposeName Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SearchPurposeName { get; set; }
public string SearchPurposeName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SearchPurposeName();
function set_SearchPurposeName(value);
function get_SearchPurposeName();
function set_SearchPurposeName(value);
Property Value
Type: String
Search Purpose Name used for the Credit Report search
See Also
GlobalCreditReportResultCodes Class
GlobalCreditReportResultCodes Members


GlobalCriminalRecordCheckDisclosure Class

GlobalCriminalRecordCheckDisclosure Class GBG Web Service Developers Guide
Criminal Record Check disclosure report information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCriminalRecordCheckDisclosure

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCriminalRecordCheckDisclosure
[SerializableAttribute]
public class GlobalCriminalRecordCheckDisclosure
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCriminalRecordCheckDisclosure = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCriminalRecordCheckDisclosure');
GlobalCheck.DataLib.GlobalCriminalRecordCheckDisclosure = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCriminalRecordCheckDisclosure');
See Also
GlobalCriminalRecordCheckDisclosure Members


GlobalCriminalRecordCheckDisclosure Members

GlobalCriminalRecordCheckDisclosure Members GBG Web Service Developers Guide
The GlobalCriminalRecordCheckDisclosure type exposes the following members.
Properties
 | Name | Description
Public property | AdditionalInformation | The Type Literal
Public property | CriminalRecordCheckDisclosureOffences | CriminalRecordCheckDisclosureOffences Property
Public property | DisclosureDate | The disclosure date
Public property | Reference | Reference Property
Public property | Status | Status Property
Back to Top
See Also
GlobalCriminalRecordCheckDisclosure Class


GlobalCriminalRecordCheckDisclosure Properties

GlobalCriminalRecordCheckDisclosure Properties GBG Web Service Developers Guide
The GlobalCriminalRecordCheckDisclosure type exposes the following members.
Properties
 | Name | Description
Public property | AdditionalInformation | The Type Literal
Public property | CriminalRecordCheckDisclosureOffences | CriminalRecordCheckDisclosureOffences Property
Public property | DisclosureDate | The disclosure date
Public property | Reference | Reference Property
Public property | Status | Status Property
Back to Top
See Also
GlobalCriminalRecordCheckDisclosure Class


GlobalCriminalRecordCheckDisclosure.AdditionalInformation Property

GlobalCriminalRecordCheckDisclosure AdditionalInformation Property GBG Web Service Developers Guide
The Type Literal

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AdditionalInformation { get; set; }
public string AdditionalInformation { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AdditionalInformation();
function set_AdditionalInformation(value);
function get_AdditionalInformation();
function set_AdditionalInformation(value);
Property Value
Type: String

            Contains the Type Literal
            This property will be validated against the following named regular expression: Generic
See Also
GlobalCriminalRecordCheckDisclosure Class
GlobalCriminalRecordCheckDisclosure Members


GlobalCriminalRecordCheckDisclosure.CriminalRecordCheckDisclosureOffences Property

GlobalCriminalRecordCheckDisclosure CriminalRecordCheckDisclosureOffences Property GBG Web Service Developers Guide
CriminalRecordCheckDisclosureOffences Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalCriminalRecordCheckDisclosureOffence> CriminalRecordCheckDisclosureOffences { get; set; }
public List<GlobalCriminalRecordCheckDisclosureOffence> CriminalRecordCheckDisclosureOffences { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CriminalRecordCheckDisclosureOffences();
function set_CriminalRecordCheckDisclosureOffences(value);
function get_CriminalRecordCheckDisclosureOffences();
function set_CriminalRecordCheckDisclosureOffences(value);
Property Value
Type: List GlobalCriminalRecordCheckDisclosureOffence

            Contains the CriminalRecordCheckDisclosureOffences

See Also
GlobalCriminalRecordCheckDisclosure Class
GlobalCriminalRecordCheckDisclosure Members


GlobalCriminalRecordCheckDisclosure.DisclosureDate Property

GlobalCriminalRecordCheckDisclosure DisclosureDate Property GBG Web Service Developers Guide
The disclosure date

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime DisclosureDate { get; set; }
public DateTime DisclosureDate { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DisclosureDate();
function set_DisclosureDate(value);
function get_DisclosureDate();
function set_DisclosureDate(value);
Property Value
Type: DateTime
See Also
GlobalCriminalRecordCheckDisclosure Class
GlobalCriminalRecordCheckDisclosure Members


GlobalCriminalRecordCheckDisclosure.Reference Property

GlobalCriminalRecordCheckDisclosure Reference Property GBG Web Service Developers Guide
Reference Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Reference { get; set; }
public string Reference { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Reference();
function set_Reference(value);
function get_Reference();
function set_Reference(value);
Property Value
Type: String

            Contains the disclosure reference
            This property will be validated against the following named regular expression: ShortGeneric
See Also
GlobalCriminalRecordCheckDisclosure Class
GlobalCriminalRecordCheckDisclosure Members


GlobalCriminalRecordCheckDisclosure.Status Property

GlobalCriminalRecordCheckDisclosure Status Property GBG Web Service Developers Guide
Status Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Status { get; set; }
public int Status { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Status();
function set_Status(value);
function get_Status();
function set_Status(value);
Property Value
Type: Int32
See Also
GlobalCriminalRecordCheckDisclosure Class
GlobalCriminalRecordCheckDisclosure Members


GlobalCriminalRecordCheckDisclosureOffence Class

GlobalCriminalRecordCheckDisclosureOffence Class GBG Web Service Developers Guide
Criminal record check disclosure offense information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalCriminalRecordCheckDisclosureOffence

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalCriminalRecordCheckDisclosureOffence
[SerializableAttribute]
public class GlobalCriminalRecordCheckDisclosureOffence
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCriminalRecordCheckDisclosureOffence = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCriminalRecordCheckDisclosureOffence');
GlobalCheck.DataLib.GlobalCriminalRecordCheckDisclosureOffence = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalCriminalRecordCheckDisclosureOffence');
See Also
GlobalCriminalRecordCheckDisclosureOffence Members


GlobalCriminalRecordCheckDisclosureOffence Members

GlobalCriminalRecordCheckDisclosureOffence Members GBG Web Service Developers Guide
The GlobalCriminalRecordCheckDisclosureOffence type exposes the following members.
Properties
 | Name | Description
Public property | Description | Description Property
Public property | Location | Location Property
Public property | OffenceDate | The Offence date
Public property | OffenceType | The Offence type
Back to Top
See Also
GlobalCriminalRecordCheckDisclosureOffence Class


GlobalCriminalRecordCheckDisclosureOffence Properties

GlobalCriminalRecordCheckDisclosureOffence Properties GBG Web Service Developers Guide
The GlobalCriminalRecordCheckDisclosureOffence type exposes the following members.
Properties
 | Name | Description
Public property | Description | Description Property
Public property | Location | Location Property
Public property | OffenceDate | The Offence date
Public property | OffenceType | The Offence type
Back to Top
See Also
GlobalCriminalRecordCheckDisclosureOffence Class


GlobalCriminalRecordCheckDisclosureOffence.Description Property

GlobalCriminalRecordCheckDisclosureOffence Description Property GBG Web Service Developers Guide
Description Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Description();
function set_Description(value);
function get_Description();
function set_Description(value);
Property Value
Type: String

            Contains the Description
            This property will be validated against the following named regular expression: Generic
See Also
GlobalCriminalRecordCheckDisclosureOffence Class
GlobalCriminalRecordCheckDisclosureOffence Members


GlobalCriminalRecordCheckDisclosureOffence.Location Property

GlobalCriminalRecordCheckDisclosureOffence Location Property GBG Web Service Developers Guide
Location Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Location { get; set; }
public string Location { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Location();
function set_Location(value);
function get_Location();
function set_Location(value);
Property Value
Type: String

            Contains the Location
            This property will be validated against the following named regular expression: ShortGeneric
See Also
GlobalCriminalRecordCheckDisclosureOffence Class
GlobalCriminalRecordCheckDisclosureOffence Members


GlobalCriminalRecordCheckDisclosureOffence.OffenceDate Property

GlobalCriminalRecordCheckDisclosureOffence OffenceDate Property GBG Web Service Developers Guide
The Offence date

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime OffenceDate { get; set; }
public DateTime OffenceDate { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OffenceDate();
function set_OffenceDate(value);
function get_OffenceDate();
function set_OffenceDate(value);
Property Value
Type: DateTime
See Also
GlobalCriminalRecordCheckDisclosureOffence Class
GlobalCriminalRecordCheckDisclosureOffence Members


GlobalCriminalRecordCheckDisclosureOffence.OffenceType Property

GlobalCriminalRecordCheckDisclosureOffence OffenceType Property GBG Web Service Developers Guide
The Offence type

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalCriminalRecordCheckDisclosureOffenceType OffenceType { get; set; }
public GlobalCriminalRecordCheckDisclosureOffenceType OffenceType { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OffenceType();
function set_OffenceType(value);
function get_OffenceType();
function set_OffenceType(value);
Property Value
Type: GlobalCriminalRecordCheckDisclosureOffenceType
See Also
GlobalCriminalRecordCheckDisclosureOffence Class
GlobalCriminalRecordCheckDisclosureOffence Members


GlobalCriminalRecordCheckDisclosureOffenceType Enumeration

GlobalCriminalRecordCheckDisclosureOffenceType Enumeration GBG Web Service Developers Guide
Contains global criminal record check disclosure offense types.

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalCriminalRecordCheckDisclosureOffenceType
[SerializableAttribute]
public enum GlobalCriminalRecordCheckDisclosureOffenceType
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCriminalRecordCheckDisclosureOffenceType = function();
GlobalCheck.DataLib.GlobalCriminalRecordCheckDisclosureOffenceType.createEnum('GlobalCheck.DataLib.GlobalCriminalRecordCheckDisclosureOffenceType', false);
GlobalCheck.DataLib.GlobalCriminalRecordCheckDisclosureOffenceType = function();
GlobalCheck.DataLib.GlobalCriminalRecordCheckDisclosureOffenceType.createEnum('GlobalCheck.DataLib.GlobalCriminalRecordCheckDisclosureOffenceType', false);
Members
Member name | Value | Description
Caution | 1 | Caution
Conviction | 2 | Conviction
See Also


GlobalCurrentTime Enumeration

GlobalCurrentTime Enumeration GBG Web Service Developers Guide
Current time in employment

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalCurrentTime
[SerializableAttribute]
public enum GlobalCurrentTime
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalCurrentTime = function();
GlobalCheck.DataLib.GlobalCurrentTime.createEnum('GlobalCheck.DataLib.GlobalCurrentTime', false);
GlobalCheck.DataLib.GlobalCurrentTime = function();
GlobalCheck.DataLib.GlobalCurrentTime.createEnum('GlobalCheck.DataLib.GlobalCurrentTime', false);
Members
Member name | Value | Description
Years5Plus | 0 | 5+ years
Years2to5 | 1 | 2-5 years
Years0to2 | 2 | 0-2 years
See Also


GlobalDataExtract Class

GlobalDataExtract Class GBG Web Service Developers Guide
Contains details of a DataExtract
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalDataExtract

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalDataExtract
[SerializableAttribute]
public class GlobalDataExtract
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDataExtract = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDataExtract');
GlobalCheck.DataLib.GlobalDataExtract = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDataExtract');
See Also
GlobalDataExtract Members


GlobalDataExtract Members

GlobalDataExtract Members GBG Web Service Developers Guide
The GlobalDataExtract type exposes the following members.
Properties
 | Name | Description
Public property | CreatedByAccountName | CreatedByAccountName
Public property | CreatedByID | CreatedByID
Public property | End | End Property
Public property | Format | Format Property
Public property | ID | DataExtractID Property
Public property | Name | Name Property
Public property | OrgID | OrgID Property
Public property | Repeat | Version Property
Public property | Start | Start Property
Public property | State | Format Property
Public property | Type | Type Property
Public property | Version | Version Property
Back to Top
See Also
GlobalDataExtract Class


GlobalDataExtract Properties

GlobalDataExtract Properties GBG Web Service Developers Guide
The GlobalDataExtract type exposes the following members.
Properties
 | Name | Description
Public property | CreatedByAccountName | CreatedByAccountName
Public property | CreatedByID | CreatedByID
Public property | End | End Property
Public property | Format | Format Property
Public property | ID | DataExtractID Property
Public property | Name | Name Property
Public property | OrgID | OrgID Property
Public property | Repeat | Version Property
Public property | Start | Start Property
Public property | State | Format Property
Public property | Type | Type Property
Public property | Version | Version Property
Back to Top
See Also
GlobalDataExtract Class


GlobalDataExtract.CreatedByAccountName Property

GlobalDataExtract CreatedByAccountName Property GBG Web Service Developers Guide
CreatedByAccountName

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CreatedByAccountName { get; set; }
public string CreatedByAccountName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CreatedByAccountName();
function set_CreatedByAccountName(value);
function get_CreatedByAccountName();
function set_CreatedByAccountName(value);
Property Value
Type: String

            Name of the user who created the extract

See Also
GlobalDataExtract Class
GlobalDataExtract Members


GlobalDataExtract.CreatedByID Property

GlobalDataExtract CreatedByID Property GBG Web Service Developers Guide
CreatedByID

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid CreatedByID { get; set; }
public Guid CreatedByID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CreatedByID();
function set_CreatedByID(value);
function get_CreatedByID();
function set_CreatedByID(value);
Property Value
Type: Guid

            Unique identifier of the user who created the extract

See Also
GlobalDataExtract Class
GlobalDataExtract Members


GlobalDataExtract.End Property

GlobalDataExtract End Property GBG Web Service Developers Guide
End Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> End { get; set; }
public Nullable<DateTime> End { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_End();
function set_End(value);
function get_End();
function set_End(value);
Property Value
Type: Nullable DateTime

            Date from which a DataExtract ends

See Also
GlobalDataExtract Class
GlobalDataExtract Members


GlobalDataExtract.Format Property

GlobalDataExtract Format Property GBG Web Service Developers Guide
Format Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalDataExtractFormat Format { get; set; }
public GlobalDataExtractFormat Format { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Format();
function set_Format(value);
function get_Format();
function set_Format(value);
Property Value
Type: GlobalDataExtractFormat

            The Format of DataExtract

See Also
GlobalDataExtract Class
GlobalDataExtract Members


GlobalDataExtract.ID Property

GlobalDataExtract ID Property GBG Web Service Developers Guide
DataExtractID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ID { get; set; }
public Guid ID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ID();
function set_ID(value);
function get_ID();
function set_ID(value);
Property Value
Type: Guid

            Unique identifier for DataExtract

See Also
GlobalDataExtract Class
GlobalDataExtract Members


GlobalDataExtract.Name Property

GlobalDataExtract Name Property GBG Web Service Developers Guide
Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String

            DataExtract Name

See Also
GlobalDataExtract Class
GlobalDataExtract Members


GlobalDataExtract.OrgID Property

GlobalDataExtract OrgID Property GBG Web Service Developers Guide
OrgID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid OrgID { get; set; }
public Guid OrgID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OrgID();
function set_OrgID(value);
function get_OrgID();
function set_OrgID(value);
Property Value
Type: Guid

            Unique identifier for DataExtract Organisation

See Also
GlobalDataExtract Class
GlobalDataExtract Members


GlobalDataExtract.Repeat Property

GlobalDataExtract Repeat Property GBG Web Service Developers Guide
Version Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Repeat { get; set; }
public bool Repeat { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Repeat();
function set_Repeat(value);
function get_Repeat();
function set_Repeat(value);
Property Value
Type: Boolean

            DataExtract Version

See Also
GlobalDataExtract Class
GlobalDataExtract Members


GlobalDataExtract.Start Property

GlobalDataExtract Start Property GBG Web Service Developers Guide
Start Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> Start { get; set; }
public Nullable<DateTime> Start { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Start();
function set_Start(value);
function get_Start();
function set_Start(value);
Property Value
Type: Nullable DateTime

            Date from which a DataExtract starts

See Also
GlobalDataExtract Class
GlobalDataExtract Members


GlobalDataExtract.State Property

GlobalDataExtract State Property GBG Web Service Developers Guide
Format Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalDataExtractState State { get; set; }
public GlobalDataExtractState State { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_State();
function set_State(value);
function get_State();
function set_State(value);
Property Value
Type: GlobalDataExtractState

            The Format of DataExtract

See Also
GlobalDataExtract Class
GlobalDataExtract Members


GlobalDataExtract.Type Property

GlobalDataExtract Type Property GBG Web Service Developers Guide
Type Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalDataExtractType Type { get; set; }
public GlobalDataExtractType Type { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Type();
function set_Type(value);
function get_Type();
function set_Type(value);
Property Value
Type: GlobalDataExtractType

            The type of DataExtract

See Also
GlobalDataExtract Class
GlobalDataExtract Members


GlobalDataExtract.Version Property

GlobalDataExtract Version Property GBG Web Service Developers Guide
Version Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Version { get; set; }
public string Version { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Version();
function set_Version(value);
function get_Version();
function set_Version(value);
Property Value
Type: String

            DataExtract Version

See Also
GlobalDataExtract Class
GlobalDataExtract Members


GlobalDataExtractDownloadHistory Class

GlobalDataExtractDownloadHistory Class GBG Web Service Developers Guide
Contains details of a Data Extract Download History
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalDataExtractDownloadHistory

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalDataExtractDownloadHistory
[SerializableAttribute]
public class GlobalDataExtractDownloadHistory
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDataExtractDownloadHistory = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDataExtractDownloadHistory');
GlobalCheck.DataLib.GlobalDataExtractDownloadHistory = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDataExtractDownloadHistory');
See Also
GlobalDataExtractDownloadHistory Members


GlobalDataExtractDownloadHistory Members

GlobalDataExtractDownloadHistory Members GBG Web Service Developers Guide
The GlobalDataExtractDownloadHistory type exposes the following members.
Properties
 | Name | Description
Public property | AccountID | AccountID
Public property | AccountName | AccountName
Public property | Timestamp | Start Property
Back to Top
See Also
GlobalDataExtractDownloadHistory Class


GlobalDataExtractDownloadHistory Properties

GlobalDataExtractDownloadHistory Properties GBG Web Service Developers Guide
The GlobalDataExtractDownloadHistory type exposes the following members.
Properties
 | Name | Description
Public property | AccountID | AccountID
Public property | AccountName | AccountName
Public property | Timestamp | Start Property
Back to Top
See Also
GlobalDataExtractDownloadHistory Class


GlobalDataExtractDownloadHistory.AccountID Property

GlobalDataExtractDownloadHistory AccountID Property GBG Web Service Developers Guide
AccountID

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid AccountID { get; set; }
public Guid AccountID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AccountID();
function set_AccountID(value);
function get_AccountID();
function set_AccountID(value);
Property Value
Type: Guid

            Unique identifier of the user who downloaded the extract

See Also
GlobalDataExtractDownloadHistory Class
GlobalDataExtractDownloadHistory Members


GlobalDataExtractDownloadHistory.AccountName Property

GlobalDataExtractDownloadHistory AccountName Property GBG Web Service Developers Guide
AccountName

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AccountName { get; set; }
public string AccountName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AccountName();
function set_AccountName(value);
function get_AccountName();
function set_AccountName(value);
Property Value
Type: String

            Name of the user who downloaded the extract

See Also
GlobalDataExtractDownloadHistory Class
GlobalDataExtractDownloadHistory Members


GlobalDataExtractDownloadHistory.Timestamp Property

GlobalDataExtractDownloadHistory Timestamp Property GBG Web Service Developers Guide
Start Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Timestamp { get; set; }
public DateTime Timestamp { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Timestamp();
function set_Timestamp(value);
function get_Timestamp();
function set_Timestamp(value);
Property Value
Type: DateTime

            Date the extract was downloaded

See Also
GlobalDataExtractDownloadHistory Class
GlobalDataExtractDownloadHistory Members


GlobalDataExtractFormat Enumeration

GlobalDataExtractFormat Enumeration GBG Web Service Developers Guide
The format of the DataExtract

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalDataExtractFormat
[SerializableAttribute]
public enum GlobalDataExtractFormat
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDataExtractFormat = function();
GlobalCheck.DataLib.GlobalDataExtractFormat.createEnum('GlobalCheck.DataLib.GlobalDataExtractFormat', false);
GlobalCheck.DataLib.GlobalDataExtractFormat = function();
GlobalCheck.DataLib.GlobalDataExtractFormat.createEnum('GlobalCheck.DataLib.GlobalDataExtractFormat', false);
Members
Member name | Value | Description
CSV | 1 | Comma Separated Values
TSV | 2 | Tab Separated Values
EXCEL | 3 | Excel
See Also


GlobalDataExtracts Class

GlobalDataExtracts Class GBG Web Service Developers Guide
Contains paged results from a request for summary details of Data Extracts
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalDataExtracts

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalDataExtracts
public class GlobalDataExtracts
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDataExtracts = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDataExtracts');
GlobalCheck.DataLib.GlobalDataExtracts = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDataExtracts');
See Also
GlobalDataExtracts Members


GlobalDataExtracts Members

GlobalDataExtracts Members GBG Web Service Developers Guide
The GlobalDataExtracts type exposes the following members.
Properties
 | Name | Description
Public property | Extracts | Extracts Property
Public property | PageSize | PageSize Property
Public property | TotalExtracts | TotalExtracts Property
Public property | TotalPages | TotalPages Property
Back to Top
See Also
GlobalDataExtracts Class


GlobalDataExtracts Properties

GlobalDataExtracts Properties GBG Web Service Developers Guide
The GlobalDataExtracts type exposes the following members.
Properties
 | Name | Description
Public property | Extracts | Extracts Property
Public property | PageSize | PageSize Property
Public property | TotalExtracts | TotalExtracts Property
Public property | TotalPages | TotalPages Property
Back to Top
See Also
GlobalDataExtracts Class


GlobalDataExtracts.Extracts Property

GlobalDataExtracts Extracts Property GBG Web Service Developers Guide
Extracts Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalDataExtract> Extracts { get; set; }
public List<GlobalDataExtract> Extracts { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Extracts();
function set_Extracts(value);
function get_Extracts();
function set_Extracts(value);
Property Value
Type: List GlobalDataExtract

            Filtered list of Data Extracts

See Also
GlobalDataExtracts Class
GlobalDataExtracts Members


GlobalDataExtracts.PageSize Property

GlobalDataExtracts PageSize Property GBG Web Service Developers Guide
PageSize Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint PageSize { get; set; }
public uint PageSize { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PageSize();
function set_PageSize(value);
function get_PageSize();
function set_PageSize(value);
Property Value
Type: UInt32

            Maximum number of results returned from the paged request

See Also
GlobalDataExtracts Class
GlobalDataExtracts Members


GlobalDataExtracts.TotalExtracts Property

GlobalDataExtracts TotalExtracts Property GBG Web Service Developers Guide
TotalExtracts Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalExtracts { get; set; }
public uint TotalExtracts { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalExtracts();
function set_TotalExtracts(value);
function get_TotalExtracts();
function set_TotalExtracts(value);
Property Value
Type: UInt32

            Total number of extracts matching the query

See Also
GlobalDataExtracts Class
GlobalDataExtracts Members


GlobalDataExtracts.TotalPages Property

GlobalDataExtracts TotalPages Property GBG Web Service Developers Guide
TotalPages Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalPages { get; set; }
public uint TotalPages { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalPages();
function set_TotalPages(value);
function get_TotalPages();
function set_TotalPages(value);
Property Value
Type: UInt32

            The total number of pages that would be required to return all the results, based on a page size of PageSize

See Also
GlobalDataExtracts Class
GlobalDataExtracts Members


GlobalDataExtractState Enumeration

GlobalDataExtractState Enumeration GBG Web Service Developers Guide
The state of the DataExtract

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalDataExtractState
[SerializableAttribute]
public enum GlobalDataExtractState
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDataExtractState = function();
GlobalCheck.DataLib.GlobalDataExtractState.createEnum('GlobalCheck.DataLib.GlobalDataExtractState', false);
GlobalCheck.DataLib.GlobalDataExtractState = function();
GlobalCheck.DataLib.GlobalDataExtractState.createEnum('GlobalCheck.DataLib.GlobalDataExtractState', false);
Members
Member name | Value | Description
Scheduled | 1 | Scheduled state
Ready | 2 | Ready for download state
Failed | 3 | Failed state
Expired | 4 | Expired state
Cancelled | 5 | Cancelled state
See Also


GlobalDataExtractType Enumeration

GlobalDataExtractType Enumeration GBG Web Service Developers Guide
The DataExtract type

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataExtractLib (in GlobalCheck.DataExtractLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalDataExtractType
[SerializableAttribute]
public enum GlobalDataExtractType
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDataExtractType = function();
GlobalCheck.DataLib.GlobalDataExtractType.createEnum('GlobalCheck.DataLib.GlobalDataExtractType', false);
GlobalCheck.DataLib.GlobalDataExtractType = function();
GlobalCheck.DataLib.GlobalDataExtractType.createEnum('GlobalCheck.DataLib.GlobalDataExtractType', false);
Members
Member name | Value | Description
UserDefined | 1 | A User-defined Extract
Day | 2 | A Daily Extract
Week | 3 | A Weekly Extract
Fortnight | 4 | A Fortnightly Extract
Month | 5 | A Monthly Extract
See Also


GlobalDecisionBanding Class

GlobalDecisionBanding Class GBG Web Service Developers Guide
Profile Decision Bands
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalDecisionBanding

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalDecisionBanding
[SerializableAttribute]
public class GlobalDecisionBanding
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDecisionBanding = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDecisionBanding');
GlobalCheck.DataLib.GlobalDecisionBanding = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDecisionBanding');
See Also
GlobalDecisionBanding Members


GlobalDecisionBanding Members

GlobalDecisionBanding Members GBG Web Service Developers Guide
The GlobalDecisionBanding type exposes the following members.
Properties
 | Name | Description
Public property | Bands | Bands Property
Public property | ExceptionText | ExceptionText Property
Back to Top
See Also
GlobalDecisionBanding Class


GlobalDecisionBanding Properties

GlobalDecisionBanding Properties GBG Web Service Developers Guide
The GlobalDecisionBanding type exposes the following members.
Properties
 | Name | Description
Public property | Bands | Bands Property
Public property | ExceptionText | ExceptionText Property
Back to Top
See Also
GlobalDecisionBanding Class


GlobalDecisionBanding.Bands Property

GlobalDecisionBanding Bands Property GBG Web Service Developers Guide
Bands Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalBand> Bands { get; set; }
public List<GlobalBand> Bands { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Bands();
function set_Bands(value);
function get_Bands();
function set_Bands(value);
Property Value
Type: List GlobalBand

            Collection of Decision Bands

See Also
GlobalDecisionBanding Class
GlobalDecisionBanding Members


GlobalDecisionBanding.ExceptionText Property

GlobalDecisionBanding ExceptionText Property GBG Web Service Developers Guide
ExceptionText Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ExceptionText { get; set; }
public string ExceptionText { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExceptionText();
function set_ExceptionText(value);
function get_ExceptionText();
function set_ExceptionText(value);
Property Value
Type: String

            Exception Text for any scoring not covered by the Decision Bands

See Also
GlobalDecisionBanding Class
GlobalDecisionBanding Members


GlobalDenmark Class

GlobalDenmark Class GBG Web Service Developers Guide
Denmark identity details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalDenmark

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalDenmark
[SerializableAttribute]
public class GlobalDenmark
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDenmark = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDenmark');
GlobalCheck.DataLib.GlobalDenmark = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDenmark');
See Also
GlobalDenmark Members


GlobalDenmark Members

GlobalDenmark Members GBG Web Service Developers Guide
The GlobalDenmark type exposes the following members.
Properties
 | Name | Description
Public property | IdentityCard | Identity Card Property - CPR-Denmark
Back to Top
See Also
GlobalDenmark Class


GlobalDenmark Properties

GlobalDenmark Properties GBG Web Service Developers Guide
The GlobalDenmark type exposes the following members.
Properties
 | Name | Description
Public property | IdentityCard | Identity Card Property - CPR-Denmark
Back to Top
See Also
GlobalDenmark Class


GlobalDenmark.IdentityCard Property

GlobalDenmark IdentityCard Property GBG Web Service Developers Guide
Identity Card Property - CPR-Denmark

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalIdentityCard IdentityCard { get; set; }
public GlobalIdentityCard IdentityCard { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IdentityCard();
function set_IdentityCard(value);
function get_IdentityCard();
function set_IdentityCard(value);
Property Value
Type: GlobalIdentityCard

            This property will be validated against the following named regular expression: IdentityCardNumber
See Also
GlobalDenmark Class
GlobalDenmark Members


GlobalDeviceIDResultCodes Class

GlobalDeviceIDResultCodes Class GBG Web Service Developers Guide
Results data returned by the DeviceID Item Check
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalItemCheckResultCodes
GlobalCheck.DataLib GlobalDeviceIDResultCodes

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalDeviceIDResultCodes : GlobalItemCheckResultCodes
public class GlobalDeviceIDResultCodes : GlobalItemCheckResultCodes
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDeviceIDResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDeviceIDResultCodes',
    GlobalCheck.DataLib.GlobalItemCheckResultCodes);
GlobalCheck.DataLib.GlobalDeviceIDResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDeviceIDResultCodes',
    GlobalCheck.DataLib.GlobalItemCheckResultCodes);
See Also
GlobalDeviceIDResultCodes Members


GlobalDeviceIDResultCodes Members

GlobalDeviceIDResultCodes Members GBG Web Service Developers Guide
The GlobalDeviceIDResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | DeviceID | DeviceID Property
Public property | TrackingNumber | TrackingNumber Property
Back to Top
See Also
GlobalDeviceIDResultCodes Class


GlobalDeviceIDResultCodes Properties

GlobalDeviceIDResultCodes Properties GBG Web Service Developers Guide
The GlobalDeviceIDResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | DeviceID | DeviceID Property
Public property | TrackingNumber | TrackingNumber Property
Back to Top
See Also
GlobalDeviceIDResultCodes Class


GlobalDeviceIDResultCodes.DeviceID Property

GlobalDeviceIDResultCodes DeviceID Property GBG Web Service Developers Guide
DeviceID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DeviceID { get; set; }
public string DeviceID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DeviceID();
function set_DeviceID(value);
function get_DeviceID();
function set_DeviceID(value);
Property Value
Type: String
Device identity
See Also
GlobalDeviceIDResultCodes Class
GlobalDeviceIDResultCodes Members


GlobalDeviceIDResultCodes.TrackingNumber Property

GlobalDeviceIDResultCodes TrackingNumber Property GBG Web Service Developers Guide
TrackingNumber Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TrackingNumber { get; set; }
public string TrackingNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TrackingNumber();
function set_TrackingNumber(value);
function get_TrackingNumber();
function set_TrackingNumber(value);
Property Value
Type: String
Tracking number
See Also
GlobalDeviceIDResultCodes Class
GlobalDeviceIDResultCodes Members


GlobalDispatchReportStatus Enumeration

GlobalDispatchReportStatus Enumeration GBG Web Service Developers Guide
Defines the GlobalDispatchReportStatus

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalDispatchReportStatus
[SerializableAttribute]
public enum GlobalDispatchReportStatus
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDispatchReportStatus = function();
GlobalCheck.DataLib.GlobalDispatchReportStatus.createEnum('GlobalCheck.DataLib.GlobalDispatchReportStatus', false);
GlobalCheck.DataLib.GlobalDispatchReportStatus = function();
GlobalCheck.DataLib.GlobalDispatchReportStatus.createEnum('GlobalCheck.DataLib.GlobalDispatchReportStatus', false);
Members
Member name | Value | Description
None | 0 | Full licence
Clear | 1 | Clear with no endorsements, convictions or points
Unclear | 2 | Unclear
See Also


GlobalDispatchResult Class

GlobalDispatchResult Class GBG Web Service Developers Guide
Contains Dispatch result data
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalDispatchResult

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalDispatchResult : IDecrypt
[SerializableAttribute]
public class GlobalDispatchResult : IDecrypt
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDispatchResult = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDispatchResult',
    null,
    GlobalCheck.DataLib.IDecrypt);
GlobalCheck.DataLib.GlobalDispatchResult = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDispatchResult',
    null,
    GlobalCheck.DataLib.IDecrypt);
See Also
GlobalDispatchResult Members


GlobalDispatchResult Members

GlobalDispatchResult Members GBG Web Service Developers Guide
The GlobalDispatchResult type exposes the following members.
Properties
 | Name | Description
Public property | CriminalRecordCheckDisclosure | Contains an individuals UK Driving Licence
Public property | DVLADrivingLicenceReport | Contains a DVAL report on a licence
Back to Top
See Also
GlobalDispatchResult Class


GlobalDispatchResult Properties

GlobalDispatchResult Properties GBG Web Service Developers Guide
The GlobalDispatchResult type exposes the following members.
Properties
 | Name | Description
Public property | CriminalRecordCheckDisclosure | Contains an individuals UK Driving Licence
Public property | DVLADrivingLicenceReport | Contains a DVAL report on a licence
Back to Top
See Also
GlobalDispatchResult Class


GlobalDispatchResult.CriminalRecordCheckDisclosure Property

GlobalDispatchResult CriminalRecordCheckDisclosure Property GBG Web Service Developers Guide
Contains an individuals UK Driving Licence

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalCriminalRecordCheckDisclosure CriminalRecordCheckDisclosure { get; set; }
public GlobalCriminalRecordCheckDisclosure CriminalRecordCheckDisclosure { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CriminalRecordCheckDisclosure();
function set_CriminalRecordCheckDisclosure(value);
function get_CriminalRecordCheckDisclosure();
function set_CriminalRecordCheckDisclosure(value);
Property Value
Type: GlobalCriminalRecordCheckDisclosure
See Also
GlobalDispatchResult Class
GlobalDispatchResult Members


GlobalDispatchResult.DVLADrivingLicenceReport Property

GlobalDispatchResult DVLADrivingLicenceReport Property GBG Web Service Developers Guide
Contains a DVAL report on a licence

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalDVLADrivingLicenceReport DVLADrivingLicenceReport { get; set; }
public GlobalDVLADrivingLicenceReport DVLADrivingLicenceReport { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DVLADrivingLicenceReport();
function set_DVLADrivingLicenceReport(value);
function get_DVLADrivingLicenceReport();
function set_DVLADrivingLicenceReport(value);
Property Value
Type: GlobalDVLADrivingLicenceReport
See Also
GlobalDispatchResult Class
GlobalDispatchResult Members


GlobalDIVData Class

GlobalDIVData Class GBG Web Service Developers Guide
Document Image Validation data class
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalDIVData

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalDIVData : IDecrypt
[SerializableAttribute]
public class GlobalDIVData : IDecrypt
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDIVData = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDIVData',
    null,
    GlobalCheck.DataLib.IDecrypt);
GlobalCheck.DataLib.GlobalDIVData = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDIVData',
    null,
    GlobalCheck.DataLib.IDecrypt);
See Also
GlobalDIVData Members


GlobalDIVData Members

GlobalDIVData Members GBG Web Service Developers Guide
The GlobalDIVData type exposes the following members.
Properties
 | Name | Description
Public property | AuthenticationID | AuthenticationID Property
Public property | ChainID | ChainID Property - future: we can use the ChainID to link this to Authentication Records
Public property | Checks | Checks Property
Public property | Document | Document Property
Public property | ExtractedData |
Public property | Image | Image Property
Public property | OrgID | OrgID Property
Public property | ProcessedImage | ProcessedImage Property
Public property | Status | Status Property
Public property | TestResults | TestResults Property
Back to Top
See Also
GlobalDIVData Class


GlobalDIVData Properties

GlobalDIVData Properties GBG Web Service Developers Guide
The GlobalDIVData type exposes the following members.
Properties
 | Name | Description
Public property | AuthenticationID | AuthenticationID Property
Public property | ChainID | ChainID Property - future: we can use the ChainID to link this to Authentication Records
Public property | Checks | Checks Property
Public property | Document | Document Property
Public property | ExtractedData |
Public property | Image | Image Property
Public property | OrgID | OrgID Property
Public property | ProcessedImage | ProcessedImage Property
Public property | Status | Status Property
Public property | TestResults | TestResults Property
Back to Top
See Also
GlobalDIVData Class


GlobalDIVData.AuthenticationID Property

GlobalDIVData AuthenticationID Property GBG Web Service Developers Guide
AuthenticationID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid AuthenticationID { get; set; }
public Guid AuthenticationID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AuthenticationID();
function set_AuthenticationID(value);
function get_AuthenticationID();
function set_AuthenticationID(value);
Property Value
Type: Guid

            Unique identifier for the Authentication of the Document Image

See Also
GlobalDIVData Class
GlobalDIVData Members


GlobalDIVData.ChainID Property

GlobalDIVData ChainID Property GBG Web Service Developers Guide
ChainID Property - future: we can use the ChainID to link this to Authentication Records

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> ChainID { get; set; }
public Nullable<Guid> ChainID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ChainID();
function set_ChainID(value);
function get_ChainID();
function set_ChainID(value);
Property Value
Type: Nullable Guid

            Unique identifier for the a series of Authentication records

See Also
GlobalDIVData Class
GlobalDIVData Members


GlobalDIVData.Checks Property

GlobalDIVData Checks Property GBG Web Service Developers Guide
Checks Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ImageChecks Checks { get; set; }
public ImageChecks Checks { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Checks();
function set_Checks(value);
function get_Checks();
function set_Checks(value);
Property Value
Type: ImageChecks

            Pre-process image checks describing the quality of the image

See Also
GlobalDIVData Class
GlobalDIVData Members


GlobalDIVData.Document Property

GlobalDIVData Document Property GBG Web Service Developers Guide
Document Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DocumentDetails Document { get; set; }
public DocumentDetails Document { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Document();
function set_Document(value);
function get_Document();
function set_Document(value);
Property Value
Type: DocumentDetails

            Document specific data

See Also
GlobalDIVData Class
GlobalDIVData Members


GlobalDIVData.ExtractedData Property

GlobalDIVData ExtractedData Property GBG Web Service Developers Guide

[Missing <summary> documentation for "P:GlobalCheck.DataLib.GlobalDIVData.ExtractedData"]

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExtractedData ExtractedData { get; set; }
public ExtractedData ExtractedData { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExtractedData();
function set_ExtractedData(value);
function get_ExtractedData();
function set_ExtractedData(value);
Property Value
Type: ExtractedData

            Document data extracted from the document image

See Also
GlobalDIVData Class
GlobalDIVData Members


GlobalDIVData.Image Property

GlobalDIVData Image Property GBG Web Service Developers Guide
Image Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ImageData Image { get; set; }
public ImageData Image { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Image();
function set_Image(value);
function get_Image();
function set_Image(value);
Property Value
Type: ImageData

            Image dimension and crop details

See Also
GlobalDIVData Class
GlobalDIVData Members


GlobalDIVData.OrgID Property

GlobalDIVData OrgID Property GBG Web Service Developers Guide
OrgID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid OrgID { get; set; }
public Guid OrgID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OrgID();
function set_OrgID(value);
function get_OrgID();
function set_OrgID(value);
Property Value
Type: Guid

            Unique identifier of the organisation

See Also
GlobalDIVData Class
GlobalDIVData Members


GlobalDIVData.ProcessedImage Property

GlobalDIVData ProcessedImage Property GBG Web Service Developers Guide
ProcessedImage Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ProcessedImage { get; set; }
public byte[] ProcessedImage { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProcessedImage();
function set_ProcessedImage(value);
function get_ProcessedImage();
function set_ProcessedImage(value);
Property Value
Type:  Byte

            byte array of the processed image

See Also
GlobalDIVData Class
GlobalDIVData Members


GlobalDIVData.Status Property

GlobalDIVData Status Property GBG Web Service Developers Guide
Status Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalDIVData..::..GlobalDocumentExtractedStatus Status { get; set; }
public GlobalDIVData..::..GlobalDocumentExtractedStatus Status { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Status();
function set_Status(value);
function get_Status();
function set_Status(value);
Property Value
Type: GlobalDIVData GlobalDocumentExtractedStatus

            Document extraction status. The current processing status

See Also
GlobalDIVData Class
GlobalDIVData Members


GlobalDIVData.TestResults Property

GlobalDIVData TestResults Property GBG Web Service Developers Guide
TestResults Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<DocumentForgeryTests> TestResults { get; set; }
public List<DocumentForgeryTests> TestResults { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TestResults();
function set_TestResults(value);
function get_TestResults();
function set_TestResults(value);
Property Value
Type: List DocumentForgeryTests

            Test results

See Also
GlobalDIVData Class
GlobalDIVData Members


GlobalDIVData.GlobalDocumentExtractedStatus Enumeration

GlobalDIVData GlobalDocumentExtractedStatus Enumeration GBG Web Service Developers Guide
Extraction Status

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum GlobalDocumentExtractedStatus
public enum GlobalDocumentExtractedStatus
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDocumentExtractedStatus = function();
GlobalCheck.DataLib.GlobalDocumentExtractedStatus.createEnum('GlobalCheck.DataLib.GlobalDocumentExtractedStatus', false);
GlobalCheck.DataLib.GlobalDocumentExtractedStatus = function();
GlobalCheck.DataLib.GlobalDocumentExtractedStatus.createEnum('GlobalCheck.DataLib.GlobalDocumentExtractedStatus', false);
Members
Member name | Value | Description
UnknownDocument | 0 | Unknown document
LowQualityImage | 1 | Low quality image
UnableToProcess | 2 | Unable to process the image
Completed | 3 | Completed
InProgress | 4 | Image still being processed
See Also


GlobalDocumentCategorySubmissionType Class

GlobalDocumentCategorySubmissionType Class GBG Web Service Developers Guide
Defines the different ways a document can be submitted by an applicant
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalDocumentCategorySubmissionType

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalDocumentCategorySubmissionType
[SerializableAttribute]
public class GlobalDocumentCategorySubmissionType
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDocumentCategorySubmissionType = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDocumentCategorySubmissionType');
GlobalCheck.DataLib.GlobalDocumentCategorySubmissionType = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDocumentCategorySubmissionType');
See Also
GlobalDocumentCategorySubmissionType Members


GlobalDocumentCategorySubmissionType Members

GlobalDocumentCategorySubmissionType Members GBG Web Service Developers Guide
The GlobalDocumentCategorySubmissionType type exposes the following members.
Properties
 | Name | Description
Public property | SubmissionType | How documents will be submitted
Public property | Type | Type of document
Back to Top
See Also
GlobalDocumentCategorySubmissionType Class


GlobalDocumentCategorySubmissionType Properties

GlobalDocumentCategorySubmissionType Properties GBG Web Service Developers Guide
The GlobalDocumentCategorySubmissionType type exposes the following members.
Properties
 | Name | Description
Public property | SubmissionType | How documents will be submitted
Public property | Type | Type of document
Back to Top
See Also
GlobalDocumentCategorySubmissionType Class


GlobalDocumentCategorySubmissionType.SubmissionType Property

GlobalDocumentCategorySubmissionType SubmissionType Property GBG Web Service Developers Guide
How documents will be submitted

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalDocumentSubmissionType SubmissionType { get; set; }
public GlobalDocumentSubmissionType SubmissionType { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SubmissionType();
function set_SubmissionType(value);
function get_SubmissionType();
function set_SubmissionType(value);
Property Value
Type: GlobalDocumentSubmissionType
See Also
GlobalDocumentCategorySubmissionType Class
GlobalDocumentCategorySubmissionType Members


GlobalDocumentCategorySubmissionType.Type Property

GlobalDocumentCategorySubmissionType Type Property GBG Web Service Developers Guide
Type of document

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Type { get; set; }
public uint Type { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Type();
function set_Type(value);
function get_Type();
function set_Type(value);
Property Value
Type: UInt32
See Also
GlobalDocumentCategorySubmissionType Class
GlobalDocumentCategorySubmissionType Members


GlobalDocumentCheckResultCodes Class

GlobalDocumentCheckResultCodes Class GBG Web Service Developers Guide
Results data returned by the Document Checking Item Check
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalItemCheckResultCodes
GlobalCheck.DataLib GlobalDocumentCheckResultCodes

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalDocumentCheckResultCodes : GlobalItemCheckResultCodes
public class GlobalDocumentCheckResultCodes : GlobalItemCheckResultCodes
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDocumentCheckResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDocumentCheckResultCodes',
    GlobalCheck.DataLib.GlobalItemCheckResultCodes);
GlobalCheck.DataLib.GlobalDocumentCheckResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDocumentCheckResultCodes',
    GlobalCheck.DataLib.GlobalItemCheckResultCodes);
See Also
GlobalDocumentCheckResultCodes Members


GlobalDocumentCheckResultCodes Members

GlobalDocumentCheckResultCodes Members GBG Web Service Developers Guide
The GlobalDocumentCheckResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | DrivingLicenceFraudDocumentReferences | Driving Licence Fraud Document Reference Property
Public property | PassportFraudDocumentReferences | Passport Fraud Document Reference Property
Back to Top
See Also
GlobalDocumentCheckResultCodes Class


GlobalDocumentCheckResultCodes Properties

GlobalDocumentCheckResultCodes Properties GBG Web Service Developers Guide
The GlobalDocumentCheckResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | DrivingLicenceFraudDocumentReferences | Driving Licence Fraud Document Reference Property
Public property | PassportFraudDocumentReferences | Passport Fraud Document Reference Property
Back to Top
See Also
GlobalDocumentCheckResultCodes Class


GlobalDocumentCheckResultCodes.DrivingLicenceFraudDocumentReferences Property

GlobalDocumentCheckResultCodes DrivingLicenceFraudDocumentReferences Property GBG Web Service Developers Guide
Driving Licence Fraud Document Reference Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> DrivingLicenceFraudDocumentReferences { get; set; }
public List<string> DrivingLicenceFraudDocumentReferences { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DrivingLicenceFraudDocumentReferences();
function set_DrivingLicenceFraudDocumentReferences(value);
function get_DrivingLicenceFraudDocumentReferences();
function set_DrivingLicenceFraudDocumentReferences(value);
Property Value
Type: List String

            List of Driving Licence Fraud Document References

See Also
GlobalDocumentCheckResultCodes Class
GlobalDocumentCheckResultCodes Members


GlobalDocumentCheckResultCodes.PassportFraudDocumentReferences Property

GlobalDocumentCheckResultCodes PassportFraudDocumentReferences Property GBG Web Service Developers Guide
Passport Fraud Document Reference Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> PassportFraudDocumentReferences { get; set; }
public List<string> PassportFraudDocumentReferences { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PassportFraudDocumentReferences();
function set_PassportFraudDocumentReferences(value);
function get_PassportFraudDocumentReferences();
function set_PassportFraudDocumentReferences(value);
Property Value
Type: List String

            List of Passport Fraud Document References

See Also
GlobalDocumentCheckResultCodes Class
GlobalDocumentCheckResultCodes Members


GlobalDocumentSubmissionType Enumeration

GlobalDocumentSubmissionType Enumeration GBG Web Service Developers Guide
The DataExtract type

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.CaseLib (in GlobalCheck.CaseLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalDocumentSubmissionType
[SerializableAttribute]
public enum GlobalDocumentSubmissionType
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDocumentSubmissionType = function();
GlobalCheck.DataLib.GlobalDocumentSubmissionType.createEnum('GlobalCheck.DataLib.GlobalDocumentSubmissionType', false);
GlobalCheck.DataLib.GlobalDocumentSubmissionType = function();
GlobalCheck.DataLib.GlobalDocumentSubmissionType.createEnum('GlobalCheck.DataLib.GlobalDocumentSubmissionType', false);
Members
Member name | Value | Description
None | 0 | No document
Author | 1 | Will upload
Applicant | 2 | Will provide later
InPossesion | 3 | Already have the documents
PostOffice | 4 | Documents to be take to the Post office for verification
See Also


GlobalDocumentType Enumeration

GlobalDocumentType Enumeration GBG Web Service Developers Guide
Document type

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum GlobalDocumentType
public enum GlobalDocumentType
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDocumentType = function();
GlobalCheck.DataLib.GlobalDocumentType.createEnum('GlobalCheck.DataLib.GlobalDocumentType', false);
GlobalCheck.DataLib.GlobalDocumentType = function();
GlobalCheck.DataLib.GlobalDocumentType.createEnum('GlobalCheck.DataLib.GlobalDocumentType', false);
Members
Member name | Value | Description
Passport | 0 | Passport
DrivingLicence | 1 | Driving Licence
IDCard | 2 | ID Card
Unknown | 3 | Unknown document type
See Also


GlobalDVLADrivingLicenceCategory Class

GlobalDVLADrivingLicenceCategory Class GBG Web Service Developers Guide
/// DVLA Driving Licence Category information.
Inheritance Hierarchy
System Object
XmlDeserializeBase GlobalDVLADrivingLicenceCategory
GlobalCheck.DataLib GlobalDVLADrivingLicenceCategory

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalDVLADrivingLicenceCategory : XmlDeserializeBase<GlobalDVLADrivingLicenceCategory>
[SerializableAttribute]
public class GlobalDVLADrivingLicenceCategory : XmlDeserializeBase<GlobalDVLADrivingLicenceCategory>
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDVLADrivingLicenceCategory = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDVLADrivingLicenceCategory',
    GlobalCheck.DataLib.XmlDeserializeBase`1);
GlobalCheck.DataLib.GlobalDVLADrivingLicenceCategory = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDVLADrivingLicenceCategory',
    GlobalCheck.DataLib.XmlDeserializeBase`1);
See Also
GlobalDVLADrivingLicenceCategory Members


GlobalDVLADrivingLicenceCategory Members

GlobalDVLADrivingLicenceCategory Members GBG Web Service Developers Guide
The GlobalDVLADrivingLicenceCategory type exposes the following members.
Properties
 | Name | Description
Public property | Code | The endorsement code
Public property | Description | The description
Back to Top
See Also
GlobalDVLADrivingLicenceCategory Class


GlobalDVLADrivingLicenceCategory Properties

GlobalDVLADrivingLicenceCategory Properties GBG Web Service Developers Guide
The GlobalDVLADrivingLicenceCategory type exposes the following members.
Properties
 | Name | Description
Public property | Code | The endorsement code
Public property | Description | The description
Back to Top
See Also
GlobalDVLADrivingLicenceCategory Class


GlobalDVLADrivingLicenceCategory.Code Property

GlobalDVLADrivingLicenceCategory Code Property GBG Web Service Developers Guide
The endorsement code

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Code { get; set; }
public string Code { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Code();
function set_Code(value);
function get_Code();
function set_Code(value);
Property Value
Type: String
Remarks

            This property will be validated against the following named regular expression: UKDrivingLicenceCategoryCode
See Also
GlobalDVLADrivingLicenceCategory Class
GlobalDVLADrivingLicenceCategory Members


GlobalDVLADrivingLicenceCategory.Description Property

GlobalDVLADrivingLicenceCategory Description Property GBG Web Service Developers Guide
The description

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Description();
function set_Description(value);
function get_Description();
function set_Description(value);
Property Value
Type: String
Remarks

            This property will be validated against the following named regular expression: Generic
See Also
GlobalDVLADrivingLicenceCategory Class
GlobalDVLADrivingLicenceCategory Members


GlobalDVLADrivingLicenceEndorsement Class

GlobalDVLADrivingLicenceEndorsement Class GBG Web Service Developers Guide
/// DVLA endorsement information.
Inheritance Hierarchy
System Object
XmlDeserializeBase GlobalDVLADrivingLicenceEndorsement
GlobalCheck.DataLib GlobalDVLADrivingLicenceEndorsement

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalDVLADrivingLicenceEndorsement : XmlDeserializeBase<GlobalDVLADrivingLicenceEndorsement>
[SerializableAttribute]
public class GlobalDVLADrivingLicenceEndorsement : XmlDeserializeBase<GlobalDVLADrivingLicenceEndorsement>
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDVLADrivingLicenceEndorsement = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDVLADrivingLicenceEndorsement',
    GlobalCheck.DataLib.XmlDeserializeBase`1);
GlobalCheck.DataLib.GlobalDVLADrivingLicenceEndorsement = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDVLADrivingLicenceEndorsement',
    GlobalCheck.DataLib.XmlDeserializeBase`1);
See Also
GlobalDVLADrivingLicenceEndorsement Members


GlobalDVLADrivingLicenceEndorsement Members

GlobalDVLADrivingLicenceEndorsement Members GBG Web Service Developers Guide
The GlobalDVLADrivingLicenceEndorsement type exposes the following members.
Properties
 | Name | Description
Public property | Code | The endorsement code
Public property | Description | The description
Public property | Duration | The duration of the endorsement on the licence in years
Public property | EndorsementType | The Endorsement type
Public property | IsDurationFromConviction | Indicates if the duration is from the date of conviction. If this value is false, then the duration is calculated from the date of the offence
Back to Top
See Also
GlobalDVLADrivingLicenceEndorsement Class


GlobalDVLADrivingLicenceEndorsement Properties

GlobalDVLADrivingLicenceEndorsement Properties GBG Web Service Developers Guide
The GlobalDVLADrivingLicenceEndorsement type exposes the following members.
Properties
 | Name | Description
Public property | Code | The endorsement code
Public property | Description | The description
Public property | Duration | The duration of the endorsement on the licence in years
Public property | EndorsementType | The Endorsement type
Public property | IsDurationFromConviction | Indicates if the duration is from the date of conviction. If this value is false, then the duration is calculated from the date of the offence
Back to Top
See Also
GlobalDVLADrivingLicenceEndorsement Class


GlobalDVLADrivingLicenceEndorsement.Code Property

GlobalDVLADrivingLicenceEndorsement Code Property GBG Web Service Developers Guide
The endorsement code

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Code { get; set; }
public string Code { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Code();
function set_Code(value);
function get_Code();
function set_Code(value);
Property Value
Type: String
Remarks

            This property will be validated against the following named regular expression: UKDrivingLicenceEndorsementCode
See Also
GlobalDVLADrivingLicenceEndorsement Class
GlobalDVLADrivingLicenceEndorsement Members


GlobalDVLADrivingLicenceEndorsement.Description Property

GlobalDVLADrivingLicenceEndorsement Description Property GBG Web Service Developers Guide
The description

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Description();
function set_Description(value);
function get_Description();
function set_Description(value);
Property Value
Type: String
Remarks

            This property will be validated against the following named regular expression: Generic
See Also
GlobalDVLADrivingLicenceEndorsement Class
GlobalDVLADrivingLicenceEndorsement Members


GlobalDVLADrivingLicenceEndorsement.Duration Property

GlobalDVLADrivingLicenceEndorsement Duration Property GBG Web Service Developers Guide
The duration of the endorsement on the licence in years

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Duration { get; set; }
public int Duration { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Duration();
function set_Duration(value);
function get_Duration();
function set_Duration(value);
Property Value
Type: Int32
See Also
GlobalDVLADrivingLicenceEndorsement Class
GlobalDVLADrivingLicenceEndorsement Members


GlobalDVLADrivingLicenceEndorsement.EndorsementType Property

GlobalDVLADrivingLicenceEndorsement EndorsementType Property GBG Web Service Developers Guide
The Endorsement type

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EndorsementType { get; set; }
public string EndorsementType { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_EndorsementType();
function set_EndorsementType(value);
function get_EndorsementType();
function set_EndorsementType(value);
Property Value
Type: String
Remarks

            This property will be validated against the following named regular expression: ShortGeneric
See Also
GlobalDVLADrivingLicenceEndorsement Class
GlobalDVLADrivingLicenceEndorsement Members


GlobalDVLADrivingLicenceEndorsement.IsDurationFromConviction Property

GlobalDVLADrivingLicenceEndorsement IsDurationFromConviction Property GBG Web Service Developers Guide
Indicates if the duration is from the date of conviction. If this value is false, then the duration is calculated from the date of the offence

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsDurationFromConviction { get; set; }
public bool IsDurationFromConviction { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IsDurationFromConviction();
function set_IsDurationFromConviction(value);
function get_IsDurationFromConviction();
function set_IsDurationFromConviction(value);
Property Value
Type: Boolean
See Also
GlobalDVLADrivingLicenceEndorsement Class
GlobalDVLADrivingLicenceEndorsement Members


GlobalDVLADrivingLicenceReport Class

GlobalDVLADrivingLicenceReport Class GBG Web Service Developers Guide
/// DVLA driving licence report information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalDVLADrivingLicenceReport

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalDVLADrivingLicenceReport
[SerializableAttribute]
public class GlobalDVLADrivingLicenceReport
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDVLADrivingLicenceReport = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDVLADrivingLicenceReport');
GlobalCheck.DataLib.GlobalDVLADrivingLicenceReport = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDVLADrivingLicenceReport');
See Also
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport Members

GlobalDVLADrivingLicenceReport Members GBG Web Service Developers Guide
The GlobalDVLADrivingLicenceReport type exposes the following members.
Properties
 | Name | Description
Public property | AddressCity | AddressCity Property
Public property | AddressLine1 | AddressLine1 Property
Public property | AddressLine2 | AddressLine2 Property
Public property | AddressLine3 | AddressLine3 Property
Public property | AddressRegion | AddressRegion Property
Public property | Categories | DVLADrivingLicenceReportCategory Property
Public property | DateOfBirth | The licence date of birth
Public property | Disqualified | Disqualified Property
Public property | DisqualifiedUntil | DisqualifiedUntil Property
Public property | Endorsements | DVLADrivingLicenceReportEndorsement Property
Public property | ExpiryDate | The expiry date
Public property | Forenames | The forenames
Public property | Gender | The Gender
Public property | IssueNumber | IssueNumber Property
Public property | LicenceNumber | The licence number
Public property | LicenseType | LicenseType Property
Public property | NilReturn | NilReturn Property
Public property | Postcode | Postcode Property
Public property | Status | Status Property
Public property | Surname | The surname
Public property | TypeLiteral | The Type Literal
Back to Top
See Also
GlobalDVLADrivingLicenceReport Class


GlobalDVLADrivingLicenceReport Properties

GlobalDVLADrivingLicenceReport Properties GBG Web Service Developers Guide
The GlobalDVLADrivingLicenceReport type exposes the following members.
Properties
 | Name | Description
Public property | AddressCity | AddressCity Property
Public property | AddressLine1 | AddressLine1 Property
Public property | AddressLine2 | AddressLine2 Property
Public property | AddressLine3 | AddressLine3 Property
Public property | AddressRegion | AddressRegion Property
Public property | Categories | DVLADrivingLicenceReportCategory Property
Public property | DateOfBirth | The licence date of birth
Public property | Disqualified | Disqualified Property
Public property | DisqualifiedUntil | DisqualifiedUntil Property
Public property | Endorsements | DVLADrivingLicenceReportEndorsement Property
Public property | ExpiryDate | The expiry date
Public property | Forenames | The forenames
Public property | Gender | The Gender
Public property | IssueNumber | IssueNumber Property
Public property | LicenceNumber | The licence number
Public property | LicenseType | LicenseType Property
Public property | NilReturn | NilReturn Property
Public property | Postcode | Postcode Property
Public property | Status | Status Property
Public property | Surname | The surname
Public property | TypeLiteral | The Type Literal
Back to Top
See Also
GlobalDVLADrivingLicenceReport Class


GlobalDVLADrivingLicenceReport.AddressCity Property

GlobalDVLADrivingLicenceReport AddressCity Property GBG Web Service Developers Guide
AddressCity Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AddressCity { get; set; }
public string AddressCity { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressCity();
function set_AddressCity(value);
function get_AddressCity();
function set_AddressCity(value);
Property Value
Type: String

            Contains the AddressCity
            This property will be validated against the following named regular expression: ShortGeneric
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.AddressLine1 Property

GlobalDVLADrivingLicenceReport AddressLine1 Property GBG Web Service Developers Guide
AddressLine1 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AddressLine1 { get; set; }
public string AddressLine1 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressLine1();
function set_AddressLine1(value);
function get_AddressLine1();
function set_AddressLine1(value);
Property Value
Type: String

            Contains the AddressLine1
            This property will be validated against the following named regular expression: ShortGeneric
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.AddressLine2 Property

GlobalDVLADrivingLicenceReport AddressLine2 Property GBG Web Service Developers Guide
AddressLine2 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AddressLine2 { get; set; }
public string AddressLine2 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressLine2();
function set_AddressLine2(value);
function get_AddressLine2();
function set_AddressLine2(value);
Property Value
Type: String

            Contains the AddressLine2
            This property will be validated against the following named regular expression: ShortGeneric
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.AddressLine3 Property

GlobalDVLADrivingLicenceReport AddressLine3 Property GBG Web Service Developers Guide
AddressLine3 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AddressLine3 { get; set; }
public string AddressLine3 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressLine3();
function set_AddressLine3(value);
function get_AddressLine3();
function set_AddressLine3(value);
Property Value
Type: String

            Contains the AddressLine2
            This property will be validated against the following named regular expression: ShortGeneric
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.AddressRegion Property

GlobalDVLADrivingLicenceReport AddressRegion Property GBG Web Service Developers Guide
AddressRegion Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AddressRegion { get; set; }
public string AddressRegion { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressRegion();
function set_AddressRegion(value);
function get_AddressRegion();
function set_AddressRegion(value);
Property Value
Type: String

            Contains the AddressRegion
            This property will be validated against the following named regular expression: ShortGeneric
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.Categories Property

GlobalDVLADrivingLicenceReport Categories Property GBG Web Service Developers Guide
DVLADrivingLicenceReportCategory Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalDVLADrivingLicenceReportCategory> Categories { get; set; }
public List<GlobalDVLADrivingLicenceReportCategory> Categories { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Categories();
function set_Categories(value);
function get_Categories();
function set_Categories(value);
Property Value
Type: List GlobalDVLADrivingLicenceReportCategory

            Contains the DVLADrivingLicenceReportCategory

See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.DateOfBirth Property

GlobalDVLADrivingLicenceReport DateOfBirth Property GBG Web Service Developers Guide
The licence date of birth

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> DateOfBirth { get; set; }
public Nullable<DateTime> DateOfBirth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DateOfBirth();
function set_DateOfBirth(value);
function get_DateOfBirth();
function set_DateOfBirth(value);
Property Value
Type: Nullable DateTime
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.Disqualified Property

GlobalDVLADrivingLicenceReport Disqualified Property GBG Web Service Developers Guide
Disqualified Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Disqualified { get; set; }
public bool Disqualified { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Disqualified();
function set_Disqualified(value);
function get_Disqualified();
function set_Disqualified(value);
Property Value
Type: Boolean

            Contains the Disqualified properties

See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.DisqualifiedUntil Property

GlobalDVLADrivingLicenceReport DisqualifiedUntil Property GBG Web Service Developers Guide
DisqualifiedUntil Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> DisqualifiedUntil { get; set; }
public Nullable<DateTime> DisqualifiedUntil { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DisqualifiedUntil();
function set_DisqualifiedUntil(value);
function get_DisqualifiedUntil();
function set_DisqualifiedUntil(value);
Property Value
Type: Nullable DateTime

            How long the licence was disqualified for

See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.Endorsements Property

GlobalDVLADrivingLicenceReport Endorsements Property GBG Web Service Developers Guide
DVLADrivingLicenceReportEndorsement Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalDVLADrivingLicenceReportEndorsement> Endorsements { get; set; }
public List<GlobalDVLADrivingLicenceReportEndorsement> Endorsements { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Endorsements();
function set_Endorsements(value);
function get_Endorsements();
function set_Endorsements(value);
Property Value
Type: List GlobalDVLADrivingLicenceReportEndorsement

            Contains the DVLADrivingLicenceReportEndorsement

See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.ExpiryDate Property

GlobalDVLADrivingLicenceReport ExpiryDate Property GBG Web Service Developers Guide
The expiry date

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> ExpiryDate { get; set; }
public Nullable<DateTime> ExpiryDate { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryDate();
function set_ExpiryDate(value);
function get_ExpiryDate();
function set_ExpiryDate(value);
Property Value
Type: Nullable DateTime
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.Forenames Property

GlobalDVLADrivingLicenceReport Forenames Property GBG Web Service Developers Guide
The forenames

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Forenames { get; set; }
public string Forenames { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Forenames();
function set_Forenames(value);
function get_Forenames();
function set_Forenames(value);
Property Value
Type: String

            Contains the Licence Number
            This property will be validated against the following named regular expression: StandardNames
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.Gender Property

GlobalDVLADrivingLicenceReport Gender Property GBG Web Service Developers Guide
The Gender

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalGender Gender { get; set; }
public GlobalGender Gender { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Gender();
function set_Gender(value);
function get_Gender();
function set_Gender(value);
Property Value
Type: GlobalGender
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.IssueNumber Property

GlobalDVLADrivingLicenceReport IssueNumber Property GBG Web Service Developers Guide
IssueNumber Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IssueNumber { get; set; }
public int IssueNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IssueNumber();
function set_IssueNumber(value);
function get_IssueNumber();
function set_IssueNumber(value);
Property Value
Type: Int32

            Contains the Issue number on the individuals driving licence

See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.LicenceNumber Property

GlobalDVLADrivingLicenceReport LicenceNumber Property GBG Web Service Developers Guide
The licence number

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LicenceNumber { get; set; }
public string LicenceNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_LicenceNumber();
function set_LicenceNumber(value);
function get_LicenceNumber();
function set_LicenceNumber(value);
Property Value
Type: String

            Contains the licence forenames
            This property will be validated against the following named regular expression: UKDriverNumber
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.LicenseType Property

GlobalDVLADrivingLicenceReport LicenseType Property GBG Web Service Developers Guide
LicenseType Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LicenseType { get; set; }
public string LicenseType { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_LicenseType();
function set_LicenseType(value);
function get_LicenseType();
function set_LicenseType(value);
Property Value
Type: String

            Contains the LicenseType
            This property will be validated against the following named regular expression: UKDriverLicenceType
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.NilReturn Property

GlobalDVLADrivingLicenceReport NilReturn Property GBG Web Service Developers Guide
NilReturn Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int NilReturn { get; set; }
public int NilReturn { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_NilReturn();
function set_NilReturn(value);
function get_NilReturn();
function set_NilReturn(value);
Property Value
Type: Int32

            Indicates the Nil return status (0, 1, 2 or 3)

See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.Postcode Property

GlobalDVLADrivingLicenceReport Postcode Property GBG Web Service Developers Guide
Postcode Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Postcode { get; set; }
public string Postcode { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Postcode();
function set_Postcode(value);
function get_Postcode();
function set_Postcode(value);
Property Value
Type: String

            Contains the postcode from an individuals driving licence.
            This property will be validated against the following named regular expression: UKPostcode
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.Status Property

GlobalDVLADrivingLicenceReport Status Property GBG Web Service Developers Guide
Status Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalDispatchReportStatus Status { get; set; }
public GlobalDispatchReportStatus Status { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Status();
function set_Status(value);
function get_Status();
function set_Status(value);
Property Value
Type: GlobalDispatchReportStatus
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.Surname Property

GlobalDVLADrivingLicenceReport Surname Property GBG Web Service Developers Guide
The surname

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Surname { get; set; }
public string Surname { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Surname();
function set_Surname(value);
function get_Surname();
function set_Surname(value);
Property Value
Type: String

            Contains the surname of the applicant.
            This property will be validated against the following named regular expression: StandardName
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReport.TypeLiteral Property

GlobalDVLADrivingLicenceReport TypeLiteral Property GBG Web Service Developers Guide
The Type Literal

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TypeLiteral { get; set; }
public string TypeLiteral { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TypeLiteral();
function set_TypeLiteral(value);
function get_TypeLiteral();
function set_TypeLiteral(value);
Property Value
Type: String

            Contains the Type Literal
            This property will be validated against the following named regular expression: ShortGeneric
See Also
GlobalDVLADrivingLicenceReport Class
GlobalDVLADrivingLicenceReport Members


GlobalDVLADrivingLicenceReportCategory Class

GlobalDVLADrivingLicenceReportCategory Class GBG Web Service Developers Guide
DVLA driving licence report category information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalDVLADrivingLicenceReportCategory

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalDVLADrivingLicenceReportCategory
[SerializableAttribute]
public class GlobalDVLADrivingLicenceReportCategory
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDVLADrivingLicenceReportCategory = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDVLADrivingLicenceReportCategory');
GlobalCheck.DataLib.GlobalDVLADrivingLicenceReportCategory = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDVLADrivingLicenceReportCategory');
See Also
GlobalDVLADrivingLicenceReportCategory Members


GlobalDVLADrivingLicenceReportCategory Members

GlobalDVLADrivingLicenceReportCategory Members GBG Web Service Developers Guide
The GlobalDVLADrivingLicenceReportCategory type exposes the following members.
Properties
 | Name | Description
Public property | Code | Code Property
Public property | ExpiryDate | The expiry date
Public property | Identifier | Identifier Property
Public property | Restrictions | Restrictions Property
Public property | StartDate | The start date
Public property | Status | Status Property
Back to Top
See Also
GlobalDVLADrivingLicenceReportCategory Class


GlobalDVLADrivingLicenceReportCategory Properties

GlobalDVLADrivingLicenceReportCategory Properties GBG Web Service Developers Guide
The GlobalDVLADrivingLicenceReportCategory type exposes the following members.
Properties
 | Name | Description
Public property | Code | Code Property
Public property | ExpiryDate | The expiry date
Public property | Identifier | Identifier Property
Public property | Restrictions | Restrictions Property
Public property | StartDate | The start date
Public property | Status | Status Property
Back to Top
See Also
GlobalDVLADrivingLicenceReportCategory Class


GlobalDVLADrivingLicenceReportCategory.Code Property

GlobalDVLADrivingLicenceReportCategory Code Property GBG Web Service Developers Guide
Code Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Code { get; set; }
public string Code { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Code();
function set_Code(value);
function get_Code();
function set_Code(value);
Property Value
Type: String

            Contains the Code
            This property will be validated against the following named regular expression: ThreeCharCode
See Also
GlobalDVLADrivingLicenceReportCategory Class
GlobalDVLADrivingLicenceReportCategory Members


GlobalDVLADrivingLicenceReportCategory.ExpiryDate Property

GlobalDVLADrivingLicenceReportCategory ExpiryDate Property GBG Web Service Developers Guide
The expiry date

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> ExpiryDate { get; set; }
public Nullable<DateTime> ExpiryDate { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryDate();
function set_ExpiryDate(value);
function get_ExpiryDate();
function set_ExpiryDate(value);
Property Value
Type: Nullable DateTime
See Also
GlobalDVLADrivingLicenceReportCategory Class
GlobalDVLADrivingLicenceReportCategory Members


GlobalDVLADrivingLicenceReportCategory.Identifier Property

GlobalDVLADrivingLicenceReportCategory Identifier Property GBG Web Service Developers Guide
Identifier Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Identifier { get; set; }
public string Identifier { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Identifier();
function set_Identifier(value);
function get_Identifier();
function set_Identifier(value);
Property Value
Type: String

            Contains the Identifier
            This property will be validated against the following named regular expression: ThreeLetterCode
See Also
GlobalDVLADrivingLicenceReportCategory Class
GlobalDVLADrivingLicenceReportCategory Members


GlobalDVLADrivingLicenceReportCategory.Restrictions Property

GlobalDVLADrivingLicenceReportCategory Restrictions Property GBG Web Service Developers Guide
Restrictions Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<double> Restrictions { get; set; }
public List<double> Restrictions { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Restrictions();
function set_Restrictions(value);
function get_Restrictions();
function set_Restrictions(value);
Property Value
Type: List Double
See Also
GlobalDVLADrivingLicenceReportCategory Class
GlobalDVLADrivingLicenceReportCategory Members


GlobalDVLADrivingLicenceReportCategory.StartDate Property

GlobalDVLADrivingLicenceReportCategory StartDate Property GBG Web Service Developers Guide
The start date

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> StartDate { get; set; }
public Nullable<DateTime> StartDate { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_StartDate();
function set_StartDate(value);
function get_StartDate();
function set_StartDate(value);
Property Value
Type: Nullable DateTime
See Also
GlobalDVLADrivingLicenceReportCategory Class
GlobalDVLADrivingLicenceReportCategory Members


GlobalDVLADrivingLicenceReportCategory.Status Property

GlobalDVLADrivingLicenceReportCategory Status Property GBG Web Service Developers Guide
Status Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalDVLADrivingLicenceReportCategoryType Status { get; set; }
public GlobalDVLADrivingLicenceReportCategoryType Status { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Status();
function set_Status(value);
function get_Status();
function set_Status(value);
Property Value
Type: GlobalDVLADrivingLicenceReportCategoryType

            Contains the Status

See Also
GlobalDVLADrivingLicenceReportCategory Class
GlobalDVLADrivingLicenceReportCategory Members


GlobalDVLADrivingLicenceReportCategoryType Enumeration

GlobalDVLADrivingLicenceReportCategoryType Enumeration GBG Web Service Developers Guide
Defines the GlobalCaseDispatchLicenceCategoryStatus

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalDVLADrivingLicenceReportCategoryType
[SerializableAttribute]
public enum GlobalDVLADrivingLicenceReportCategoryType
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDVLADrivingLicenceReportCategoryType = function();
GlobalCheck.DataLib.GlobalDVLADrivingLicenceReportCategoryType.createEnum('GlobalCheck.DataLib.GlobalDVLADrivingLicenceReportCategoryType', false);
GlobalCheck.DataLib.GlobalDVLADrivingLicenceReportCategoryType = function();
GlobalCheck.DataLib.GlobalDVLADrivingLicenceReportCategoryType.createEnum('GlobalCheck.DataLib.GlobalDVLADrivingLicenceReportCategoryType', false);
Members
Member name | Value | Description
Full | 0 | Full licence
Provisional | 1 | Provisional licence
See Also


GlobalDVLADrivingLicenceReportEndorsement Class

GlobalDVLADrivingLicenceReportEndorsement Class GBG Web Service Developers Guide
DVLA driving licence report endorsement information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalDVLADrivingLicenceReportEndorsement

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalDVLADrivingLicenceReportEndorsement
[SerializableAttribute]
public class GlobalDVLADrivingLicenceReportEndorsement
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDVLADrivingLicenceReportEndorsement = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDVLADrivingLicenceReportEndorsement');
GlobalCheck.DataLib.GlobalDVLADrivingLicenceReportEndorsement = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDVLADrivingLicenceReportEndorsement');
See Also
GlobalDVLADrivingLicenceReportEndorsement Members


GlobalDVLADrivingLicenceReportEndorsement Members

GlobalDVLADrivingLicenceReportEndorsement Members GBG Web Service Developers Guide
The GlobalDVLADrivingLicenceReportEndorsement type exposes the following members.
Properties
 | Name | Description
Public property | ConvictionDate | ConvictionDate Property
Public property | OffenceCode | OffenceCode Property
Public property | OffenceDate | OffenceDate Property
Public property | Points | Points Property
Back to Top
See Also
GlobalDVLADrivingLicenceReportEndorsement Class


GlobalDVLADrivingLicenceReportEndorsement Properties

GlobalDVLADrivingLicenceReportEndorsement Properties GBG Web Service Developers Guide
The GlobalDVLADrivingLicenceReportEndorsement type exposes the following members.
Properties
 | Name | Description
Public property | ConvictionDate | ConvictionDate Property
Public property | OffenceCode | OffenceCode Property
Public property | OffenceDate | OffenceDate Property
Public property | Points | Points Property
Back to Top
See Also
GlobalDVLADrivingLicenceReportEndorsement Class


GlobalDVLADrivingLicenceReportEndorsement.ConvictionDate Property

GlobalDVLADrivingLicenceReportEndorsement ConvictionDate Property GBG Web Service Developers Guide
ConvictionDate Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> ConvictionDate { get; set; }
public Nullable<DateTime> ConvictionDate { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ConvictionDate();
function set_ConvictionDate(value);
function get_ConvictionDate();
function set_ConvictionDate(value);
Property Value
Type: Nullable DateTime
See Also
GlobalDVLADrivingLicenceReportEndorsement Class
GlobalDVLADrivingLicenceReportEndorsement Members


GlobalDVLADrivingLicenceReportEndorsement.OffenceCode Property

GlobalDVLADrivingLicenceReportEndorsement OffenceCode Property GBG Web Service Developers Guide
OffenceCode Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OffenceCode { get; set; }
public string OffenceCode { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OffenceCode();
function set_OffenceCode(value);
function get_OffenceCode();
function set_OffenceCode(value);
Property Value
Type: String

            Contains the OffenceCode
            This property will be validated against the following named regular expression: UKDrivingLicenceEndorsementCode
See Also
GlobalDVLADrivingLicenceReportEndorsement Class
GlobalDVLADrivingLicenceReportEndorsement Members


GlobalDVLADrivingLicenceReportEndorsement.OffenceDate Property

GlobalDVLADrivingLicenceReportEndorsement OffenceDate Property GBG Web Service Developers Guide
OffenceDate Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime OffenceDate { get; set; }
public DateTime OffenceDate { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OffenceDate();
function set_OffenceDate(value);
function get_OffenceDate();
function set_OffenceDate(value);
Property Value
Type: DateTime
See Also
GlobalDVLADrivingLicenceReportEndorsement Class
GlobalDVLADrivingLicenceReportEndorsement Members


GlobalDVLADrivingLicenceReportEndorsement.Points Property

GlobalDVLADrivingLicenceReportEndorsement Points Property GBG Web Service Developers Guide
Points Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Points { get; set; }
public int Points { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Points();
function set_Points(value);
function get_Points();
function set_Points(value);
Property Value
Type: Int32
See Also
GlobalDVLADrivingLicenceReportEndorsement Class
GlobalDVLADrivingLicenceReportEndorsement Members


GlobalDVLADrivingLicenceRestriction Class

GlobalDVLADrivingLicenceRestriction Class GBG Web Service Developers Guide
/// DVLA Driving Licence Restriction information.
Inheritance Hierarchy
System Object
XmlDeserializeBase GlobalDVLADrivingLicenceRestriction
GlobalCheck.DataLib GlobalDVLADrivingLicenceRestriction

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalDVLADrivingLicenceRestriction : XmlDeserializeBase<GlobalDVLADrivingLicenceRestriction>
[SerializableAttribute]
public class GlobalDVLADrivingLicenceRestriction : XmlDeserializeBase<GlobalDVLADrivingLicenceRestriction>
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalDVLADrivingLicenceRestriction = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDVLADrivingLicenceRestriction',
    GlobalCheck.DataLib.XmlDeserializeBase`1);
GlobalCheck.DataLib.GlobalDVLADrivingLicenceRestriction = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalDVLADrivingLicenceRestriction',
    GlobalCheck.DataLib.XmlDeserializeBase`1);
See Also
GlobalDVLADrivingLicenceRestriction Members


GlobalDVLADrivingLicenceRestriction Members

GlobalDVLADrivingLicenceRestriction Members GBG Web Service Developers Guide
The GlobalDVLADrivingLicenceRestriction type exposes the following members.
Properties
 | Name | Description
Public property | Code | The endorsement code
Public property | Description | The description
Back to Top
See Also
GlobalDVLADrivingLicenceRestriction Class


GlobalDVLADrivingLicenceRestriction Properties

GlobalDVLADrivingLicenceRestriction Properties GBG Web Service Developers Guide
The GlobalDVLADrivingLicenceRestriction type exposes the following members.
Properties
 | Name | Description
Public property | Code | The endorsement code
Public property | Description | The description
Back to Top
See Also
GlobalDVLADrivingLicenceRestriction Class


GlobalDVLADrivingLicenceRestriction.Code Property

GlobalDVLADrivingLicenceRestriction Code Property GBG Web Service Developers Guide
The endorsement code

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Code { get; set; }
public double Code { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Code();
function set_Code(value);
function get_Code();
function set_Code(value);
Property Value
Type: Double
See Also
GlobalDVLADrivingLicenceRestriction Class
GlobalDVLADrivingLicenceRestriction Members


GlobalDVLADrivingLicenceRestriction.Description Property

GlobalDVLADrivingLicenceRestriction Description Property GBG Web Service Developers Guide
The description

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Description();
function set_Description(value);
function get_Description();
function set_Description(value);
Property Value
Type: String
Remarks

            This property will be validated against the following named regular expression: Generic
See Also
GlobalDVLADrivingLicenceRestriction Class
GlobalDVLADrivingLicenceRestriction Members


GlobalElectricitySupplier Class

GlobalElectricitySupplier Class GBG Web Service Developers Guide
Contains the electricity supply number information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalElectricitySupplier

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalElectricitySupplier
[SerializableAttribute]
public class GlobalElectricitySupplier
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalElectricitySupplier = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalElectricitySupplier');
GlobalCheck.DataLib.GlobalElectricitySupplier = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalElectricitySupplier');
See Also
GlobalElectricitySupplier Members


GlobalElectricitySupplier Members

GlobalElectricitySupplier Members GBG Web Service Developers Guide
The GlobalElectricitySupplier type exposes the following members.
Properties
 | Name | Description
Public property | MailSort | Mailsort Property
Public property | Number | Number Property
Public property | Postcode | Postcode Property
Back to Top
See Also
GlobalElectricitySupplier Class


GlobalElectricitySupplier Properties

GlobalElectricitySupplier Properties GBG Web Service Developers Guide
The GlobalElectricitySupplier type exposes the following members.
Properties
 | Name | Description
Public property | MailSort | Mailsort Property
Public property | Number | Number Property
Public property | Postcode | Postcode Property
Back to Top
See Also
GlobalElectricitySupplier Class


GlobalElectricitySupplier.MailSort Property

GlobalElectricitySupplier MailSort Property GBG Web Service Developers Guide
Mailsort Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MailSort { get; set; }
public string MailSort { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MailSort();
function set_MailSort(value);
function get_MailSort();
function set_MailSort(value);
Property Value
Type: String

            Containing the mail sort from an individuals electricity bill. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: MailSort
See Also
GlobalElectricitySupplier Class
GlobalElectricitySupplier Members


GlobalElectricitySupplier.Number Property

GlobalElectricitySupplier Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            Electricity Supply Number

See Also
GlobalElectricitySupplier Class
GlobalElectricitySupplier Members


GlobalElectricitySupplier.Postcode Property

GlobalElectricitySupplier Postcode Property GBG Web Service Developers Guide
Postcode Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Postcode { get; set; }
public string Postcode { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Postcode();
function set_Postcode(value);
function get_Postcode();
function set_Postcode(value);
Property Value
Type: String

            Containing the postcode from an individuals electricity bill. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Postcode
See Also
GlobalElectricitySupplier Class
GlobalElectricitySupplier Members


GlobalEmployment Class

GlobalEmployment Class GBG Web Service Developers Guide
Contains employment information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalEmployment

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalEmployment
[SerializableAttribute]
public class GlobalEmployment
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalEmployment = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalEmployment');
GlobalCheck.DataLib.GlobalEmployment = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalEmployment');
See Also
GlobalEmployment Members


GlobalEmployment Members

GlobalEmployment Members GBG Web Service Developers Guide
The GlobalEmployment type exposes the following members.
Properties
 | Name | Description
Public property | CurrentTime | CurrentTime Property
Public property | EmploymentStatus | EmploymentStatus Property
Public property | ResidenceType | ResidenceType Property
Back to Top
See Also
GlobalEmployment Class


GlobalEmployment Properties

GlobalEmployment Properties GBG Web Service Developers Guide
The GlobalEmployment type exposes the following members.
Properties
 | Name | Description
Public property | CurrentTime | CurrentTime Property
Public property | EmploymentStatus | EmploymentStatus Property
Public property | ResidenceType | ResidenceType Property
Back to Top
See Also
GlobalEmployment Class


GlobalEmployment.CurrentTime Property

GlobalEmployment CurrentTime Property GBG Web Service Developers Guide
CurrentTime Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalCurrentTime CurrentTime { get; set; }
public GlobalCurrentTime CurrentTime { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CurrentTime();
function set_CurrentTime(value);
function get_CurrentTime();
function set_CurrentTime(value);
Property Value
Type: GlobalCurrentTime

            How long the individual has been at their current place of employment. This property may be omitted to indicate that this information is not available.

See Also
GlobalEmployment Class
GlobalEmployment Members


GlobalEmployment.EmploymentStatus Property

GlobalEmployment EmploymentStatus Property GBG Web Service Developers Guide
EmploymentStatus Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalEmploymentStatus EmploymentStatus { get; set; }
public GlobalEmploymentStatus EmploymentStatus { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_EmploymentStatus();
function set_EmploymentStatus(value);
function get_EmploymentStatus();
function set_EmploymentStatus(value);
Property Value
Type: GlobalEmploymentStatus

            The employment status the individual has. This property may be omitted to indicate that this information is not available.

See Also
GlobalEmployment Class
GlobalEmployment Members


GlobalEmployment.ResidenceType Property

GlobalEmployment ResidenceType Property GBG Web Service Developers Guide
ResidenceType Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalResidenceType ResidenceType { get; set; }
public GlobalResidenceType ResidenceType { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ResidenceType();
function set_ResidenceType(value);
function get_ResidenceType();
function set_ResidenceType(value);
Property Value
Type: GlobalResidenceType

            The type of home ownership the individual has. This property may be omitted to indicate that this information is not available.

See Also
GlobalEmployment Class
GlobalEmployment Members


GlobalEmploymentStatus Enumeration

GlobalEmploymentStatus Enumeration GBG Web Service Developers Guide
Employment status information

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalEmploymentStatus
[SerializableAttribute]
public enum GlobalEmploymentStatus
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalEmploymentStatus = function();
GlobalCheck.DataLib.GlobalEmploymentStatus.createEnum('GlobalCheck.DataLib.GlobalEmploymentStatus', false);
GlobalCheck.DataLib.GlobalEmploymentStatus = function();
GlobalCheck.DataLib.GlobalEmploymentStatus.createEnum('GlobalCheck.DataLib.GlobalEmploymentStatus', false);
Members
Member name | Value | Description
FTPerm | 0 | Full-time Permanent
PTPerm | 1 | Part-time Permanent
SelfEmployed | 2 | Self Employed
Retired | 3 | Retired
Homemaker | 4 | Homemaker
Unemployed | 5 | Unemployed
Student | 6 | Student
ArmedForces | 7 | Armed Forces
Employed | 8 | Employed
ReceivesPension | 9 | In receipt of pension
CarerChild | 10 | Carer for child
CarerOver16 | 11 | Carer for over 16
FTEducation | 12 | Full-time Education
Other | 13 | Other
See Also


GlobalEuropeanIdentityCard Class

GlobalEuropeanIdentityCard Class GBG Web Service Developers Guide
European identity card information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalEuropeanIdentityCard

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalEuropeanIdentityCard
[SerializableAttribute]
public class GlobalEuropeanIdentityCard
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalEuropeanIdentityCard = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalEuropeanIdentityCard');
GlobalCheck.DataLib.GlobalEuropeanIdentityCard = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalEuropeanIdentityCard');
See Also
GlobalEuropeanIdentityCard Members


GlobalEuropeanIdentityCard Members

GlobalEuropeanIdentityCard Members GBG Web Service Developers Guide
The GlobalEuropeanIdentityCard type exposes the following members.
Properties
 | Name | Description
Public property | CountryOfIssue | Country Of Issue Property
Public property | CountryOfNationality | Country Of Nationality Property
Public property | ExpiryDay | ExpiryDay Property
Public property | ExpiryMonth | Expiry Month Property
Public property | ExpiryYear | Expiry Year Property
Public property | Line1 | Line1 Property
Public property | Line2 | Line2 Property
Public property | Line3 | Line 3 Property
Back to Top
See Also
GlobalEuropeanIdentityCard Class


GlobalEuropeanIdentityCard Properties

GlobalEuropeanIdentityCard Properties GBG Web Service Developers Guide
The GlobalEuropeanIdentityCard type exposes the following members.
Properties
 | Name | Description
Public property | CountryOfIssue | Country Of Issue Property
Public property | CountryOfNationality | Country Of Nationality Property
Public property | ExpiryDay | ExpiryDay Property
Public property | ExpiryMonth | Expiry Month Property
Public property | ExpiryYear | Expiry Year Property
Public property | Line1 | Line1 Property
Public property | Line2 | Line2 Property
Public property | Line3 | Line 3 Property
Back to Top
See Also
GlobalEuropeanIdentityCard Class


GlobalEuropeanIdentityCard.CountryOfIssue Property

GlobalEuropeanIdentityCard CountryOfIssue Property GBG Web Service Developers Guide
Country Of Issue Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CountryOfIssue { get; set; }
public string CountryOfIssue { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CountryOfIssue();
function set_CountryOfIssue(value);
function get_CountryOfIssue();
function set_CountryOfIssue(value);
Property Value
Type: String

            Contains the country of issue. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Country
See Also
GlobalEuropeanIdentityCard Class
GlobalEuropeanIdentityCard Members


GlobalEuropeanIdentityCard.CountryOfNationality Property

GlobalEuropeanIdentityCard CountryOfNationality Property GBG Web Service Developers Guide
Country Of Nationality Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CountryOfNationality { get; set; }
public string CountryOfNationality { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CountryOfNationality();
function set_CountryOfNationality(value);
function get_CountryOfNationality();
function set_CountryOfNationality(value);
Property Value
Type: String

            Contains the country of nationality. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Country
See Also
GlobalEuropeanIdentityCard Class
GlobalEuropeanIdentityCard Members


GlobalEuropeanIdentityCard.ExpiryDay Property

GlobalEuropeanIdentityCard ExpiryDay Property GBG Web Service Developers Guide
ExpiryDay Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExpiryDay { get; set; }
public int ExpiryDay { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryDay();
function set_ExpiryDay(value);
function get_ExpiryDay();
function set_ExpiryDay(value);
Property Value
Type: Int32

            Integer in the range 1-31 representing the day of the month of the expiry day of an individuals id card.
            This property will be validated against the following named regular expression: day
See Also
GlobalEuropeanIdentityCard Class
GlobalEuropeanIdentityCard Members


GlobalEuropeanIdentityCard.ExpiryMonth Property

GlobalEuropeanIdentityCard ExpiryMonth Property GBG Web Service Developers Guide
Expiry Month Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExpiryMonth { get; set; }
public int ExpiryMonth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryMonth();
function set_ExpiryMonth(value);
function get_ExpiryMonth();
function set_ExpiryMonth(value);
Property Value
Type: Int32

            Integer in the range 1-12 representing the month of the expiry day of an individuals id card.
            This property will be validated against the following named regular expression: Month
See Also
GlobalEuropeanIdentityCard Class
GlobalEuropeanIdentityCard Members


GlobalEuropeanIdentityCard.ExpiryYear Property

GlobalEuropeanIdentityCard ExpiryYear Property GBG Web Service Developers Guide
Expiry Year Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExpiryYear { get; set; }
public int ExpiryYear { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryYear();
function set_ExpiryYear(value);
function get_ExpiryYear();
function set_ExpiryYear(value);
Property Value
Type: Int32

            Integer in the range 1-2099 representing the year of the expiry day of an individuals id card.
            This property will be validated against the following named regular expression: Year
See Also
GlobalEuropeanIdentityCard Class
GlobalEuropeanIdentityCard Members


GlobalEuropeanIdentityCard.Line1 Property

GlobalEuropeanIdentityCard Line1 Property GBG Web Service Developers Guide
Line1 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Line1 { get; set; }
public string Line1 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Line1();
function set_Line1(value);
function get_Line1();
function set_Line1(value);
Property Value
Type: String

            European identity card line 1.

See Also
GlobalEuropeanIdentityCard Class
GlobalEuropeanIdentityCard Members


GlobalEuropeanIdentityCard.Line2 Property

GlobalEuropeanIdentityCard Line2 Property GBG Web Service Developers Guide
Line2 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Line2 { get; set; }
public string Line2 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Line2();
function set_Line2(value);
function get_Line2();
function set_Line2(value);
Property Value
Type: String

            European identity card line 2.

See Also
GlobalEuropeanIdentityCard Class
GlobalEuropeanIdentityCard Members


GlobalEuropeanIdentityCard.Line3 Property

GlobalEuropeanIdentityCard Line3 Property GBG Web Service Developers Guide
Line 3 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Line3 { get; set; }
public string Line3 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Line3();
function set_Line3(value);
function get_Line3();
function set_Line3(value);
Property Value
Type: String

            Contains Line 3 of an individuals Identity Card number (MachineReadableZone3). This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: IDLine3MachineReadableZone3
See Also
GlobalEuropeanIdentityCard Class
GlobalEuropeanIdentityCard Members


GlobalGender Enumeration

GlobalGender Enumeration GBG Web Service Developers Guide
Gender of an individual.

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalGender
[SerializableAttribute]
public enum GlobalGender
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalGender = function();
GlobalCheck.DataLib.GlobalGender.createEnum('GlobalCheck.DataLib.GlobalGender', false);
GlobalCheck.DataLib.GlobalGender = function();
GlobalCheck.DataLib.GlobalGender.createEnum('GlobalCheck.DataLib.GlobalGender', false);
Members
Member name | Value | Description
Unspecified | 0 | Unspecified
Unknown | 1 | Unknown gender
Male | 2 | Male
Female | 3 | Female
See Also


GlobalGeneric Class

GlobalGeneric Class GBG Web Service Developers Guide
Generic information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalGeneric

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalGeneric
[SerializableAttribute]
public class GlobalGeneric
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalGeneric = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalGeneric');
GlobalCheck.DataLib.GlobalGeneric = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalGeneric');
See Also
GlobalGeneric Members


GlobalGeneric Members

GlobalGeneric Members GBG Web Service Developers Guide
The GlobalGeneric type exposes the following members.
Methods
Name | Description
DelimitedHeader | Adds column headers for Data Extract to StringBuilder
Back to Top
Properties
 | Name | Description
Public property | Generic1 | Generic field Property
Public property | Generic10 | Generic field Property
Public property | Generic11 | Generic field Property
Public property | Generic12 | Generic field Property
Public property | Generic13 | Generic field Property
Public property | Generic14 | Generic field Property
Public property | Generic15 | Generic field Property
Public property | Generic16 | Generic field Property
Public property | Generic17 | Generic field Property
Public property | Generic18 | Generic field Property
Public property | Generic19 | Generic field Property
Public property | Generic2 | Generic field Property
Public property | Generic20 | Generic field Property
Public property | Generic3 | Generic field Property
Public property | Generic4 | Generic field Property
Public property | Generic5 | Generic field Property
Public property | Generic6 | Generic field Property
Public property | Generic7 | Generic field Property
Public property | Generic8 | Generic field Property
Public property | Generic9 | Generic field Property
Back to Top
See Also
GlobalGeneric Class


GlobalGeneric Methods

GlobalGeneric Methods GBG Web Service Developers Guide
The GlobalGeneric type exposes the following members.
Methods
Name | Description
DelimitedHeader | Adds column headers for Data Extract to StringBuilder
Back to Top
See Also
GlobalGeneric Class


GlobalGeneric.DelimitedHeader Method

GlobalGeneric DelimitedHeader Method GBG Web Service Developers Guide
Adds column headers for Data Extract to StringBuilder

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void DelimitedHeader(
    ref StringBuilder StringB,
    string Delimiter
)
public static void DelimitedHeader(
    ref StringBuilder StringB,
    string Delimiter
)
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalGeneric.DelimitedHeader = function(StringB, Delimiter);
GlobalCheck.DataLib.GlobalGeneric.DelimitedHeader = function(StringB, Delimiter);
Parameters
StringB
Type: System.Text StringBuilder
[ref] StringBuilder object to append strings to
Delimiter
Type: System String
Delimiter to separate columns, e.g. '\t'
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric Properties

GlobalGeneric Properties GBG Web Service Developers Guide
The GlobalGeneric type exposes the following members.
Properties
 | Name | Description
Public property | Generic1 | Generic field Property
Public property | Generic10 | Generic field Property
Public property | Generic11 | Generic field Property
Public property | Generic12 | Generic field Property
Public property | Generic13 | Generic field Property
Public property | Generic14 | Generic field Property
Public property | Generic15 | Generic field Property
Public property | Generic16 | Generic field Property
Public property | Generic17 | Generic field Property
Public property | Generic18 | Generic field Property
Public property | Generic19 | Generic field Property
Public property | Generic2 | Generic field Property
Public property | Generic20 | Generic field Property
Public property | Generic3 | Generic field Property
Public property | Generic4 | Generic field Property
Public property | Generic5 | Generic field Property
Public property | Generic6 | Generic field Property
Public property | Generic7 | Generic field Property
Public property | Generic8 | Generic field Property
Public property | Generic9 | Generic field Property
Back to Top
See Also
GlobalGeneric Class


GlobalGeneric.Generic1 Property

GlobalGeneric Generic1 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic1 { get; set; }
public string Generic1 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic1();
function set_Generic1(value);
function get_Generic1();
function set_Generic1(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic10 Property

GlobalGeneric Generic10 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic10 { get; set; }
public string Generic10 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic10();
function set_Generic10(value);
function get_Generic10();
function set_Generic10(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic11 Property

GlobalGeneric Generic11 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic11 { get; set; }
public string Generic11 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic11();
function set_Generic11(value);
function get_Generic11();
function set_Generic11(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic12 Property

GlobalGeneric Generic12 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic12 { get; set; }
public string Generic12 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic12();
function set_Generic12(value);
function get_Generic12();
function set_Generic12(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic13 Property

GlobalGeneric Generic13 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic13 { get; set; }
public string Generic13 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic13();
function set_Generic13(value);
function get_Generic13();
function set_Generic13(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic14 Property

GlobalGeneric Generic14 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic14 { get; set; }
public string Generic14 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic14();
function set_Generic14(value);
function get_Generic14();
function set_Generic14(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic15 Property

GlobalGeneric Generic15 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic15 { get; set; }
public string Generic15 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic15();
function set_Generic15(value);
function get_Generic15();
function set_Generic15(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic16 Property

GlobalGeneric Generic16 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic16 { get; set; }
public string Generic16 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic16();
function set_Generic16(value);
function get_Generic16();
function set_Generic16(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic17 Property

GlobalGeneric Generic17 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic17 { get; set; }
public string Generic17 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic17();
function set_Generic17(value);
function get_Generic17();
function set_Generic17(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic18 Property

GlobalGeneric Generic18 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic18 { get; set; }
public string Generic18 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic18();
function set_Generic18(value);
function get_Generic18();
function set_Generic18(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic19 Property

GlobalGeneric Generic19 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic19 { get; set; }
public string Generic19 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic19();
function set_Generic19(value);
function get_Generic19();
function set_Generic19(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic2 Property

GlobalGeneric Generic2 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic2 { get; set; }
public string Generic2 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic2();
function set_Generic2(value);
function get_Generic2();
function set_Generic2(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic20 Property

GlobalGeneric Generic20 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic20 { get; set; }
public string Generic20 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic20();
function set_Generic20(value);
function get_Generic20();
function set_Generic20(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic3 Property

GlobalGeneric Generic3 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic3 { get; set; }
public string Generic3 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic3();
function set_Generic3(value);
function get_Generic3();
function set_Generic3(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic4 Property

GlobalGeneric Generic4 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic4 { get; set; }
public string Generic4 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic4();
function set_Generic4(value);
function get_Generic4();
function set_Generic4(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic5 Property

GlobalGeneric Generic5 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic5 { get; set; }
public string Generic5 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic5();
function set_Generic5(value);
function get_Generic5();
function set_Generic5(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic6 Property

GlobalGeneric Generic6 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic6 { get; set; }
public string Generic6 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic6();
function set_Generic6(value);
function get_Generic6();
function set_Generic6(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic7 Property

GlobalGeneric Generic7 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic7 { get; set; }
public string Generic7 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic7();
function set_Generic7(value);
function get_Generic7();
function set_Generic7(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic8 Property

GlobalGeneric Generic8 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic8 { get; set; }
public string Generic8 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic8();
function set_Generic8(value);
function get_Generic8();
function set_Generic8(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalGeneric.Generic9 Property

GlobalGeneric Generic9 Property GBG Web Service Developers Guide
Generic field Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Generic9 { get; set; }
public string Generic9 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Generic9();
function set_Generic9(value);
function get_Generic9();
function set_Generic9(value);
Property Value
Type: String

            Contains a Generic Field. This property may be omitted or set to an empty string to indicate no value was supplied..
            This property will be validated against the following named regular expression: Generic
See Also
GlobalGeneric Class
GlobalGeneric Members


GlobalHome Class

GlobalHome Class GBG Web Service Developers Guide
Contains data returned for the home page of an Organisation
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalHome

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalHome
public class GlobalHome
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalHome = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalHome');
GlobalCheck.DataLib.GlobalHome = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalHome');
See Also
GlobalHome Members


GlobalHome Members

GlobalHome Members GBG Web Service Developers Guide
The GlobalHome type exposes the following members.
Properties
 | Name | Description
Public property | OrgName | OrgName Property
Public property | Resources | Resources Property
Public property | SupportContact | SupportContact Property
Back to Top
See Also
GlobalHome Class


GlobalHome Properties

GlobalHome Properties GBG Web Service Developers Guide
The GlobalHome type exposes the following members.
Properties
 | Name | Description
Public property | OrgName | OrgName Property
Public property | Resources | Resources Property
Public property | SupportContact | SupportContact Property
Back to Top
See Also
GlobalHome Class


GlobalHome.OrgName Property

GlobalHome OrgName Property GBG Web Service Developers Guide
OrgName Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OrgName { get; set; }
public string OrgName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OrgName();
function set_OrgName(value);
function get_OrgName();
function set_OrgName(value);
Property Value
Type: String

            Organisation Name

See Also
GlobalHome Class
GlobalHome Members


GlobalHome.Resources Property

GlobalHome Resources Property GBG Web Service Developers Guide
Resources Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalResource> Resources { get; set; }
public List<GlobalResource> Resources { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Resources();
function set_Resources(value);
function get_Resources();
function set_Resources(value);
Property Value
Type: List GlobalResource

            List of Resources the current user has permission to access

See Also
GlobalHome Class
GlobalHome Members


GlobalHome.SupportContact Property

GlobalHome SupportContact Property GBG Web Service Developers Guide
SupportContact Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalSupportContact SupportContact { get; set; }
public GlobalSupportContact SupportContact { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SupportContact();
function set_SupportContact(value);
function get_SupportContact();
function set_SupportContact(value);
Property Value
Type: GlobalSupportContact

            Support Contact details

See Also
GlobalHome Class
GlobalHome Members


GlobalIdentityCard Class

GlobalIdentityCard Class GBG Web Service Developers Guide
International identity card details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalIdentityCard

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalIdentityCard
[SerializableAttribute]
public class GlobalIdentityCard
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalIdentityCard = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalIdentityCard');
GlobalCheck.DataLib.GlobalIdentityCard = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalIdentityCard');
See Also
GlobalIdentityCard Members


GlobalIdentityCard Members

GlobalIdentityCard Members GBG Web Service Developers Guide
The GlobalIdentityCard type exposes the following members.
Properties
 | Name | Description
Public property | Country | Identity Card Country Property
Public property | Number | Identity Card Number Property
Back to Top
See Also
GlobalIdentityCard Class


GlobalIdentityCard Properties

GlobalIdentityCard Properties GBG Web Service Developers Guide
The GlobalIdentityCard type exposes the following members.
Properties
 | Name | Description
Public property | Country | Identity Card Country Property
Public property | Number | Identity Card Number Property
Back to Top
See Also
GlobalIdentityCard Class


GlobalIdentityCard.Country Property

GlobalIdentityCard Country Property GBG Web Service Developers Guide
Identity Card Country Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Country { get; set; }
public string Country { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Country();
function set_Country(value);
function get_Country();
function set_Country(value);
Property Value
Type: String

            The country for the individuals identity card. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Country
See Also
GlobalIdentityCard Class
GlobalIdentityCard Members


GlobalIdentityCard.Number Property

GlobalIdentityCard Number Property GBG Web Service Developers Guide
Identity Card Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            The number for the individuals identity card. This property may be omitted or set to an empty string to indicate no value was supplied.
            The property will be validated against the regular expression associated with the specific country.

See Also
GlobalIdentityCard Class
GlobalIdentityCard Members


GlobalIdentityDocuments Class

GlobalIdentityDocuments Class GBG Web Service Developers Guide
Conatins identity document information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalIdentityDocuments

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalIdentityDocuments
[SerializableAttribute]
public class GlobalIdentityDocuments
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalIdentityDocuments = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalIdentityDocuments');
GlobalCheck.DataLib.GlobalIdentityDocuments = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalIdentityDocuments');
See Also
GlobalIdentityDocuments Members


GlobalIdentityDocuments Members

GlobalIdentityDocuments Members GBG Web Service Developers Guide
The GlobalIdentityDocuments type exposes the following members.
Properties
 | Name | Description
Public property | Argentina | Contains an individuals Argentinian Identity Details
Public property | Australia | Contains an individuals Australian Identity Details
Public property | Brazil | Contains an individuals Brazil Identity Details
Public property | Canada | Contains an individuals Canadian Identity Details
Public property | Denmark | Contains an individuals Danish Identity Details
Public property | EuropeanIdentityCard | Contains an individuals European Identity Card Details
Public property | IdentityCard | Contains an individuals National Identity Card Details
Public property | InternationalPassport | Contains an individuals International Passport details
Public property | Italy | Contains an individuals Italian Identity Details
Public property | Mexico | Contains an individuals Mexican Identity Details
Public property | NewZealand | Contains an individuals New Zealand Identity Details
Public property | SouthAfrica | Contains an individuals South African Identity Details
Public property | Spain | Contains an individuals Spain Identity Details
Public property | Sweden | Contains an individuals Swedish Identity Details
Public property | UK | Contains an individuals UK Identity Details
Public property | US | Contains an individuals American Identity Details
Back to Top
See Also
GlobalIdentityDocuments Class


GlobalIdentityDocuments Properties

GlobalIdentityDocuments Properties GBG Web Service Developers Guide
The GlobalIdentityDocuments type exposes the following members.
Properties
 | Name | Description
Public property | Argentina | Contains an individuals Argentinian Identity Details
Public property | Australia | Contains an individuals Australian Identity Details
Public property | Brazil | Contains an individuals Brazil Identity Details
Public property | Canada | Contains an individuals Canadian Identity Details
Public property | Denmark | Contains an individuals Danish Identity Details
Public property | EuropeanIdentityCard | Contains an individuals European Identity Card Details
Public property | IdentityCard | Contains an individuals National Identity Card Details
Public property | InternationalPassport | Contains an individuals International Passport details
Public property | Italy | Contains an individuals Italian Identity Details
Public property | Mexico | Contains an individuals Mexican Identity Details
Public property | NewZealand | Contains an individuals New Zealand Identity Details
Public property | SouthAfrica | Contains an individuals South African Identity Details
Public property | Spain | Contains an individuals Spain Identity Details
Public property | Sweden | Contains an individuals Swedish Identity Details
Public property | UK | Contains an individuals UK Identity Details
Public property | US | Contains an individuals American Identity Details
Back to Top
See Also
GlobalIdentityDocuments Class


GlobalIdentityDocuments.Argentina Property

GlobalIdentityDocuments Argentina Property GBG Web Service Developers Guide
Contains an individuals Argentinian Identity Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalArgentina Argentina { get; set; }
public GlobalArgentina Argentina { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Argentina();
function set_Argentina(value);
function get_Argentina();
function set_Argentina(value);
Property Value
Type: GlobalArgentina
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.Australia Property

GlobalIdentityDocuments Australia Property GBG Web Service Developers Guide
Contains an individuals Australian Identity Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalAustralia Australia { get; set; }
public GlobalAustralia Australia { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Australia();
function set_Australia(value);
function get_Australia();
function set_Australia(value);
Property Value
Type: GlobalAustralia
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.Brazil Property

GlobalIdentityDocuments Brazil Property GBG Web Service Developers Guide
Contains an individuals Brazil Identity Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalBrazil Brazil { get; set; }
public GlobalBrazil Brazil { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Brazil();
function set_Brazil(value);
function get_Brazil();
function set_Brazil(value);
Property Value
Type: GlobalBrazil
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.Canada Property

GlobalIdentityDocuments Canada Property GBG Web Service Developers Guide
Contains an individuals Canadian Identity Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalCanada Canada { get; set; }
public GlobalCanada Canada { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Canada();
function set_Canada(value);
function get_Canada();
function set_Canada(value);
Property Value
Type: GlobalCanada
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.Denmark Property

GlobalIdentityDocuments Denmark Property GBG Web Service Developers Guide
Contains an individuals Danish Identity Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalDenmark Denmark { get; set; }
public GlobalDenmark Denmark { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Denmark();
function set_Denmark(value);
function get_Denmark();
function set_Denmark(value);
Property Value
Type: GlobalDenmark
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.EuropeanIdentityCard Property

GlobalIdentityDocuments EuropeanIdentityCard Property GBG Web Service Developers Guide
Contains an individuals European Identity Card Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalEuropeanIdentityCard EuropeanIdentityCard { get; set; }
public GlobalEuropeanIdentityCard EuropeanIdentityCard { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_EuropeanIdentityCard();
function set_EuropeanIdentityCard(value);
function get_EuropeanIdentityCard();
function set_EuropeanIdentityCard(value);
Property Value
Type: GlobalEuropeanIdentityCard
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.IdentityCard Property

GlobalIdentityDocuments IdentityCard Property GBG Web Service Developers Guide
Contains an individuals National Identity Card Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalIdentityCard IdentityCard { get; set; }
public GlobalIdentityCard IdentityCard { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IdentityCard();
function set_IdentityCard(value);
function get_IdentityCard();
function set_IdentityCard(value);
Property Value
Type: GlobalIdentityCard
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.InternationalPassport Property

GlobalIdentityDocuments InternationalPassport Property GBG Web Service Developers Guide
Contains an individuals International Passport details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalInternationalPassport InternationalPassport { get; set; }
public GlobalInternationalPassport InternationalPassport { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_InternationalPassport();
function set_InternationalPassport(value);
function get_InternationalPassport();
function set_InternationalPassport(value);
Property Value
Type: GlobalInternationalPassport
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.Italy Property

GlobalIdentityDocuments Italy Property GBG Web Service Developers Guide
Contains an individuals Italian Identity Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalItaly Italy { get; set; }
public GlobalItaly Italy { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Italy();
function set_Italy(value);
function get_Italy();
function set_Italy(value);
Property Value
Type: GlobalItaly
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.Mexico Property

GlobalIdentityDocuments Mexico Property GBG Web Service Developers Guide
Contains an individuals Mexican Identity Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalMexico Mexico { get; set; }
public GlobalMexico Mexico { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Mexico();
function set_Mexico(value);
function get_Mexico();
function set_Mexico(value);
Property Value
Type: GlobalMexico
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.NewZealand Property

GlobalIdentityDocuments NewZealand Property GBG Web Service Developers Guide
Contains an individuals New Zealand Identity Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalNewZealand NewZealand { get; set; }
public GlobalNewZealand NewZealand { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_NewZealand();
function set_NewZealand(value);
function get_NewZealand();
function set_NewZealand(value);
Property Value
Type: GlobalNewZealand
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.SouthAfrica Property

GlobalIdentityDocuments SouthAfrica Property GBG Web Service Developers Guide
Contains an individuals South African Identity Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalSouthAfrica SouthAfrica { get; set; }
public GlobalSouthAfrica SouthAfrica { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SouthAfrica();
function set_SouthAfrica(value);
function get_SouthAfrica();
function set_SouthAfrica(value);
Property Value
Type: GlobalSouthAfrica
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.Spain Property

GlobalIdentityDocuments Spain Property GBG Web Service Developers Guide
Contains an individuals Spain Identity Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalSpain Spain { get; set; }
public GlobalSpain Spain { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Spain();
function set_Spain(value);
function get_Spain();
function set_Spain(value);
Property Value
Type: GlobalSpain
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.Sweden Property

GlobalIdentityDocuments Sweden Property GBG Web Service Developers Guide
Contains an individuals Swedish Identity Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalSweden Sweden { get; set; }
public GlobalSweden Sweden { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Sweden();
function set_Sweden(value);
function get_Sweden();
function set_Sweden(value);
Property Value
Type: GlobalSweden
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.UK Property

GlobalIdentityDocuments UK Property GBG Web Service Developers Guide
Contains an individuals UK Identity Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalUKData UK { get; set; }
public GlobalUKData UK { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_UK();
function set_UK(value);
function get_UK();
function set_UK(value);
Property Value
Type: GlobalUKData
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalIdentityDocuments.US Property

GlobalIdentityDocuments US Property GBG Web Service Developers Guide
Contains an individuals American Identity Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalUS US { get; set; }
public GlobalUS US { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_US();
function set_US(value);
function get_US();
function set_US(value);
Property Value
Type: GlobalUS
See Also
GlobalIdentityDocuments Class
GlobalIdentityDocuments Members


GlobalImage Class

GlobalImage Class GBG Web Service Developers Guide
Type and Reference of identity document images
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalImage

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalImage
[SerializableAttribute]
public class GlobalImage
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalImage = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalImage');
GlobalCheck.DataLib.GlobalImage = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalImage');
See Also
GlobalImage Members


GlobalImage Members

GlobalImage Members GBG Web Service Developers Guide
The GlobalImage type exposes the following members.
Properties
 | Name | Description
Public property | AuthenticationID | Unique Identifier for the Document Image, set this value to AuthenticationID returned from GlobalDIVData to associate this GlobalInputData to a Document Image Validation record
Public property | Type | The type of image
Back to Top
See Also
GlobalImage Class


GlobalImage Properties

GlobalImage Properties GBG Web Service Developers Guide
The GlobalImage type exposes the following members.
Properties
 | Name | Description
Public property | AuthenticationID | Unique Identifier for the Document Image, set this value to AuthenticationID returned from GlobalDIVData to associate this GlobalInputData to a Document Image Validation record
Public property | Type | The type of image
Back to Top
See Also
GlobalImage Class


GlobalImage.AuthenticationID Property

GlobalImage AuthenticationID Property GBG Web Service Developers Guide
Unique Identifier for the Document Image, set this value to AuthenticationID returned from GlobalDIVData to associate this GlobalInputData to a Document Image Validation record

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid AuthenticationID { get; set; }
public Guid AuthenticationID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AuthenticationID();
function set_AuthenticationID(value);
function get_AuthenticationID();
function set_AuthenticationID(value);
Property Value
Type: Guid
See Also
GlobalImage Class
GlobalImage Members


GlobalImage.Type Property

GlobalImage Type Property GBG Web Service Developers Guide
The type of image

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Type { get; set; }
public string Type { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Type();
function set_Type(value);
function get_Type();
function set_Type(value);
Property Value
Type: String
See Also
GlobalImage Class
GlobalImage Members


GlobalInputData Class

GlobalInputData Class GBG Web Service Developers Guide
The GlobalInputData data type contains the details of an individual, used in performing an Authentication. The data type is a container for a number of other complex data types, which split an individuals details between them.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalInputData

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalInputData : IDecrypt
[SerializableAttribute]
public class GlobalInputData : IDecrypt
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalInputData = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalInputData',
    null,
    GlobalCheck.DataLib.IDecrypt);
GlobalCheck.DataLib.GlobalInputData = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalInputData',
    null,
    GlobalCheck.DataLib.IDecrypt);
See Also
GlobalInputData Members


GlobalInputData Members

GlobalInputData Members GBG Web Service Developers Guide
The GlobalInputData type exposes the following members.
Properties
 | Name | Description
Public property | AddressDocuments | Address Document Details
Public property | Addresses | Address Details - Contains Information for Current, Previous 1, 2 and 3.
Public property | BankingDetails | Banking Details
Public property | ContactDetails | Contact Details
Public property | Employment | Employment Details
Public property | GlobalGeneric | Global Generic Details
Public property | IdentityDocuments | Identity Document Details
Public property | Images | An Individuals validated image
Public property | IsFreeFormat | Returns True if Address data is in Free Format
Public property | Location | Location Details
Public property | Personal | An Individuals Personal Details
Back to Top
See Also
GlobalInputData Class


GlobalInputData Properties

GlobalInputData Properties GBG Web Service Developers Guide
The GlobalInputData type exposes the following members.
Properties
 | Name | Description
Public property | AddressDocuments | Address Document Details
Public property | Addresses | Address Details - Contains Information for Current, Previous 1, 2 and 3.
Public property | BankingDetails | Banking Details
Public property | ContactDetails | Contact Details
Public property | Employment | Employment Details
Public property | GlobalGeneric | Global Generic Details
Public property | IdentityDocuments | Identity Document Details
Public property | Images | An Individuals validated image
Public property | IsFreeFormat | Returns True if Address data is in Free Format
Public property | Location | Location Details
Public property | Personal | An Individuals Personal Details
Back to Top
See Also
GlobalInputData Class


GlobalInputData.AddressDocuments Property

GlobalInputData AddressDocuments Property GBG Web Service Developers Guide
Address Document Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalAddressDocuments AddressDocuments { get; set; }
public GlobalAddressDocuments AddressDocuments { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressDocuments();
function set_AddressDocuments(value);
function get_AddressDocuments();
function set_AddressDocuments(value);
Property Value
Type: GlobalAddressDocuments
See Also
GlobalInputData Class
GlobalInputData Members


GlobalInputData.Addresses Property

GlobalInputData Addresses Property GBG Web Service Developers Guide
Address Details - Contains Information for Current, Previous 1, 2 and 3.

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalAddresses Addresses { get; set; }
public GlobalAddresses Addresses { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Addresses();
function set_Addresses(value);
function get_Addresses();
function set_Addresses(value);
Property Value
Type: GlobalAddresses
See Also
GlobalInputData Class
GlobalInputData Members


GlobalInputData.BankingDetails Property

GlobalInputData BankingDetails Property GBG Web Service Developers Guide
Banking Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalBankingDetails BankingDetails { get; set; }
public GlobalBankingDetails BankingDetails { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_BankingDetails();
function set_BankingDetails(value);
function get_BankingDetails();
function set_BankingDetails(value);
Property Value
Type: GlobalBankingDetails
See Also
GlobalInputData Class
GlobalInputData Members


GlobalInputData.ContactDetails Property

GlobalInputData ContactDetails Property GBG Web Service Developers Guide
Contact Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalContactDetails ContactDetails { get; set; }
public GlobalContactDetails ContactDetails { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ContactDetails();
function set_ContactDetails(value);
function get_ContactDetails();
function set_ContactDetails(value);
Property Value
Type: GlobalContactDetails
See Also
GlobalInputData Class
GlobalInputData Members


GlobalInputData.Employment Property

GlobalInputData Employment Property GBG Web Service Developers Guide
Employment Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalEmployment Employment { get; set; }
public GlobalEmployment Employment { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Employment();
function set_Employment(value);
function get_Employment();
function set_Employment(value);
Property Value
Type: GlobalEmployment
See Also
GlobalInputData Class
GlobalInputData Members


GlobalInputData.GlobalGeneric Property

GlobalInputData GlobalGeneric Property GBG Web Service Developers Guide
Global Generic Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalGeneric GlobalGeneric { get; set; }
public GlobalGeneric GlobalGeneric { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_GlobalGeneric();
function set_GlobalGeneric(value);
function get_GlobalGeneric();
function set_GlobalGeneric(value);
Property Value
Type: GlobalGeneric
See Also
GlobalInputData Class
GlobalInputData Members


GlobalInputData.IdentityDocuments Property

GlobalInputData IdentityDocuments Property GBG Web Service Developers Guide
Identity Document Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalIdentityDocuments IdentityDocuments { get; set; }
public GlobalIdentityDocuments IdentityDocuments { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IdentityDocuments();
function set_IdentityDocuments(value);
function get_IdentityDocuments();
function set_IdentityDocuments(value);
Property Value
Type: GlobalIdentityDocuments
See Also
GlobalInputData Class
GlobalInputData Members


GlobalInputData.Images Property

GlobalInputData Images Property GBG Web Service Developers Guide
An Individuals validated image

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalImage> Images { get; set; }
public List<GlobalImage> Images { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Images();
function set_Images(value);
function get_Images();
function set_Images(value);
Property Value
Type: List GlobalImage
See Also
GlobalInputData Class
GlobalInputData Members


GlobalInputData.IsFreeFormat Property

GlobalInputData IsFreeFormat Property GBG Web Service Developers Guide
Returns True if Address data is in Free Format

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsFreeFormat { get; }
public bool IsFreeFormat { get; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IsFreeFormat();
function get_IsFreeFormat();
Return Value
Type: Boolean
True if Free Format Address, False otherwise
See Also
GlobalInputData Class
GlobalInputData Members


GlobalInputData.Location Property

GlobalInputData Location Property GBG Web Service Developers Guide
Location Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalLocation Location { get; set; }
public GlobalLocation Location { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Location();
function set_Location(value);
function get_Location();
function set_Location(value);
Property Value
Type: GlobalLocation
See Also
GlobalInputData Class
GlobalInputData Members


GlobalInputData.Personal Property

GlobalInputData Personal Property GBG Web Service Developers Guide
An Individuals Personal Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalPersonal Personal { get; set; }
public GlobalPersonal Personal { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Personal();
function set_Personal(value);
function get_Personal();
function set_Personal(value);
Property Value
Type: GlobalPersonal
See Also
GlobalInputData Class
GlobalInputData Members


GlobalInternationalPassport Class

GlobalInternationalPassport Class GBG Web Service Developers Guide
International passport information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalInternationalPassport

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalInternationalPassport
[SerializableAttribute]
public class GlobalInternationalPassport
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalInternationalPassport = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalInternationalPassport');
GlobalCheck.DataLib.GlobalInternationalPassport = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalInternationalPassport');
See Also
GlobalInternationalPassport Members


GlobalInternationalPassport Members

GlobalInternationalPassport Members GBG Web Service Developers Guide
The GlobalInternationalPassport type exposes the following members.
Properties
 | Name | Description
Public property | CountryOfOrigin | Country Of Origin Property
Public property | ExpiryDay | ExpiryDay Property
Public property | ExpiryMonth | ExpiryMonth Property
Public property | ExpiryYear | ExpiryYear Property
Public property | IssueDay | IssueDay Property
Public property | IssueMonth | IssueMonth Property
Public property | IssueYear | IssueYear Property
Public property | Number | Number Property
Public property | ShortPassportNumber | ShortPassportNumber property
Back to Top
See Also
GlobalInternationalPassport Class


GlobalInternationalPassport Properties

GlobalInternationalPassport Properties GBG Web Service Developers Guide
The GlobalInternationalPassport type exposes the following members.
Properties
 | Name | Description
Public property | CountryOfOrigin | Country Of Origin Property
Public property | ExpiryDay | ExpiryDay Property
Public property | ExpiryMonth | ExpiryMonth Property
Public property | ExpiryYear | ExpiryYear Property
Public property | IssueDay | IssueDay Property
Public property | IssueMonth | IssueMonth Property
Public property | IssueYear | IssueYear Property
Public property | Number | Number Property
Public property | ShortPassportNumber | ShortPassportNumber property
Back to Top
See Also
GlobalInternationalPassport Class


GlobalInternationalPassport.CountryOfOrigin Property

GlobalInternationalPassport CountryOfOrigin Property GBG Web Service Developers Guide
Country Of Origin Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CountryOfOrigin { get; set; }
public string CountryOfOrigin { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CountryOfOrigin();
function set_CountryOfOrigin(value);
function get_CountryOfOrigin();
function set_CountryOfOrigin(value);
Property Value
Type: String

            Contains the country of origin. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Country
See Also
GlobalInternationalPassport Class
GlobalInternationalPassport Members


GlobalInternationalPassport.ExpiryDay Property

GlobalInternationalPassport ExpiryDay Property GBG Web Service Developers Guide
ExpiryDay Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExpiryDay { get; set; }
public int ExpiryDay { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryDay();
function set_ExpiryDay(value);
function get_ExpiryDay();
function set_ExpiryDay(value);
Property Value
Type: Int32

            Integer in the range 1-31 representing the day in the month of an individuals passport expiry date.
            This property will be validated against the following named regular expression: Day
See Also
GlobalInternationalPassport Class
GlobalInternationalPassport Members


GlobalInternationalPassport.ExpiryMonth Property

GlobalInternationalPassport ExpiryMonth Property GBG Web Service Developers Guide
ExpiryMonth Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExpiryMonth { get; set; }
public int ExpiryMonth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryMonth();
function set_ExpiryMonth(value);
function get_ExpiryMonth();
function set_ExpiryMonth(value);
Property Value
Type: Int32

            This property may be omitted to indicate that this information is not available.

See Also
GlobalInternationalPassport Class
GlobalInternationalPassport Members


GlobalInternationalPassport.ExpiryYear Property

GlobalInternationalPassport ExpiryYear Property GBG Web Service Developers Guide
ExpiryYear Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExpiryYear { get; set; }
public int ExpiryYear { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryYear();
function set_ExpiryYear(value);
function get_ExpiryYear();
function set_ExpiryYear(value);
Property Value
Type: Int32

            Integer in the range 1-2099 representing the year of an individuals passport expiry date.
            This property will be validated against the following named regular expression: Year
See Also
GlobalInternationalPassport Class
GlobalInternationalPassport Members


GlobalInternationalPassport.IssueDay Property

GlobalInternationalPassport IssueDay Property GBG Web Service Developers Guide
IssueDay Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IssueDay { get; set; }
public int IssueDay { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IssueDay();
function set_IssueDay(value);
function get_IssueDay();
function set_IssueDay(value);
Property Value
Type: Int32

            Integer in the range 1-31 representing the day in the month of an individuals driving licence issue date.
            This property will be validated against the following named regular expression: Day
See Also
GlobalInternationalPassport Class
GlobalInternationalPassport Members


GlobalInternationalPassport.IssueMonth Property

GlobalInternationalPassport IssueMonth Property GBG Web Service Developers Guide
IssueMonth Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IssueMonth { get; set; }
public int IssueMonth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IssueMonth();
function set_IssueMonth(value);
function get_IssueMonth();
function set_IssueMonth(value);
Property Value
Type: Int32

            Integer in the range 1-12 representing the month of an individuals driving licence issue date.
            This property will be validated against the following named regular expression: Month
See Also
GlobalInternationalPassport Class
GlobalInternationalPassport Members


GlobalInternationalPassport.IssueYear Property

GlobalInternationalPassport IssueYear Property GBG Web Service Developers Guide
IssueYear Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IssueYear { get; set; }
public int IssueYear { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IssueYear();
function set_IssueYear(value);
function get_IssueYear();
function set_IssueYear(value);
Property Value
Type: Int32

            Integer in the range 1-2099 representing the year of an individuals driving licence issue date.
            This property will be validated against the following named regular expression: Year
See Also
GlobalInternationalPassport Class
GlobalInternationalPassport Members


GlobalInternationalPassport.Number Property

GlobalInternationalPassport Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            Full Passport Number, concatenated from parts 1-9.
            This property will be validated against the following named regular expression: PassportNumber
See Also
GlobalInternationalPassport Class
GlobalInternationalPassport Members


GlobalInternationalPassport.ShortPassportNumber Property

GlobalInternationalPassport ShortPassportNumber Property GBG Web Service Developers Guide
ShortPassportNumber property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ShortPassportNumber { get; set; }
public string ShortPassportNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ShortPassportNumber();
function set_ShortPassportNumber(value);
function get_ShortPassportNumber();
function set_ShortPassportNumber(value);
Property Value
Type: String

            Contains an individuals passport number. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: InternationlPassportNumber1
See Also
GlobalInternationalPassport Class
GlobalInternationalPassport Members


GlobalItem Class

GlobalItem Class GBG Web Service Developers Guide
Base class for a Profile Item (derived classes are GlobalItemCheck and GlobalBreakpoint)
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalItem
GlobalCheck.DataLib GlobalBreakpoint
GlobalCheck.DataLib GlobalItemCheck

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class GlobalItem
[SerializableAttribute]
public abstract class GlobalItem
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalItem = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalItem');
GlobalCheck.DataLib.GlobalItem = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalItem');
See Also
GlobalItem Members


GlobalItem Members

GlobalItem Members GBG Web Service Developers Guide
The GlobalItem type exposes the following members.
Properties
 | Name | Description
Public property | AllConditionsMustBeMet | AllConditionsMustBeMet Property
Public property | DecisionBandConditions | DecisionBandConditions Property
Public property | Description | Description Property
Public property | ID | ID Property
Public property | ItemCheckConditions | ItemCheckConditions Property
Public property | Name | Name Property
Public property | ResultCodesConditions | ResultCodesConditions Property
Public property | ScoreConditions | ScoreConditions Property
Back to Top
See Also
GlobalItem Class


GlobalItem Properties

GlobalItem Properties GBG Web Service Developers Guide
The GlobalItem type exposes the following members.
Properties
 | Name | Description
Public property | AllConditionsMustBeMet | AllConditionsMustBeMet Property
Public property | DecisionBandConditions | DecisionBandConditions Property
Public property | Description | Description Property
Public property | ID | ID Property
Public property | ItemCheckConditions | ItemCheckConditions Property
Public property | Name | Name Property
Public property | ResultCodesConditions | ResultCodesConditions Property
Public property | ScoreConditions | ScoreConditions Property
Back to Top
See Also
GlobalItem Class


GlobalItem.AllConditionsMustBeMet Property

GlobalItem AllConditionsMustBeMet Property GBG Web Service Developers Guide
AllConditionsMustBeMet Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AllConditionsMustBeMet { get; set; }
public bool AllConditionsMustBeMet { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AllConditionsMustBeMet();
function set_AllConditionsMustBeMet(value);
function get_AllConditionsMustBeMet();
function set_AllConditionsMustBeMet(value);
Property Value
Type: Boolean

            True if ALL Execution Conditions must be met for Item to be executed, False if execution will occur if ANY of the conditions are met.

See Also
GlobalItem Class
GlobalItem Members


GlobalItem.DecisionBandConditions Property

GlobalItem DecisionBandConditions Property GBG Web Service Developers Guide
DecisionBandConditions Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalConditionDecision> DecisionBandConditions { get; set; }
public List<GlobalConditionDecision> DecisionBandConditions { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DecisionBandConditions();
function set_DecisionBandConditions(value);
function get_DecisionBandConditions();
function set_DecisionBandConditions(value);
Property Value
Type: List GlobalConditionDecision

            Execution Conditions based on the Decision Band generated by execution of previous Item Checks in a Profile, which determine whether this Item will be executed.

See Also
GlobalItem Class
GlobalItem Members


GlobalItem.Description Property

GlobalItem Description Property GBG Web Service Developers Guide
Description Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Description();
function set_Description(value);
function get_Description();
function set_Description(value);
Property Value
Type: String

            Description of the Item

See Also
GlobalItem Class
GlobalItem Members


GlobalItem.ID Property

GlobalItem ID Property GBG Web Service Developers Guide
ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint ID { get; set; }
public uint ID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ID();
function set_ID(value);
function get_ID();
function set_ID(value);
Property Value
Type: UInt32

            The Item identifier

See Also
GlobalItem Class
GlobalItem Members


GlobalItem.ItemCheckConditions Property

GlobalItem ItemCheckConditions Property GBG Web Service Developers Guide
ItemCheckConditions Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalConditionItemCheck> ItemCheckConditions { get; set; }
public List<GlobalConditionItemCheck> ItemCheckConditions { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ItemCheckConditions();
function set_ItemCheckConditions(value);
function get_ItemCheckConditions();
function set_ItemCheckConditions(value);
Property Value
Type: List GlobalConditionItemCheck

            Execution Conditions based on the Item Check Match Thresholds generated by execution of previous Item Checks in a Profile, which determine whether this Item will be executed.

See Also
GlobalItem Class
GlobalItem Members


GlobalItem.Name Property

GlobalItem Name Property GBG Web Service Developers Guide
Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String

            Name of the Item

See Also
GlobalItem Class
GlobalItem Members


GlobalItem.ResultCodesConditions Property

GlobalItem ResultCodesConditions Property GBG Web Service Developers Guide
ResultCodesConditions Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalConditionResultCodes> ResultCodesConditions { get; set; }
public List<GlobalConditionResultCodes> ResultCodesConditions { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ResultCodesConditions();
function set_ResultCodesConditions(value);
function get_ResultCodesConditions();
function set_ResultCodesConditions(value);
Property Value
Type: List GlobalConditionResultCodes

            Execution Conditions based on the Item Check Result Codes generated by execution of previous Item Checks in a Profile, which determine whether this Item will be executed.

See Also
GlobalItem Class
GlobalItem Members


GlobalItem.ScoreConditions Property

GlobalItem ScoreConditions Property GBG Web Service Developers Guide
ScoreConditions Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalConditionScore> ScoreConditions { get; set; }
public List<GlobalConditionScore> ScoreConditions { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ScoreConditions();
function set_ScoreConditions(value);
function get_ScoreConditions();
function set_ScoreConditions(value);
Property Value
Type: List GlobalConditionScore

            Execution Conditions based on the Score generated by execution of previous Item Checks in a Profile, which determine whether this Item will be executed.

See Also
GlobalItem Class
GlobalItem Members


GlobalItemCheck Class

GlobalItemCheck Class GBG Web Service Developers Guide
Defines an Item Check instance within a Profile
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalItem
GlobalCheck.DataLib GlobalItemCheck

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalItemCheck : GlobalItem
[SerializableAttribute]
public class GlobalItemCheck : GlobalItem
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalItemCheck = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalItemCheck',
    GlobalCheck.DataLib.GlobalItem);
GlobalCheck.DataLib.GlobalItemCheck = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalItemCheck',
    GlobalCheck.DataLib.GlobalItem);
See Also
GlobalItemCheck Members


GlobalItemCheck Members

GlobalItemCheck Members GBG Web Service Developers Guide
The GlobalItemCheck type exposes the following members.
Properties
 | Name | Description
Public property | AllowedProperties | AllowedProperties Property
Public property | Properties | Properties Property
Public property | Scoring | Scoring Property
Back to Top
See Also
GlobalItemCheck Class


GlobalItemCheck Properties

GlobalItemCheck Properties GBG Web Service Developers Guide
The GlobalItemCheck type exposes the following members.
Properties
 | Name | Description
Public property | AllowedProperties | AllowedProperties Property
Public property | Properties | Properties Property
Public property | Scoring | Scoring Property
Back to Top
See Also
GlobalItemCheck Class


GlobalItemCheck.AllowedProperties Property

GlobalItemCheck AllowedProperties Property GBG Web Service Developers Guide
AllowedProperties Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AllowedProperties { get; set; }
public bool AllowedProperties { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AllowedProperties();
function set_AllowedProperties(value);
function get_AllowedProperties();
function set_AllowedProperties(value);
Property Value
Type: Boolean

            True if the Item Check has properties that can be set by a Profile administrator, false otherwise

See Also
GlobalItemCheck Class
GlobalItemCheck Members


GlobalItemCheck.Properties Property

GlobalItemCheck Properties Property GBG Web Service Developers Guide
Properties Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalProperty> Properties { get; set; }
public List<GlobalProperty> Properties { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Properties();
function set_Properties(value);
function get_Properties();
function set_Properties(value);
Property Value
Type: List GlobalProperty

            Item Check Properties

See Also
GlobalItemCheck Class
GlobalItemCheck Members


GlobalItemCheck.Scoring Property

GlobalItemCheck Scoring Property GBG Web Service Developers Guide
Scoring Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalScoring Scoring { get; set; }
public GlobalScoring Scoring { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Scoring();
function set_Scoring(value);
function get_Scoring();
function set_Scoring(value);
Property Value
Type: GlobalScoring

            Item Check Scoring

See Also
GlobalItemCheck Class
GlobalItemCheck Members


GlobalItemCheckEvent Class

GlobalItemCheckEvent Class GBG Web Service Developers Guide
Contains Item Check Event - used for logging
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalItemCheckEvent

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalItemCheckEvent
[SerializableAttribute]
public class GlobalItemCheckEvent
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalItemCheckEvent = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalItemCheckEvent');
GlobalCheck.DataLib.GlobalItemCheckEvent = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalItemCheckEvent');
See Also
GlobalItemCheckEvent Members


GlobalItemCheckEvent Members

GlobalItemCheckEvent Members GBG Web Service Developers Guide
The GlobalItemCheckEvent type exposes the following members.
Properties
 | Name | Description
Public property | Attempt | Attempt
Public property | BillingPoints | BillingPoints
Public property | DataProviderID | Data Provider UID
Public property | IsTimeout | IsTimeout
Public property | ItemID | ItemID
Public property | Status | Status
Public property | TimingMS | TimingMS
Back to Top
See Also
GlobalItemCheckEvent Class


GlobalItemCheckEvent Properties

GlobalItemCheckEvent Properties GBG Web Service Developers Guide
The GlobalItemCheckEvent type exposes the following members.
Properties
 | Name | Description
Public property | Attempt | Attempt
Public property | BillingPoints | BillingPoints
Public property | DataProviderID | Data Provider UID
Public property | IsTimeout | IsTimeout
Public property | ItemID | ItemID
Public property | Status | Status
Public property | TimingMS | TimingMS
Back to Top
See Also
GlobalItemCheckEvent Class


GlobalItemCheckEvent.Attempt Property

GlobalItemCheckEvent Attempt Property GBG Web Service Developers Guide
Attempt

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Attempt { get; set; }
public uint Attempt { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Attempt();
function set_Attempt(value);
function get_Attempt();
function set_Attempt(value);
Property Value
Type: UInt32
See Also
GlobalItemCheckEvent Class
GlobalItemCheckEvent Members


GlobalItemCheckEvent.BillingPoints Property

GlobalItemCheckEvent BillingPoints Property GBG Web Service Developers Guide
BillingPoints

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint BillingPoints { get; set; }
public uint BillingPoints { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_BillingPoints();
function set_BillingPoints(value);
function get_BillingPoints();
function set_BillingPoints(value);
Property Value
Type: UInt32
See Also
GlobalItemCheckEvent Class
GlobalItemCheckEvent Members


GlobalItemCheckEvent.DataProviderID Property

GlobalItemCheckEvent DataProviderID Property GBG Web Service Developers Guide
Data Provider UID

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid DataProviderID { get; set; }
public Guid DataProviderID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DataProviderID();
function set_DataProviderID(value);
function get_DataProviderID();
function set_DataProviderID(value);
Property Value
Type: Guid
See Also
GlobalItemCheckEvent Class
GlobalItemCheckEvent Members


GlobalItemCheckEvent.IsTimeout Property

GlobalItemCheckEvent IsTimeout Property GBG Web Service Developers Guide
IsTimeout

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsTimeout { get; set; }
public bool IsTimeout { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IsTimeout();
function set_IsTimeout(value);
function get_IsTimeout();
function set_IsTimeout(value);
Property Value
Type: Boolean
See Also
GlobalItemCheckEvent Class
GlobalItemCheckEvent Members


GlobalItemCheckEvent.ItemID Property

GlobalItemCheckEvent ItemID Property GBG Web Service Developers Guide
ItemID

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint ItemID { get; set; }
public uint ItemID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ItemID();
function set_ItemID(value);
function get_ItemID();
function set_ItemID(value);
Property Value
Type: UInt32
See Also
GlobalItemCheckEvent Class
GlobalItemCheckEvent Members


GlobalItemCheckEvent.Status Property

GlobalItemCheckEvent Status Property GBG Web Service Developers Guide
Status

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Status { get; set; }
public string Status { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Status();
function set_Status(value);
function get_Status();
function set_Status(value);
Property Value
Type: String
See Also
GlobalItemCheckEvent Class
GlobalItemCheckEvent Members


GlobalItemCheckEvent.TimingMS Property

GlobalItemCheckEvent TimingMS Property GBG Web Service Developers Guide
TimingMS

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TimingMS { get; set; }
public uint TimingMS { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TimingMS();
function set_TimingMS(value);
function get_TimingMS();
function set_TimingMS(value);
Property Value
Type: UInt32
See Also
GlobalItemCheckEvent Class
GlobalItemCheckEvent Members


GlobalItemCheckMatch Class

GlobalItemCheckMatch Class GBG Web Service Developers Guide
Container for the matching conditions for each item check
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalItemCheckMatch

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalItemCheckMatch
[SerializableAttribute]
public class GlobalItemCheckMatch
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalItemCheckMatch = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalItemCheckMatch');
GlobalCheck.DataLib.GlobalItemCheckMatch = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalItemCheckMatch');
See Also
GlobalItemCheckMatch Members


GlobalItemCheckMatch Members

GlobalItemCheckMatch Members GBG Web Service Developers Guide
The GlobalItemCheckMatch type exposes the following members.
Properties
 | Name | Description
Public property | Address | Address Property
Public property | Alert | Alert Property
Public property | DOB | DOB Property
Public property | Forename | Forename Property
 | ItemCheckMatches | Item Check Match Codes
Public property | Match | Match Property
Public property | MatchAll | Match ALL property
Public property | Mismatch | Mismatch Porperty
Public property | Surname | Surname Property
Public property | UID | Item check Unique ID
Back to Top
See Also
GlobalItemCheckMatch Class


GlobalItemCheckMatch Properties

GlobalItemCheckMatch Properties GBG Web Service Developers Guide
The GlobalItemCheckMatch type exposes the following members.
Properties
 | Name | Description
Public property | Address | Address Property
Public property | Alert | Alert Property
Public property | DOB | DOB Property
Public property | Forename | Forename Property
 | ItemCheckMatches | Item Check Match Codes
Public property | Match | Match Property
Public property | MatchAll | Match ALL property
Public property | Mismatch | Mismatch Porperty
Public property | Surname | Surname Property
Public property | UID | Item check Unique ID
Back to Top
See Also
GlobalItemCheckMatch Class


GlobalItemCheckMatch.Address Property

GlobalItemCheckMatch Address Property GBG Web Service Developers Guide
Address Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Fields Address { get; set; }
public Fields Address { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Address();
function set_Address(value);
function get_Address();
function set_Address(value);
Property Value
Type: Fields

            All the codes that relate to an address match/mismatch

See Also
GlobalItemCheckMatch Class
GlobalItemCheckMatch Members


GlobalItemCheckMatch.Alert Property

GlobalItemCheckMatch Alert Property GBG Web Service Developers Guide
Alert Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Fields Alert { get; set; }
public Fields Alert { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Alert();
function set_Alert(value);
function get_Alert();
function set_Alert(value);
Property Value
Type: Fields

            All the codes that relate to an Alert match/mismatch

See Also
GlobalItemCheckMatch Class
GlobalItemCheckMatch Members


GlobalItemCheckMatch.DOB Property

GlobalItemCheckMatch DOB Property GBG Web Service Developers Guide
DOB Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Fields DOB { get; set; }
public Fields DOB { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DOB();
function set_DOB(value);
function get_DOB();
function set_DOB(value);
Property Value
Type: Fields

            All the codes that relate to an DOB match/mismatch

See Also
GlobalItemCheckMatch Class
GlobalItemCheckMatch Members


GlobalItemCheckMatch.Forename Property

GlobalItemCheckMatch Forename Property GBG Web Service Developers Guide
Forename Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Fields Forename { get; set; }
public Fields Forename { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Forename();
function set_Forename(value);
function get_Forename();
function set_Forename(value);
Property Value
Type: Fields

            All the codes that relate to an Forename match/mismatch

See Also
GlobalItemCheckMatch Class
GlobalItemCheckMatch Members


GlobalItemCheckMatch.ItemCheckMatches Property

GlobalItemCheckMatch ItemCheckMatches Property GBG Web Service Developers Guide
Item Check Match Codes

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<GlobalItemCheckMatch> ItemCheckMatches { get; }
public static List<GlobalItemCheckMatch> ItemCheckMatches { get; }
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalItemCheckMatch.get_ItemCheckMatches = function();
GlobalCheck.DataLib.GlobalItemCheckMatch.get_ItemCheckMatches = function();
Property Value
Type: List GlobalItemCheckMatch
See Also
GlobalItemCheckMatch Class
GlobalItemCheckMatch Members


GlobalItemCheckMatch.Match Property

GlobalItemCheckMatch Match Property GBG Web Service Developers Guide
Match Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResultCode Match { get; set; }
public ResultCode Match { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Match();
function set_Match(value);
function get_Match();
function set_Match(value);
Property Value
Type: ResultCode

            All the codes that cause the item check to pass

See Also
GlobalItemCheckMatch Class
GlobalItemCheckMatch Members


GlobalItemCheckMatch.MatchAll Property

GlobalItemCheckMatch MatchAll Property GBG Web Service Developers Guide
Match ALL property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MatchAll { get; set; }
public bool MatchAll { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MatchAll();
function set_MatchAll(value);
function get_MatchAll();
function set_MatchAll(value);
Property Value
Type: Boolean

            This property determines if in order for the item check to pass all the Match codes must be returned

See Also
GlobalItemCheckMatch Class
GlobalItemCheckMatch Members


GlobalItemCheckMatch.Mismatch Property

GlobalItemCheckMatch Mismatch Property GBG Web Service Developers Guide
Mismatch Porperty

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResultCode Mismatch { get; set; }
public ResultCode Mismatch { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Mismatch();
function set_Mismatch(value);
function get_Mismatch();
function set_Mismatch(value);
Property Value
Type: ResultCode

            All the codes that cause the item check to fail

See Also
GlobalItemCheckMatch Class
GlobalItemCheckMatch Members


GlobalItemCheckMatch.Surname Property

GlobalItemCheckMatch Surname Property GBG Web Service Developers Guide
Surname Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Fields Surname { get; set; }
public Fields Surname { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Surname();
function set_Surname(value);
function get_Surname();
function set_Surname(value);
Property Value
Type: Fields

            All the codes that relate to an Surname match/mismatch

See Also
GlobalItemCheckMatch Class
GlobalItemCheckMatch Members


GlobalItemCheckMatch.UID Property

GlobalItemCheckMatch UID Property GBG Web Service Developers Guide
Item check Unique ID

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int UID { get; set; }
public int UID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_UID();
function set_UID(value);
function get_UID();
function set_UID(value);
Property Value
Type: Int32
See Also
GlobalItemCheckMatch Class
GlobalItemCheckMatch Members


GlobalItemCheckResultCode Class

GlobalItemCheckResultCode Class GBG Web Service Developers Guide
Result code details
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalItemCheckResultCode

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalItemCheckResultCode
public class GlobalItemCheckResultCode
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalItemCheckResultCode = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalItemCheckResultCode');
GlobalCheck.DataLib.GlobalItemCheckResultCode = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalItemCheckResultCode');
See Also
GlobalItemCheckResultCode Members


GlobalItemCheckResultCode Members

GlobalItemCheckResultCode Members GBG Web Service Developers Guide
The GlobalItemCheckResultCode type exposes the following members.
Properties
 | Name | Description
Public property | Code | Code Property
Public property | Description | Description Property
Public property | Override | Override Property
Back to Top
See Also
GlobalItemCheckResultCode Class


GlobalItemCheckResultCode Properties

GlobalItemCheckResultCode Properties GBG Web Service Developers Guide
The GlobalItemCheckResultCode type exposes the following members.
Properties
 | Name | Description
Public property | Code | Code Property
Public property | Description | Description Property
Public property | Override | Override Property
Back to Top
See Also
GlobalItemCheckResultCode Class


GlobalItemCheckResultCode.Code Property

GlobalItemCheckResultCode Code Property GBG Web Service Developers Guide
Code Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Code { get; set; }
public int Code { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Code();
function set_Code(value);
function get_Code();
function set_Code(value);
Property Value
Type: Int32
See Also
GlobalItemCheckResultCode Class
GlobalItemCheckResultCode Members


GlobalItemCheckResultCode.Description Property

GlobalItemCheckResultCode Description Property GBG Web Service Developers Guide
Description Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Description();
function set_Description(value);
function get_Description();
function set_Description(value);
Property Value
Type: String
See Also
GlobalItemCheckResultCode Class
GlobalItemCheckResultCode Members


GlobalItemCheckResultCode.Override Property

GlobalItemCheckResultCode Override Property GBG Web Service Developers Guide
Override Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Override { get; set; }
public string Override { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Override();
function set_Override(value);
function get_Override();
function set_Override(value);
Property Value
Type: String

            If Item Check results have been overriden, this property contains any override text supplied for the Force Override operation

See Also
GlobalItemCheckResultCode Class
GlobalItemCheckResultCode Members


GlobalItemCheckResultCodes Class

GlobalItemCheckResultCodes Class GBG Web Service Developers Guide
Container for result code information returned from an authentication.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalItemCheckResultCodes
GlobalCheck.DataLib Global3DSecureCheckResultCodes
GlobalCheck.DataLib GlobalCreditReportResultCodes
GlobalCheck.DataLib GlobalDeviceIDResultCodes
GlobalCheck.DataLib GlobalDocumentCheckResultCodes
GlobalCheck.DataLib GlobalSanctionsResultCodes
GlobalCheck.DataLib GlobalSharedFraudResultCodes
GlobalCheck.DataLib GlobalTelephoneResultCodes

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalItemCheckResultCodes
public class GlobalItemCheckResultCodes
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalItemCheckResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalItemCheckResultCodes');
GlobalCheck.DataLib.GlobalItemCheckResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalItemCheckResultCodes');
See Also
GlobalItemCheckResultCodes Members


GlobalItemCheckResultCodes Members

GlobalItemCheckResultCodes Members GBG Web Service Developers Guide
The GlobalItemCheckResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | Address | Address Property
Public property | Alert | Alert Property
Public property | Comment | Comment Property
Public property | Country | Country supported by item check
Public property | Description | Description Property
Public property | DOB | DOB Property
Public property | Forename | Forename Property
Public property | ID | ID Property
Public property | Match | Match Property
Public property | Mismatch | Mismatch Property
Public property | Name | Name Property
Public property | Pass | Pass Property
Public property | Surname | Surname Property
Public property | Warning | Warning Property
Back to Top
See Also
GlobalItemCheckResultCodes Class


GlobalItemCheckResultCodes Properties

GlobalItemCheckResultCodes Properties GBG Web Service Developers Guide
The GlobalItemCheckResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | Address | Address Property
Public property | Alert | Alert Property
Public property | Comment | Comment Property
Public property | Country | Country supported by item check
Public property | Description | Description Property
Public property | DOB | DOB Property
Public property | Forename | Forename Property
Public property | ID | ID Property
Public property | Match | Match Property
Public property | Mismatch | Mismatch Property
Public property | Name | Name Property
Public property | Pass | Pass Property
Public property | Surname | Surname Property
Public property | Warning | Warning Property
Back to Top
See Also
GlobalItemCheckResultCodes Class


GlobalItemCheckResultCodes.Address Property

GlobalItemCheckResultCodes Address Property GBG Web Service Developers Guide
Address Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalMatch Address { get; set; }
public GlobalMatch Address { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Address();
function set_Address(value);
function get_Address();
function set_Address(value);
Property Value
Type: GlobalMatch
See Also
GlobalItemCheckResultCodes Class
GlobalItemCheckResultCodes Members


GlobalItemCheckResultCodes.Alert Property

GlobalItemCheckResultCodes Alert Property GBG Web Service Developers Guide
Alert Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalMatch Alert { get; set; }
public GlobalMatch Alert { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Alert();
function set_Alert(value);
function get_Alert();
function set_Alert(value);
Property Value
Type: GlobalMatch
See Also
GlobalItemCheckResultCodes Class
GlobalItemCheckResultCodes Members


GlobalItemCheckResultCodes.Comment Property

GlobalItemCheckResultCodes Comment Property GBG Web Service Developers Guide
Comment Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalItemCheckResultCode> Comment { get; set; }
public List<GlobalItemCheckResultCode> Comment { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Comment();
function set_Comment(value);
function get_Comment();
function set_Comment(value);
Property Value
Type: List GlobalItemCheckResultCode
See Also
GlobalItemCheckResultCodes Class
GlobalItemCheckResultCodes Members


GlobalItemCheckResultCodes.Country Property

GlobalItemCheckResultCodes Country Property GBG Web Service Developers Guide
Country supported by item check

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Country { get; set; }
public string Country { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Country();
function set_Country(value);
function get_Country();
function set_Country(value);
Property Value
Type: String
See Also
GlobalItemCheckResultCodes Class
GlobalItemCheckResultCodes Members


GlobalItemCheckResultCodes.Description Property

GlobalItemCheckResultCodes Description Property GBG Web Service Developers Guide
Description Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Description();
function set_Description(value);
function get_Description();
function set_Description(value);
Property Value
Type: String
See Also
GlobalItemCheckResultCodes Class
GlobalItemCheckResultCodes Members


GlobalItemCheckResultCodes.DOB Property

GlobalItemCheckResultCodes DOB Property GBG Web Service Developers Guide
DOB Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalMatch DOB { get; set; }
public GlobalMatch DOB { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DOB();
function set_DOB(value);
function get_DOB();
function set_DOB(value);
Property Value
Type: GlobalMatch
See Also
GlobalItemCheckResultCodes Class
GlobalItemCheckResultCodes Members


GlobalItemCheckResultCodes.Forename Property

GlobalItemCheckResultCodes Forename Property GBG Web Service Developers Guide
Forename Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalMatch Forename { get; set; }
public GlobalMatch Forename { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Forename();
function set_Forename(value);
function get_Forename();
function set_Forename(value);
Property Value
Type: GlobalMatch
See Also
GlobalItemCheckResultCodes Class
GlobalItemCheckResultCodes Members


GlobalItemCheckResultCodes.ID Property

GlobalItemCheckResultCodes ID Property GBG Web Service Developers Guide
ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ID { get; set; }
public int ID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ID();
function set_ID(value);
function get_ID();
function set_ID(value);
Property Value
Type: Int32
See Also
GlobalItemCheckResultCodes Class
GlobalItemCheckResultCodes Members


GlobalItemCheckResultCodes.Match Property

GlobalItemCheckResultCodes Match Property GBG Web Service Developers Guide
Match Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalItemCheckResultCode> Match { get; set; }
public List<GlobalItemCheckResultCode> Match { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Match();
function set_Match(value);
function get_Match();
function set_Match(value);
Property Value
Type: List GlobalItemCheckResultCode
See Also
GlobalItemCheckResultCodes Class
GlobalItemCheckResultCodes Members


GlobalItemCheckResultCodes.Mismatch Property

GlobalItemCheckResultCodes Mismatch Property GBG Web Service Developers Guide
Mismatch Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalItemCheckResultCode> Mismatch { get; set; }
public List<GlobalItemCheckResultCode> Mismatch { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Mismatch();
function set_Mismatch(value);
function get_Mismatch();
function set_Mismatch(value);
Property Value
Type: List GlobalItemCheckResultCode
See Also
GlobalItemCheckResultCodes Class
GlobalItemCheckResultCodes Members


GlobalItemCheckResultCodes.Name Property

GlobalItemCheckResultCodes Name Property GBG Web Service Developers Guide
Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String
See Also
GlobalItemCheckResultCodes Class
GlobalItemCheckResultCodes Members


GlobalItemCheckResultCodes.Pass Property

GlobalItemCheckResultCodes Pass Property GBG Web Service Developers Guide
Pass Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalMatch Pass { get; set; }
public GlobalMatch Pass { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Pass();
function set_Pass(value);
function get_Pass();
function set_Pass(value);
Property Value
Type: GlobalMatch
See Also
GlobalItemCheckResultCodes Class
GlobalItemCheckResultCodes Members


GlobalItemCheckResultCodes.Surname Property

GlobalItemCheckResultCodes Surname Property GBG Web Service Developers Guide
Surname Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalMatch Surname { get; set; }
public GlobalMatch Surname { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Surname();
function set_Surname(value);
function get_Surname();
function set_Surname(value);
Property Value
Type: GlobalMatch
See Also
GlobalItemCheckResultCodes Class
GlobalItemCheckResultCodes Members


GlobalItemCheckResultCodes.Warning Property

GlobalItemCheckResultCodes Warning Property GBG Web Service Developers Guide
Warning Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalItemCheckResultCode> Warning { get; set; }
public List<GlobalItemCheckResultCode> Warning { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Warning();
function set_Warning(value);
function get_Warning();
function set_Warning(value);
Property Value
Type: List GlobalItemCheckResultCode
See Also
GlobalItemCheckResultCodes Class
GlobalItemCheckResultCodes Members


GlobalKeyValuePair(TKey, TValue) Structure

GlobalKeyValuePair TKey, TValue Structure GBG Web Service Developers Guide
Serializable KeyValuePair

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct GlobalKeyValuePair<TKey, TValue>
[SerializableAttribute]
public struct GlobalKeyValuePair<TKey, TValue>
JavaScript
View Colorized Copy to Clipboard Print
JavaScript does not support generic types or methods.
JavaScript does not support generic types or methods.
Type Parameters
TKey
[Missing <typeparam name="TKey"/> documentation for "T:GlobalCheck.DataLib.GlobalKeyValuePair`2"]
TValue
[Missing <typeparam name="TValue"/> documentation for "T:GlobalCheck.DataLib.GlobalKeyValuePair`2"]
See Also
GlobalKeyValuePair TKey, TValue  Members


GlobalKeyValuePair(TKey, TValue) Members

GlobalKeyValuePair TKey, TValue Members GBG Web Service Developers Guide
The GlobalKeyValuePair TKey, TValue type exposes the following members.
Properties
 | Name | Description
Public property | Key | The Key
Public property | Value | The Value
Back to Top
See Also
GlobalKeyValuePair TKey, TValue Structure


GlobalKeyValuePair(TKey, TValue) Properties

GlobalKeyValuePair TKey, TValue Properties GBG Web Service Developers Guide
The GlobalKeyValuePair TKey, TValue type exposes the following members.
Properties
 | Name | Description
Public property | Key | The Key
Public property | Value | The Value
Back to Top
See Also
GlobalKeyValuePair TKey, TValue Structure


GlobalKeyValuePair(TKey, TValue).Key Property

GlobalKeyValuePair TKey, TValue Key Property GBG Web Service Developers Guide
The Key

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TKey Key { get; set; }
public TKey Key { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Key();
function set_Key(value);
function get_Key();
function set_Key(value);
Property Value
Type: TKey
See Also
GlobalKeyValuePair TKey, TValue  Structure
GlobalKeyValuePair TKey, TValue  Members


GlobalKeyValuePair(TKey, TValue).Value Property

GlobalKeyValuePair TKey, TValue Value Property GBG Web Service Developers Guide
The Value

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TValue Value { get; set; }
public TValue Value { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Value();
function set_Value(value);
function get_Value();
function set_Value(value);
Property Value
Type: TValue
See Also
GlobalKeyValuePair TKey, TValue  Structure
GlobalKeyValuePair TKey, TValue  Members


GlobalLandTelephone Class

GlobalLandTelephone Class GBG Web Service Developers Guide
Contains land telephone information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalLandTelephone

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalLandTelephone
[SerializableAttribute]
public class GlobalLandTelephone
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalLandTelephone = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalLandTelephone');
GlobalCheck.DataLib.GlobalLandTelephone = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalLandTelephone');
See Also
GlobalLandTelephone Members


GlobalLandTelephone Members

GlobalLandTelephone Members GBG Web Service Developers Guide
The GlobalLandTelephone type exposes the following members.
Properties
 | Name | Description
Public property | ExDirectory | Ex directory Property
Public property | Number | Number Property
Back to Top
See Also
GlobalLandTelephone Class


GlobalLandTelephone Properties

GlobalLandTelephone Properties GBG Web Service Developers Guide
The GlobalLandTelephone type exposes the following members.
Properties
 | Name | Description
Public property | ExDirectory | Ex directory Property
Public property | Number | Number Property
Back to Top
See Also
GlobalLandTelephone Class


GlobalLandTelephone.ExDirectory Property

GlobalLandTelephone ExDirectory Property GBG Web Service Developers Guide
Ex directory Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExDirectory { get; set; }
public bool ExDirectory { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExDirectory();
function set_ExDirectory(value);
function get_ExDirectory();
function set_ExDirectory(value);
Property Value
Type: Boolean

            true if the individuals phone number is ex-directory, false otherwise. This property may be omitted to indicate that this information is not available.

See Also
GlobalLandTelephone Class
GlobalLandTelephone Members


GlobalLandTelephone.Number Property

GlobalLandTelephone Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            Contains an individuals telephone number (including STD code). Note: telephone number and may be supplied with or without a space between the STD code and number, e.g. ‘01234 567890’ or ‘01234567890’.
            This property may be omitted or set to an empty string to indicate no value was supplied
            This property will be validated against the following named regular expression: TelephoneNumber
See Also
GlobalLandTelephone Class
GlobalLandTelephone Members


GlobalLicence Class

GlobalLicence Class GBG Web Service Developers Guide
Global Licence
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalLicence

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalLicence
public class GlobalLicence
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalLicence = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalLicence');
GlobalCheck.DataLib.GlobalLicence = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalLicence');
See Also
GlobalLicence Members


GlobalLicence Members

GlobalLicence Members GBG Web Service Developers Guide
The GlobalLicence type exposes the following members.
Properties
 | Name | Description
Public property | ItemChecks | ItemChecks Property
Public property | Options | Options Property
Back to Top
See Also
GlobalLicence Class


GlobalLicence Properties

GlobalLicence Properties GBG Web Service Developers Guide
The GlobalLicence type exposes the following members.
Properties
 | Name | Description
Public property | ItemChecks | ItemChecks Property
Public property | Options | Options Property
Back to Top
See Also
GlobalLicence Class


GlobalLicence.ItemChecks Property

GlobalLicence ItemChecks Property GBG Web Service Developers Guide
ItemChecks Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalLicenceItem> ItemChecks { get; set; }
public List<GlobalLicenceItem> ItemChecks { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ItemChecks();
function set_ItemChecks(value);
function get_ItemChecks();
function set_ItemChecks(value);
Property Value
Type: List GlobalLicenceItem

            Item Checks that may be enabled on the Licence

See Also
GlobalLicence Class
GlobalLicence Members


GlobalLicence.Options Property

GlobalLicence Options Property GBG Web Service Developers Guide
Options Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalLicenceItem> Options { get; set; }
public List<GlobalLicenceItem> Options { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Options();
function set_Options(value);
function get_Options();
function set_Options(value);
Property Value
Type: List GlobalLicenceItem

            Options that may be enabled on the Licence

See Also
GlobalLicence Class
GlobalLicence Members


GlobalLicenceItem Class

GlobalLicenceItem Class GBG Web Service Developers Guide
A Licence Item
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalLicenceItem

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalLicenceItem
public class GlobalLicenceItem
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalLicenceItem = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalLicenceItem');
GlobalCheck.DataLib.GlobalLicenceItem = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalLicenceItem');
See Also
GlobalLicenceItem Members


GlobalLicenceItem Members

GlobalLicenceItem Members GBG Web Service Developers Guide
The GlobalLicenceItem type exposes the following members.
Properties
 | Name | Description
Public property | Country | Country Property
Public property | Description | Description Property
Public property | Enabled | Enabled Property
Public property | ID | ID Property
Public property | Name | Name Property
Public property | Pending | Pending Property
Public property | SupplierAccount | SupplierAccount Property
Back to Top
See Also
GlobalLicenceItem Class


GlobalLicenceItem Properties

GlobalLicenceItem Properties GBG Web Service Developers Guide
The GlobalLicenceItem type exposes the following members.
Properties
 | Name | Description
Public property | Country | Country Property
Public property | Description | Description Property
Public property | Enabled | Enabled Property
Public property | ID | ID Property
Public property | Name | Name Property
Public property | Pending | Pending Property
Public property | SupplierAccount | SupplierAccount Property
Back to Top
See Also
GlobalLicenceItem Class


GlobalLicenceItem.Country Property

GlobalLicenceItem Country Property GBG Web Service Developers Guide
Country Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Country { get; set; }
public string Country { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Country();
function set_Country(value);
function get_Country();
function set_Country(value);
Property Value
Type: String

            Name of country supported by the Licence item, or "International"
            if not country specific

See Also
GlobalLicenceItem Class
GlobalLicenceItem Members


GlobalLicenceItem.Description Property

GlobalLicenceItem Description Property GBG Web Service Developers Guide
Description Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Description();
function set_Description(value);
function get_Description();
function set_Description(value);
Property Value
Type: String

            Description of the Licence Item

See Also
GlobalLicenceItem Class
GlobalLicenceItem Members


GlobalLicenceItem.Enabled Property

GlobalLicenceItem Enabled Property GBG Web Service Developers Guide
Enabled Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Enabled { get; set; }
public bool Enabled { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Enabled();
function set_Enabled(value);
function get_Enabled();
function set_Enabled(value);
Property Value
Type: Boolean

            True if the Item is enabled in the Licence, false otherwise

See Also
GlobalLicenceItem Class
GlobalLicenceItem Members


GlobalLicenceItem.ID Property

GlobalLicenceItem ID Property GBG Web Service Developers Guide
ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint ID { get; set; }
public uint ID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ID();
function set_ID(value);
function get_ID();
function set_ID(value);
Property Value
Type: UInt32

            Identifier of the Licence Item

See Also
GlobalLicenceItem Class
GlobalLicenceItem Members


GlobalLicenceItem.Name Property

GlobalLicenceItem Name Property GBG Web Service Developers Guide
Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String

            Name of the Licence Item

See Also
GlobalLicenceItem Class
GlobalLicenceItem Members


GlobalLicenceItem.Pending Property

GlobalLicenceItem Pending Property GBG Web Service Developers Guide
Pending Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Pending { get; set; }
public bool Pending { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Pending();
function set_Pending(value);
function get_Pending();
function set_Pending(value);
Property Value
Type: Boolean

            True if the Item is pending a service action by the GBGroup Helpdesk before it can be, false otherwise

See Also
GlobalLicenceItem Class
GlobalLicenceItem Members


GlobalLicenceItem.SupplierAccount Property

GlobalLicenceItem SupplierAccount Property GBG Web Service Developers Guide
SupplierAccount Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalSupplierAccount SupplierAccount { get; set; }
public GlobalSupplierAccount SupplierAccount { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SupplierAccount();
function set_SupplierAccount(value);
function get_SupplierAccount();
function set_SupplierAccount(value);
Property Value
Type: GlobalSupplierAccount

            Internal property used to configure GIDE before an authentication request

See Also
GlobalLicenceItem Class
GlobalLicenceItem Members


GlobalLocation Class

GlobalLocation Class GBG Web Service Developers Guide
Location details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalLocation

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalLocation
[SerializableAttribute]
public class GlobalLocation
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalLocation = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalLocation');
GlobalCheck.DataLib.GlobalLocation = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalLocation');
See Also
GlobalLocation Members


GlobalLocation Members

GlobalLocation Members GBG Web Service Developers Guide
The GlobalLocation type exposes the following members.
Properties
 | Name | Description
Public property | AcceptHeaders | Accept Headers Property
Public property | BlackBoxID | Black BoxID Property
Public property | Country | Country Property
Public property | IndividualID | Individual ID Property
Public property | IPAddress | IP Property
Public property | State | State Property
Public property | UserAgent | User Agent Property
Back to Top
See Also
GlobalLocation Class


GlobalLocation Properties

GlobalLocation Properties GBG Web Service Developers Guide
The GlobalLocation type exposes the following members.
Properties
 | Name | Description
Public property | AcceptHeaders | Accept Headers Property
Public property | BlackBoxID | Black BoxID Property
Public property | Country | Country Property
Public property | IndividualID | Individual ID Property
Public property | IPAddress | IP Property
Public property | State | State Property
Public property | UserAgent | User Agent Property
Back to Top
See Also
GlobalLocation Class


GlobalLocation.AcceptHeaders Property

GlobalLocation AcceptHeaders Property GBG Web Service Developers Guide
Accept Headers Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AcceptHeaders { get; set; }
public string AcceptHeaders { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AcceptHeaders();
function set_AcceptHeaders(value);
function get_AcceptHeaders();
function set_AcceptHeaders(value);
Property Value
Type: String

            The exact content of the HTTP accept header as sent to the merchant from the card holder’s browser (user agent).  This property may be omitted or set to an empty string to indicate no value was supplied.

See Also
GlobalLocation Class
GlobalLocation Members


GlobalLocation.BlackBoxID Property

GlobalLocation BlackBoxID Property GBG Web Service Developers Guide
Black BoxID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BlackBoxID { get; set; }
public string BlackBoxID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_BlackBoxID();
function set_BlackBoxID(value);
function get_BlackBoxID();
function set_BlackBoxID(value);
Property Value
Type: String

            The blackbox information as captured by the client application. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: BlackBoxID
See Also
GlobalLocation Class
GlobalLocation Members


GlobalLocation.Country Property

GlobalLocation Country Property GBG Web Service Developers Guide
Country Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Country { get; set; }
public string Country { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Country();
function set_Country(value);
function get_Country();
function set_Country(value);
Property Value
Type: String

            The country where individual is located. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Country
See Also
GlobalLocation Class
GlobalLocation Members


GlobalLocation.IndividualID Property

GlobalLocation IndividualID Property GBG Web Service Developers Guide
Individual ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string IndividualID { get; set; }
public string IndividualID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IndividualID();
function set_IndividualID(value);
function get_IndividualID();
function set_IndividualID(value);
Property Value
Type: String

            This should be a uniquely identifiable code that is created by the customer and can be in any character format but have a limit of 50 characters. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: IndividualID
See Also
GlobalLocation Class
GlobalLocation Members


GlobalLocation.IPAddress Property

GlobalLocation IPAddress Property GBG Web Service Developers Guide
IP Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string IPAddress { get; set; }
public string IPAddress { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IPAddress();
function set_IPAddress(value);
function get_IPAddress();
function set_IPAddress(value);
Property Value
Type: String

            IPAddress of the individual being authenticated. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: IPAddress
See Also
GlobalLocation Class
GlobalLocation Members


GlobalLocation.State Property

GlobalLocation State Property GBG Web Service Developers Guide
State Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string State { get; set; }
public string State { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_State();
function set_State(value);
function get_State();
function set_State(value);
Property Value
Type: String

            The state where individual is located. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: State
See Also
GlobalLocation Class
GlobalLocation Members


GlobalLocation.UserAgent Property

GlobalLocation UserAgent Property GBG Web Service Developers Guide
User Agent Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UserAgent { get; set; }
public string UserAgent { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_UserAgent();
function set_UserAgent(value);
function get_UserAgent();
function set_UserAgent(value);
Property Value
Type: String

            The exact content of the HTTP user-agent header as sent to the merchant from the card holder’s user agent. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: UserAgent
See Also
GlobalLocation Class
GlobalLocation Members


GlobalMatch Enumeration

GlobalMatch Enumeration GBG Web Service Developers Guide
Match value

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalMatch
[SerializableAttribute]
public enum GlobalMatch
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalMatch = function();
GlobalCheck.DataLib.GlobalMatch.createEnum('GlobalCheck.DataLib.GlobalMatch', false);
GlobalCheck.DataLib.GlobalMatch = function();
GlobalCheck.DataLib.GlobalMatch.createEnum('GlobalCheck.DataLib.GlobalMatch', false);
Members
Member name | Value | Description
NA | 0 | NA
Match | 1 | Match
Mismatch | 2 | Mismatch
Nomatch | 3 | Nomatch
See Also


GlobalMedicare Class

GlobalMedicare Class GBG Web Service Developers Guide
Medicare details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalMedicare

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalMedicare
[SerializableAttribute]
public class GlobalMedicare
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalMedicare = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalMedicare');
GlobalCheck.DataLib.GlobalMedicare = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalMedicare');
See Also
GlobalMedicare Members


GlobalMedicare Members

GlobalMedicare Members GBG Web Service Developers Guide
The GlobalMedicare type exposes the following members.
Properties
 | Name | Description
Public property | CardNumber | Card Number Property
Public property | ReferenceNumber | Reference Number Property
Public property | SurnameAtCitizenship | Surname At Citizenship Property
Back to Top
See Also
GlobalMedicare Class


GlobalMedicare Properties

GlobalMedicare Properties GBG Web Service Developers Guide
The GlobalMedicare type exposes the following members.
Properties
 | Name | Description
Public property | CardNumber | Card Number Property
Public property | ReferenceNumber | Reference Number Property
Public property | SurnameAtCitizenship | Surname At Citizenship Property
Back to Top
See Also
GlobalMedicare Class


GlobalMedicare.CardNumber Property

GlobalMedicare CardNumber Property GBG Web Service Developers Guide
Card Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CardNumber { get; set; }
public string CardNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CardNumber();
function set_CardNumber(value);
function get_CardNumber();
function set_CardNumber(value);
Property Value
Type: String

            The number for the individuals medicare card. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AustraliaMedicareFullNumber
See Also
GlobalMedicare Class
GlobalMedicare Members


GlobalMedicare.ReferenceNumber Property

GlobalMedicare ReferenceNumber Property GBG Web Service Developers Guide
Reference Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ReferenceNumber { get; set; }
public string ReferenceNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ReferenceNumber();
function set_ReferenceNumber(value);
function get_ReferenceNumber();
function set_ReferenceNumber(value);
Property Value
Type: String

            The reference number for the individuals medicare card. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AustraliaMedicareReferenceNumber
See Also
GlobalMedicare Class
GlobalMedicare Members


GlobalMedicare.SurnameAtCitizenship Property

GlobalMedicare SurnameAtCitizenship Property GBG Web Service Developers Guide
Surname At Citizenship Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SurnameAtCitizenship { get; set; }
public string SurnameAtCitizenship { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SurnameAtCitizenship();
function set_SurnameAtCitizenship(value);
function get_SurnameAtCitizenship();
function set_SurnameAtCitizenship(value);
Property Value
Type: String

            The individuals surname at citizenship. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Surname
See Also
GlobalMedicare Class
GlobalMedicare Members


GlobalMexico Class

GlobalMexico Class GBG Web Service Developers Guide
Mexico identity details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalMexico

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalMexico
[SerializableAttribute]
public class GlobalMexico
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalMexico = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalMexico');
GlobalCheck.DataLib.GlobalMexico = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalMexico');
See Also
GlobalMexico Members


GlobalMexico Members

GlobalMexico Members GBG Web Service Developers Guide
The GlobalMexico type exposes the following members.
Properties
 | Name | Description
Public property | TaxIdentificationNumber | Tax Identification Number
Back to Top
See Also
GlobalMexico Class


GlobalMexico Properties

GlobalMexico Properties GBG Web Service Developers Guide
The GlobalMexico type exposes the following members.
Properties
 | Name | Description
Public property | TaxIdentificationNumber | Tax Identification Number
Back to Top
See Also
GlobalMexico Class


GlobalMexico.TaxIdentificationNumber Property

GlobalMexico TaxIdentificationNumber Property GBG Web Service Developers Guide
Tax Identification Number

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalMexicoTaxIdentificationNumber TaxIdentificationNumber { get; set; }
public GlobalMexicoTaxIdentificationNumber TaxIdentificationNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TaxIdentificationNumber();
function set_TaxIdentificationNumber(value);
function get_TaxIdentificationNumber();
function set_TaxIdentificationNumber(value);
Property Value
Type: GlobalMexicoTaxIdentificationNumber

            This property will be validated against the following named regular expression: MexicoTaxIdentificationNumber
See Also
GlobalMexico Class
GlobalMexico Members


GlobalMexicoTaxIdentificationNumber Class

GlobalMexicoTaxIdentificationNumber Class GBG Web Service Developers Guide
Mexico Tax Identification Number
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalMexicoTaxIdentificationNumber

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalMexicoTaxIdentificationNumber
[SerializableAttribute]
public class GlobalMexicoTaxIdentificationNumber
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalMexicoTaxIdentificationNumber = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalMexicoTaxIdentificationNumber');
GlobalCheck.DataLib.GlobalMexicoTaxIdentificationNumber = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalMexicoTaxIdentificationNumber');
See Also
GlobalMexicoTaxIdentificationNumber Members


GlobalMexicoTaxIdentificationNumber Members

GlobalMexicoTaxIdentificationNumber Members GBG Web Service Developers Guide
The GlobalMexicoTaxIdentificationNumber type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalMexicoTaxIdentificationNumber Class


GlobalMexicoTaxIdentificationNumber Properties

GlobalMexicoTaxIdentificationNumber Properties GBG Web Service Developers Guide
The GlobalMexicoTaxIdentificationNumber type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalMexicoTaxIdentificationNumber Class


GlobalMexicoTaxIdentificationNumber.Number Property

GlobalMexicoTaxIdentificationNumber Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            Contains an individuals Tax Identification Number.  This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: GlobalMexicoTaxIdentificationNumber
See Also
GlobalMexicoTaxIdentificationNumber Class
GlobalMexicoTaxIdentificationNumber Members


GlobalMobileTelephone Class

GlobalMobileTelephone Class GBG Web Service Developers Guide
Contains mobile phone information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalMobileTelephone

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalMobileTelephone
[SerializableAttribute]
public class GlobalMobileTelephone
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalMobileTelephone = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalMobileTelephone');
GlobalCheck.DataLib.GlobalMobileTelephone = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalMobileTelephone');
See Also
GlobalMobileTelephone Members


GlobalMobileTelephone Members

GlobalMobileTelephone Members GBG Web Service Developers Guide
The GlobalMobileTelephone type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalMobileTelephone Class


GlobalMobileTelephone Properties

GlobalMobileTelephone Properties GBG Web Service Developers Guide
The GlobalMobileTelephone type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalMobileTelephone Class


GlobalMobileTelephone.Number Property

GlobalMobileTelephone Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            Contains an individuals mobile telephone number.This property may be omitted or set to an empty string to indicate no value was supplied
            This property will be validated against the following named regular expression: MobileTelephoneNumber
See Also
GlobalMobileTelephone Class
GlobalMobileTelephone Members


GlobalNewZealand Class

GlobalNewZealand Class GBG Web Service Developers Guide
New Zealand identity details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalNewZealand

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalNewZealand
[SerializableAttribute]
public class GlobalNewZealand
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalNewZealand = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalNewZealand');
GlobalCheck.DataLib.GlobalNewZealand = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalNewZealand');
See Also
GlobalNewZealand Members


GlobalNewZealand Members

GlobalNewZealand Members GBG Web Service Developers Guide
The GlobalNewZealand type exposes the following members.
Properties
 | Name | Description
Public property | DrivingLicence | Driving License Details
Back to Top
See Also
GlobalNewZealand Class


GlobalNewZealand Properties

GlobalNewZealand Properties GBG Web Service Developers Guide
The GlobalNewZealand type exposes the following members.
Properties
 | Name | Description
Public property | DrivingLicence | Driving License Details
Back to Top
See Also
GlobalNewZealand Class


GlobalNewZealand.DrivingLicence Property

GlobalNewZealand DrivingLicence Property GBG Web Service Developers Guide
Driving License Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalNewZealandDrivingLicence DrivingLicence { get; set; }
public GlobalNewZealandDrivingLicence DrivingLicence { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DrivingLicence();
function set_DrivingLicence(value);
function get_DrivingLicence();
function set_DrivingLicence(value);
Property Value
Type: GlobalNewZealandDrivingLicence
See Also
GlobalNewZealand Class
GlobalNewZealand Members


GlobalNewZealandDrivingLicence Class

GlobalNewZealandDrivingLicence Class GBG Web Service Developers Guide
NZ driving licence information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalNewZealandDrivingLicence

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalNewZealandDrivingLicence
[SerializableAttribute]
public class GlobalNewZealandDrivingLicence
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalNewZealandDrivingLicence = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalNewZealandDrivingLicence');
GlobalCheck.DataLib.GlobalNewZealandDrivingLicence = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalNewZealandDrivingLicence');
See Also
GlobalNewZealandDrivingLicence Members


GlobalNewZealandDrivingLicence Members

GlobalNewZealandDrivingLicence Members GBG Web Service Developers Guide
The GlobalNewZealandDrivingLicence type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Public property | Version | State Property
Back to Top
See Also
GlobalNewZealandDrivingLicence Class


GlobalNewZealandDrivingLicence Properties

GlobalNewZealandDrivingLicence Properties GBG Web Service Developers Guide
The GlobalNewZealandDrivingLicence type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Public property | Version | State Property
Back to Top
See Also
GlobalNewZealandDrivingLicence Class


GlobalNewZealandDrivingLicence.Number Property

GlobalNewZealandDrivingLicence Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            Contains an individuals Driving Licence Number. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: NZDrivingLicenceNumber
See Also
GlobalNewZealandDrivingLicence Class
GlobalNewZealandDrivingLicence Members


GlobalNewZealandDrivingLicence.Version Property

GlobalNewZealandDrivingLicence Version Property GBG Web Service Developers Guide
State Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Version { get; set; }
public string Version { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Version();
function set_Version(value);
function get_Version();
function set_Version(value);
Property Value
Type: String

            The 3-digit code for the New Zealand Driving licences. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Version
See Also
GlobalNewZealandDrivingLicence Class
GlobalNewZealandDrivingLicence Members


GlobalOrganisation Class

GlobalOrganisation Class GBG Web Service Developers Guide
Contains details of an Organisation
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalOrganisation
GlobalCheck.DataLib GlobalOrganisationDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalOrganisation
public class GlobalOrganisation
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalOrganisation = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalOrganisation');
GlobalCheck.DataLib.GlobalOrganisation = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalOrganisation');
See Also
GlobalOrganisation Members


GlobalOrganisation Members

GlobalOrganisation Members GBG Web Service Developers Guide
The GlobalOrganisation type exposes the following members.
Properties
 | Name | Description
Public property | Active | IsActive Property
Public property | Alias | Alias Property
Public property | DomainName | DomainName Property
Public property | DomainName2 | DomainName2 Property
Public property | LegalName | LegalName Property
Public property | Name | Name Property
Public property | OrgID | OrgID Property
Public property | URUID | URUID Property
Back to Top
See Also
GlobalOrganisation Class


GlobalOrganisation Properties

GlobalOrganisation Properties GBG Web Service Developers Guide
The GlobalOrganisation type exposes the following members.
Properties
 | Name | Description
Public property | Active | IsActive Property
Public property | Alias | Alias Property
Public property | DomainName | DomainName Property
Public property | DomainName2 | DomainName2 Property
Public property | LegalName | LegalName Property
Public property | Name | Name Property
Public property | OrgID | OrgID Property
Public property | URUID | URUID Property
Back to Top
See Also
GlobalOrganisation Class


GlobalOrganisation.Active Property

GlobalOrganisation Active Property GBG Web Service Developers Guide
IsActive Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Active { get; set; }
public bool Active { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Active();
function set_Active(value);
function get_Active();
function set_Active(value);
Property Value
Type: Boolean

            True if the organisation has an active contract, false otherwise

See Also
GlobalOrganisation Class
GlobalOrganisation Members


GlobalOrganisation.Alias Property

GlobalOrganisation Alias Property GBG Web Service Developers Guide
Alias Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Alias { get; set; }
public string Alias { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Alias();
function set_Alias(value);
function get_Alias();
function set_Alias(value);
Property Value
Type: String

            Alias name for the organisation (use where organisation may be commonly reference by another name
            that is not already used in their Name or LegalName properties)

See Also
GlobalOrganisation Class
GlobalOrganisation Members


GlobalOrganisation.DomainName Property

GlobalOrganisation DomainName Property GBG Web Service Developers Guide
DomainName Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DomainName { get; set; }
public string DomainName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DomainName();
function set_DomainName(value);
function get_DomainName();
function set_DomainName(value);
Property Value
Type: String

            Unique domain name for the organisation (e.g. acme.com)

See Also
GlobalOrganisation Class
GlobalOrganisation Members


GlobalOrganisation.DomainName2 Property

GlobalOrganisation DomainName2 Property GBG Web Service Developers Guide
DomainName2 Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DomainName2 { get; set; }
public string DomainName2 { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DomainName2();
function set_DomainName2(value);
function get_DomainName2();
function set_DomainName2(value);
Property Value
Type: String

            Alternate unique domain name for the organisation (e.g. acme.com)

See Also
GlobalOrganisation Class
GlobalOrganisation Members


GlobalOrganisation.LegalName Property

GlobalOrganisation LegalName Property GBG Web Service Developers Guide
LegalName Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LegalName { get; set; }
public string LegalName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_LegalName();
function set_LegalName(value);
function get_LegalName();
function set_LegalName(value);
Property Value
Type: String

            Legal name of the organisation

See Also
GlobalOrganisation Class
GlobalOrganisation Members


GlobalOrganisation.Name Property

GlobalOrganisation Name Property GBG Web Service Developers Guide
Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String

            Organisation name

See Also
GlobalOrganisation Class
GlobalOrganisation Members


GlobalOrganisation.OrgID Property

GlobalOrganisation OrgID Property GBG Web Service Developers Guide
OrgID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid OrgID { get; set; }
public Guid OrgID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OrgID();
function set_OrgID(value);
function get_OrgID();
function set_OrgID(value);
Property Value
Type: Guid

            Unique identifier of the organisation

See Also
GlobalOrganisation Class
GlobalOrganisation Members


GlobalOrganisation.URUID Property

GlobalOrganisation URUID Property GBG Web Service Developers Guide
URUID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> URUID { get; set; }
public Nullable<Guid> URUID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_URUID();
function set_URUID(value);
function get_URUID();
function set_URUID(value);
Property Value
Type: Nullable Guid

            URU unique identifier of the organisation (if migrated from URU)

See Also
GlobalOrganisation Class
GlobalOrganisation Members


GlobalOrganisationDetails Class

GlobalOrganisationDetails Class GBG Web Service Developers Guide
Full details of an organisation that can be updated by an administrator of the parent organisation that manages the child organisation
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalOrganisation
GlobalCheck.DataLib GlobalOrganisationDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalOrganisationDetails : GlobalOrganisation
public class GlobalOrganisationDetails : GlobalOrganisation
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalOrganisationDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalOrganisationDetails',
    GlobalCheck.DataLib.GlobalOrganisation);
GlobalCheck.DataLib.GlobalOrganisationDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalOrganisationDetails',
    GlobalCheck.DataLib.GlobalOrganisation);
See Also
GlobalOrganisationDetails Members


GlobalOrganisationDetails Members

GlobalOrganisationDetails Members GBG Web Service Developers Guide
The GlobalOrganisationDetails type exposes the following members.
Properties
 | Name | Description
Public property | AdministratorPolicy | AdministratorPolicy Property
Public property | BINList | BINList Property
Public property | BINResponseText | BINResponse Property
Public property | ContractEnd | ContractEnd Property
Public property | ContractStart | ContractStart Property
Public property | ManagedBy | ManagedBy Property
Public property | ManagedCustomer | ManagedCustomer Property
Public property | ManagementContact | ManagementContact Property
Public property | SelfcarePasswordResets | SelfcarePasswordResets Property
Public property | SupportContact | SupportContact Property
Public property | TechnicalContact | TechnicalContact Property
Public property | UseEmailAsAccount | UseEmailAsAccount Property
Public property | UserPolicy | UserPolicy Property
Back to Top
See Also
GlobalOrganisationDetails Class


GlobalOrganisationDetails Properties

GlobalOrganisationDetails Properties GBG Web Service Developers Guide
The GlobalOrganisationDetails type exposes the following members.
Properties
 | Name | Description
Public property | AdministratorPolicy | AdministratorPolicy Property
Public property | BINList | BINList Property
Public property | BINResponseText | BINResponse Property
Public property | ContractEnd | ContractEnd Property
Public property | ContractStart | ContractStart Property
Public property | ManagedBy | ManagedBy Property
Public property | ManagedCustomer | ManagedCustomer Property
Public property | ManagementContact | ManagementContact Property
Public property | SelfcarePasswordResets | SelfcarePasswordResets Property
Public property | SupportContact | SupportContact Property
Public property | TechnicalContact | TechnicalContact Property
Public property | UseEmailAsAccount | UseEmailAsAccount Property
Public property | UserPolicy | UserPolicy Property
Back to Top
See Also
GlobalOrganisationDetails Class


GlobalOrganisationDetails.AdministratorPolicy Property

GlobalOrganisationDetails AdministratorPolicy Property GBG Web Service Developers Guide
AdministratorPolicy Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalPasswordPolicy AdministratorPolicy { get; set; }
public GlobalPasswordPolicy AdministratorPolicy { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AdministratorPolicy();
function set_AdministratorPolicy(value);
function get_AdministratorPolicy();
function set_AdministratorPolicy(value);
Property Value
Type: GlobalPasswordPolicy

            Password Policy for administrators of the organisation

See Also
GlobalOrganisationDetails Class
GlobalOrganisationDetails Members


GlobalOrganisationDetails.BINList Property

GlobalOrganisationDetails BINList Property GBG Web Service Developers Guide
BINList Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> BINList { get; set; }
public List<string> BINList { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_BINList();
function set_BINList(value);
function get_BINList();
function set_BINList(value);
Property Value
Type: List String

            Common separated list of Bank Identification Number ranges to block on when handling card data

See Also
GlobalOrganisationDetails Class
GlobalOrganisationDetails Members


GlobalOrganisationDetails.BINResponseText Property

GlobalOrganisationDetails BINResponseText Property GBG Web Service Developers Guide
BINResponse Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BINResponseText { get; set; }
public string BINResponseText { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_BINResponseText();
function set_BINResponseText(value);
function get_BINResponseText();
function set_BINResponseText(value);
Property Value
Type: String

            Message to display when an authentication has been blocked by the BIN List check

See Also
GlobalOrganisationDetails Class
GlobalOrganisationDetails Members


GlobalOrganisationDetails.ContractEnd Property

GlobalOrganisationDetails ContractEnd Property GBG Web Service Developers Guide
ContractEnd Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> ContractEnd { get; set; }
public Nullable<DateTime> ContractEnd { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ContractEnd();
function set_ContractEnd(value);
function get_ContractEnd();
function set_ContractEnd(value);
Property Value
Type: Nullable DateTime

            Timestamp representing when the organisation contract ends. This property may be omitted or set to an empty string to indicate no value was supplied.

See Also
GlobalOrganisationDetails Class
GlobalOrganisationDetails Members


GlobalOrganisationDetails.ContractStart Property

GlobalOrganisationDetails ContractStart Property GBG Web Service Developers Guide
ContractStart Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ContractStart { get; set; }
public DateTime ContractStart { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ContractStart();
function set_ContractStart(value);
function get_ContractStart();
function set_ContractStart(value);
Property Value
Type: DateTime

            Contract start - timestamp from when users will be able to access the service

See Also
GlobalOrganisationDetails Class
GlobalOrganisationDetails Members


GlobalOrganisationDetails.ManagedBy Property

GlobalOrganisationDetails ManagedBy Property GBG Web Service Developers Guide
ManagedBy Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ManagedBy { get; set; }
public string ManagedBy { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ManagedBy();
function set_ManagedBy(value);
function get_ManagedBy();
function set_ManagedBy(value);
Property Value
Type: String

            Name of the parent Organisation which manages this organisation

See Also
GlobalOrganisationDetails Class
GlobalOrganisationDetails Members


GlobalOrganisationDetails.ManagedCustomer Property

GlobalOrganisationDetails ManagedCustomer Property GBG Web Service Developers Guide
ManagedCustomer Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ManagedCustomer { get; set; }
public bool ManagedCustomer { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ManagedCustomer();
function set_ManagedCustomer(value);
function get_ManagedCustomer();
function set_ManagedCustomer(value);
Property Value
Type: Boolean

            If true then some aspect of administration of organisation will be managed by Helpdesk, if false then customer manages all aspects of the organisation
            will not be used for password resets

See Also
GlobalOrganisationDetails Class
GlobalOrganisationDetails Members


GlobalOrganisationDetails.ManagementContact Property

GlobalOrganisationDetails ManagementContact Property GBG Web Service Developers Guide
ManagementContact Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalContact ManagementContact { get; set; }
public GlobalContact ManagementContact { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ManagementContact();
function set_ManagementContact(value);
function get_ManagementContact();
function set_ManagementContact(value);
Property Value
Type: GlobalContact

            Management contract for the organisation

See Also
GlobalOrganisationDetails Class
GlobalOrganisationDetails Members


GlobalOrganisationDetails.SelfcarePasswordResets Property

GlobalOrganisationDetails SelfcarePasswordResets Property GBG Web Service Developers Guide
SelfcarePasswordResets Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SelfcarePasswordResets { get; set; }
public bool SelfcarePasswordResets { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SelfcarePasswordResets();
function set_SelfcarePasswordResets(value);
function get_SelfcarePasswordResets();
function set_SelfcarePasswordResets(value);
Property Value
Type: Boolean

            If true all users within the organisation will use their contact email address to request password resets, if false then emails
            will not be used for password resets

See Also
GlobalOrganisationDetails Class
GlobalOrganisationDetails Members


GlobalOrganisationDetails.SupportContact Property

GlobalOrganisationDetails SupportContact Property GBG Web Service Developers Guide
SupportContact Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalSupportContact SupportContact { get; set; }
public GlobalSupportContact SupportContact { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SupportContact();
function set_SupportContact(value);
function get_SupportContact();
function set_SupportContact(value);
Property Value
Type: GlobalSupportContact

            Support contact details for the organisation

See Also
GlobalOrganisationDetails Class
GlobalOrganisationDetails Members


GlobalOrganisationDetails.TechnicalContact Property

GlobalOrganisationDetails TechnicalContact Property GBG Web Service Developers Guide
TechnicalContact Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalContact TechnicalContact { get; set; }
public GlobalContact TechnicalContact { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TechnicalContact();
function set_TechnicalContact(value);
function get_TechnicalContact();
function set_TechnicalContact(value);
Property Value
Type: GlobalContact

            Technical contact for the organisation

See Also
GlobalOrganisationDetails Class
GlobalOrganisationDetails Members


GlobalOrganisationDetails.UseEmailAsAccount Property

GlobalOrganisationDetails UseEmailAsAccount Property GBG Web Service Developers Guide
UseEmailAsAccount Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UseEmailAsAccount { get; set; }
public bool UseEmailAsAccount { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_UseEmailAsAccount();
function set_UseEmailAsAccount(value);
function get_UseEmailAsAccount();
function set_UseEmailAsAccount(value);
Property Value
Type: Boolean

            If true all users within the organisation will use their contact email address as their account name,
            false if the account name and contact email address as managed separately

See Also
GlobalOrganisationDetails Class
GlobalOrganisationDetails Members


GlobalOrganisationDetails.UserPolicy Property

GlobalOrganisationDetails UserPolicy Property GBG Web Service Developers Guide
UserPolicy Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalPasswordPolicy UserPolicy { get; set; }
public GlobalPasswordPolicy UserPolicy { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_UserPolicy();
function set_UserPolicy(value);
function get_UserPolicy();
function set_UserPolicy(value);
Property Value
Type: GlobalPasswordPolicy

            Password Policy for user of the organisation

See Also
GlobalOrganisationDetails Class
GlobalOrganisationDetails Members


GlobalOrganisations Class

GlobalOrganisations Class GBG Web Service Developers Guide
Contains paged results from a request for summary details of child organisations
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalOrganisations

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalOrganisations
public class GlobalOrganisations
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalOrganisations = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalOrganisations');
GlobalCheck.DataLib.GlobalOrganisations = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalOrganisations');
See Also
GlobalOrganisations Members


GlobalOrganisations Members

GlobalOrganisations Members GBG Web Service Developers Guide
The GlobalOrganisations type exposes the following members.
Properties
 | Name | Description
Public property | Organisations | Organisations Property
Public property | PageSize | PageSize Property
Public property | TotalActive | TotalActive Property
Public property | TotalExpired | TotalExpired Property
Public property | TotalOrganisations | TotalOrganisations Property
Public property | TotalPages | TotalPages Property
Back to Top
See Also
GlobalOrganisations Class


GlobalOrganisations Properties

GlobalOrganisations Properties GBG Web Service Developers Guide
The GlobalOrganisations type exposes the following members.
Properties
 | Name | Description
Public property | Organisations | Organisations Property
Public property | PageSize | PageSize Property
Public property | TotalActive | TotalActive Property
Public property | TotalExpired | TotalExpired Property
Public property | TotalOrganisations | TotalOrganisations Property
Public property | TotalPages | TotalPages Property
Back to Top
See Also
GlobalOrganisations Class


GlobalOrganisations.Organisations Property

GlobalOrganisations Organisations Property GBG Web Service Developers Guide
Organisations Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalOrganisation> Organisations { get; set; }
public List<GlobalOrganisation> Organisations { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Organisations();
function set_Organisations(value);
function get_Organisations();
function set_Organisations(value);
Property Value
Type: List GlobalOrganisation

            Filtered list of Organisations

See Also
GlobalOrganisations Class
GlobalOrganisations Members


GlobalOrganisations.PageSize Property

GlobalOrganisations PageSize Property GBG Web Service Developers Guide
PageSize Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint PageSize { get; set; }
public uint PageSize { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PageSize();
function set_PageSize(value);
function get_PageSize();
function set_PageSize(value);
Property Value
Type: UInt32

            Maximum number of results returned from the paged request

See Also
GlobalOrganisations Class
GlobalOrganisations Members


GlobalOrganisations.TotalActive Property

GlobalOrganisations TotalActive Property GBG Web Service Developers Guide
TotalActive Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalActive { get; set; }
public uint TotalActive { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalActive();
function set_TotalActive(value);
function get_TotalActive();
function set_TotalActive(value);
Property Value
Type: UInt32

            Total number of active organisations that matched the query

See Also
GlobalOrganisations Class
GlobalOrganisations Members


GlobalOrganisations.TotalExpired Property

GlobalOrganisations TotalExpired Property GBG Web Service Developers Guide
TotalExpired Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalExpired { get; set; }
public uint TotalExpired { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalExpired();
function set_TotalExpired(value);
function get_TotalExpired();
function set_TotalExpired(value);
Property Value
Type: UInt32

            Total number of expired organisations that matched the query

See Also
GlobalOrganisations Class
GlobalOrganisations Members


GlobalOrganisations.TotalOrganisations Property

GlobalOrganisations TotalOrganisations Property GBG Web Service Developers Guide
TotalOrganisations Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalOrganisations { get; set; }
public uint TotalOrganisations { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalOrganisations();
function set_TotalOrganisations(value);
function get_TotalOrganisations();
function set_TotalOrganisations(value);
Property Value
Type: UInt32

            Total number of organisations that matched the query

See Also
GlobalOrganisations Class
GlobalOrganisations Members


GlobalOrganisations.TotalPages Property

GlobalOrganisations TotalPages Property GBG Web Service Developers Guide
TotalPages Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalPages { get; set; }
public uint TotalPages { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalPages();
function set_TotalPages(value);
function get_TotalPages();
function set_TotalPages(value);
Property Value
Type: UInt32

            The total number of pages that would be required to return all the results, based on a page size of PageSize

See Also
GlobalOrganisations Class
GlobalOrganisations Members


GlobalOverride Class

GlobalOverride Class GBG Web Service Developers Guide
Details associated with an Item Check whose results have been forcibly overriden
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalOverride

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalOverride
[SerializableAttribute]
public class GlobalOverride
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalOverride = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalOverride');
GlobalCheck.DataLib.GlobalOverride = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalOverride');
See Also
GlobalOverride Members


GlobalOverride Members

GlobalOverride Members GBG Web Service Developers Guide
The GlobalOverride type exposes the following members.
Properties
 | Name | Description
Public property | Description | The description why the item check was overriden
Public property | ID | The identifier of the item check to override
Back to Top
See Also
GlobalOverride Class


GlobalOverride Properties

GlobalOverride Properties GBG Web Service Developers Guide
The GlobalOverride type exposes the following members.
Properties
 | Name | Description
Public property | Description | The description why the item check was overriden
Public property | ID | The identifier of the item check to override
Back to Top
See Also
GlobalOverride Class


GlobalOverride.Description Property

GlobalOverride Description Property GBG Web Service Developers Guide
The description why the item check was overriden

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Description();
function set_Description(value);
function get_Description();
function set_Description(value);
Property Value
Type: String
See Also
GlobalOverride Class
GlobalOverride Members


GlobalOverride.ID Property

GlobalOverride ID Property GBG Web Service Developers Guide
The identifier of the item check to override

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ID { get; set; }
public int ID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ID();
function set_ID(value);
function get_ID();
function set_ID(value);
Property Value
Type: Int32
See Also
GlobalOverride Class
GlobalOverride Members


GlobalPasswordPolicy Class

GlobalPasswordPolicy Class GBG Web Service Developers Guide
Password Policy
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalPasswordPolicy

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalPasswordPolicy
public class GlobalPasswordPolicy
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalPasswordPolicy = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalPasswordPolicy');
GlobalCheck.DataLib.GlobalPasswordPolicy = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalPasswordPolicy');
See Also
GlobalPasswordPolicy Members


GlobalPasswordPolicy Members

GlobalPasswordPolicy Members GBG Web Service Developers Guide
The GlobalPasswordPolicy type exposes the following members.
Properties
 | Name | Description
Public property | ChangePasswordDays | ChangePasswordDays Property
Public property | DisableInactiveDays | DisableInactiveDays Property
Public property | Length | Length Property
Public property | Lowercase | Lowercase Property
Public property | Numeric | Numeric Property
Public property | RequirePINForSignin | RequirePINForSignin Property
Public property | Symbols | Symbols Policy
Public property | Uppercase | Uppercase Property
Back to Top
See Also
GlobalPasswordPolicy Class


GlobalPasswordPolicy Properties

GlobalPasswordPolicy Properties GBG Web Service Developers Guide
The GlobalPasswordPolicy type exposes the following members.
Properties
 | Name | Description
Public property | ChangePasswordDays | ChangePasswordDays Property
Public property | DisableInactiveDays | DisableInactiveDays Property
Public property | Length | Length Property
Public property | Lowercase | Lowercase Property
Public property | Numeric | Numeric Property
Public property | RequirePINForSignin | RequirePINForSignin Property
Public property | Symbols | Symbols Policy
Public property | Uppercase | Uppercase Property
Back to Top
See Also
GlobalPasswordPolicy Class


GlobalPasswordPolicy.ChangePasswordDays Property

GlobalPasswordPolicy ChangePasswordDays Property GBG Web Service Developers Guide
ChangePasswordDays Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<uint> ChangePasswordDays { get; set; }
public Nullable<uint> ChangePasswordDays { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ChangePasswordDays();
function set_ChangePasswordDays(value);
function get_ChangePasswordDays();
function set_ChangePasswordDays(value);
Property Value
Type: Nullable UInt32

            If set this property indicates the number of days a password remains valid before the user must be forced to change it. This property may be omitted or set to an empty string to indicate no value was supplied.

See Also
GlobalPasswordPolicy Class
GlobalPasswordPolicy Members


GlobalPasswordPolicy.DisableInactiveDays Property

GlobalPasswordPolicy DisableInactiveDays Property GBG Web Service Developers Guide
DisableInactiveDays Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<uint> DisableInactiveDays { get; set; }
public Nullable<uint> DisableInactiveDays { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DisableInactiveDays();
function set_DisableInactiveDays(value);
function get_DisableInactiveDays();
function set_DisableInactiveDays(value);
Property Value
Type: Nullable UInt32

            If set this property indicates the number of days after which an account will be automatically disabled if it is not used. This property may be omitted or set to an empty string to indicate no value was supplied.

See Also
GlobalPasswordPolicy Class
GlobalPasswordPolicy Members


GlobalPasswordPolicy.Length Property

GlobalPasswordPolicy Length Property GBG Web Service Developers Guide
Length Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Length { get; set; }
public uint Length { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Length();
function set_Length(value);
function get_Length();
function set_Length(value);
Property Value
Type: UInt32

            Password Minimum Length

See Also
GlobalPasswordPolicy Class
GlobalPasswordPolicy Members


GlobalPasswordPolicy.Lowercase Property

GlobalPasswordPolicy Lowercase Property GBG Web Service Developers Guide
Lowercase Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Lowercase { get; set; }
public uint Lowercase { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Lowercase();
function set_Lowercase(value);
function get_Lowercase();
function set_Lowercase(value);
Property Value
Type: UInt32

            Minimum number of lowercase letters in the password

See Also
GlobalPasswordPolicy Class
GlobalPasswordPolicy Members


GlobalPasswordPolicy.Numeric Property

GlobalPasswordPolicy Numeric Property GBG Web Service Developers Guide
Numeric Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Numeric { get; set; }
public uint Numeric { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Numeric();
function set_Numeric(value);
function get_Numeric();
function set_Numeric(value);
Property Value
Type: UInt32

            Minimum number of numeric characters in the password

See Also
GlobalPasswordPolicy Class
GlobalPasswordPolicy Members


GlobalPasswordPolicy.RequirePINForSignin Property

GlobalPasswordPolicy RequirePINForSignin Property GBG Web Service Developers Guide
RequirePINForSignin Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RequirePINForSignin { get; set; }
public bool RequirePINForSignin { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_RequirePINForSignin();
function set_RequirePINForSignin(value);
function get_RequirePINForSignin();
function set_RequirePINForSignin(value);
Property Value
Type: Boolean

            True if a PIN is required for Sign in, False otherwise

See Also
GlobalPasswordPolicy Class
GlobalPasswordPolicy Members


GlobalPasswordPolicy.Symbols Property

GlobalPasswordPolicy Symbols Property GBG Web Service Developers Guide
Symbols Policy

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Symbols { get; set; }
public uint Symbols { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Symbols();
function set_Symbols(value);
function get_Symbols();
function set_Symbols(value);
Property Value
Type: UInt32

            Minimum number of symbolic (non-alphanumeric) characters in the password

See Also
GlobalPasswordPolicy Class
GlobalPasswordPolicy Members


GlobalPasswordPolicy.Uppercase Property

GlobalPasswordPolicy Uppercase Property GBG Web Service Developers Guide
Uppercase Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Uppercase { get; set; }
public uint Uppercase { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Uppercase();
function set_Uppercase(value);
function get_Uppercase();
function set_Uppercase(value);
Property Value
Type: UInt32

            Minimum number of uppercase letters in the password

See Also
GlobalPasswordPolicy Class
GlobalPasswordPolicy Members


GlobalPEPIntelligenceData Class

GlobalPEPIntelligenceData Class GBG Web Service Developers Guide
Information about an entity from PEP Intelligence data
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalPEPIntelligenceData

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalPEPIntelligenceData
public class GlobalPEPIntelligenceData
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalPEPIntelligenceData = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalPEPIntelligenceData');
GlobalCheck.DataLib.GlobalPEPIntelligenceData = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalPEPIntelligenceData');
See Also
GlobalPEPIntelligenceData Members


GlobalPEPIntelligenceData Members

GlobalPEPIntelligenceData Members GBG Web Service Developers Guide
The GlobalPEPIntelligenceData type exposes the following members.
Properties
 | Name | Description
Public property | Aliases | Aliases
Public property | Fullname | Fullname
Public property | IdentityInformation | Alias
Public property | SanctionsAddresses | SanctionsAddresses
Public property | SanctionsDates | SanctionsDates
Public property | SanctionsPositions | Dates
Back to Top
See Also
GlobalPEPIntelligenceData Class


GlobalPEPIntelligenceData Properties

GlobalPEPIntelligenceData Properties GBG Web Service Developers Guide
The GlobalPEPIntelligenceData type exposes the following members.
Properties
 | Name | Description
Public property | Aliases | Aliases
Public property | Fullname | Fullname
Public property | IdentityInformation | Alias
Public property | SanctionsAddresses | SanctionsAddresses
Public property | SanctionsDates | SanctionsDates
Public property | SanctionsPositions | Dates
Back to Top
See Also
GlobalPEPIntelligenceData Class


GlobalPEPIntelligenceData.Aliases Property

GlobalPEPIntelligenceData Aliases Property GBG Web Service Developers Guide
Aliases

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> Aliases { get; set; }
public List<string> Aliases { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Aliases();
function set_Aliases(value);
function get_Aliases();
function set_Aliases(value);
Property Value
Type: List String

            Represents a list of aliases for the entity

See Also
GlobalPEPIntelligenceData Class
GlobalPEPIntelligenceData Members


GlobalPEPIntelligenceData.Fullname Property

GlobalPEPIntelligenceData Fullname Property GBG Web Service Developers Guide
Fullname

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Fullname { get; set; }
public string Fullname { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Fullname();
function set_Fullname(value);
function get_Fullname();
function set_Fullname(value);
Property Value
Type: String

            Represents the full name of the matched entity

See Also
GlobalPEPIntelligenceData Class
GlobalPEPIntelligenceData Members


GlobalPEPIntelligenceData.IdentityInformation Property

GlobalPEPIntelligenceData IdentityInformation Property GBG Web Service Developers Guide
Alias

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> IdentityInformation { get; set; }
public List<string> IdentityInformation { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IdentityInformation();
function set_IdentityInformation(value);
function get_IdentityInformation();
function set_IdentityInformation(value);
Property Value
Type: List String

            Represents a list of passport numbers for the entity

See Also
GlobalPEPIntelligenceData Class
GlobalPEPIntelligenceData Members


GlobalPEPIntelligenceData.SanctionsAddresses Property

GlobalPEPIntelligenceData SanctionsAddresses Property GBG Web Service Developers Guide
SanctionsAddresses

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalSanctionsAddress> SanctionsAddresses { get; set; }
public List<GlobalSanctionsAddress> SanctionsAddresses { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SanctionsAddresses();
function set_SanctionsAddresses(value);
function get_SanctionsAddresses();
function set_SanctionsAddresses(value);
Property Value
Type: List GlobalSanctionsAddress

            Represents a list of addresses for the entity

See Also
GlobalPEPIntelligenceData Class
GlobalPEPIntelligenceData Members


GlobalPEPIntelligenceData.SanctionsDates Property

GlobalPEPIntelligenceData SanctionsDates Property GBG Web Service Developers Guide
SanctionsDates

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalSanctionsDate> SanctionsDates { get; set; }
public List<GlobalSanctionsDate> SanctionsDates { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SanctionsDates();
function set_SanctionsDates(value);
function get_SanctionsDates();
function set_SanctionsDates(value);
Property Value
Type: List GlobalSanctionsDate

            Represents a list of Birth and Death dates for the entity.

See Also
GlobalPEPIntelligenceData Class
GlobalPEPIntelligenceData Members


GlobalPEPIntelligenceData.SanctionsPositions Property

GlobalPEPIntelligenceData SanctionsPositions Property GBG Web Service Developers Guide
Dates

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalSanctionsPosition> SanctionsPositions { get; set; }
public List<GlobalSanctionsPosition> SanctionsPositions { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SanctionsPositions();
function set_SanctionsPositions(value);
function get_SanctionsPositions();
function set_SanctionsPositions(value);
Property Value
Type: List GlobalSanctionsPosition

            Represents a list of Birth and Death dates for the entity.

See Also
GlobalPEPIntelligenceData Class
GlobalPEPIntelligenceData Members


GlobalPermission Enumeration

GlobalPermission Enumeration GBG Web Service Developers Guide
Contains Permissions.

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalPermission
[SerializableAttribute]
public enum GlobalPermission
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalPermission = function();
GlobalCheck.DataLib.GlobalPermission.createEnum('GlobalCheck.DataLib.GlobalPermission', false);
GlobalCheck.DataLib.GlobalPermission = function();
GlobalCheck.DataLib.GlobalPermission.createEnum('GlobalCheck.DataLib.GlobalPermission', false);
Members
Member name | Value | Description
None | 0 | None Permission
Read | 1 | Read Permission
Execute | 2 | Execute Permission
Manage | 3 | Manage Permission
Full | 4 | Full Permission
See Also


GlobalPersonal Class

GlobalPersonal Class GBG Web Service Developers Guide
Contains all the personal details for an individual including alternate details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalPersonal

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalPersonal
[SerializableAttribute]
public class GlobalPersonal
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalPersonal = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalPersonal');
GlobalCheck.DataLib.GlobalPersonal = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalPersonal');
See Also
GlobalPersonal Members


GlobalPersonal Members

GlobalPersonal Members GBG Web Service Developers Guide
The GlobalPersonal type exposes the following members.
Properties
 | Name | Description
Public property | Aliases | Additional aliases of an Individual - not used for matching
Public property | AlternateName | An Individuals Alternate Details
Public property | PersonalDetails | An Individuals Personal Details
Back to Top
See Also
GlobalPersonal Class


GlobalPersonal Properties

GlobalPersonal Properties GBG Web Service Developers Guide
The GlobalPersonal type exposes the following members.
Properties
 | Name | Description
Public property | Aliases | Additional aliases of an Individual - not used for matching
Public property | AlternateName | An Individuals Alternate Details
Public property | PersonalDetails | An Individuals Personal Details
Back to Top
See Also
GlobalPersonal Class


GlobalPersonal.Aliases Property

GlobalPersonal Aliases Property GBG Web Service Developers Guide
Additional aliases of an Individual - not used for matching

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalAlternateName> Aliases { get; set; }
public List<GlobalAlternateName> Aliases { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Aliases();
function set_Aliases(value);
function get_Aliases();
function set_Aliases(value);
Property Value
Type: List GlobalAlternateName
See Also
GlobalPersonal Class
GlobalPersonal Members


GlobalPersonal.AlternateName Property

GlobalPersonal AlternateName Property GBG Web Service Developers Guide
An Individuals Alternate Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalAlternateName AlternateName { get; set; }
public GlobalAlternateName AlternateName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AlternateName();
function set_AlternateName(value);
function get_AlternateName();
function set_AlternateName(value);
Property Value
Type: GlobalAlternateName
See Also
GlobalPersonal Class
GlobalPersonal Members


GlobalPersonal.PersonalDetails Property

GlobalPersonal PersonalDetails Property GBG Web Service Developers Guide
An Individuals Personal Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalPersonalDetails PersonalDetails { get; set; }
public GlobalPersonalDetails PersonalDetails { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PersonalDetails();
function set_PersonalDetails(value);
function get_PersonalDetails();
function set_PersonalDetails(value);
Property Value
Type: GlobalPersonalDetails
See Also
GlobalPersonal Class
GlobalPersonal Members


GlobalPersonalDetails Class

GlobalPersonalDetails Class GBG Web Service Developers Guide
Contains all the personal details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalPersonalDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalPersonalDetails
[SerializableAttribute]
public class GlobalPersonalDetails
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalPersonalDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalPersonalDetails');
GlobalCheck.DataLib.GlobalPersonalDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalPersonalDetails');
See Also
GlobalPersonalDetails Members


GlobalPersonalDetails Members

GlobalPersonalDetails Members GBG Web Service Developers Guide
The GlobalPersonalDetails type exposes the following members.
Properties
 | Name | Description
Public property | AdditionalMiddleNames | AdditionalMiddleNames Name Property - not used for matching
Public property | Birth | Birth Details
Public property | CountryOfBirth | Country Of Birth Property
Public property | DOBDay | Date Of Birth Day Property
Public property | DOBMonth | Date Of Month Day Property
Public property | DOBYear | Date Of Year Day Property
Public property | Forename | Forename Property
Public property | Gender | Gender Property
Public property | MiddleName | Middle Name Property
Public property | SecondSurname | SecondSurname Property
Public property | Surname | Surname Property
Public property | Title | Title Property
Back to Top
See Also
GlobalPersonalDetails Class


GlobalPersonalDetails Properties

GlobalPersonalDetails Properties GBG Web Service Developers Guide
The GlobalPersonalDetails type exposes the following members.
Properties
 | Name | Description
Public property | AdditionalMiddleNames | AdditionalMiddleNames Name Property - not used for matching
Public property | Birth | Birth Details
Public property | CountryOfBirth | Country Of Birth Property
Public property | DOBDay | Date Of Birth Day Property
Public property | DOBMonth | Date Of Month Day Property
Public property | DOBYear | Date Of Year Day Property
Public property | Forename | Forename Property
Public property | Gender | Gender Property
Public property | MiddleName | Middle Name Property
Public property | SecondSurname | SecondSurname Property
Public property | Surname | Surname Property
Public property | Title | Title Property
Back to Top
See Also
GlobalPersonalDetails Class


GlobalPersonalDetails.AdditionalMiddleNames Property

GlobalPersonalDetails AdditionalMiddleNames Property GBG Web Service Developers Guide
AdditionalMiddleNames Name Property - not used for matching

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> AdditionalMiddleNames { get; set; }
public List<string> AdditionalMiddleNames { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AdditionalMiddleNames();
function set_AdditionalMiddleNames(value);
function get_AdditionalMiddleNames();
function set_AdditionalMiddleNames(value);
Property Value
Type: List String

            Additional middle names.  This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: MiddleName
See Also
GlobalPersonalDetails Class
GlobalPersonalDetails Members


GlobalPersonalDetails.Birth Property

GlobalPersonalDetails Birth Property GBG Web Service Developers Guide
Birth Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalUKBirth Birth { get; set; }
public GlobalUKBirth Birth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Birth();
function set_Birth(value);
function get_Birth();
function set_Birth(value);
Property Value
Type: GlobalUKBirth
See Also
GlobalPersonalDetails Class
GlobalPersonalDetails Members


GlobalPersonalDetails.CountryOfBirth Property

GlobalPersonalDetails CountryOfBirth Property GBG Web Service Developers Guide
Country Of Birth Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CountryOfBirth { get; set; }
public string CountryOfBirth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CountryOfBirth();
function set_CountryOfBirth(value);
function get_CountryOfBirth();
function set_CountryOfBirth(value);
Property Value
Type: String

            The country where the individual was born. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Country
See Also
GlobalPersonalDetails Class
GlobalPersonalDetails Members


GlobalPersonalDetails.DOBDay Property

GlobalPersonalDetails DOBDay Property GBG Web Service Developers Guide
Date Of Birth Day Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DOBDay { get; set; }
public int DOBDay { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DOBDay();
function set_DOBDay(value);
function get_DOBDay();
function set_DOBDay(value);
Property Value
Type: Int32

            Integer in the range 1-31 representing the day in the month of an individuals date of birth. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Day
See Also
GlobalPersonalDetails Class
GlobalPersonalDetails Members


GlobalPersonalDetails.DOBMonth Property

GlobalPersonalDetails DOBMonth Property GBG Web Service Developers Guide
Date Of Month Day Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DOBMonth { get; set; }
public int DOBMonth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DOBMonth();
function set_DOBMonth(value);
function get_DOBMonth();
function set_DOBMonth(value);
Property Value
Type: Int32

            Integer in the range 1-12 representing the month of an individuals date of birth. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Month
See Also
GlobalPersonalDetails Class
GlobalPersonalDetails Members


GlobalPersonalDetails.DOBYear Property

GlobalPersonalDetails DOBYear Property GBG Web Service Developers Guide
Date Of Year Day Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DOBYear { get; set; }
public int DOBYear { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DOBYear();
function set_DOBYear(value);
function get_DOBYear();
function set_DOBYear(value);
Property Value
Type: Int32

            Integer in the range 1-2099 representing the day in the year of an individuals date of birth. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Year
See Also
GlobalPersonalDetails Class
GlobalPersonalDetails Members


GlobalPersonalDetails.Forename Property

GlobalPersonalDetails Forename Property GBG Web Service Developers Guide
Forename Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Forename { get; set; }
public string Forename { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Forename();
function set_Forename(value);
function get_Forename();
function set_Forename(value);
Property Value
Type: String

            The forename of an individual.  This property may be omitted or set to an empty string to indicate no value was supplied for UK authentications. It must be supplied when performing an authentication against any other country.
            This property will be validated against the following named regular expression: Forename
See Also
GlobalPersonalDetails Class
GlobalPersonalDetails Members


GlobalPersonalDetails.Gender Property

GlobalPersonalDetails Gender Property GBG Web Service Developers Guide
Gender Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalGender Gender { get; set; }
public GlobalGender Gender { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Gender();
function set_Gender(value);
function get_Gender();
function set_Gender(value);
Property Value
Type: GlobalGender

            Individual’s gender. This property may be omitted indicate no value was supplied (alternatively the value of 'Unspecified' can be passed) for UK authentications. It must be supplied when performing an authentication against any other country.
            Possible values are:
            Male
            Female
            Unknown
            Unspecified

See Also
GlobalPersonalDetails Class
GlobalPersonalDetails Members


GlobalPersonalDetails.MiddleName Property

GlobalPersonalDetails MiddleName Property GBG Web Service Developers Guide
Middle Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MiddleName { get; set; }
public string MiddleName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MiddleName();
function set_MiddleName(value);
function get_MiddleName();
function set_MiddleName(value);
Property Value
Type: String

            The middle name of an individual.  This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: MiddleName
See Also
GlobalPersonalDetails Class
GlobalPersonalDetails Members


GlobalPersonalDetails.SecondSurname Property

GlobalPersonalDetails SecondSurname Property GBG Web Service Developers Guide
SecondSurname Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SecondSurname { get; set; }
public string SecondSurname { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SecondSurname();
function set_SecondSurname(value);
function get_SecondSurname();
function set_SecondSurname(value);
Property Value
Type: String

            The 2nd Surname of an individual.  This property may be omitted or set to an empty string to indicate no value was supplied for UK authentications.
            This property will be validated against the following named regular expression: Surname
See Also
GlobalPersonalDetails Class
GlobalPersonalDetails Members


GlobalPersonalDetails.Surname Property

GlobalPersonalDetails Surname Property GBG Web Service Developers Guide
Surname Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Surname { get; set; }
public string Surname { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Surname();
function set_Surname(value);
function get_Surname();
function set_Surname(value);
Property Value
Type: String

            The surname of an individual.  This property may be omitted or set to an empty string to indicate no value was supplied for UK authentications. It must be supplied when performing an authentication against any other country.
            This property will be validated against the following named regular expression: Surname
See Also
GlobalPersonalDetails Class
GlobalPersonalDetails Members


GlobalPersonalDetails.Title Property

GlobalPersonalDetails Title Property GBG Web Service Developers Guide
Title Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Title { get; set; }
public string Title { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Title();
function set_Title(value);
function get_Title();
function set_Title(value);
Property Value
Type: String

            The title (e.g. Mr/Mrs/Dr) of an individual. This property may be omitted or set to an empty string to indicate no value was supplied for UK authentications. It must be supplied when performing an authentication against any other country.
            This property will be validated against the following named regular expression: Title
See Also
GlobalPersonalDetails Class
GlobalPersonalDetails Members


GlobalProfile Class

GlobalProfile Class GBG Web Service Developers Guide
Contains details of a Profile
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalProfile
GlobalCheck.DataLib GlobalProfileVersion

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalProfile
public class GlobalProfile
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalProfile = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalProfile');
GlobalCheck.DataLib.GlobalProfile = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalProfile');
See Also
GlobalProfile Members


GlobalProfile Members

GlobalProfile Members GBG Web Service Developers Guide
The GlobalProfile type exposes the following members.
Properties
 | Name | Description
Public property | Created | Created Property
Public property | Description | Description Property
Public property | ID | ID Property
Public property | Name | Name Property
Public property | Updated | Updated Property
Public property | UpdatedBy | UpdatedBy Property
Public property | UpdatedByAccount | UpdatedByAccount Property
Back to Top
See Also
GlobalProfile Class


GlobalProfile Properties

GlobalProfile Properties GBG Web Service Developers Guide
The GlobalProfile type exposes the following members.
Properties
 | Name | Description
Public property | Created | Created Property
Public property | Description | Description Property
Public property | ID | ID Property
Public property | Name | Name Property
Public property | Updated | Updated Property
Public property | UpdatedBy | UpdatedBy Property
Public property | UpdatedByAccount | UpdatedByAccount Property
Back to Top
See Also
GlobalProfile Class


GlobalProfile.Created Property

GlobalProfile Created Property GBG Web Service Developers Guide
Created Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Created { get; set; }
public DateTime Created { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Created();
function set_Created(value);
function get_Created();
function set_Created(value);
Property Value
Type: DateTime

            Date the first Profile in the chain was created

See Also
GlobalProfile Class
GlobalProfile Members


GlobalProfile.Description Property

GlobalProfile Description Property GBG Web Service Developers Guide
Description Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Description();
function set_Description(value);
function get_Description();
function set_Description(value);
Property Value
Type: String

            The description of the profile.

See Also
GlobalProfile Class
GlobalProfile Members


GlobalProfile.ID Property

GlobalProfile ID Property GBG Web Service Developers Guide
ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ID { get; set; }
public Guid ID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ID();
function set_ID(value);
function get_ID();
function set_ID(value);
Property Value
Type: Guid

            The identifier of the profile

See Also
GlobalProfile Class
GlobalProfile Members


GlobalProfile.Name Property

GlobalProfile Name Property GBG Web Service Developers Guide
Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String

            The Name of the profile

See Also
GlobalProfile Class
GlobalProfile Members


GlobalProfile.Updated Property

GlobalProfile Updated Property GBG Web Service Developers Guide
Updated Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Updated { get; set; }
public DateTime Updated { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Updated();
function set_Updated(value);
function get_Updated();
function set_Updated(value);
Property Value
Type: DateTime

            Date the last time the Profile Name or Description was updated

See Also
GlobalProfile Class
GlobalProfile Members


GlobalProfile.UpdatedBy Property

GlobalProfile UpdatedBy Property GBG Web Service Developers Guide
UpdatedBy Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid UpdatedBy { get; set; }
public Guid UpdatedBy { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_UpdatedBy();
function set_UpdatedBy(value);
function get_UpdatedBy();
function set_UpdatedBy(value);
Property Value
Type: Guid

            Unique identifier user who updated the Profile Name or Description

See Also
GlobalProfile Class
GlobalProfile Members


GlobalProfile.UpdatedByAccount Property

GlobalProfile UpdatedByAccount Property GBG Web Service Developers Guide
UpdatedByAccount Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UpdatedByAccount { get; set; }
public string UpdatedByAccount { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_UpdatedByAccount();
function set_UpdatedByAccount(value);
function get_UpdatedByAccount();
function set_UpdatedByAccount(value);
Property Value
Type: String

            Account name in the form user@domain of the user who updated the Profile Name or Description

See Also
GlobalProfile Class
GlobalProfile Members


GlobalProfileDetails Class

GlobalProfileDetails Class GBG Web Service Developers Guide
Full Profile Details including Decision Bands, Item Checks, Properties, Scoring and Execution Conditions
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalProfile
GlobalCheck.DataLib GlobalProfileVersion
GlobalCheck.DataLib GlobalProfileDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalProfileDetails : GlobalProfileVersion
public class GlobalProfileDetails : GlobalProfileVersion
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalProfileDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalProfileDetails',
    GlobalCheck.DataLib.GlobalProfileVersion);
GlobalCheck.DataLib.GlobalProfileDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalProfileDetails',
    GlobalCheck.DataLib.GlobalProfileVersion);
See Also
GlobalProfileDetails Members


GlobalProfileDetails Members

GlobalProfileDetails Members GBG Web Service Developers Guide
The GlobalProfileDetails type exposes the following members.
Properties
 | Name | Description
Public property | DecisionBanding | DecisionBands Property
Public property | Items | Items Property
Back to Top
See Also
GlobalProfileDetails Class


GlobalProfileDetails Properties

GlobalProfileDetails Properties GBG Web Service Developers Guide
The GlobalProfileDetails type exposes the following members.
Properties
 | Name | Description
Public property | DecisionBanding | DecisionBands Property
Public property | Items | Items Property
Back to Top
See Also
GlobalProfileDetails Class


GlobalProfileDetails.DecisionBanding Property

GlobalProfileDetails DecisionBanding Property GBG Web Service Developers Guide
DecisionBands Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalDecisionBanding DecisionBanding { get; set; }
public GlobalDecisionBanding DecisionBanding { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DecisionBanding();
function set_DecisionBanding(value);
function get_DecisionBanding();
function set_DecisionBanding(value);
Property Value
Type: GlobalDecisionBanding

            Decision Bands applied to Profile Score

See Also
GlobalProfileDetails Class
GlobalProfileDetails Members


GlobalProfileDetails.Items Property

GlobalProfileDetails Items Property GBG Web Service Developers Guide
Items Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalItem> Items { get; set; }
public List<GlobalItem> Items { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Items();
function set_Items(value);
function get_Items();
function set_Items(value);
Property Value
Type: List GlobalItem

            Item checks to be executed by the Profile

See Also
GlobalProfileDetails Class
GlobalProfileDetails Members


GlobalProfileIDVersion Class

GlobalProfileIDVersion Class GBG Web Service Developers Guide
Profile ID and Version
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalProfileIDVersion

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalProfileIDVersion
public class GlobalProfileIDVersion
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalProfileIDVersion = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalProfileIDVersion');
GlobalCheck.DataLib.GlobalProfileIDVersion = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalProfileIDVersion');
See Also
GlobalProfileIDVersion Members


GlobalProfileIDVersion Members

GlobalProfileIDVersion Members GBG Web Service Developers Guide
The GlobalProfileIDVersion type exposes the following members.
Properties
 | Name | Description
Public property | ID | ID Property
Public property | Version | Version Property
Back to Top
See Also
GlobalProfileIDVersion Class


GlobalProfileIDVersion Properties

GlobalProfileIDVersion Properties GBG Web Service Developers Guide
The GlobalProfileIDVersion type exposes the following members.
Properties
 | Name | Description
Public property | ID | ID Property
Public property | Version | Version Property
Back to Top
See Also
GlobalProfileIDVersion Class


GlobalProfileIDVersion.ID Property

GlobalProfileIDVersion ID Property GBG Web Service Developers Guide
ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ID { get; set; }
public Guid ID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ID();
function set_ID(value);
function get_ID();
function set_ID(value);
Property Value
Type: Guid

            The identifier of the profile

See Also
GlobalProfileIDVersion Class
GlobalProfileIDVersion Members


GlobalProfileIDVersion.Version Property

GlobalProfileIDVersion Version Property GBG Web Service Developers Guide
Version Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<uint> Version { get; set; }
public Nullable<uint> Version { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Version();
function set_Version(value);
function get_Version();
function set_Version(value);
Property Value
Type: Nullable UInt32

            The Version of the profile, may be omitted or set to 0 to indicate Profile in Effective state

See Also
GlobalProfileIDVersion Class
GlobalProfileIDVersion Members


GlobalProfileState Enumeration

GlobalProfileState Enumeration GBG Web Service Developers Guide
Profile State

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalProfileState
[SerializableAttribute]
public enum GlobalProfileState
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalProfileState = function();
GlobalCheck.DataLib.GlobalProfileState.createEnum('GlobalCheck.DataLib.GlobalProfileState', false);
GlobalCheck.DataLib.GlobalProfileState = function();
GlobalCheck.DataLib.GlobalProfileState.createEnum('GlobalCheck.DataLib.GlobalProfileState', false);
Members
Member name | Value | Description
Test | 0 | Test state
PreEffective | 1 | Pre-effective state
Effective | 2 | Effective state
Retired | 3 | Retired state
See Also


GlobalProfileVersion Class

GlobalProfileVersion Class GBG Web Service Developers Guide
Profile Version details
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalProfile
GlobalCheck.DataLib GlobalProfileVersion
GlobalCheck.DataLib GlobalProfileDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalProfileVersion : GlobalProfile
public class GlobalProfileVersion : GlobalProfile
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalProfileVersion = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalProfileVersion',
    GlobalCheck.DataLib.GlobalProfile);
GlobalCheck.DataLib.GlobalProfileVersion = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalProfileVersion',
    GlobalCheck.DataLib.GlobalProfile);
See Also
GlobalProfileVersion Members


GlobalProfileVersion Members

GlobalProfileVersion Members GBG Web Service Developers Guide
The GlobalProfileVersion type exposes the following members.
Properties
 | Name | Description
Public property | AddressFormat | Property that determines how the address fields are displayed
Public property | AddressLookupEnabled | AddressLookupEnabled Property
Public property | Country | Country Property
Public property | DisableInputStorage | DisableInputStorage Property
Public property | DocumentImageStorage | DocumentImageStorage Property
Public property | DocumentImageValidation | DocumentImageValidation Property
Public property | End | End Property
Public property | HasUK | HasUK Property
Public property | ItemIDs | ItemChecksIDs Property
Public property | OrgID | OrgID Property
Public property | ReAuthenticationLifetime | ReAuthenticationLifetime Property
Public property | Revision | Revision Property
Public property | RevisionNote | RevisionNote Property
Public property | SessionBlocking | SessionBlocking Property
Public property | Start | Start Property
Public property | State | State Property
Public property | Version | Version Property
Public property | VersionCreated | VersionCreated Date
Public property | VersionUpdated | VersionUpdated
Public property | VersionUpdatedBy | VersionUpdatedBy
Public property | VersionUpdatedByAccount | VersionUpdatedByAccount Property
Back to Top
See Also
GlobalProfileVersion Class


GlobalProfileVersion Properties

GlobalProfileVersion Properties GBG Web Service Developers Guide
The GlobalProfileVersion type exposes the following members.
Properties
 | Name | Description
Public property | AddressFormat | Property that determines how the address fields are displayed
Public property | AddressLookupEnabled | AddressLookupEnabled Property
Public property | Country | Country Property
Public property | DisableInputStorage | DisableInputStorage Property
Public property | DocumentImageStorage | DocumentImageStorage Property
Public property | DocumentImageValidation | DocumentImageValidation Property
Public property | End | End Property
Public property | HasUK | HasUK Property
Public property | ItemIDs | ItemChecksIDs Property
Public property | OrgID | OrgID Property
Public property | ReAuthenticationLifetime | ReAuthenticationLifetime Property
Public property | Revision | Revision Property
Public property | RevisionNote | RevisionNote Property
Public property | SessionBlocking | SessionBlocking Property
Public property | Start | Start Property
Public property | State | State Property
Public property | Version | Version Property
Public property | VersionCreated | VersionCreated Date
Public property | VersionUpdated | VersionUpdated
Public property | VersionUpdatedBy | VersionUpdatedBy
Public property | VersionUpdatedByAccount | VersionUpdatedByAccount Property
Back to Top
See Also
GlobalProfileVersion Class


GlobalProfileVersion.AddressFormat Property

GlobalProfileVersion AddressFormat Property GBG Web Service Developers Guide
Property that determines how the address fields are displayed

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalAddressFormat AddressFormat { get; set; }
public GlobalAddressFormat AddressFormat { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressFormat();
function set_AddressFormat(value);
function get_AddressFormat();
function set_AddressFormat(value);
Property Value
Type: GlobalAddressFormat

            Determines how the address fields are to be displayed. The options are either free or fixed format or both.

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.AddressLookupEnabled Property

GlobalProfileVersion AddressLookupEnabled Property GBG Web Service Developers Guide
AddressLookupEnabled Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AddressLookupEnabled { get; set; }
public bool AddressLookupEnabled { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressLookupEnabled();
function set_AddressLookupEnabled(value);
function get_AddressLookupEnabled();
function set_AddressLookupEnabled(value);
Property Value
Type: Boolean

            True if the Profile has Address Lookup Enabled, false if not

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.Country Property

GlobalProfileVersion Country Property GBG Web Service Developers Guide
Country Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Country { get; set; }
public string Country { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Country();
function set_Country(value);
function get_Country();
function set_Country(value);
Property Value
Type: String

            Name of country supported by Item Checks within the Profile, or "International"
            if not country specific

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.DisableInputStorage Property

GlobalProfileVersion DisableInputStorage Property GBG Web Service Developers Guide
DisableInputStorage Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DisableInputStorage { get; set; }
public bool DisableInputStorage { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DisableInputStorage();
function set_DisableInputStorage(value);
function get_DisableInputStorage();
function set_DisableInputStorage(value);
Property Value
Type: Boolean

            True if input supplied when processing an authentication should NOT be stored, false otherwise

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.DocumentImageStorage Property

GlobalProfileVersion DocumentImageStorage Property GBG Web Service Developers Guide
DocumentImageStorage Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DocumentImageStorage { get; set; }
public bool DocumentImageStorage { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DocumentImageStorage();
function set_DocumentImageStorage(value);
function get_DocumentImageStorage();
function set_DocumentImageStorage(value);
Property Value
Type: Boolean

            True if the Profile has Document Image Storage enabled, false if not

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.DocumentImageValidation Property

GlobalProfileVersion DocumentImageValidation Property GBG Web Service Developers Guide
DocumentImageValidation Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DocumentImageValidation { get; set; }
public bool DocumentImageValidation { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DocumentImageValidation();
function set_DocumentImageValidation(value);
function get_DocumentImageValidation();
function set_DocumentImageValidation(value);
Property Value
Type: Boolean

            True if the Profile has Document Image Validation enabled, false if not

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.End Property

GlobalProfileVersion End Property GBG Web Service Developers Guide
End Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> End { get; set; }
public Nullable<DateTime> End { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_End();
function set_End(value);
function get_End();
function set_End(value);
Property Value
Type: Nullable DateTime

            Date from which a Profile should be 'Retired'

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.HasUK Property

GlobalProfileVersion HasUK Property GBG Web Service Developers Guide
HasUK Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasUK { get; set; }
public bool HasUK { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_HasUK();
function set_HasUK(value);
function get_HasUK();
function set_HasUK(value);
Property Value
Type: Boolean

            True if Profile contains a UK check

Remarks

            Internal property used for checking if FFAME should be enabled

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.ItemIDs Property

GlobalProfileVersion ItemIDs Property GBG Web Service Developers Guide
ItemChecksIDs Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<uint> ItemIDs { get; set; }
public List<uint> ItemIDs { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ItemIDs();
function set_ItemIDs(value);
function get_ItemIDs();
function set_ItemIDs(value);
Property Value
Type: List UInt32

            A list of item id's that are included in the profile

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.OrgID Property

GlobalProfileVersion OrgID Property GBG Web Service Developers Guide
OrgID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid OrgID { get; set; }
public Guid OrgID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OrgID();
function set_OrgID(value);
function get_OrgID();
function set_OrgID(value);
Property Value
Type: Guid

            Unique identifier of the organisation the profile is from

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.ReAuthenticationLifetime Property

GlobalProfileVersion ReAuthenticationLifetime Property GBG Web Service Developers Guide
ReAuthenticationLifetime Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<uint> ReAuthenticationLifetime { get; set; }
public Nullable<uint> ReAuthenticationLifetime { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ReAuthenticationLifetime();
function set_ReAuthenticationLifetime(value);
function get_ReAuthenticationLifetime();
function set_ReAuthenticationLifetime(value);
Property Value
Type: Nullable UInt32

            Period of time that a user is permitted to apply incremental verifications and/or forced overrides, starting from the initial authentication

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.Revision Property

GlobalProfileVersion Revision Property GBG Web Service Developers Guide
Revision Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Revision { get; set; }
public uint Revision { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Revision();
function set_Revision(value);
function get_Revision();
function set_Revision(value);
Property Value
Type: UInt32

            Profile Revision

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.RevisionNote Property

GlobalProfileVersion RevisionNote Property GBG Web Service Developers Guide
RevisionNote Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RevisionNote { get; set; }
public string RevisionNote { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_RevisionNote();
function set_RevisionNote(value);
function get_RevisionNote();
function set_RevisionNote(value);
Property Value
Type: String

            Description of the last change made to the profile.

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.SessionBlocking Property

GlobalProfileVersion SessionBlocking Property GBG Web Service Developers Guide
SessionBlocking Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SessionBlocking { get; set; }
public bool SessionBlocking { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SessionBlocking();
function set_SessionBlocking(value);
function get_SessionBlocking();
function set_SessionBlocking(value);
Property Value
Type: Boolean

            True if ID3global portal should prevent the same input being submitted twice in succession, false if not

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.Start Property

GlobalProfileVersion Start Property GBG Web Service Developers Guide
Start Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> Start { get; set; }
public Nullable<DateTime> Start { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Start();
function set_Start(value);
function get_Start();
function set_Start(value);
Property Value
Type: Nullable DateTime

            Date from which a Profile should enter the 'Effective' state

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.State Property

GlobalProfileVersion State Property GBG Web Service Developers Guide
State Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalProfileState State { get; set; }
public GlobalProfileState State { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_State();
function set_State(value);
function get_State();
function set_State(value);
Property Value
Type: GlobalProfileState

            The Profile state:

            Test : Profile is in test state
            Pre-effective: A future start date has been set for the Profile
            Effective: Profile start date has been passed
            Retired: Profile end date has been set and is in the past, or Profile has been replaced by a newer Revision

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.Version Property

GlobalProfileVersion Version Property GBG Web Service Developers Guide
Version Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Version { get; set; }
public uint Version { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Version();
function set_Version(value);
function get_Version();
function set_Version(value);
Property Value
Type: UInt32

            Profile Version

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.VersionCreated Property

GlobalProfileVersion VersionCreated Property GBG Web Service Developers Guide
VersionCreated Date

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime VersionCreated { get; set; }
public DateTime VersionCreated { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_VersionCreated();
function set_VersionCreated(value);
function get_VersionCreated();
function set_VersionCreated(value);
Property Value
Type: DateTime

            The creation date of the Profile Version

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.VersionUpdated Property

GlobalProfileVersion VersionUpdated Property GBG Web Service Developers Guide
VersionUpdated

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime VersionUpdated { get; set; }
public DateTime VersionUpdated { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_VersionUpdated();
function set_VersionUpdated(value);
function get_VersionUpdated();
function set_VersionUpdated(value);
Property Value
Type: DateTime

            The date the Profile Version was updated

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.VersionUpdatedBy Property

GlobalProfileVersion VersionUpdatedBy Property GBG Web Service Developers Guide
VersionUpdatedBy

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid VersionUpdatedBy { get; set; }
public Guid VersionUpdatedBy { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_VersionUpdatedBy();
function set_VersionUpdatedBy(value);
function get_VersionUpdatedBy();
function set_VersionUpdatedBy(value);
Property Value
Type: Guid

            Unique identifier of the user who update this version of the Profile

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProfileVersion.VersionUpdatedByAccount Property

GlobalProfileVersion VersionUpdatedByAccount Property GBG Web Service Developers Guide
VersionUpdatedByAccount Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string VersionUpdatedByAccount { get; set; }
public string VersionUpdatedByAccount { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_VersionUpdatedByAccount();
function set_VersionUpdatedByAccount(value);
function get_VersionUpdatedByAccount();
function set_VersionUpdatedByAccount(value);
Property Value
Type: String

            Account name in the form user@domain of the user who update this version of the Profile

See Also
GlobalProfileVersion Class
GlobalProfileVersion Members


GlobalProperty Class

GlobalProperty Class GBG Web Service Developers Guide
An Item Check Property
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalProperty

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalProperty
[SerializableAttribute]
public class GlobalProperty
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalProperty = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalProperty');
GlobalCheck.DataLib.GlobalProperty = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalProperty');
See Also
GlobalProperty Members


GlobalProperty Members

GlobalProperty Members GBG Web Service Developers Guide
The GlobalProperty type exposes the following members.
Properties
 | Name | Description
Public property | MultipleValues | MultipleValues Property
Public property | Name | Name Property
Public property | Values | Values Property
Back to Top
See Also
GlobalProperty Class


GlobalProperty Properties

GlobalProperty Properties GBG Web Service Developers Guide
The GlobalProperty type exposes the following members.
Properties
 | Name | Description
Public property | MultipleValues | MultipleValues Property
Public property | Name | Name Property
Public property | Values | Values Property
Back to Top
See Also
GlobalProperty Class


GlobalProperty.MultipleValues Property

GlobalProperty MultipleValues Property GBG Web Service Developers Guide
MultipleValues Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MultipleValues { get; set; }
public bool MultipleValues { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MultipleValues();
function set_MultipleValues(value);
function get_MultipleValues();
function set_MultipleValues(value);
Property Value
Type: Boolean
See Also
GlobalProperty Class
GlobalProperty Members


GlobalProperty.Name Property

GlobalProperty Name Property GBG Web Service Developers Guide
Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String

            Property name

See Also
GlobalProperty Class
GlobalProperty Members


GlobalProperty.Values Property

GlobalProperty Values Property GBG Web Service Developers Guide
Values Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Dictionary<string, bool> Values { get; set; }
public Dictionary<string, bool> Values { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Values();
function set_Values(value);
function get_Values();
function set_Values(value);
Property Value
Type: Dictionary String, Boolean
See Also
GlobalProperty Class
GlobalProperty Members


GlobalProvince Class

GlobalProvince Class GBG Web Service Developers Guide
Contains the code and name of provinces / states.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalProvince

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalProvince
[SerializableAttribute]
public class GlobalProvince
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalProvince = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalProvince');
GlobalCheck.DataLib.GlobalProvince = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalProvince');
See Also
GlobalProvince Members


GlobalProvince Members

GlobalProvince Members GBG Web Service Developers Guide
The GlobalProvince type exposes the following members.
Properties
 | Name | Description
Public property | Code | Province Code Property
Public property | Name | Province Name Property
Back to Top
See Also
GlobalProvince Class


GlobalProvince Properties

GlobalProvince Properties GBG Web Service Developers Guide
The GlobalProvince type exposes the following members.
Properties
 | Name | Description
Public property | Code | Province Code Property
Public property | Name | Province Name Property
Back to Top
See Also
GlobalProvince Class


GlobalProvince.Code Property

GlobalProvince Code Property GBG Web Service Developers Guide
Province Code Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Code { get; set; }
public string Code { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Code();
function set_Code(value);
function get_Code();
function set_Code(value);
Property Value
Type: String
See Also
GlobalProvince Class
GlobalProvince Members


GlobalProvince.Name Property

GlobalProvince Name Property GBG Web Service Developers Guide
Province Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String
See Also
GlobalProvince Class
GlobalProvince Members


GlobalReportDetails Class

GlobalReportDetails Class GBG Web Service Developers Guide
Describes an ID3global Report
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalReportDetails

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ReportsLib (in GlobalCheck.ReportsLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalReportDetails
public class GlobalReportDetails
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalReportDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalReportDetails');
GlobalCheck.DataLib.GlobalReportDetails = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalReportDetails');
See Also
GlobalReportDetails Members


GlobalReportDetails Members

GlobalReportDetails Members GBG Web Service Developers Guide
The GlobalReportDetails type exposes the following members.
Properties
 | Name | Description
Public property | Description | Description of the Report
Public property | Name | Name of the Report
Back to Top
See Also
GlobalReportDetails Class


GlobalReportDetails Properties

GlobalReportDetails Properties GBG Web Service Developers Guide
The GlobalReportDetails type exposes the following members.
Properties
 | Name | Description
Public property | Description | Description of the Report
Public property | Name | Name of the Report
Back to Top
See Also
GlobalReportDetails Class


GlobalReportDetails.Description Property

GlobalReportDetails Description Property GBG Web Service Developers Guide
Description of the Report

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ReportsLib (in GlobalCheck.ReportsLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Description();
function set_Description(value);
function get_Description();
function set_Description(value);
Property Value
Type: String
See Also
GlobalReportDetails Class
GlobalReportDetails Members


GlobalReportDetails.Name Property

GlobalReportDetails Name Property GBG Web Service Developers Guide
Name of the Report

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ReportsLib (in GlobalCheck.ReportsLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String
See Also
GlobalReportDetails Class
GlobalReportDetails Members


GlobalReportParameter Class

GlobalReportParameter Class GBG Web Service Developers Guide
Report Parameter class to store simple names and values
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalReportParameter

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ReportsLib (in GlobalCheck.ReportsLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalReportParameter
public class GlobalReportParameter
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalReportParameter = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalReportParameter');
GlobalCheck.DataLib.GlobalReportParameter = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalReportParameter');
See Also
GlobalReportParameter Members


GlobalReportParameter Members

GlobalReportParameter Members GBG Web Service Developers Guide
The GlobalReportParameter type exposes the following members.
Properties
 | Name | Description
Public property | DefaultValues | Default values for the object
Public property | Name | Report Property Name
Public property | Prompt | Prompt for the object
Public property | Type | Report Property Type (Boolean, DateTime, Integer, Float, String)
Public property | ValidValues | Valid values for the object
Public property | Value | Report Property Value
Back to Top
See Also
GlobalReportParameter Class


GlobalReportParameter Properties

GlobalReportParameter Properties GBG Web Service Developers Guide
The GlobalReportParameter type exposes the following members.
Properties
 | Name | Description
Public property | DefaultValues | Default values for the object
Public property | Name | Report Property Name
Public property | Prompt | Prompt for the object
Public property | Type | Report Property Type (Boolean, DateTime, Integer, Float, String)
Public property | ValidValues | Valid values for the object
Public property | Value | Report Property Value
Back to Top
See Also
GlobalReportParameter Class


GlobalReportParameter.DefaultValues Property

GlobalReportParameter DefaultValues Property GBG Web Service Developers Guide
Default values for the object

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ReportsLib (in GlobalCheck.ReportsLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> DefaultValues { get; set; }
public List<string> DefaultValues { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DefaultValues();
function set_DefaultValues(value);
function get_DefaultValues();
function set_DefaultValues(value);
Property Value
Type: List String
See Also
GlobalReportParameter Class
GlobalReportParameter Members


GlobalReportParameter.Name Property

GlobalReportParameter Name Property GBG Web Service Developers Guide
Report Property Name

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ReportsLib (in GlobalCheck.ReportsLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String
See Also
GlobalReportParameter Class
GlobalReportParameter Members


GlobalReportParameter.Prompt Property

GlobalReportParameter Prompt Property GBG Web Service Developers Guide
Prompt for the object

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ReportsLib (in GlobalCheck.ReportsLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Prompt { get; set; }
public string Prompt { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Prompt();
function set_Prompt(value);
function get_Prompt();
function set_Prompt(value);
Property Value
Type: String
See Also
GlobalReportParameter Class
GlobalReportParameter Members


GlobalReportParameter.Type Property

GlobalReportParameter Type Property GBG Web Service Developers Guide
Report Property Type (Boolean, DateTime, Integer, Float, String)

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ReportsLib (in GlobalCheck.ReportsLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Type { get; set; }
public string Type { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Type();
function set_Type(value);
function get_Type();
function set_Type(value);
Property Value
Type: String
See Also
GlobalReportParameter Class
GlobalReportParameter Members


GlobalReportParameter.ValidValues Property

GlobalReportParameter ValidValues Property GBG Web Service Developers Guide
Valid values for the object

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ReportsLib (in GlobalCheck.ReportsLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Dictionary<string, string> ValidValues { get; set; }
public Dictionary<string, string> ValidValues { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ValidValues();
function set_ValidValues(value);
function get_ValidValues();
function set_ValidValues(value);
Property Value
Type: Dictionary String, String
See Also
GlobalReportParameter Class
GlobalReportParameter Members


GlobalReportParameter.Value Property

GlobalReportParameter Value Property GBG Web Service Developers Guide
Report Property Value

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ReportsLib (in GlobalCheck.ReportsLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Value { get; set; }
public string Value { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Value();
function set_Value(value);
function get_Value();
function set_Value(value);
Property Value
Type: String
See Also
GlobalReportParameter Class
GlobalReportParameter Members


GlobalResidenceType Enumeration

GlobalResidenceType Enumeration GBG Web Service Developers Guide
Residence type information.

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalResidenceType
[SerializableAttribute]
public enum GlobalResidenceType
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalResidenceType = function();
GlobalCheck.DataLib.GlobalResidenceType.createEnum('GlobalCheck.DataLib.GlobalResidenceType', false);
GlobalCheck.DataLib.GlobalResidenceType = function();
GlobalCheck.DataLib.GlobalResidenceType.createEnum('GlobalCheck.DataLib.GlobalResidenceType', false);
Members
Member name | Value | Description
HomeOwnerOutright | 0 | Home owner (owned outright)
HomeOwnerMortgage | 1 | Home owner (subject to mortgage)
Tenant | 2 | Tenant
LivingWithRelatives | 3 | Living with relatives
See Also


GlobalResource Class

GlobalResource Class GBG Web Service Developers Guide
ID3global Resource
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalResource

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalResource
public class GlobalResource
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalResource = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalResource');
GlobalCheck.DataLib.GlobalResource = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalResource');
See Also
GlobalResource Members


GlobalResource Members

GlobalResource Members GBG Web Service Developers Guide
The GlobalResource type exposes the following members.
Properties
 | Name | Description
Public property | Name | Name Property
Public property | Permission | Permission Property
Public property | ResourceID | ResourceID Property
Back to Top
See Also
GlobalResource Class


GlobalResource Properties

GlobalResource Properties GBG Web Service Developers Guide
The GlobalResource type exposes the following members.
Properties
 | Name | Description
Public property | Name | Name Property
Public property | Permission | Permission Property
Public property | ResourceID | ResourceID Property
Back to Top
See Also
GlobalResource Class


GlobalResource.Name Property

GlobalResource Name Property GBG Web Service Developers Guide
Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String

            Resource Name

See Also
GlobalResource Class
GlobalResource Members


GlobalResource.Permission Property

GlobalResource Permission Property GBG Web Service Developers Guide
Permission Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalPermission Permission { get; set; }
public GlobalPermission Permission { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Permission();
function set_Permission(value);
function get_Permission();
function set_Permission(value);
Property Value
Type: GlobalPermission

            The permission the current user has on the resource

See Also
GlobalResource Class
GlobalResource Members


GlobalResource.ResourceID Property

GlobalResource ResourceID Property GBG Web Service Developers Guide
ResourceID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ResourceID { get; set; }
public Guid ResourceID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ResourceID();
function set_ResourceID(value);
function get_ResourceID();
function set_ResourceID(value);
Property Value
Type: Guid

            Unique identifier of Resource

See Also
GlobalResource Class
GlobalResource Members


GlobalResultData Class

GlobalResultData Class GBG Web Service Developers Guide
Container for the results of an authentication.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalResultData

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalResultData
public class GlobalResultData
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalResultData = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalResultData');
GlobalCheck.DataLib.GlobalResultData = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalResultData');
See Also
GlobalResultData Members


GlobalResultData Members

GlobalResultData Members GBG Web Service Developers Guide
The GlobalResultData type exposes the following members.
Methods
Name | Description
URUResultDetailsLookup | Looks up item check name and result code description text
Back to Top
Properties
 | Name | Description
Public property | AuthenticationID | Authentication ID
Public property | BandText | Band Text Property
Public property | ChainID | Authentication Chain ID Property
Public property | Country | Country Property
Public property | CustomerRef | Customer Reference Property
Public property | NoRetry | No Retry Property
Public property | ProfileID | Profile ID Property
Public property | ProfileName | Profile Name Property
Public property | ProfileRevision | Profile Revision Property
Public property | ProfileState | Profile State Property
Public property | ProfileVersion | Profile Version Property
Public property | ResultCodes | ResultCodes Property
Public property | Score | Score Property
Public property | Status | Status Property
Public property | Timestamp | The Timestamp of the Authentication
Public property | UserBreakpoint | User Breakpoint Property
Back to Top
See Also
GlobalResultData Class


GlobalResultData Methods

GlobalResultData Methods GBG Web Service Developers Guide
The GlobalResultData type exposes the following members.
Methods
Name | Description
URUResultDetailsLookup | Looks up item check name and result code description text
Back to Top
See Also
GlobalResultData Class


GlobalResultData.URUResultDetailsLookup Method

GlobalResultData URUResultDetailsLookup Method GBG Web Service Developers Guide
Looks up item check name and result code description text

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<GlobalItemCheckResultCodes> URUResultDetailsLookup(
    List<GlobalItemCheckResultCodes> oResults
)
public static List<GlobalItemCheckResultCodes> URUResultDetailsLookup(
    List<GlobalItemCheckResultCodes> oResults
)
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalResultData.URUResultDetailsLookup = function(oResults);
GlobalCheck.DataLib.GlobalResultData.URUResultDetailsLookup = function(oResults);
Parameters
oResults
Type: System.Collections.Generic List GlobalItemCheckResultCodes
The URU results object
Return Value
Type: List GlobalItemCheckResultCodes
[Missing <returns> documentation for "M:GlobalCheck.DataLib.GlobalResultData.URUResultDetailsLookup(System.Collections.Generic.List{GlobalCheck.DataLib.GlobalItemCheckResultCodes})"]
See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData Properties

GlobalResultData Properties GBG Web Service Developers Guide
The GlobalResultData type exposes the following members.
Properties
 | Name | Description
Public property | AuthenticationID | Authentication ID
Public property | BandText | Band Text Property
Public property | ChainID | Authentication Chain ID Property
Public property | Country | Country Property
Public property | CustomerRef | Customer Reference Property
Public property | NoRetry | No Retry Property
Public property | ProfileID | Profile ID Property
Public property | ProfileName | Profile Name Property
Public property | ProfileRevision | Profile Revision Property
Public property | ProfileState | Profile State Property
Public property | ProfileVersion | Profile Version Property
Public property | ResultCodes | ResultCodes Property
Public property | Score | Score Property
Public property | Status | Status Property
Public property | Timestamp | The Timestamp of the Authentication
Public property | UserBreakpoint | User Breakpoint Property
Back to Top
See Also
GlobalResultData Class


GlobalResultData.AuthenticationID Property

GlobalResultData AuthenticationID Property GBG Web Service Developers Guide
Authentication ID

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid AuthenticationID { get; set; }
public Guid AuthenticationID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AuthenticationID();
function set_AuthenticationID(value);
function get_AuthenticationID();
function set_AuthenticationID(value);
Property Value
Type: Guid

            Unique identifier for the Authentication Log.

See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.BandText Property

GlobalResultData BandText Property GBG Web Service Developers Guide
Band Text Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BandText { get; set; }
public string BandText { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_BandText();
function set_BandText(value);
function get_BandText();
function set_BandText(value);
Property Value
Type: String

            Band Text generated by the Authentication

See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.ChainID Property

GlobalResultData ChainID Property GBG Web Service Developers Guide
Authentication Chain ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ChainID { get; set; }
public Guid ChainID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ChainID();
function set_ChainID(value);
function get_ChainID();
function set_ChainID(value);
Property Value
Type: Guid

            Unique identifier for the authentication using multiple profiles or reathentications.

See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.Country Property

GlobalResultData Country Property GBG Web Service Developers Guide
Country Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Country { get; set; }
public string Country { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Country();
function set_Country(value);
function get_Country();
function set_Country(value);
Property Value
Type: String

            Name of country supported by Item Checks within the Profile, or "International"
            if not country specific

See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.CustomerRef Property

GlobalResultData CustomerRef Property GBG Web Service Developers Guide
Customer Reference Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CustomerRef { get; set; }
public string CustomerRef { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CustomerRef();
function set_CustomerRef(value);
function get_CustomerRef();
function set_CustomerRef(value);
Property Value
Type: String

            Customer Reference supplied with the Authentication.

See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.NoRetry Property

GlobalResultData NoRetry Property GBG Web Service Developers Guide
No Retry Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool NoRetry { get; set; }
public bool NoRetry { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_NoRetry();
function set_NoRetry(value);
function get_NoRetry();
function set_NoRetry(value);
Property Value
Type: Boolean

            True if Authentication halted at a No-retry User Breakpoint

See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.ProfileID Property

GlobalResultData ProfileID Property GBG Web Service Developers Guide
Profile ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ProfileID { get; set; }
public Guid ProfileID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProfileID();
function set_ProfileID(value);
function get_ProfileID();
function set_ProfileID(value);
Property Value
Type: Guid

            Unique identifier of the Profile.

See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.ProfileName Property

GlobalResultData ProfileName Property GBG Web Service Developers Guide
Profile Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ProfileName { get; set; }
public string ProfileName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProfileName();
function set_ProfileName(value);
function get_ProfileName();
function set_ProfileName(value);
Property Value
Type: String

            Name of the Profile

See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.ProfileRevision Property

GlobalResultData ProfileRevision Property GBG Web Service Developers Guide
Profile Revision Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint ProfileRevision { get; set; }
public uint ProfileRevision { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProfileRevision();
function set_ProfileRevision(value);
function get_ProfileRevision();
function set_ProfileRevision(value);
Property Value
Type: UInt32

            Revision of the Profile

See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.ProfileState Property

GlobalResultData ProfileState Property GBG Web Service Developers Guide
Profile State Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalProfileState ProfileState { get; set; }
public GlobalProfileState ProfileState { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProfileState();
function set_ProfileState(value);
function get_ProfileState();
function set_ProfileState(value);
Property Value
Type: GlobalProfileState
See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.ProfileVersion Property

GlobalResultData ProfileVersion Property GBG Web Service Developers Guide
Profile Version Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint ProfileVersion { get; set; }
public uint ProfileVersion { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProfileVersion();
function set_ProfileVersion(value);
function get_ProfileVersion();
function set_ProfileVersion(value);
Property Value
Type: UInt32

            Version of the Profile

See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.ResultCodes Property

GlobalResultData ResultCodes Property GBG Web Service Developers Guide
ResultCodes Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalItemCheckResultCodes> ResultCodes { get; set; }
public List<GlobalItemCheckResultCodes> ResultCodes { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ResultCodes();
function set_ResultCodes(value);
function get_ResultCodes();
function set_ResultCodes(value);
Property Value
Type: List GlobalItemCheckResultCodes

            Result codes returned by each Item Check.

See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.Score Property

GlobalResultData Score Property GBG Web Service Developers Guide
Score Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Score { get; set; }
public int Score { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Score();
function set_Score(value);
function get_Score();
function set_Score(value);
Property Value
Type: Int32

            Score generated by the Authentication

See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.Status Property

GlobalResultData Status Property GBG Web Service Developers Guide
Status Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ATKStatus Status { get; set; }
public ATKStatus Status { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Status();
function set_Status(value);
function get_Status();
function set_Status(value);
Property Value
Type: ATKStatus

            Status returned from GIDE following processing Authentication

See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.Timestamp Property

GlobalResultData Timestamp Property GBG Web Service Developers Guide
The Timestamp of the Authentication

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Timestamp { get; set; }
public DateTime Timestamp { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Timestamp();
function set_Timestamp(value);
function get_Timestamp();
function set_Timestamp(value);
Property Value
Type: DateTime

            Date/Time the Authentication was completed .

See Also
GlobalResultData Class
GlobalResultData Members


GlobalResultData.UserBreakpoint Property

GlobalResultData UserBreakpoint Property GBG Web Service Developers Guide
User Breakpoint Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint UserBreakpoint { get; set; }
public uint UserBreakpoint { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_UserBreakpoint();
function set_UserBreakpoint(value);
function get_UserBreakpoint();
function set_UserBreakpoint(value);
Property Value
Type: UInt32

            Index of User Breakpoint that the Authentication halted on, or zero if no User Breakpoint was met

See Also
GlobalResultData Class
GlobalResultData Members


GlobalRole Class

GlobalRole Class GBG Web Service Developers Guide
Contains details of a Role
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalRole

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalRole
public class GlobalRole
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalRole = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalRole');
GlobalCheck.DataLib.GlobalRole = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalRole');
See Also
GlobalRole Members


GlobalRole Members

GlobalRole Members GBG Web Service Developers Guide
The GlobalRole type exposes the following members.
Properties
 | Name | Description
Public property | Active | Active Property
Public property | Created | Created Property
Public property | Description | Description Property
Public property | DomainName | DomainName Property
Public property | HelpdeskAccess | HelpdeskAccess Property
Public property | IsAdminPolicy | IsAdminPolicy Property
Public property | IsMember | IsMember Property
Public property | Name | Name Property
Public property | OrgID | OrgID Property
Public property | OrgName | OrgName Property
Public property | RoleID | RoleID Property
Public property | System | System Property
Back to Top
See Also
GlobalRole Class


GlobalRole Properties

GlobalRole Properties GBG Web Service Developers Guide
The GlobalRole type exposes the following members.
Properties
 | Name | Description
Public property | Active | Active Property
Public property | Created | Created Property
Public property | Description | Description Property
Public property | DomainName | DomainName Property
Public property | HelpdeskAccess | HelpdeskAccess Property
Public property | IsAdminPolicy | IsAdminPolicy Property
Public property | IsMember | IsMember Property
Public property | Name | Name Property
Public property | OrgID | OrgID Property
Public property | OrgName | OrgName Property
Public property | RoleID | RoleID Property
Public property | System | System Property
Back to Top
See Also
GlobalRole Class


GlobalRole.Active Property

GlobalRole Active Property GBG Web Service Developers Guide
Active Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Active { get; set; }
public bool Active { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Active();
function set_Active(value);
function get_Active();
function set_Active(value);
Property Value
Type: Boolean

            True if the Role is active, false if disabled

See Also
GlobalRole Class
GlobalRole Members


GlobalRole.Created Property

GlobalRole Created Property GBG Web Service Developers Guide
Created Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Created { get; set; }
public DateTime Created { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Created();
function set_Created(value);
function get_Created();
function set_Created(value);
Property Value
Type: DateTime

            Timestamp of when the role was created

See Also
GlobalRole Class
GlobalRole Members


GlobalRole.Description Property

GlobalRole Description Property GBG Web Service Developers Guide
Description Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Description();
function set_Description(value);
function get_Description();
function set_Description(value);
Property Value
Type: String

            Description of the Role

See Also
GlobalRole Class
GlobalRole Members


GlobalRole.DomainName Property

GlobalRole DomainName Property GBG Web Service Developers Guide
DomainName Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DomainName { get; set; }
public string DomainName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DomainName();
function set_DomainName(value);
function get_DomainName();
function set_DomainName(value);
Property Value
Type: String

            Domain name component of the full roles name, i.e. 'domainname' from 'username@domainname'

See Also
GlobalRole Class
GlobalRole Members


GlobalRole.HelpdeskAccess Property

GlobalRole HelpdeskAccess Property GBG Web Service Developers Guide
HelpdeskAccess Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HelpdeskAccess { get; set; }
public bool HelpdeskAccess { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_HelpdeskAccess();
function set_HelpdeskAccess(value);
function get_HelpdeskAccess();
function set_HelpdeskAccess(value);
Property Value
Type: Boolean

            True if Helpdesk Access has been enabled on the Role

See Also
GlobalRole Class
GlobalRole Members


GlobalRole.IsAdminPolicy Property

GlobalRole IsAdminPolicy Property GBG Web Service Developers Guide
IsAdminPolicy Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAdminPolicy { get; set; }
public bool IsAdminPolicy { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IsAdminPolicy();
function set_IsAdminPolicy(value);
function get_IsAdminPolicy();
function set_IsAdminPolicy(value);
Property Value
Type: Boolean

            True if the organisations Admin Password Policy should apply to members of this Role,
            False if the organisations User Password Policy should apply to members of this Role.
            Note: if a user is a member of multiple roles with different Policies then the
            Admin policy will apply

See Also
GlobalRole Class
GlobalRole Members


GlobalRole.IsMember Property

GlobalRole IsMember Property GBG Web Service Developers Guide
IsMember Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsMember { get; set; }
public bool IsMember { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IsMember();
function set_IsMember(value);
function get_IsMember();
function set_IsMember(value);
Property Value
Type: Boolean

            True if the current account is a member of the Role

See Also
GlobalRole Class
GlobalRole Members


GlobalRole.Name Property

GlobalRole Name Property GBG Web Service Developers Guide
Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String

            Name of the Role - must be unique within the Organisation

See Also
GlobalRole Class
GlobalRole Members


GlobalRole.OrgID Property

GlobalRole OrgID Property GBG Web Service Developers Guide
OrgID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid OrgID { get; set; }
public Guid OrgID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OrgID();
function set_OrgID(value);
function get_OrgID();
function set_OrgID(value);
Property Value
Type: Guid

            Unique identifier of the organisation the account is a member of

See Also
GlobalRole Class
GlobalRole Members


GlobalRole.OrgName Property

GlobalRole OrgName Property GBG Web Service Developers Guide
OrgName Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OrgName { get; set; }
public string OrgName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_OrgName();
function set_OrgName(value);
function get_OrgName();
function set_OrgName(value);
Property Value
Type: String

            Name of the organisation the account is a member of

See Also
GlobalRole Class
GlobalRole Members


GlobalRole.RoleID Property

GlobalRole RoleID Property GBG Web Service Developers Guide
RoleID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid RoleID { get; set; }
public Guid RoleID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_RoleID();
function set_RoleID(value);
function get_RoleID();
function set_RoleID(value);
Property Value
Type: Guid

            Unique identifier of the Role

See Also
GlobalRole Class
GlobalRole Members


GlobalRole.System Property

GlobalRole System Property GBG Web Service Developers Guide
System Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool System { get; set; }
public bool System { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_System();
function set_System(value);
function get_System();
function set_System(value);
Property Value
Type: Boolean

            True if the role is created and managed by the system

See Also
GlobalRole Class
GlobalRole Members


GlobalRoleMember Class

GlobalRoleMember Class GBG Web Service Developers Guide
Contains Role Member
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalRoleMember

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalRoleMember
[SerializableAttribute]
public class GlobalRoleMember
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalRoleMember = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalRoleMember');
GlobalCheck.DataLib.GlobalRoleMember = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalRoleMember');
See Also
GlobalRoleMember Members


GlobalRoleMember Members

GlobalRoleMember Members GBG Web Service Developers Guide
The GlobalRoleMember type exposes the following members.
Properties
 | Name | Description
Public property | AccountID | AccountID Property
Public property | Active | Active Property
Public property | DomainName | DomainName Property
Public property | IsMember | IsMember Property
Public property | Name | Name Property
Public property | Username | Username Property
Back to Top
See Also
GlobalRoleMember Class


GlobalRoleMember Properties

GlobalRoleMember Properties GBG Web Service Developers Guide
The GlobalRoleMember type exposes the following members.
Properties
 | Name | Description
Public property | AccountID | AccountID Property
Public property | Active | Active Property
Public property | DomainName | DomainName Property
Public property | IsMember | IsMember Property
Public property | Name | Name Property
Public property | Username | Username Property
Back to Top
See Also
GlobalRoleMember Class


GlobalRoleMember.AccountID Property

GlobalRoleMember AccountID Property GBG Web Service Developers Guide
AccountID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid AccountID { get; set; }
public Guid AccountID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AccountID();
function set_AccountID(value);
function get_AccountID();
function set_AccountID(value);
Property Value
Type: Guid

            Unique identifier of the account

See Also
GlobalRoleMember Class
GlobalRoleMember Members


GlobalRoleMember.Active Property

GlobalRoleMember Active Property GBG Web Service Developers Guide
Active Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Active { get; set; }
public bool Active { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Active();
function set_Active(value);
function get_Active();
function set_Active(value);
Property Value
Type: Boolean

            True if the account is active, false otherwise

See Also
GlobalRoleMember Class
GlobalRoleMember Members


GlobalRoleMember.DomainName Property

GlobalRoleMember DomainName Property GBG Web Service Developers Guide
DomainName Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DomainName { get; set; }
public string DomainName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DomainName();
function set_DomainName(value);
function get_DomainName();
function set_DomainName(value);
Property Value
Type: String

            Domain name component of the full account name, i.e. 'domainname' from 'username@domainname'

See Also
GlobalRoleMember Class
GlobalRoleMember Members


GlobalRoleMember.IsMember Property

GlobalRoleMember IsMember Property GBG Web Service Developers Guide
IsMember Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsMember { get; set; }
public bool IsMember { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IsMember();
function set_IsMember(value);
function get_IsMember();
function set_IsMember(value);
Property Value
Type: Boolean

            True if the account is member of the Role, false otherwise

See Also
GlobalRoleMember Class
GlobalRoleMember Members


GlobalRoleMember.Name Property

GlobalRoleMember Name Property GBG Web Service Developers Guide
Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String

            Name of the account holder, e.g. 'John Smith'

See Also
GlobalRoleMember Class
GlobalRoleMember Members


GlobalRoleMember.Username Property

GlobalRoleMember Username Property GBG Web Service Developers Guide
Username Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Username { get; set; }
public string Username { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Username();
function set_Username(value);
function get_Username();
function set_Username(value);
Property Value
Type: String

            Username component of the full account name, i.e. 'username' from 'username@domainname'

See Also
GlobalRoleMember Class
GlobalRoleMember Members


GlobalRoleMembers Class

GlobalRoleMembers Class GBG Web Service Developers Guide
Contains paged results from a request for summary details of Role Members
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalRoleMembers

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalRoleMembers
public class GlobalRoleMembers
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalRoleMembers = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalRoleMembers');
GlobalCheck.DataLib.GlobalRoleMembers = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalRoleMembers');
See Also
GlobalRoleMembers Members


GlobalRoleMembers Members

GlobalRoleMembers Members GBG Web Service Developers Guide
The GlobalRoleMembers type exposes the following members.
Properties
 | Name | Description
Public property | Members | Members Property
Public property | PageSize | PageSize Property
Public property | TotalAccounts | TotalAccounts Property
Public property | TotalMembers | TotalMembers Property
Public property | TotalNotMembers | TotalNotMembers Property
Public property | TotalPages | TotalPages Property
Back to Top
See Also
GlobalRoleMembers Class


GlobalRoleMembers Properties

GlobalRoleMembers Properties GBG Web Service Developers Guide
The GlobalRoleMembers type exposes the following members.
Properties
 | Name | Description
Public property | Members | Members Property
Public property | PageSize | PageSize Property
Public property | TotalAccounts | TotalAccounts Property
Public property | TotalMembers | TotalMembers Property
Public property | TotalNotMembers | TotalNotMembers Property
Public property | TotalPages | TotalPages Property
Back to Top
See Also
GlobalRoleMembers Class


GlobalRoleMembers.Members Property

GlobalRoleMembers Members Property GBG Web Service Developers Guide
Members Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalRoleMember> Members { get; set; }
public List<GlobalRoleMember> Members { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Members();
function set_Members(value);
function get_Members();
function set_Members(value);
Property Value
Type: List GlobalRoleMember

            Filtered list of Role Members

See Also
GlobalRoleMembers Class
GlobalRoleMembers Members


GlobalRoleMembers.PageSize Property

GlobalRoleMembers PageSize Property GBG Web Service Developers Guide
PageSize Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint PageSize { get; set; }
public uint PageSize { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PageSize();
function set_PageSize(value);
function get_PageSize();
function set_PageSize(value);
Property Value
Type: UInt32

            Maximum number of results returned from the paged request

See Also
GlobalRoleMembers Class
GlobalRoleMembers Members


GlobalRoleMembers.TotalAccounts Property

GlobalRoleMembers TotalAccounts Property GBG Web Service Developers Guide
TotalAccounts Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalAccounts { get; set; }
public uint TotalAccounts { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalAccounts();
function set_TotalAccounts(value);
function get_TotalAccounts();
function set_TotalAccounts(value);
Property Value
Type: UInt32

            Total number of accounts that matched the query

See Also
GlobalRoleMembers Class
GlobalRoleMembers Members


GlobalRoleMembers.TotalMembers Property

GlobalRoleMembers TotalMembers Property GBG Web Service Developers Guide
TotalMembers Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalMembers { get; set; }
public uint TotalMembers { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalMembers();
function set_TotalMembers(value);
function get_TotalMembers();
function set_TotalMembers(value);
Property Value
Type: UInt32

            Total number of matching accounts that are members of the role

See Also
GlobalRoleMembers Class
GlobalRoleMembers Members


GlobalRoleMembers.TotalNotMembers Property

GlobalRoleMembers TotalNotMembers Property GBG Web Service Developers Guide
TotalNotMembers Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalNotMembers { get; set; }
public uint TotalNotMembers { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalNotMembers();
function set_TotalNotMembers(value);
function get_TotalNotMembers();
function set_TotalNotMembers(value);
Property Value
Type: UInt32

            Total number of matching accounts that are not members of the role

See Also
GlobalRoleMembers Class
GlobalRoleMembers Members


GlobalRoleMembers.TotalPages Property

GlobalRoleMembers TotalPages Property GBG Web Service Developers Guide
TotalPages Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalPages { get; set; }
public uint TotalPages { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalPages();
function set_TotalPages(value);
function get_TotalPages();
function set_TotalPages(value);
Property Value
Type: UInt32

            The total number of pages that would be required to return all the results, based on a page size of PageSize

See Also
GlobalRoleMembers Class
GlobalRoleMembers Members


GlobalRolePermission Class

GlobalRolePermission Class GBG Web Service Developers Guide
Contains Permission for a Role.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalRolePermission

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalRolePermission
[SerializableAttribute]
public class GlobalRolePermission
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalRolePermission = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalRolePermission');
GlobalCheck.DataLib.GlobalRolePermission = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalRolePermission');
See Also
GlobalRolePermission Members


GlobalRolePermission Members

GlobalRolePermission Members GBG Web Service Developers Guide
The GlobalRolePermission type exposes the following members.
Properties
 | Name | Description
Public property | Permission | Permission Property
Public property | Role | Role Property
Public property | System | System Property
Back to Top
See Also
GlobalRolePermission Class


GlobalRolePermission Properties

GlobalRolePermission Properties GBG Web Service Developers Guide
The GlobalRolePermission type exposes the following members.
Properties
 | Name | Description
Public property | Permission | Permission Property
Public property | Role | Role Property
Public property | System | System Property
Back to Top
See Also
GlobalRolePermission Class


GlobalRolePermission.Permission Property

GlobalRolePermission Permission Property GBG Web Service Developers Guide
Permission Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalPermission Permission { get; set; }
public GlobalPermission Permission { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Permission();
function set_Permission(value);
function get_Permission();
function set_Permission(value);
Property Value
Type: GlobalPermission

            Permission granted to Role on a Resource

See Also
GlobalRolePermission Class
GlobalRolePermission Members


GlobalRolePermission.Role Property

GlobalRolePermission Role Property GBG Web Service Developers Guide
Role Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalRole Role { get; set; }
public GlobalRole Role { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Role();
function set_Role(value);
function get_Role();
function set_Role(value);
Property Value
Type: GlobalRole

            Role assigned to the Permission

See Also
GlobalRolePermission Class
GlobalRolePermission Members


GlobalRolePermission.System Property

GlobalRolePermission System Property GBG Web Service Developers Guide
System Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool System { get; set; }
public bool System { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_System();
function set_System(value);
function get_System();
function set_System(value);
Property Value
Type: Boolean

            True if Permission is set by the system and is immutable

See Also
GlobalRolePermission Class
GlobalRolePermission Members


GlobalRoles Class

GlobalRoles Class GBG Web Service Developers Guide
Contains paged results from a request for summary details of Roles
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalRoles

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalRoles
public class GlobalRoles
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalRoles = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalRoles');
GlobalCheck.DataLib.GlobalRoles = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalRoles');
See Also
GlobalRoles Members


GlobalRoles Members

GlobalRoles Members GBG Web Service Developers Guide
The GlobalRoles type exposes the following members.
Properties
 | Name | Description
Public property | PageSize | PageSize Property
Public property | Roles | Roles Property
Public property | TotalActive | TotalActive Property
Public property | TotalExpired | TotalExpired Property
Public property | TotalPages | TotalPages Property
Public property | TotalRoles | TotalRoles Property
Back to Top
See Also
GlobalRoles Class


GlobalRoles Properties

GlobalRoles Properties GBG Web Service Developers Guide
The GlobalRoles type exposes the following members.
Properties
 | Name | Description
Public property | PageSize | PageSize Property
Public property | Roles | Roles Property
Public property | TotalActive | TotalActive Property
Public property | TotalExpired | TotalExpired Property
Public property | TotalPages | TotalPages Property
Public property | TotalRoles | TotalRoles Property
Back to Top
See Also
GlobalRoles Class


GlobalRoles.PageSize Property

GlobalRoles PageSize Property GBG Web Service Developers Guide
PageSize Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint PageSize { get; set; }
public uint PageSize { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PageSize();
function set_PageSize(value);
function get_PageSize();
function set_PageSize(value);
Property Value
Type: UInt32

            Maximum number of results returned from the paged request

See Also
GlobalRoles Class
GlobalRoles Members


GlobalRoles.Roles Property

GlobalRoles Roles Property GBG Web Service Developers Guide
Roles Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalRole> Roles { get; set; }
public List<GlobalRole> Roles { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Roles();
function set_Roles(value);
function get_Roles();
function set_Roles(value);
Property Value
Type: List GlobalRole

            Filtered list of Roles

See Also
GlobalRoles Class
GlobalRoles Members


GlobalRoles.TotalActive Property

GlobalRoles TotalActive Property GBG Web Service Developers Guide
TotalActive Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalActive { get; set; }
public uint TotalActive { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalActive();
function set_TotalActive(value);
function get_TotalActive();
function set_TotalActive(value);
Property Value
Type: UInt32

            Total number of active accounts that matched the query

See Also
GlobalRoles Class
GlobalRoles Members


GlobalRoles.TotalExpired Property

GlobalRoles TotalExpired Property GBG Web Service Developers Guide
TotalExpired Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalExpired { get; set; }
public uint TotalExpired { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalExpired();
function set_TotalExpired(value);
function get_TotalExpired();
function set_TotalExpired(value);
Property Value
Type: UInt32

            Total number of expired accounts that matched the query

See Also
GlobalRoles Class
GlobalRoles Members


GlobalRoles.TotalPages Property

GlobalRoles TotalPages Property GBG Web Service Developers Guide
TotalPages Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalPages { get; set; }
public uint TotalPages { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalPages();
function set_TotalPages(value);
function get_TotalPages();
function set_TotalPages(value);
Property Value
Type: UInt32

            The total number of pages that would be required to return all the results, based on a page size of PageSize

See Also
GlobalRoles Class
GlobalRoles Members


GlobalRoles.TotalRoles Property

GlobalRoles TotalRoles Property GBG Web Service Developers Guide
TotalRoles Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.AccountLib (in GlobalCheck.AccountLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint TotalRoles { get; set; }
public uint TotalRoles { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TotalRoles();
function set_TotalRoles(value);
function get_TotalRoles();
function set_TotalRoles(value);
Property Value
Type: UInt32

            Total number of roles that matched the query

See Also
GlobalRoles Class
GlobalRoles Members


GlobalSanctionsAddress Class

GlobalSanctionsAddress Class GBG Web Service Developers Guide
Address information about an entity from Sanctions & Enforcements data
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalSanctionsAddress

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalSanctionsAddress
public class GlobalSanctionsAddress
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalSanctionsAddress = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSanctionsAddress');
GlobalCheck.DataLib.GlobalSanctionsAddress = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSanctionsAddress');
See Also
GlobalSanctionsAddress Members


GlobalSanctionsAddress Members

GlobalSanctionsAddress Members GBG Web Service Developers Guide
The GlobalSanctionsAddress type exposes the following members.
Properties
 | Name | Description
Public property | AddressLine | AddressLine Property
Public property | City | City Property
Public property | Country | Country Property
Public property | Region | Region Property
Back to Top
See Also
GlobalSanctionsAddress Class


GlobalSanctionsAddress Properties

GlobalSanctionsAddress Properties GBG Web Service Developers Guide
The GlobalSanctionsAddress type exposes the following members.
Properties
 | Name | Description
Public property | AddressLine | AddressLine Property
Public property | City | City Property
Public property | Country | Country Property
Public property | Region | Region Property
Back to Top
See Also
GlobalSanctionsAddress Class


GlobalSanctionsAddress.AddressLine Property

GlobalSanctionsAddress AddressLine Property GBG Web Service Developers Guide
AddressLine Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AddressLine { get; set; }
public string AddressLine { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_AddressLine();
function set_AddressLine(value);
function get_AddressLine();
function set_AddressLine(value);
Property Value
Type: String

            Address line (e.g. street address), comma separated if more than one.

See Also
GlobalSanctionsAddress Class
GlobalSanctionsAddress Members


GlobalSanctionsAddress.City Property

GlobalSanctionsAddress City Property GBG Web Service Developers Guide
City Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string City { get; set; }
public string City { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_City();
function set_City(value);
function get_City();
function set_City(value);
Property Value
Type: String

            City line from address (e.g. “London”).

See Also
GlobalSanctionsAddress Class
GlobalSanctionsAddress Members


GlobalSanctionsAddress.Country Property

GlobalSanctionsAddress Country Property GBG Web Service Developers Guide
Country Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Country { get; set; }
public string Country { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Country();
function set_Country(value);
function get_Country();
function set_Country(value);
Property Value
Type: String

            Country from address (e.g. “United Kingdom”).

See Also
GlobalSanctionsAddress Class
GlobalSanctionsAddress Members


GlobalSanctionsAddress.Region Property

GlobalSanctionsAddress Region Property GBG Web Service Developers Guide
Region Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Region { get; set; }
public string Region { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Region();
function set_Region(value);
function get_Region();
function set_Region(value);
Property Value
Type: String

            Region from address

See Also
GlobalSanctionsAddress Class
GlobalSanctionsAddress Members


GlobalSanctionsDate Class

GlobalSanctionsDate Class GBG Web Service Developers Guide
Birth / Death information about an entity from Sanctions & Enforcements data
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalSanctionsDate

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalSanctionsDate
public class GlobalSanctionsDate
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalSanctionsDate = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSanctionsDate');
GlobalCheck.DataLib.GlobalSanctionsDate = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSanctionsDate');
See Also
GlobalSanctionsDate Members


GlobalSanctionsDate Members

GlobalSanctionsDate Members GBG Web Service Developers Guide
The GlobalSanctionsDate type exposes the following members.
Properties
 | Name | Description
Public property | DateType | Date Type
Public property | Day | Day property
Public property | Month | Month property
Public property | Year | Year property
Back to Top
See Also
GlobalSanctionsDate Class


GlobalSanctionsDate Properties

GlobalSanctionsDate Properties GBG Web Service Developers Guide
The GlobalSanctionsDate type exposes the following members.
Properties
 | Name | Description
Public property | DateType | Date Type
Public property | Day | Day property
Public property | Month | Month property
Public property | Year | Year property
Back to Top
See Also
GlobalSanctionsDate Class


GlobalSanctionsDate.DateType Property

GlobalSanctionsDate DateType Property GBG Web Service Developers Guide
Date Type

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalSanctionsDateType DateType { get; set; }
public GlobalSanctionsDateType DateType { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DateType();
function set_DateType(value);
function get_DateType();
function set_DateType(value);
Property Value
Type: GlobalSanctionsDateType

            Represents the type of date.

See Also
GlobalSanctionsDate Class
GlobalSanctionsDate Members


GlobalSanctionsDate.Day Property

GlobalSanctionsDate Day Property GBG Web Service Developers Guide
Day property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> Day { get; set; }
public Nullable<int> Day { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Day();
function set_Day(value);
function get_Day();
function set_Day(value);
Property Value
Type: Nullable Int32

            Integer in the range 1-31 representing the day in the month.

            This property may be omitted to indicate that this information is not available.

See Also
GlobalSanctionsDate Class
GlobalSanctionsDate Members


GlobalSanctionsDate.Month Property

GlobalSanctionsDate Month Property GBG Web Service Developers Guide
Month property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> Month { get; set; }
public Nullable<int> Month { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Month();
function set_Month(value);
function get_Month();
function set_Month(value);
Property Value
Type: Nullable Int32

            Integer in the range 1-12 representing the calendar month.

            This property may be omitted to indicate that this information is not available.

See Also
GlobalSanctionsDate Class
GlobalSanctionsDate Members


GlobalSanctionsDate.Year Property

GlobalSanctionsDate Year Property GBG Web Service Developers Guide
Year property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> Year { get; set; }
public Nullable<int> Year { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Year();
function set_Year(value);
function get_Year();
function set_Year(value);
Property Value
Type: Nullable Int32

            Integer in the range 0-9999 representing the calendar year.

            This property may be omitted to indicate that this information is not available.

See Also
GlobalSanctionsDate Class
GlobalSanctionsDate Members


GlobalSanctionsDateType Enumeration

GlobalSanctionsDateType Enumeration GBG Web Service Developers Guide
Sanctions Date Type

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum GlobalSanctionsDateType
public enum GlobalSanctionsDateType
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalSanctionsDateType = function();
GlobalCheck.DataLib.GlobalSanctionsDateType.createEnum('GlobalCheck.DataLib.GlobalSanctionsDateType', false);
GlobalCheck.DataLib.GlobalSanctionsDateType = function();
GlobalCheck.DataLib.GlobalSanctionsDateType.createEnum('GlobalCheck.DataLib.GlobalSanctionsDateType', false);
Members
Member name | Value | Description
Unknown | 0 | Unknown
Birth | 1 | Birth Date
Death | 2 | Death Date
See Also


GlobalSanctionsEnforcementData Class

GlobalSanctionsEnforcementData Class GBG Web Service Developers Guide
Information about an entity from Sanctions & Enforcements data
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalSanctionsEnforcementData

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalSanctionsEnforcementData
public class GlobalSanctionsEnforcementData
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalSanctionsEnforcementData = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSanctionsEnforcementData');
GlobalCheck.DataLib.GlobalSanctionsEnforcementData = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSanctionsEnforcementData');
See Also
GlobalSanctionsEnforcementData Members


GlobalSanctionsEnforcementData Members

GlobalSanctionsEnforcementData Members GBG Web Service Developers Guide
The GlobalSanctionsEnforcementData type exposes the following members.
Properties
 | Name | Description
Public property | Aliases | Aliases Property
Public property | Fullname | Fullname Property
Public property | IdentityInformation | IdentityInformation Property
Public property | SanctionsAddresses | SanctionsAddresses Property
Public property | SanctionsBodies | SanctionBodies Property
Public property | SanctionsDates | SanctionsDates Property
Back to Top
See Also
GlobalSanctionsEnforcementData Class


GlobalSanctionsEnforcementData Properties

GlobalSanctionsEnforcementData Properties GBG Web Service Developers Guide
The GlobalSanctionsEnforcementData type exposes the following members.
Properties
 | Name | Description
Public property | Aliases | Aliases Property
Public property | Fullname | Fullname Property
Public property | IdentityInformation | IdentityInformation Property
Public property | SanctionsAddresses | SanctionsAddresses Property
Public property | SanctionsBodies | SanctionBodies Property
Public property | SanctionsDates | SanctionsDates Property
Back to Top
See Also
GlobalSanctionsEnforcementData Class


GlobalSanctionsEnforcementData.Aliases Property

GlobalSanctionsEnforcementData Aliases Property GBG Web Service Developers Guide
Aliases Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> Aliases { get; set; }
public List<string> Aliases { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Aliases();
function set_Aliases(value);
function get_Aliases();
function set_Aliases(value);
Property Value
Type: List String

            Represents a list of aliases for the matched entity

See Also
GlobalSanctionsEnforcementData Class
GlobalSanctionsEnforcementData Members


GlobalSanctionsEnforcementData.Fullname Property

GlobalSanctionsEnforcementData Fullname Property GBG Web Service Developers Guide
Fullname Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Fullname { get; set; }
public string Fullname { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Fullname();
function set_Fullname(value);
function get_Fullname();
function set_Fullname(value);
Property Value
Type: String

            Represents the full name of the matched entity

See Also
GlobalSanctionsEnforcementData Class
GlobalSanctionsEnforcementData Members


GlobalSanctionsEnforcementData.IdentityInformation Property

GlobalSanctionsEnforcementData IdentityInformation Property GBG Web Service Developers Guide
IdentityInformation Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> IdentityInformation { get; set; }
public List<string> IdentityInformation { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IdentityInformation();
function set_IdentityInformation(value);
function get_IdentityInformation();
function set_IdentityInformation(value);
Property Value
Type: List String

            Represents a list of passport numbers for the matched entity

See Also
GlobalSanctionsEnforcementData Class
GlobalSanctionsEnforcementData Members


GlobalSanctionsEnforcementData.SanctionsAddresses Property

GlobalSanctionsEnforcementData SanctionsAddresses Property GBG Web Service Developers Guide
SanctionsAddresses Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalSanctionsAddress> SanctionsAddresses { get; set; }
public List<GlobalSanctionsAddress> SanctionsAddresses { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SanctionsAddresses();
function set_SanctionsAddresses(value);
function get_SanctionsAddresses();
function set_SanctionsAddresses(value);
Property Value
Type: List GlobalSanctionsAddress

            Represents a list of addresses for the matched entity

See Also
GlobalSanctionsEnforcementData Class
GlobalSanctionsEnforcementData Members


GlobalSanctionsEnforcementData.SanctionsBodies Property

GlobalSanctionsEnforcementData SanctionsBodies Property GBG Web Service Developers Guide
SanctionBodies Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> SanctionsBodies { get; set; }
public List<string> SanctionsBodies { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SanctionsBodies();
function set_SanctionsBodies(value);
function get_SanctionsBodies();
function set_SanctionsBodies(value);
Property Value
Type: List String

            Represents a list of matched Sanctions Bodies for the matched entity

See Also
GlobalSanctionsEnforcementData Class
GlobalSanctionsEnforcementData Members


GlobalSanctionsEnforcementData.SanctionsDates Property

GlobalSanctionsEnforcementData SanctionsDates Property GBG Web Service Developers Guide
SanctionsDates Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalSanctionsDate> SanctionsDates { get; set; }
public List<GlobalSanctionsDate> SanctionsDates { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SanctionsDates();
function set_SanctionsDates(value);
function get_SanctionsDates();
function set_SanctionsDates(value);
Property Value
Type: List GlobalSanctionsDate

            Represents a list of Birth and Death dates for the matched entity

See Also
GlobalSanctionsEnforcementData Class
GlobalSanctionsEnforcementData Members


GlobalSanctionsIssuer Class

GlobalSanctionsIssuer Class GBG Web Service Developers Guide
Contains the Issuer details for Sanctions.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalSanctionsIssuer

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalSanctionsIssuer
public class GlobalSanctionsIssuer
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalSanctionsIssuer = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSanctionsIssuer');
GlobalCheck.DataLib.GlobalSanctionsIssuer = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSanctionsIssuer');
See Also
GlobalSanctionsIssuer Members


GlobalSanctionsIssuer Members

GlobalSanctionsIssuer Members GBG Web Service Developers Guide
The GlobalSanctionsIssuer type exposes the following members.
Properties
 | Name | Description
Public property | ID | ID Property
Public property | Name | Name Property
 | SanctionsIssuers | Issuers supported by Sanctions Checks
Public property | Type | Type Property
Back to Top
See Also
GlobalSanctionsIssuer Class


GlobalSanctionsIssuer Properties

GlobalSanctionsIssuer Properties GBG Web Service Developers Guide
The GlobalSanctionsIssuer type exposes the following members.
Properties
 | Name | Description
Public property | ID | ID Property
Public property | Name | Name Property
 | SanctionsIssuers | Issuers supported by Sanctions Checks
Public property | Type | Type Property
Back to Top
See Also
GlobalSanctionsIssuer Class


GlobalSanctionsIssuer.ID Property

GlobalSanctionsIssuer ID Property GBG Web Service Developers Guide
ID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint ID { get; set; }
public uint ID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ID();
function set_ID(value);
function get_ID();
function set_ID(value);
Property Value
Type: UInt32
See Also
GlobalSanctionsIssuer Class
GlobalSanctionsIssuer Members


GlobalSanctionsIssuer.Name Property

GlobalSanctionsIssuer Name Property GBG Web Service Developers Guide
Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Name();
function set_Name(value);
function get_Name();
function set_Name(value);
Property Value
Type: String
See Also
GlobalSanctionsIssuer Class
GlobalSanctionsIssuer Members


GlobalSanctionsIssuer.SanctionsIssuers Property

GlobalSanctionsIssuer SanctionsIssuers Property GBG Web Service Developers Guide
Issuers supported by Sanctions Checks

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<GlobalSanctionsIssuer> SanctionsIssuers { get; }
public static List<GlobalSanctionsIssuer> SanctionsIssuers { get; }
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalSanctionsIssuer.get_SanctionsIssuers = function();
GlobalCheck.DataLib.GlobalSanctionsIssuer.get_SanctionsIssuers = function();
Property Value
Type: List GlobalSanctionsIssuer
See Also
GlobalSanctionsIssuer Class
GlobalSanctionsIssuer Members


GlobalSanctionsIssuer.Type Property

GlobalSanctionsIssuer Type Property GBG Web Service Developers Guide
Type Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Type { get; set; }
public string Type { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Type();
function set_Type(value);
function get_Type();
function set_Type(value);
Property Value
Type: String
See Also
GlobalSanctionsIssuer Class
GlobalSanctionsIssuer Members


GlobalSanctionsMatch Class

GlobalSanctionsMatch Class GBG Web Service Developers Guide
Data returned for a Sanctions match
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalSanctionsMatch

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalSanctionsMatch
public class GlobalSanctionsMatch
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalSanctionsMatch = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSanctionsMatch');
GlobalCheck.DataLib.GlobalSanctionsMatch = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSanctionsMatch');
See Also
GlobalSanctionsMatch Members


GlobalSanctionsMatch Members

GlobalSanctionsMatch Members GBG Web Service Developers Guide
The GlobalSanctionsMatch type exposes the following members.
Properties
 | Name | Description
Public property | SanctionID | SanctionID Property
Public property | Score | Score Property
Public property | Url | Url Property
Back to Top
See Also
GlobalSanctionsMatch Class


GlobalSanctionsMatch Properties

GlobalSanctionsMatch Properties GBG Web Service Developers Guide
The GlobalSanctionsMatch type exposes the following members.
Properties
 | Name | Description
Public property | SanctionID | SanctionID Property
Public property | Score | Score Property
Public property | Url | Url Property
Back to Top
See Also
GlobalSanctionsMatch Class


GlobalSanctionsMatch.SanctionID Property

GlobalSanctionsMatch SanctionID Property GBG Web Service Developers Guide
SanctionID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SanctionID { get; set; }
public string SanctionID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SanctionID();
function set_SanctionID(value);
function get_SanctionID();
function set_SanctionID(value);
Property Value
Type: String
Represents a reference to a match returned by the Sanctions Item Check
See Also
GlobalSanctionsMatch Class
GlobalSanctionsMatch Members


GlobalSanctionsMatch.Score Property

GlobalSanctionsMatch Score Property GBG Web Service Developers Guide
Score Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Score { get; set; }
public uint Score { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Score();
function set_Score(value);
function get_Score();
function set_Score(value);
Property Value
Type: UInt32

            Represents a score out of 100 for the match returned by the Sanctions Item Check

See Also
GlobalSanctionsMatch Class
GlobalSanctionsMatch Members


GlobalSanctionsMatch.Url Property

GlobalSanctionsMatch Url Property GBG Web Service Developers Guide
Url Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Url { get; set; }
public string Url { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Url();
function set_Url(value);
function get_Url();
function set_Url(value);
Property Value
Type: String

            Represents a reference to a URL where more information about the match returned by the Sanctions Item Check can be retrieved

See Also
GlobalSanctionsMatch Class
GlobalSanctionsMatch Members


GlobalSanctionsPosition Class

GlobalSanctionsPosition Class GBG Web Service Developers Guide
Information about an entity from Sanctions & Enforcements data
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalSanctionsPosition

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalSanctionsPosition
public class GlobalSanctionsPosition
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalSanctionsPosition = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSanctionsPosition');
GlobalCheck.DataLib.GlobalSanctionsPosition = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSanctionsPosition');
See Also
GlobalSanctionsPosition Members


GlobalSanctionsPosition Members

GlobalSanctionsPosition Members GBG Web Service Developers Guide
The GlobalSanctionsPosition type exposes the following members.
Properties
 | Name | Description
Public property | Country | Country Property
Public property | Position | Position Property
Back to Top
See Also
GlobalSanctionsPosition Class


GlobalSanctionsPosition Properties

GlobalSanctionsPosition Properties GBG Web Service Developers Guide
The GlobalSanctionsPosition type exposes the following members.
Properties
 | Name | Description
Public property | Country | Country Property
Public property | Position | Position Property
Back to Top
See Also
GlobalSanctionsPosition Class


GlobalSanctionsPosition.Country Property

GlobalSanctionsPosition Country Property GBG Web Service Developers Guide
Country Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Country { get; set; }
public string Country { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Country();
function set_Country(value);
function get_Country();
function set_Country(value);
Property Value
Type: String

            Country code for the Position.

See Also
GlobalSanctionsPosition Class
GlobalSanctionsPosition Members


GlobalSanctionsPosition.Position Property

GlobalSanctionsPosition Position Property GBG Web Service Developers Guide
Position Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Position { get; set; }
public string Position { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Position();
function set_Position(value);
function get_Position();
function set_Position(value);
Property Value
Type: String

            Position of the entity.

See Also
GlobalSanctionsPosition Class
GlobalSanctionsPosition Members


GlobalSanctionsResultCodes Class

GlobalSanctionsResultCodes Class GBG Web Service Developers Guide
Results data returned by the Sanctions Item Check
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalItemCheckResultCodes
GlobalCheck.DataLib GlobalSanctionsResultCodes

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalSanctionsResultCodes : GlobalItemCheckResultCodes
public class GlobalSanctionsResultCodes : GlobalItemCheckResultCodes
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalSanctionsResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSanctionsResultCodes',
    GlobalCheck.DataLib.GlobalItemCheckResultCodes);
GlobalCheck.DataLib.GlobalSanctionsResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSanctionsResultCodes',
    GlobalCheck.DataLib.GlobalItemCheckResultCodes);
See Also
GlobalSanctionsResultCodes Members


GlobalSanctionsResultCodes Members

GlobalSanctionsResultCodes Members GBG Web Service Developers Guide
The GlobalSanctionsResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | SanctionsMatches | SanctionsMatches Property
Back to Top
See Also
GlobalSanctionsResultCodes Class


GlobalSanctionsResultCodes Properties

GlobalSanctionsResultCodes Properties GBG Web Service Developers Guide
The GlobalSanctionsResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | SanctionsMatches | SanctionsMatches Property
Back to Top
See Also
GlobalSanctionsResultCodes Class


GlobalSanctionsResultCodes.SanctionsMatches Property

GlobalSanctionsResultCodes SanctionsMatches Property GBG Web Service Developers Guide
SanctionsMatches Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalSanctionsMatch> SanctionsMatches { get; set; }
public List<GlobalSanctionsMatch> SanctionsMatches { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SanctionsMatches();
function set_SanctionsMatches(value);
function get_SanctionsMatches();
function set_SanctionsMatches(value);
Property Value
Type: List GlobalSanctionsMatch

            List of Sanctions Matches

See Also
GlobalSanctionsResultCodes Class
GlobalSanctionsResultCodes Members


GlobalScoring Class

GlobalScoring Class GBG Web Service Developers Guide
Scoring applied to an Item Check within a Profile
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalScoring

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalScoring
[SerializableAttribute]
public class GlobalScoring
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalScoring = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalScoring');
GlobalCheck.DataLib.GlobalScoring = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalScoring');
See Also
GlobalScoring Members


GlobalScoring Members

GlobalScoring Members GBG Web Service Developers Guide
The GlobalScoring type exposes the following members.
Properties
 | Name | Description
Public property | Comment | Comment Property
Public property | Match | Match Property
Public property | MatchThreshold | MatchThreshold Property
Public property | Mismatch | Mismatch Property
Public property | Warning | Warning Property
Back to Top
See Also
GlobalScoring Class


GlobalScoring Properties

GlobalScoring Properties GBG Web Service Developers Guide
The GlobalScoring type exposes the following members.
Properties
 | Name | Description
Public property | Comment | Comment Property
Public property | Match | Match Property
Public property | MatchThreshold | MatchThreshold Property
Public property | Mismatch | Mismatch Property
Public property | Warning | Warning Property
Back to Top
See Also
GlobalScoring Class


GlobalScoring.Comment Property

GlobalScoring Comment Property GBG Web Service Developers Guide
Comment Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalWeighting> Comment { get; set; }
public List<GlobalWeighting> Comment { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Comment();
function set_Comment(value);
function get_Comment();
function set_Comment(value);
Property Value
Type: List GlobalWeighting

            Scoring applied to Comment category of Result Codes supported by the Item Check

See Also
GlobalScoring Class
GlobalScoring Members


GlobalScoring.Match Property

GlobalScoring Match Property GBG Web Service Developers Guide
Match Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalWeighting> Match { get; set; }
public List<GlobalWeighting> Match { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Match();
function set_Match(value);
function get_Match();
function set_Match(value);
Property Value
Type: List GlobalWeighting

            Scoring applied to Match category of Result Codes supported by the Item Check

See Also
GlobalScoring Class
GlobalScoring Members


GlobalScoring.MatchThreshold Property

GlobalScoring MatchThreshold Property GBG Web Service Developers Guide
MatchThreshold Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MatchThreshold { get; set; }
public int MatchThreshold { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MatchThreshold();
function set_MatchThreshold(value);
function get_MatchThreshold();
function set_MatchThreshold(value);
Property Value
Type: Int32

            Threshold value for the minimum Score that must be reached from the Weightings set on the Result Codes in order for this Item Check to have 'Matched'

See Also
GlobalScoring Class
GlobalScoring Members


GlobalScoring.Mismatch Property

GlobalScoring Mismatch Property GBG Web Service Developers Guide
Mismatch Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalWeighting> Mismatch { get; set; }
public List<GlobalWeighting> Mismatch { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Mismatch();
function set_Mismatch(value);
function get_Mismatch();
function set_Mismatch(value);
Property Value
Type: List GlobalWeighting

            Scoring applied to Mismatch category of Result Codes supported by the Item Check

See Also
GlobalScoring Class
GlobalScoring Members


GlobalScoring.Warning Property

GlobalScoring Warning Property GBG Web Service Developers Guide
Warning Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<GlobalWeighting> Warning { get; set; }
public List<GlobalWeighting> Warning { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Warning();
function set_Warning(value);
function get_Warning();
function set_Warning(value);
Property Value
Type: List GlobalWeighting

            Scoring applied to Warning category of Result Codes supported by the Item Check

See Also
GlobalScoring Class
GlobalScoring Members


GlobalSharedFraudResultCodes Class

GlobalSharedFraudResultCodes Class GBG Web Service Developers Guide
Shared Fraud Item Check Result data
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalItemCheckResultCodes
GlobalCheck.DataLib GlobalSharedFraudResultCodes

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalSharedFraudResultCodes : GlobalItemCheckResultCodes
public class GlobalSharedFraudResultCodes : GlobalItemCheckResultCodes
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalSharedFraudResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSharedFraudResultCodes',
    GlobalCheck.DataLib.GlobalItemCheckResultCodes);
GlobalCheck.DataLib.GlobalSharedFraudResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSharedFraudResultCodes',
    GlobalCheck.DataLib.GlobalItemCheckResultCodes);
See Also
GlobalSharedFraudResultCodes Members


GlobalSharedFraudResultCodes Members

GlobalSharedFraudResultCodes Members GBG Web Service Developers Guide
The GlobalSharedFraudResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | EventID | EventID Property
Public property | RiskAssessmentID | RiskAssessmentID Property
Back to Top
See Also
GlobalSharedFraudResultCodes Class


GlobalSharedFraudResultCodes Properties

GlobalSharedFraudResultCodes Properties GBG Web Service Developers Guide
The GlobalSharedFraudResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | EventID | EventID Property
Public property | RiskAssessmentID | RiskAssessmentID Property
Back to Top
See Also
GlobalSharedFraudResultCodes Class


GlobalSharedFraudResultCodes.EventID Property

GlobalSharedFraudResultCodes EventID Property GBG Web Service Developers Guide
EventID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EventID { get; set; }
public string EventID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_EventID();
function set_EventID(value);
function get_EventID();
function set_EventID(value);
Property Value
Type: String

            Event Identity

See Also
GlobalSharedFraudResultCodes Class
GlobalSharedFraudResultCodes Members


GlobalSharedFraudResultCodes.RiskAssessmentID Property

GlobalSharedFraudResultCodes RiskAssessmentID Property GBG Web Service Developers Guide
RiskAssessmentID Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RiskAssessmentID { get; set; }
public string RiskAssessmentID { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_RiskAssessmentID();
function set_RiskAssessmentID(value);
function get_RiskAssessmentID();
function set_RiskAssessmentID(value);
Property Value
Type: String

            Risk Assessment Identity

See Also
GlobalSharedFraudResultCodes Class
GlobalSharedFraudResultCodes Members


GlobalShortPassport Class

GlobalShortPassport Class GBG Web Service Developers Guide
Short passport number.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalShortPassport

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalShortPassport
[SerializableAttribute]
public class GlobalShortPassport
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalShortPassport = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalShortPassport');
GlobalCheck.DataLib.GlobalShortPassport = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalShortPassport');
See Also
GlobalShortPassport Members


GlobalShortPassport Members

GlobalShortPassport Members GBG Web Service Developers Guide
The GlobalShortPassport type exposes the following members.
Properties
 | Name | Description
Public property | CountryOfOrigin | Country Of Origin Property
Public property | Number | Number Property
Back to Top
See Also
GlobalShortPassport Class


GlobalShortPassport Properties

GlobalShortPassport Properties GBG Web Service Developers Guide
The GlobalShortPassport type exposes the following members.
Properties
 | Name | Description
Public property | CountryOfOrigin | Country Of Origin Property
Public property | Number | Number Property
Back to Top
See Also
GlobalShortPassport Class


GlobalShortPassport.CountryOfOrigin Property

GlobalShortPassport CountryOfOrigin Property GBG Web Service Developers Guide
Country Of Origin Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CountryOfOrigin { get; set; }
public string CountryOfOrigin { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CountryOfOrigin();
function set_CountryOfOrigin(value);
function get_CountryOfOrigin();
function set_CountryOfOrigin(value);
Property Value
Type: String

            The country of origin on the individuals passport. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Country
See Also
GlobalShortPassport Class
GlobalShortPassport Members


GlobalShortPassport.Number Property

GlobalShortPassport Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            The short passport number for an individuals passport. This property may be omitted or set to an empty string to indicate no value was supplied.

See Also
GlobalShortPassport Class
GlobalShortPassport Members


GlobalSpain Class

GlobalSpain Class GBG Web Service Developers Guide
Spain identity details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalSpain

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalSpain
[SerializableAttribute]
public class GlobalSpain
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalSpain = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSpain');
GlobalCheck.DataLib.GlobalSpain = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSpain');
See Also
GlobalSpain Members


GlobalSpain Members

GlobalSpain Members GBG Web Service Developers Guide
The GlobalSpain type exposes the following members.
Properties
 | Name | Description
Public property | TaxIDNumber | TaxIDNumber
Back to Top
See Also
GlobalSpain Class


GlobalSpain Properties

GlobalSpain Properties GBG Web Service Developers Guide
The GlobalSpain type exposes the following members.
Properties
 | Name | Description
Public property | TaxIDNumber | TaxIDNumber
Back to Top
See Also
GlobalSpain Class


GlobalSpain.TaxIDNumber Property

GlobalSpain TaxIDNumber Property GBG Web Service Developers Guide
TaxIDNumber

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalSpainTaxIDNumber TaxIDNumber { get; set; }
public GlobalSpainTaxIDNumber TaxIDNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TaxIDNumber();
function set_TaxIDNumber(value);
function get_TaxIDNumber();
function set_TaxIDNumber(value);
Property Value
Type: GlobalSpainTaxIDNumber

            This property will be validated against the following named regular expression: SpainTaxIDNumber
See Also
GlobalSpain Class
GlobalSpain Members


GlobalSpainTaxIDNumber Class

GlobalSpainTaxIDNumber Class GBG Web Service Developers Guide
Spain TaxID Number
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalSpainTaxIDNumber

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalSpainTaxIDNumber
[SerializableAttribute]
public class GlobalSpainTaxIDNumber
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalSpainTaxIDNumber = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSpainTaxIDNumber');
GlobalCheck.DataLib.GlobalSpainTaxIDNumber = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSpainTaxIDNumber');
See Also
GlobalSpainTaxIDNumber Members


GlobalSpainTaxIDNumber Members

GlobalSpainTaxIDNumber Members GBG Web Service Developers Guide
The GlobalSpainTaxIDNumber type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalSpainTaxIDNumber Class


GlobalSpainTaxIDNumber Properties

GlobalSpainTaxIDNumber Properties GBG Web Service Developers Guide
The GlobalSpainTaxIDNumber type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalSpainTaxIDNumber Class


GlobalSpainTaxIDNumber.Number Property

GlobalSpainTaxIDNumber Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            Contains an individuals TaxID Number.  This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: GlobalSpainTaxIDNumber
See Also
GlobalSpainTaxIDNumber Class
GlobalSpainTaxIDNumber Members


GlobalSupportContact Class

GlobalSupportContact Class GBG Web Service Developers Guide
Organisation Support Contact Details
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalSupportContact

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalSupportContact
public class GlobalSupportContact
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalSupportContact = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSupportContact');
GlobalCheck.DataLib.GlobalSupportContact = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalSupportContact');
See Also
GlobalSupportContact Members


GlobalSupportContact Members

GlobalSupportContact Members GBG Web Service Developers Guide
The GlobalSupportContact type exposes the following members.
Properties
 | Name | Description
Public property | Email | Email Property
Public property | Hours | Hours Property
Public property | Telephone | Telephone Property
Back to Top
See Also
GlobalSupportContact Class


GlobalSupportContact Properties

GlobalSupportContact Properties GBG Web Service Developers Guide
The GlobalSupportContact type exposes the following members.
Properties
 | Name | Description
Public property | Email | Email Property
Public property | Hours | Hours Property
Public property | Telephone | Telephone Property
Back to Top
See Also
GlobalSupportContact Class


GlobalSupportContact.Email Property

GlobalSupportContact Email Property GBG Web Service Developers Guide
Email Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Email { get; set; }
public string Email { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Email();
function set_Email(value);
function get_Email();
function set_Email(value);
Property Value
Type: String

            Support Desk Contact Email address

See Also
GlobalSupportContact Class
GlobalSupportContact Members


GlobalSupportContact.Hours Property

GlobalSupportContact Hours Property GBG Web Service Developers Guide
Hours Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Hours { get; set; }
public string Hours { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Hours();
function set_Hours(value);
function get_Hours();
function set_Hours(value);
Property Value
Type: String

            Support Desk Hours of Operation

See Also
GlobalSupportContact Class
GlobalSupportContact Members


GlobalSupportContact.Telephone Property

GlobalSupportContact Telephone Property GBG Web Service Developers Guide
Telephone Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.OrgLib (in GlobalCheck.OrgLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Telephone { get; set; }
public string Telephone { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Telephone();
function set_Telephone(value);
function get_Telephone();
function set_Telephone(value);
Property Value
Type: String

            Support Desk Contact Telephone Number

See Also
GlobalSupportContact Class
GlobalSupportContact Members


GlobalTelephoneResultCodes Class

GlobalTelephoneResultCodes Class GBG Web Service Developers Guide
Telephone Item Check Result data
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalItemCheckResultCodes
GlobalCheck.DataLib GlobalTelephoneResultCodes

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GlobalTelephoneResultCodes : GlobalItemCheckResultCodes
public class GlobalTelephoneResultCodes : GlobalItemCheckResultCodes
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalTelephoneResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalTelephoneResultCodes',
    GlobalCheck.DataLib.GlobalItemCheckResultCodes);
GlobalCheck.DataLib.GlobalTelephoneResultCodes = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalTelephoneResultCodes',
    GlobalCheck.DataLib.GlobalItemCheckResultCodes);
See Also
GlobalTelephoneResultCodes Members


GlobalTelephoneResultCodes Members

GlobalTelephoneResultCodes Members GBG Web Service Developers Guide
The GlobalTelephoneResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | PublishedTelephoneNumber | PublishedTelephoneNumber Property
Back to Top
See Also
GlobalTelephoneResultCodes Class


GlobalTelephoneResultCodes Properties

GlobalTelephoneResultCodes Properties GBG Web Service Developers Guide
The GlobalTelephoneResultCodes type exposes the following members.
Properties
 | Name | Description
Public property | PublishedTelephoneNumber | PublishedTelephoneNumber Property
Back to Top
See Also
GlobalTelephoneResultCodes Class


GlobalTelephoneResultCodes.PublishedTelephoneNumber Property

GlobalTelephoneResultCodes PublishedTelephoneNumber Property GBG Web Service Developers Guide
PublishedTelephoneNumber Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PublishedTelephoneNumber { get; set; }
public string PublishedTelephoneNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_PublishedTelephoneNumber();
function set_PublishedTelephoneNumber(value);
function get_PublishedTelephoneNumber();
function set_PublishedTelephoneNumber(value);
Property Value
Type: String

            Published Telephone Number returned for specified Name & Address

See Also
GlobalTelephoneResultCodes Class
GlobalTelephoneResultCodes Members


GlobalUKAddressDocuments Class

GlobalUKAddressDocuments Class GBG Web Service Developers Guide
Contains UK Address Document Information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalUKAddressDocuments

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalUKAddressDocuments
[SerializableAttribute]
public class GlobalUKAddressDocuments
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalUKAddressDocuments = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUKAddressDocuments');
GlobalCheck.DataLib.GlobalUKAddressDocuments = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUKAddressDocuments');
See Also
GlobalUKAddressDocuments Members


GlobalUKAddressDocuments Members

GlobalUKAddressDocuments Members GBG Web Service Developers Guide
The GlobalUKAddressDocuments type exposes the following members.
Properties
 | Name | Description
Public property | ElectricitySupplier | Electricity Supplier
Back to Top
See Also
GlobalUKAddressDocuments Class


GlobalUKAddressDocuments Properties

GlobalUKAddressDocuments Properties GBG Web Service Developers Guide
The GlobalUKAddressDocuments type exposes the following members.
Properties
 | Name | Description
Public property | ElectricitySupplier | Electricity Supplier
Back to Top
See Also
GlobalUKAddressDocuments Class


GlobalUKAddressDocuments.ElectricitySupplier Property

GlobalUKAddressDocuments ElectricitySupplier Property GBG Web Service Developers Guide
Electricity Supplier

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalElectricitySupplier ElectricitySupplier { get; set; }
public GlobalElectricitySupplier ElectricitySupplier { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ElectricitySupplier();
function set_ElectricitySupplier(value);
function get_ElectricitySupplier();
function set_ElectricitySupplier(value);
Property Value
Type: GlobalElectricitySupplier
See Also
GlobalUKAddressDocuments Class
GlobalUKAddressDocuments Members


GlobalUKBirth Class

GlobalUKBirth Class GBG Web Service Developers Guide
Birth details of an individual.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalUKBirth

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalUKBirth
[SerializableAttribute]
public class GlobalUKBirth
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalUKBirth = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUKBirth');
GlobalCheck.DataLib.GlobalUKBirth = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUKBirth');
See Also
GlobalUKBirth Members


GlobalUKBirth Members

GlobalUKBirth Members GBG Web Service Developers Guide
The GlobalUKBirth type exposes the following members.
Methods
Name | Description
DelimitedHeader | Adds column headers for Data Extract to StringBuilder
Back to Top
Properties
 | Name | Description
Public property | Country | Country Property
Public property | CountryOfBirth | Country Of Birth Property
Public property | MothersMaidenName | Mothers Maiden Name Property
Public property | MunicipalityOfBirth | Municipality Of Birth Property
Public property | ProvinceOfBirth | Province Of Birth Property
Public property | SurnameAtBirth | Surname At Birth Property
Public property | TownOfBirth | Town Of Birth Property
Back to Top
See Also
GlobalUKBirth Class


GlobalUKBirth Methods

GlobalUKBirth Methods GBG Web Service Developers Guide
The GlobalUKBirth type exposes the following members.
Methods
Name | Description
DelimitedHeader | Adds column headers for Data Extract to StringBuilder
Back to Top
See Also
GlobalUKBirth Class


GlobalUKBirth.DelimitedHeader Method

GlobalUKBirth DelimitedHeader Method GBG Web Service Developers Guide
Adds column headers for Data Extract to StringBuilder

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void DelimitedHeader(
    ref StringBuilder StringB,
    string Delimiter
)
public static void DelimitedHeader(
    ref StringBuilder StringB,
    string Delimiter
)
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalUKBirth.DelimitedHeader = function(StringB, Delimiter);
GlobalCheck.DataLib.GlobalUKBirth.DelimitedHeader = function(StringB, Delimiter);
Parameters
StringB
Type: System.Text StringBuilder
[ref] StringBuilder object to append strings to
Delimiter
Type: System String
Delimiter to separate columns, e.g. '\t'
See Also
GlobalUKBirth Class
GlobalUKBirth Members


GlobalUKBirth Properties

GlobalUKBirth Properties GBG Web Service Developers Guide
The GlobalUKBirth type exposes the following members.
Properties
 | Name | Description
Public property | Country | Country Property
Public property | CountryOfBirth | Country Of Birth Property
Public property | MothersMaidenName | Mothers Maiden Name Property
Public property | MunicipalityOfBirth | Municipality Of Birth Property
Public property | ProvinceOfBirth | Province Of Birth Property
Public property | SurnameAtBirth | Surname At Birth Property
Public property | TownOfBirth | Town Of Birth Property
Back to Top
See Also
GlobalUKBirth Class


GlobalUKBirth.Country Property

GlobalUKBirth Country Property GBG Web Service Developers Guide
Country Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalUKBirthsIndexCountry Country { get; set; }
public GlobalUKBirthsIndexCountry Country { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Country();
function set_Country(value);
function get_Country();
function set_Country(value);
Property Value
Type: GlobalUKBirthsIndexCountry

            Contains an UK individuals country where their birth was registered. This property must be supplied
            Possible values are:
            ENGLANDWALES
            OTHER

See Also
GlobalUKBirth Class
GlobalUKBirth Members


GlobalUKBirth.CountryOfBirth Property

GlobalUKBirth CountryOfBirth Property GBG Web Service Developers Guide
Country Of Birth Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CountryOfBirth { get; set; }
public string CountryOfBirth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CountryOfBirth();
function set_CountryOfBirth(value);
function get_CountryOfBirth();
function set_CountryOfBirth(value);
Property Value
Type: String

            The individuals country at birth. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Country
See Also
GlobalUKBirth Class
GlobalUKBirth Members


GlobalUKBirth.MothersMaidenName Property

GlobalUKBirth MothersMaidenName Property GBG Web Service Developers Guide
Mothers Maiden Name Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MothersMaidenName { get; set; }
public string MothersMaidenName { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MothersMaidenName();
function set_MothersMaidenName(value);
function get_MothersMaidenName();
function set_MothersMaidenName(value);
Property Value
Type: String

            The mothers maiden mame of the individual. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Surname
See Also
GlobalUKBirth Class
GlobalUKBirth Members


GlobalUKBirth.MunicipalityOfBirth Property

GlobalUKBirth MunicipalityOfBirth Property GBG Web Service Developers Guide
Municipality Of Birth Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MunicipalityOfBirth { get; set; }
public string MunicipalityOfBirth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MunicipalityOfBirth();
function set_MunicipalityOfBirth(value);
function get_MunicipalityOfBirth();
function set_MunicipalityOfBirth(value);
Property Value
Type: String

            The individuals municipality of birth. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalUKBirth Class
GlobalUKBirth Members


GlobalUKBirth.ProvinceOfBirth Property

GlobalUKBirth ProvinceOfBirth Property GBG Web Service Developers Guide
Province Of Birth Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ProvinceOfBirth { get; set; }
public string ProvinceOfBirth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ProvinceOfBirth();
function set_ProvinceOfBirth(value);
function get_ProvinceOfBirth();
function set_ProvinceOfBirth(value);
Property Value
Type: String

            The individuals province of birth. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalUKBirth Class
GlobalUKBirth Members


GlobalUKBirth.SurnameAtBirth Property

GlobalUKBirth SurnameAtBirth Property GBG Web Service Developers Guide
Surname At Birth Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SurnameAtBirth { get; set; }
public string SurnameAtBirth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SurnameAtBirth();
function set_SurnameAtBirth(value);
function get_SurnameAtBirth();
function set_SurnameAtBirth(value);
Property Value
Type: String

            The individuals surname at birth. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Surname
See Also
GlobalUKBirth Class
GlobalUKBirth Members


GlobalUKBirth.TownOfBirth Property

GlobalUKBirth TownOfBirth Property GBG Web Service Developers Guide
Town Of Birth Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TownOfBirth { get; set; }
public string TownOfBirth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_TownOfBirth();
function set_TownOfBirth(value);
function get_TownOfBirth();
function set_TownOfBirth(value);
Property Value
Type: String

            The individuals town of birth. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: AddressLine
See Also
GlobalUKBirth Class
GlobalUKBirth Members


GlobalUKBirthsIndexCountry Enumeration

GlobalUKBirthsIndexCountry Enumeration GBG Web Service Developers Guide
Country details for an individual.

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public enum GlobalUKBirthsIndexCountry
[SerializableAttribute]
public enum GlobalUKBirthsIndexCountry
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalUKBirthsIndexCountry = function();
GlobalCheck.DataLib.GlobalUKBirthsIndexCountry.createEnum('GlobalCheck.DataLib.GlobalUKBirthsIndexCountry', false);
GlobalCheck.DataLib.GlobalUKBirthsIndexCountry = function();
GlobalCheck.DataLib.GlobalUKBirthsIndexCountry.createEnum('GlobalCheck.DataLib.GlobalUKBirthsIndexCountry', false);
Members
Member name | Value | Description
UNSPECIFIED | 0 | unspecified
ENGLANDWALES | 1 | England and wales
OTHER | 2 | Other
See Also


GlobalUKData Class

GlobalUKData Class GBG Web Service Developers Guide
Contains UK identity documents.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalUKData

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalUKData
[SerializableAttribute]
public class GlobalUKData
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalUKData = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUKData');
GlobalCheck.DataLib.GlobalUKData = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUKData');
See Also
GlobalUKData Members


GlobalUKData Members

GlobalUKData Members GBG Web Service Developers Guide
The GlobalUKData type exposes the following members.
Properties
 | Name | Description
Public property | DrivingLicence | Contains an individuals UK Driving Licence
Public property | NationalInsuranceNumber | Contains an individuals UK National Insurance Number
Public property | Passport | Contains an individuals UK Passport Details
Back to Top
See Also
GlobalUKData Class


GlobalUKData Properties

GlobalUKData Properties GBG Web Service Developers Guide
The GlobalUKData type exposes the following members.
Properties
 | Name | Description
Public property | DrivingLicence | Contains an individuals UK Driving Licence
Public property | NationalInsuranceNumber | Contains an individuals UK National Insurance Number
Public property | Passport | Contains an individuals UK Passport Details
Back to Top
See Also
GlobalUKData Class


GlobalUKData.DrivingLicence Property

GlobalUKData DrivingLicence Property GBG Web Service Developers Guide
Contains an individuals UK Driving Licence

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalUKDrivingLicence DrivingLicence { get; set; }
public GlobalUKDrivingLicence DrivingLicence { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DrivingLicence();
function set_DrivingLicence(value);
function get_DrivingLicence();
function set_DrivingLicence(value);
Property Value
Type: GlobalUKDrivingLicence
See Also
GlobalUKData Class
GlobalUKData Members


GlobalUKData.NationalInsuranceNumber Property

GlobalUKData NationalInsuranceNumber Property GBG Web Service Developers Guide
Contains an individuals UK National Insurance Number

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalUKNationalInsuranceNumber NationalInsuranceNumber { get; set; }
public GlobalUKNationalInsuranceNumber NationalInsuranceNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_NationalInsuranceNumber();
function set_NationalInsuranceNumber(value);
function get_NationalInsuranceNumber();
function set_NationalInsuranceNumber(value);
Property Value
Type: GlobalUKNationalInsuranceNumber
See Also
GlobalUKData Class
GlobalUKData Members


GlobalUKData.Passport Property

GlobalUKData Passport Property GBG Web Service Developers Guide
Contains an individuals UK Passport Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalUKPassport Passport { get; set; }
public GlobalUKPassport Passport { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Passport();
function set_Passport(value);
function get_Passport();
function set_Passport(value);
Property Value
Type: GlobalUKPassport
See Also
GlobalUKData Class
GlobalUKData Members


GlobalUKDrivingLicence Class

GlobalUKDrivingLicence Class GBG Web Service Developers Guide
UK driving licence information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalUKDrivingLicence

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalUKDrivingLicence
[SerializableAttribute]
public class GlobalUKDrivingLicence
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalUKDrivingLicence = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUKDrivingLicence');
GlobalCheck.DataLib.GlobalUKDrivingLicence = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUKDrivingLicence');
See Also
GlobalUKDrivingLicence Members


GlobalUKDrivingLicence Members

GlobalUKDrivingLicence Members GBG Web Service Developers Guide
The GlobalUKDrivingLicence type exposes the following members.
Properties
 | Name | Description
Public property | ExpiryDay | ExpiryDay Property
Public property | ExpiryMonth | ExpiryMonth Property
Public property | ExpiryYear | ExpiryYear Property
Public property | IssueDay | IssueDay Property
Public property | IssueMonth | IssueMonth Property
Public property | IssueNumber | IssueNumber Property
Public property | IssueYear | IssueYear Property
Public property | MailSort | Mailsort Property
Public property | Microfiche | Microfiche Property
Public property | Number | Number Property
Public property | Postcode | Postcode Property
Back to Top
See Also
GlobalUKDrivingLicence Class


GlobalUKDrivingLicence Properties

GlobalUKDrivingLicence Properties GBG Web Service Developers Guide
The GlobalUKDrivingLicence type exposes the following members.
Properties
 | Name | Description
Public property | ExpiryDay | ExpiryDay Property
Public property | ExpiryMonth | ExpiryMonth Property
Public property | ExpiryYear | ExpiryYear Property
Public property | IssueDay | IssueDay Property
Public property | IssueMonth | IssueMonth Property
Public property | IssueNumber | IssueNumber Property
Public property | IssueYear | IssueYear Property
Public property | MailSort | Mailsort Property
Public property | Microfiche | Microfiche Property
Public property | Number | Number Property
Public property | Postcode | Postcode Property
Back to Top
See Also
GlobalUKDrivingLicence Class


GlobalUKDrivingLicence.ExpiryDay Property

GlobalUKDrivingLicence ExpiryDay Property GBG Web Service Developers Guide
ExpiryDay Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExpiryDay { get; set; }
public int ExpiryDay { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryDay();
function set_ExpiryDay(value);
function get_ExpiryDay();
function set_ExpiryDay(value);
Property Value
Type: Int32

            Integer in the range 1-31 representing the day in the month of an individuals passport expiry date.
            This property will be validated against the following named regular expression: Day
See Also
GlobalUKDrivingLicence Class
GlobalUKDrivingLicence Members


GlobalUKDrivingLicence.ExpiryMonth Property

GlobalUKDrivingLicence ExpiryMonth Property GBG Web Service Developers Guide
ExpiryMonth Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExpiryMonth { get; set; }
public int ExpiryMonth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryMonth();
function set_ExpiryMonth(value);
function get_ExpiryMonth();
function set_ExpiryMonth(value);
Property Value
Type: Int32

            This property may be omitted to indicate that this information is not available.

See Also
GlobalUKDrivingLicence Class
GlobalUKDrivingLicence Members


GlobalUKDrivingLicence.ExpiryYear Property

GlobalUKDrivingLicence ExpiryYear Property GBG Web Service Developers Guide
ExpiryYear Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExpiryYear { get; set; }
public int ExpiryYear { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryYear();
function set_ExpiryYear(value);
function get_ExpiryYear();
function set_ExpiryYear(value);
Property Value
Type: Int32

            Integer in the range 1-2099 representing the year of an individuals driving licence expiry date.
            This property will be validated against the following named regular expression: Year
See Also
GlobalUKDrivingLicence Class
GlobalUKDrivingLicence Members


GlobalUKDrivingLicence.IssueDay Property

GlobalUKDrivingLicence IssueDay Property GBG Web Service Developers Guide
IssueDay Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IssueDay { get; set; }
public int IssueDay { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IssueDay();
function set_IssueDay(value);
function get_IssueDay();
function set_IssueDay(value);
Property Value
Type: Int32

            Integer in the range 1-31 representing the day in the month of an individuals driving licence issue date.
            This property will be validated against the following named regular expression: Day
See Also
GlobalUKDrivingLicence Class
GlobalUKDrivingLicence Members


GlobalUKDrivingLicence.IssueMonth Property

GlobalUKDrivingLicence IssueMonth Property GBG Web Service Developers Guide
IssueMonth Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IssueMonth { get; set; }
public int IssueMonth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IssueMonth();
function set_IssueMonth(value);
function get_IssueMonth();
function set_IssueMonth(value);
Property Value
Type: Int32

            Integer in the range 1-12 representing the month of an individuals driving licence issue date.
            This property will be validated against the following named regular expression: Month
See Also
GlobalUKDrivingLicence Class
GlobalUKDrivingLicence Members


GlobalUKDrivingLicence.IssueNumber Property

GlobalUKDrivingLicence IssueNumber Property GBG Web Service Developers Guide
IssueNumber Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IssueNumber { get; set; }
public int IssueNumber { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IssueNumber();
function set_IssueNumber(value);
function get_IssueNumber();
function set_IssueNumber(value);
Property Value
Type: Int32

            Contains the Issue number on the individuals driving licence

See Also
GlobalUKDrivingLicence Class
GlobalUKDrivingLicence Members


GlobalUKDrivingLicence.IssueYear Property

GlobalUKDrivingLicence IssueYear Property GBG Web Service Developers Guide
IssueYear Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IssueYear { get; set; }
public int IssueYear { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_IssueYear();
function set_IssueYear(value);
function get_IssueYear();
function set_IssueYear(value);
Property Value
Type: Int32

            Integer in the range 1-2099 representing the year of an individuals driving licence issue date.
            This property will be validated against the following named regular expression: Year
See Also
GlobalUKDrivingLicence Class
GlobalUKDrivingLicence Members


GlobalUKDrivingLicence.MailSort Property

GlobalUKDrivingLicence MailSort Property GBG Web Service Developers Guide
Mailsort Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MailSort { get; set; }
public string MailSort { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MailSort();
function set_MailSort(value);
function get_MailSort();
function set_MailSort(value);
Property Value
Type: String

            Contains the mail sort from an individuals driving licence. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: MailSort
See Also
GlobalUKDrivingLicence Class
GlobalUKDrivingLicence Members


GlobalUKDrivingLicence.Microfiche Property

GlobalUKDrivingLicence Microfiche Property GBG Web Service Developers Guide
Microfiche Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Microfiche { get; set; }
public string Microfiche { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Microfiche();
function set_Microfiche(value);
function get_Microfiche();
function set_Microfiche(value);
Property Value
Type: String

            Contains the Microfiche from an individuals driving licence. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Microfiche
See Also
GlobalUKDrivingLicence Class
GlobalUKDrivingLicence Members


GlobalUKDrivingLicence.Number Property

GlobalUKDrivingLicence Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            UK Driving Licence Number

See Also
GlobalUKDrivingLicence Class
GlobalUKDrivingLicence Members


GlobalUKDrivingLicence.Postcode Property

GlobalUKDrivingLicence Postcode Property GBG Web Service Developers Guide
Postcode Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Postcode { get; set; }
public string Postcode { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Postcode();
function set_Postcode(value);
function get_Postcode();
function set_Postcode(value);
Property Value
Type: String

            Contains the postcode from an individuals driving licence. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: Postcode
See Also
GlobalUKDrivingLicence Class
GlobalUKDrivingLicence Members


GlobalUKNationalInsuranceNumber Class

GlobalUKNationalInsuranceNumber Class GBG Web Service Developers Guide
UK national insurance number details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalUKNationalInsuranceNumber

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalUKNationalInsuranceNumber
[SerializableAttribute]
public class GlobalUKNationalInsuranceNumber
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalUKNationalInsuranceNumber = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUKNationalInsuranceNumber');
GlobalCheck.DataLib.GlobalUKNationalInsuranceNumber = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUKNationalInsuranceNumber');
See Also
GlobalUKNationalInsuranceNumber Members


GlobalUKNationalInsuranceNumber Members

GlobalUKNationalInsuranceNumber Members GBG Web Service Developers Guide
The GlobalUKNationalInsuranceNumber type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalUKNationalInsuranceNumber Class


GlobalUKNationalInsuranceNumber Properties

GlobalUKNationalInsuranceNumber Properties GBG Web Service Developers Guide
The GlobalUKNationalInsuranceNumber type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalUKNationalInsuranceNumber Class


GlobalUKNationalInsuranceNumber.Number Property

GlobalUKNationalInsuranceNumber Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            An Individuals national insurance number. This property may be omitted or set to an empty string to indicate no value was supplied.

See Also
GlobalUKNationalInsuranceNumber Class
GlobalUKNationalInsuranceNumber Members


GlobalUKPassport Class

GlobalUKPassport Class GBG Web Service Developers Guide
UK Passport information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalUKPassport

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalUKPassport
[SerializableAttribute]
public class GlobalUKPassport
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalUKPassport = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUKPassport');
GlobalCheck.DataLib.GlobalUKPassport = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUKPassport');
See Also
GlobalUKPassport Members


GlobalUKPassport Members

GlobalUKPassport Members GBG Web Service Developers Guide
The GlobalUKPassport type exposes the following members.
Properties
 | Name | Description
Public property | ExpiryDay | Expiry Day Property
Public property | ExpiryMonth | Expiry Month Property
Public property | ExpiryYear | Expiry Year Property
Public property | Number | Number Property
Back to Top
See Also
GlobalUKPassport Class


GlobalUKPassport Properties

GlobalUKPassport Properties GBG Web Service Developers Guide
The GlobalUKPassport type exposes the following members.
Properties
 | Name | Description
Public property | ExpiryDay | Expiry Day Property
Public property | ExpiryMonth | Expiry Month Property
Public property | ExpiryYear | Expiry Year Property
Public property | Number | Number Property
Back to Top
See Also
GlobalUKPassport Class


GlobalUKPassport.ExpiryDay Property

GlobalUKPassport ExpiryDay Property GBG Web Service Developers Guide
Expiry Day Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExpiryDay { get; set; }
public int ExpiryDay { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryDay();
function set_ExpiryDay(value);
function get_ExpiryDay();
function set_ExpiryDay(value);
Property Value
Type: Int32

            Integer in the range 1-31 representing the day in the month of an individuals passport expiry date.
            This property will be validated against the following named regular expression: Day
See Also
GlobalUKPassport Class
GlobalUKPassport Members


GlobalUKPassport.ExpiryMonth Property

GlobalUKPassport ExpiryMonth Property GBG Web Service Developers Guide
Expiry Month Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExpiryMonth { get; set; }
public int ExpiryMonth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryMonth();
function set_ExpiryMonth(value);
function get_ExpiryMonth();
function set_ExpiryMonth(value);
Property Value
Type: Int32

            Integer in the range 1-12 representing the the month of an individuals passport expiry date.
            This property will be validated against the following named regular expression: Month
See Also
GlobalUKPassport Class
GlobalUKPassport Members


GlobalUKPassport.ExpiryYear Property

GlobalUKPassport ExpiryYear Property GBG Web Service Developers Guide
Expiry Year Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExpiryYear { get; set; }
public int ExpiryYear { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_ExpiryYear();
function set_ExpiryYear(value);
function get_ExpiryYear();
function set_ExpiryYear(value);
Property Value
Type: Int32

            Integer in the range  0-2099 representing the the year of an individuals passport expiry date.
            This property will be validated against the following named regular expression: Year
See Also
GlobalUKPassport Class
GlobalUKPassport Members


GlobalUKPassport.Number Property

GlobalUKPassport Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            UK Passport Number

See Also
GlobalUKPassport Class
GlobalUKPassport Members


GlobalUS Class

GlobalUS Class GBG Web Service Developers Guide
US identity details.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalUS

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalUS
[SerializableAttribute]
public class GlobalUS
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalUS = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUS');
GlobalCheck.DataLib.GlobalUS = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUS');
See Also
GlobalUS Members


GlobalUS Members

GlobalUS Members GBG Web Service Developers Guide
The GlobalUS type exposes the following members.
Properties
 | Name | Description
Public property | DrivingLicense | Driving License Details
Public property | SocialSecurity | Social Security Details
Back to Top
See Also
GlobalUS Class


GlobalUS Properties

GlobalUS Properties GBG Web Service Developers Guide
The GlobalUS type exposes the following members.
Properties
 | Name | Description
Public property | DrivingLicense | Driving License Details
Public property | SocialSecurity | Social Security Details
Back to Top
See Also
GlobalUS Class


GlobalUS.DrivingLicense Property

GlobalUS DrivingLicense Property GBG Web Service Developers Guide
Driving License Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalUSDrivingLicense DrivingLicense { get; set; }
public GlobalUSDrivingLicense DrivingLicense { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DrivingLicense();
function set_DrivingLicense(value);
function get_DrivingLicense();
function set_DrivingLicense(value);
Property Value
Type: GlobalUSDrivingLicense
See Also
GlobalUS Class
GlobalUS Members


GlobalUS.SocialSecurity Property

GlobalUS SocialSecurity Property GBG Web Service Developers Guide
Social Security Details

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalUSSocialSecurity SocialSecurity { get; set; }
public GlobalUSSocialSecurity SocialSecurity { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SocialSecurity();
function set_SocialSecurity(value);
function get_SocialSecurity();
function set_SocialSecurity(value);
Property Value
Type: GlobalUSSocialSecurity
See Also
GlobalUS Class
GlobalUS Members


GlobalUSDrivingLicense Class

GlobalUSDrivingLicense Class GBG Web Service Developers Guide
US driving license
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalUSDrivingLicense

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalUSDrivingLicense
[SerializableAttribute]
public class GlobalUSDrivingLicense
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalUSDrivingLicense = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUSDrivingLicense');
GlobalCheck.DataLib.GlobalUSDrivingLicense = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUSDrivingLicense');
See Also
GlobalUSDrivingLicense Members


GlobalUSDrivingLicense Members

GlobalUSDrivingLicense Members GBG Web Service Developers Guide
The GlobalUSDrivingLicense type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Public property | State | State Property
Back to Top
See Also
GlobalUSDrivingLicense Class


GlobalUSDrivingLicense Properties

GlobalUSDrivingLicense Properties GBG Web Service Developers Guide
The GlobalUSDrivingLicense type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Public property | State | State Property
Back to Top
See Also
GlobalUSDrivingLicense Class


GlobalUSDrivingLicense.Number Property

GlobalUSDrivingLicense Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            Contains an individuals Driving Licence Number. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: USDrivingLicenceNumber
See Also
GlobalUSDrivingLicense Class
GlobalUSDrivingLicense Members


GlobalUSDrivingLicense.State Property

GlobalUSDrivingLicense State Property GBG Web Service Developers Guide
State Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string State { get; set; }
public string State { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_State();
function set_State(value);
function get_State();
function set_State(value);
Property Value
Type: String

            The 2-character code for the US State which issued the individuals Driving Licence. This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: State
See Also
GlobalUSDrivingLicense Class
GlobalUSDrivingLicense Members


GlobalUSSocialSecurity Class

GlobalUSSocialSecurity Class GBG Web Service Developers Guide
US social security number.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalUSSocialSecurity

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalUSSocialSecurity
[SerializableAttribute]
public class GlobalUSSocialSecurity
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalUSSocialSecurity = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUSSocialSecurity');
GlobalCheck.DataLib.GlobalUSSocialSecurity = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalUSSocialSecurity');
See Also
GlobalUSSocialSecurity Members


GlobalUSSocialSecurity Members

GlobalUSSocialSecurity Members GBG Web Service Developers Guide
The GlobalUSSocialSecurity type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalUSSocialSecurity Class


GlobalUSSocialSecurity Properties

GlobalUSSocialSecurity Properties GBG Web Service Developers Guide
The GlobalUSSocialSecurity type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalUSSocialSecurity Class


GlobalUSSocialSecurity.Number Property

GlobalUSSocialSecurity Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            Contains an individuals Social Security Number.  This property may be omitted or set to an empty string to indicate no value was supplied.
            This property will be validated against the following named regular expression: SocialSecurityNumber
See Also
GlobalUSSocialSecurity Class
GlobalUSSocialSecurity Members


GlobalWeighting Class

GlobalWeighting Class GBG Web Service Developers Guide
Score Weighting applied to a Result Code on an Item Check in a Profile
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalWeighting

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalWeighting
[SerializableAttribute]
public class GlobalWeighting
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalWeighting = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalWeighting');
GlobalCheck.DataLib.GlobalWeighting = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalWeighting');
See Also
GlobalWeighting Members


GlobalWeighting Members

GlobalWeighting Members GBG Web Service Developers Guide
The GlobalWeighting type exposes the following members.
Properties
 | Name | Description
Public property | Code | Code Property
Public property | Weighting | Weighting Property
Back to Top
See Also
GlobalWeighting Class


GlobalWeighting Properties

GlobalWeighting Properties GBG Web Service Developers Guide
The GlobalWeighting type exposes the following members.
Properties
 | Name | Description
Public property | Code | Code Property
Public property | Weighting | Weighting Property
Back to Top
See Also
GlobalWeighting Class


GlobalWeighting.Code Property

GlobalWeighting Code Property GBG Web Service Developers Guide
Code Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Code { get; set; }
public uint Code { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Code();
function set_Code(value);
function get_Code();
function set_Code(value);
Property Value
Type: UInt32

            Result Code to apply score weighting

See Also
GlobalWeighting Class
GlobalWeighting Members


GlobalWeighting.Weighting Property

GlobalWeighting Weighting Property GBG Web Service Developers Guide
Weighting Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.ProfileLib (in GlobalCheck.ProfileLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Weighting { get; set; }
public int Weighting { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Weighting();
function set_Weighting(value);
function get_Weighting();
function set_Weighting(value);
Property Value
Type: Int32

            Score weighting applied to the result code specified by Code

See Also
GlobalWeighting Class
GlobalWeighting Members


GlobalWorkTelephone Class

GlobalWorkTelephone Class GBG Web Service Developers Guide
Contains work telephone information.
Inheritance Hierarchy
System Object
GlobalCheck.DataLib GlobalWorkTelephone

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlobalWorkTelephone
[SerializableAttribute]
public class GlobalWorkTelephone
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.GlobalWorkTelephone = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalWorkTelephone');
GlobalCheck.DataLib.GlobalWorkTelephone = function();

Type.createClass(
    'GlobalCheck.DataLib.GlobalWorkTelephone');
See Also
GlobalWorkTelephone Members


GlobalWorkTelephone Members

GlobalWorkTelephone Members GBG Web Service Developers Guide
The GlobalWorkTelephone type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalWorkTelephone Class


GlobalWorkTelephone Properties

GlobalWorkTelephone Properties GBG Web Service Developers Guide
The GlobalWorkTelephone type exposes the following members.
Properties
 | Name | Description
Public property | Number | Number Property
Back to Top
See Also
GlobalWorkTelephone Class


GlobalWorkTelephone.Number Property

GlobalWorkTelephone Number Property GBG Web Service Developers Guide
Number Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Number { get; set; }
public string Number { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Number();
function set_Number(value);
function get_Number();
function set_Number(value);
Property Value
Type: String

            Contains an individuals work telephone number (including STD code). Note: telephone number and may be supplied with or without a space between the STD code and number, e.g. ‘01234 567890’ or ‘01234567890’.
            This property may be omitted or set to an empty string to indicate no value was supplied
            This property will be validated against the following named regular expression: TelephoneNumber
See Also
GlobalWorkTelephone Class
GlobalWorkTelephone Members


ImageChecks Class

ImageChecks Class GBG Web Service Developers Guide
Checks run against the supplied image to check if the document is the valid quality
Inheritance Hierarchy
System Object
GlobalCheck.DataLib ImageChecks

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ImageChecks
public class ImageChecks
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.ImageChecks = function();

Type.createClass(
    'GlobalCheck.DataLib.ImageChecks');
GlobalCheck.DataLib.ImageChecks = function();

Type.createClass(
    'GlobalCheck.DataLib.ImageChecks');
See Also
ImageChecks Members


ImageChecks Members

ImageChecks Members GBG Web Service Developers Guide
The ImageChecks type exposes the following members.
Properties
 | Name | Description
Public property | Blur | Blur Property
Public property | Coloured | Is Colored Property
Public property | Dark | Dark Property
Public property | DocumentHasMrz | DocumentHasMrz visible quality
Public property | Dpi | Dpi Property
Public property | Entropy | Entropy Property
Public property | Expired | Expired Property
Public property | MrzVisible | Mrz visible quality
Public property | Overall | Overall Property
Public property | Size | Size Property
Back to Top
See Also
ImageChecks Class


ImageChecks Properties

ImageChecks Properties GBG Web Service Developers Guide
The ImageChecks type exposes the following members.
Properties
 | Name | Description
Public property | Blur | Blur Property
Public property | Coloured | Is Colored Property
Public property | Dark | Dark Property
Public property | DocumentHasMrz | DocumentHasMrz visible quality
Public property | Dpi | Dpi Property
Public property | Entropy | Entropy Property
Public property | Expired | Expired Property
Public property | MrzVisible | Mrz visible quality
Public property | Overall | Overall Property
Public property | Size | Size Property
Back to Top
See Also
ImageChecks Class


ImageChecks.Blur Property

ImageChecks Blur Property GBG Web Service Developers Guide
Blur Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Blur { get; set; }
public bool Blur { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Blur();
function set_Blur(value);
function get_Blur();
function set_Blur(value);
Property Value
Type: Boolean

            Blurred image result

See Also
ImageChecks Class
ImageChecks Members


ImageChecks.Coloured Property

ImageChecks Coloured Property GBG Web Service Developers Guide
Is Colored Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Coloured { get; set; }
public bool Coloured { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Coloured();
function set_Coloured(value);
function get_Coloured();
function set_Coloured(value);
Property Value
Type: Boolean

            Colored image check result

See Also
ImageChecks Class
ImageChecks Members


ImageChecks.Dark Property

ImageChecks Dark Property GBG Web Service Developers Guide
Dark Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Dark { get; set; }
public bool Dark { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Dark();
function set_Dark(value);
function get_Dark();
function set_Dark(value);
Property Value
Type: Boolean

            Darkness check result

See Also
ImageChecks Class
ImageChecks Members


ImageChecks.DocumentHasMrz Property

ImageChecks DocumentHasMrz Property GBG Web Service Developers Guide
DocumentHasMrz visible quality

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DocumentHasMrz { get; set; }
public bool DocumentHasMrz { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_DocumentHasMrz();
function set_DocumentHasMrz(value);
function get_DocumentHasMrz();
function set_DocumentHasMrz(value);
Property Value
Type: Boolean

            DocumentHasMrz image check result

See Also
ImageChecks Class
ImageChecks Members


ImageChecks.Dpi Property

ImageChecks Dpi Property GBG Web Service Developers Guide
Dpi Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Dpi { get; set; }
public bool Dpi { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Dpi();
function set_Dpi(value);
function get_Dpi();
function set_Dpi(value);
Property Value
Type: Boolean

            Dpi check result

See Also
ImageChecks Class
ImageChecks Members


ImageChecks.Entropy Property

ImageChecks Entropy Property GBG Web Service Developers Guide
Entropy Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Entropy { get; set; }
public bool Entropy { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Entropy();
function set_Entropy(value);
function get_Entropy();
function set_Entropy(value);
Property Value
Type: Boolean

            Entropy check result

See Also
ImageChecks Class
ImageChecks Members


ImageChecks.Expired Property

ImageChecks Expired Property GBG Web Service Developers Guide
Expired Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Expired { get; set; }
public bool Expired { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Expired();
function set_Expired(value);
function get_Expired();
function set_Expired(value);
Property Value
Type: Boolean

            Expired image check result

See Also
ImageChecks Class
ImageChecks Members


ImageChecks.MrzVisible Property

ImageChecks MrzVisible Property GBG Web Service Developers Guide
Mrz visible quality

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MrzVisible { get; set; }
public bool MrzVisible { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_MrzVisible();
function set_MrzVisible(value);
function get_MrzVisible();
function set_MrzVisible(value);
Property Value
Type: Boolean

            Mrz image check result

See Also
ImageChecks Class
ImageChecks Members


ImageChecks.Overall Property

ImageChecks Overall Property GBG Web Service Developers Guide
Overall Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Overall { get; set; }
public bool Overall { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Overall();
function set_Overall(value);
function get_Overall();
function set_Overall(value);
Property Value
Type: Boolean

            Overall image check result

See Also
ImageChecks Class
ImageChecks Members


ImageChecks.Size Property

ImageChecks Size Property GBG Web Service Developers Guide
Size Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Size { get; set; }
public bool Size { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Size();
function set_Size(value);
function get_Size();
function set_Size(value);
Property Value
Type: Boolean

            Size check result

See Also
ImageChecks Class
ImageChecks Members


ImageData Class

ImageData Class GBG Web Service Developers Guide
Data relating to the image and the image in Byte[] format
Inheritance Hierarchy
System Object
GlobalCheck.DataLib ImageData

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ImageData
public class ImageData
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.ImageData = function();

Type.createClass(
    'GlobalCheck.DataLib.ImageData');
GlobalCheck.DataLib.ImageData = function();

Type.createClass(
    'GlobalCheck.DataLib.ImageData');
See Also
ImageData Members


ImageData Members

ImageData Members GBG Web Service Developers Guide
The ImageData type exposes the following members.
Properties
 | Name | Description
Public property | CroppedHeight | CroppedHeight Property
Public property | CroppedWidth | CroppedWidth Property
Public property | SubmittedHeight | SubmittedHeight Propery
Public property | SubmittedWidth | SubmittedWidth Property
Back to Top
See Also
ImageData Class


ImageData Properties

ImageData Properties GBG Web Service Developers Guide
The ImageData type exposes the following members.
Properties
 | Name | Description
Public property | CroppedHeight | CroppedHeight Property
Public property | CroppedWidth | CroppedWidth Property
Public property | SubmittedHeight | SubmittedHeight Propery
Public property | SubmittedWidth | SubmittedWidth Property
Back to Top
See Also
ImageData Class


ImageData.CroppedHeight Property

ImageData CroppedHeight Property GBG Web Service Developers Guide
CroppedHeight Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CroppedHeight { get; set; }
public int CroppedHeight { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CroppedHeight();
function set_CroppedHeight(value);
function get_CroppedHeight();
function set_CroppedHeight(value);
Property Value
Type: Int32

            Resulting image height

See Also
ImageData Class
ImageData Members


ImageData.CroppedWidth Property

ImageData CroppedWidth Property GBG Web Service Developers Guide
CroppedWidth Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CroppedWidth { get; set; }
public int CroppedWidth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_CroppedWidth();
function set_CroppedWidth(value);
function get_CroppedWidth();
function set_CroppedWidth(value);
Property Value
Type: Int32

            Resulting image width

See Also
ImageData Class
ImageData Members


ImageData.SubmittedHeight Property

ImageData SubmittedHeight Property GBG Web Service Developers Guide
SubmittedHeight Propery

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int SubmittedHeight { get; set; }
public int SubmittedHeight { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SubmittedHeight();
function set_SubmittedHeight(value);
function get_SubmittedHeight();
function set_SubmittedHeight(value);
Property Value
Type: Int32

            Submitted image height

See Also
ImageData Class
ImageData Members


ImageData.SubmittedWidth Property

ImageData SubmittedWidth Property GBG Web Service Developers Guide
SubmittedWidth Property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DIVLib (in GlobalCheck.DIVLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int SubmittedWidth { get; set; }
public int SubmittedWidth { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_SubmittedWidth();
function set_SubmittedWidth(value);
function get_SubmittedWidth();
function set_SubmittedWidth(value);
Property Value
Type: Int32

            Submitted image width

See Also
ImageData Class
ImageData Members


ResultCode Class

ResultCode Class GBG Web Service Developers Guide
Container for the list of result codes
Inheritance Hierarchy
System Object
GlobalCheck.DataLib ResultCode

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ResultCode
[SerializableAttribute]
public class ResultCode
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.DataLib.ResultCode = function();

Type.createClass(
    'GlobalCheck.DataLib.ResultCode');
GlobalCheck.DataLib.ResultCode = function();

Type.createClass(
    'GlobalCheck.DataLib.ResultCode');
See Also
ResultCode Members


ResultCode Members

ResultCode Members GBG Web Service Developers Guide
The ResultCode type exposes the following members.
Properties
 | Name | Description
Public property | Code | Result code property
Back to Top
See Also
ResultCode Class


ResultCode Properties

ResultCode Properties GBG Web Service Developers Guide
The ResultCode type exposes the following members.
Properties
 | Name | Description
Public property | Code | Result code property
Back to Top
See Also
ResultCode Class


ResultCode.Code Property

ResultCode Code Property GBG Web Service Developers Guide
Result code property

Namespace: GlobalCheck.DataLib
Assembly: GlobalCheck.DataLib (in GlobalCheck.DataLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<int> Code { get; set; }
public List<int> Code { get; set; }
JavaScript
View Colorized Copy to Clipboard Print
function get_Code();
function set_Code(value);
function get_Code();
function set_Code(value);
Property Value
Type: List Int32
See Also
ResultCode Class
ResultCode Members


GlobalCheck.ID3gLib Namespace

GlobalCheck.ID3gLib Namespace GBG Web Service Developers Guide

[Missing <summary> documentation for "N:GlobalCheck.ID3gLib"]

Interfaces
 | Interface | Description
Public interface | IGlobalAuthenticate | Interface for processing Authentications and Address Lookups
Public interface | IGlobalCaseManagement | Interface for managing Profiles and Licence
Public interface | IGlobalConfig | Interface for uploading document images
Public interface | IGlobalCredentials | Interface for credential checking
Public interface | IGlobalDocImage | Interface for uploading document images
Public interface | IGlobalMembership | Interface for managing accounts
Public interface | IGlobalOrganisation | Interface for managing organisations
Public interface | IGlobalProfile | Interface for managing Profiles and Licence
Public interface | IGlobalSearch | Interface for processing Authentications and Address Lookups


IGlobalAuthenticate Interface

IGlobalAuthenticate Interface GBG Web Service Developers Guide
Interface for processing Authentications and Address Lookups

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGlobalAuthenticate
public interface IGlobalAuthenticate
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.ID3gLib.IGlobalAuthenticate = function();
GlobalCheck.ID3gLib.IGlobalAuthenticate.createInterface('GlobalCheck.ID3gLib.IGlobalAuthenticate');
GlobalCheck.ID3gLib.IGlobalAuthenticate = function();
GlobalCheck.ID3gLib.IGlobalAuthenticate.createInterface('GlobalCheck.ID3gLib.IGlobalAuthenticate');
See Also
IGlobalAuthenticate Members
GlobalCheck.ID3gLib Namespace


IGlobalAuthenticate Members

IGlobalAuthenticate Members GBG Web Service Developers Guide
The IGlobalAuthenticate type exposes the following members.
Methods
 | Name | Description
Public method | AddressLookup | This method performs an address lookup based on partial address information and returns a list af address that match the information
Public method | AuthenticateMP | The method authenticates the input data against multiple Profiles
Public method | AuthenticateSP | This method Authenticates the user data against the specified profile
Public method | ForceOverride | Method used to perform a Force Override against an existing Authentication record specified by the AuthenticationId parameter
Public method | IncrementalVerification | This method performs an incremental authentication to allow further processing of an identity check continued from an existing Authentication record specified by the AuthenticationID parameter
Back to Top
See Also
IGlobalAuthenticate Interface
GlobalCheck.ID3gLib Namespace


IGlobalAuthenticate Methods

IGlobalAuthenticate Methods GBG Web Service Developers Guide
The IGlobalAuthenticate type exposes the following members.
Methods
 | Name | Description
Public method | AddressLookup | This method performs an address lookup based on partial address information and returns a list af address that match the information
Public method | AuthenticateMP | The method authenticates the input data against multiple Profiles
Public method | AuthenticateSP | This method Authenticates the user data against the specified profile
Public method | ForceOverride | Method used to perform a Force Override against an existing Authentication record specified by the AuthenticationId parameter
Public method | IncrementalVerification | This method performs an incremental authentication to allow further processing of an identity check continued from an existing Authentication record specified by the AuthenticationID parameter
Back to Top
See Also
IGlobalAuthenticate Interface
GlobalCheck.ID3gLib Namespace


IGlobalAuthenticate.AddressLookup Method

IGlobalAuthenticate AddressLookup Method GBG Web Service Developers Guide
This method performs an address lookup based on partial address information and returns a list af address that match the information

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalAddress> AddressLookup(
    GlobalAddress InputData
)
List<GlobalAddress> AddressLookup(
    GlobalAddress InputData
)
JavaScript
View Colorized Copy to Clipboard Print
function AddressLookup(InputData);
function AddressLookup(InputData);
Parameters
InputData
Type: GlobalCheck.DataLib GlobalAddress
The GlobalAddress object
Return Value
Type: List GlobalAddress
An array of GlobalAddress objects
See Also
IGlobalAuthenticate Interface
IGlobalAuthenticate Members
GlobalCheck.ID3gLib Namespace


IGlobalAuthenticate.AuthenticateMP Method

IGlobalAuthenticate AuthenticateMP Method GBG Web Service Developers Guide
The method authenticates the input data against multiple Profiles

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalResultData> AuthenticateMP(
    List<GlobalProfileIDVersion> ProfileIDVersions,
    string CustomerReference,
    GlobalInputData InputData
)
List<GlobalResultData> AuthenticateMP(
    List<GlobalProfileIDVersion> ProfileIDVersions,
    string CustomerReference,
    GlobalInputData InputData
)
JavaScript
View Colorized Copy to Clipboard Print
function AuthenticateMP(ProfileIDVersions, CustomerReference, InputData);
function AuthenticateMP(ProfileIDVersions, CustomerReference, InputData);
Parameters
ProfileIDVersions
Type: System.Collections.Generic List GlobalProfileIDVersion
An array of GlobalProfileIDVersion profiles to execute
CustomerReference
Type: System String
Customer reference
InputData
Type: GlobalCheck.DataLib GlobalInputData
GlobalInputData object
Return Value
Type: List GlobalResultData
An array of GlobalResultDataObjects
See Also
IGlobalAuthenticate Interface
IGlobalAuthenticate Members
GlobalCheck.ID3gLib Namespace


IGlobalAuthenticate.AuthenticateSP Method

IGlobalAuthenticate AuthenticateSP Method GBG Web Service Developers Guide
This method Authenticates the user data against the specified profile

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalResultData AuthenticateSP(
    GlobalProfileIDVersion ProfileIDVersion,
    string CustomerReference,
    GlobalInputData InputData
)
GlobalResultData AuthenticateSP(
    GlobalProfileIDVersion ProfileIDVersion,
    string CustomerReference,
    GlobalInputData InputData
)
JavaScript
View Colorized Copy to Clipboard Print
function AuthenticateSP(ProfileIDVersion, CustomerReference, InputData);
function AuthenticateSP(ProfileIDVersion, CustomerReference, InputData);
Parameters
ProfileIDVersion
Type: GlobalCheck.DataLib GlobalProfileIDVersion
Unique identifier and version of the profile to execute
CustomerReference
Type: System String
Customer reference
InputData
Type: GlobalCheck.DataLib GlobalInputData
The GlobalInputData object
Return Value
Type: GlobalResultData
GlobalResultData object
See Also
IGlobalAuthenticate Interface
IGlobalAuthenticate Members
GlobalCheck.ID3gLib Namespace


IGlobalAuthenticate.ForceOverride Method

IGlobalAuthenticate ForceOverride Method GBG Web Service Developers Guide
Method used to perform a Force Override against an existing Authentication record specified by the AuthenticationId parameter

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalResultData ForceOverride(
    Guid AuthenticationID,
    GlobalProfileIDVersion ProfileIDVersion,
    string CustomerReference,
    List<GlobalOverride> Overrides
)
GlobalResultData ForceOverride(
    Guid AuthenticationID,
    GlobalProfileIDVersion ProfileIDVersion,
    string CustomerReference,
    List<GlobalOverride> Overrides
)
JavaScript
View Colorized Copy to Clipboard Print
function ForceOverride(AuthenticationID, ProfileIDVersion, CustomerReference, Overrides);
function ForceOverride(AuthenticationID, ProfileIDVersion, CustomerReference, Overrides);
Parameters
AuthenticationID
Type: System Guid
The authentication ID of the existing authentication
ProfileIDVersion
Type: GlobalCheck.DataLib GlobalProfileIDVersion
Unique identifier and version of the profile to execute
CustomerReference
Type: System String
The customer reference
Overrides
Type: System.Collections.Generic List GlobalOverride
An array of GlobalOverride objects
Return Value
Type: GlobalResultData
GlobalResultData object
See Also
IGlobalAuthenticate Interface
IGlobalAuthenticate Members
GlobalCheck.ID3gLib Namespace


IGlobalAuthenticate.IncrementalVerification Method

IGlobalAuthenticate IncrementalVerification Method GBG Web Service Developers Guide
This method performs an incremental authentication to allow further processing of an identity check continued from an existing Authentication record specified by the AuthenticationID parameter

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalResultData IncrementalVerification(
    Guid AuthenticationID,
    GlobalProfileIDVersion ProfileIDVersion,
    string CustomerReference,
    GlobalInputData InputData
)
GlobalResultData IncrementalVerification(
    Guid AuthenticationID,
    GlobalProfileIDVersion ProfileIDVersion,
    string CustomerReference,
    GlobalInputData InputData
)
JavaScript
View Colorized Copy to Clipboard Print
function IncrementalVerification(AuthenticationID, ProfileIDVersion, CustomerReference, InputData);
function IncrementalVerification(AuthenticationID, ProfileIDVersion, CustomerReference, InputData);
Parameters
AuthenticationID
Type: System Guid
The authentication ID of the existing authentication
ProfileIDVersion
Type: GlobalCheck.DataLib GlobalProfileIDVersion
Unique identifier and version of the profile to execute
CustomerReference
Type: System String
Customer reference
InputData
Type: GlobalCheck.DataLib GlobalInputData
The GlobalInputData object
Return Value
Type: GlobalResultData
GlobalResultData object
See Also
IGlobalAuthenticate Interface
IGlobalAuthenticate Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement Interface

IGlobalCaseManagement Interface GBG Web Service Developers Guide
Interface for managing Profiles and Licence

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGlobalCaseManagement
public interface IGlobalCaseManagement
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.ID3gLib.IGlobalCaseManagement = function();
GlobalCheck.ID3gLib.IGlobalCaseManagement.createInterface('GlobalCheck.ID3gLib.IGlobalCaseManagement');
GlobalCheck.ID3gLib.IGlobalCaseManagement = function();
GlobalCheck.ID3gLib.IGlobalCaseManagement.createInterface('GlobalCheck.ID3gLib.IGlobalCaseManagement');
See Also
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement Members

IGlobalCaseManagement Members GBG Web Service Developers Guide
The IGlobalCaseManagement type exposes the following members.
Methods
 | Name | Description
Public method | CreateCase | Creates a new Case
Public method | CreateFullCase | Creates a new Case
Public method | DispatchCase | Dispatches a case to an external checking service
Public method | GetCaseDetails | Get CaseDetails for a given Case
Public method | GetCaseInputData | Gets the input data of a case
Public method | GetCases | Gets list of Data Case
Public method | RaiseChargingPoint | Raise a charging point on a case
Public method | SaveCaseDocuments | Saves the documents of a case
Public method | SaveDocumentResult | Saves the validation and authentication result of a document
Public method | SaveExternalDataResult | Saves the selected external data matches such as PEP and Sanctions matches
Public method | SaveManualDispatchResult | Saves a manually processed dispatch result
Public method | SaveResult | Saves a case result
Public method | UpdateCase | Updates a Case
Public method | UpdateState | Updates the state of a case
Back to Top
See Also
IGlobalCaseManagement Interface
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement Methods

IGlobalCaseManagement Methods GBG Web Service Developers Guide
The IGlobalCaseManagement type exposes the following members.
Methods
 | Name | Description
Public method | CreateCase | Creates a new Case
Public method | CreateFullCase | Creates a new Case
Public method | DispatchCase | Dispatches a case to an external checking service
Public method | GetCaseDetails | Get CaseDetails for a given Case
Public method | GetCaseInputData | Gets the input data of a case
Public method | GetCases | Gets list of Data Case
Public method | RaiseChargingPoint | Raise a charging point on a case
Public method | SaveCaseDocuments | Saves the documents of a case
Public method | SaveDocumentResult | Saves the validation and authentication result of a document
Public method | SaveExternalDataResult | Saves the selected external data matches such as PEP and Sanctions matches
Public method | SaveManualDispatchResult | Saves a manually processed dispatch result
Public method | SaveResult | Saves a case result
Public method | UpdateCase | Updates a Case
Public method | UpdateState | Updates the state of a case
Back to Top
See Also
IGlobalCaseManagement Interface
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement.CreateCase Method

IGlobalCaseManagement CreateCase Method GBG Web Service Developers Guide
Creates a new Case

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Guid CreateCase(
    Guid OrgID,
    Guid LinkedAccountId,
    string Reference,
    string Name,
    int State,
    int AuthorType,
    Guid ProductId,
    List<GlobalCaseReference> CustomerReferences,
    List<GlobalKeyValuePair<string, string>> Properties,
    List<GlobalProfileIDVersion> Profiles,
    GlobalInputData InputData
)
Guid CreateCase(
    Guid OrgID,
    Guid LinkedAccountId,
    string Reference,
    string Name,
    int State,
    int AuthorType,
    Guid ProductId,
    List<GlobalCaseReference> CustomerReferences,
    List<GlobalKeyValuePair<string, string>> Properties,
    List<GlobalProfileIDVersion> Profiles,
    GlobalInputData InputData
)
JavaScript
View Colorized Copy to Clipboard Print
function CreateCase(OrgID, LinkedAccountId, Reference, Name, State, AuthorType, ProductId, CustomerReferences, Properties, Profiles, InputData);
function CreateCase(OrgID, LinkedAccountId, Reference, Name, State, AuthorType, ProductId, CustomerReferences, Properties, Profiles, InputData);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
LinkedAccountId
Type: System Guid
Linked account that the case if for, optional
Reference
Type: System String
Case Reference
Name
Type: System String
Name of the case
State
Type: System Int32
State of the case
AuthorType
Type: System Int32
The AuthorType of the case
ProductId
Type: System Guid
The Product the case relates to
CustomerReferences
Type: System.Collections.Generic List GlobalCaseReference
List of CustomerReferences, optional
Properties
Type: System.Collections.Generic List GlobalKeyValuePair  String, String
List of case properties, optional
Profiles
Type: System.Collections.Generic List GlobalProfileIDVersion
A list of Profiles to associate with the case.
InputData
Type: GlobalCheck.DataLib GlobalInputData
Input data to store against the case
Return Value
Type: Guid

            The case id of the newly created case

See Also
IGlobalCaseManagement Interface
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement.CreateFullCase Method

IGlobalCaseManagement CreateFullCase Method GBG Web Service Developers Guide
Creates a new Case

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Guid CreateFullCase(
    Guid OrgID,
    Guid LinkedAccountId,
    string Reference,
    string Name,
    int State,
    int AuthorType,
    Nullable<int> Verdict,
    Guid ProductId,
    Nullable<bool> DisclaimerAccepted,
    List<GlobalCaseReference> CustomerReferences,
    List<GlobalKeyValuePair<string, string>> Properties,
    List<GlobalProfileIDVersion> Profiles,
    List<GlobalDocumentCategorySubmissionType> DocumentCategorySubmissionTypes,
    List<GlobalCaseDocument> Documents,
    List<GlobalCaseConsent> Consents,
    GlobalInputData InputData
)
Guid CreateFullCase(
    Guid OrgID,
    Guid LinkedAccountId,
    string Reference,
    string Name,
    int State,
    int AuthorType,
    Nullable<int> Verdict,
    Guid ProductId,
    Nullable<bool> DisclaimerAccepted,
    List<GlobalCaseReference> CustomerReferences,
    List<GlobalKeyValuePair<string, string>> Properties,
    List<GlobalProfileIDVersion> Profiles,
    List<GlobalDocumentCategorySubmissionType> DocumentCategorySubmissionTypes,
    List<GlobalCaseDocument> Documents,
    List<GlobalCaseConsent> Consents,
    GlobalInputData InputData
)
JavaScript
View Colorized Copy to Clipboard Print
function CreateFullCase(OrgID, LinkedAccountId, Reference, Name, State, AuthorType, Verdict, ProductId, DisclaimerAccepted, CustomerReferences, Properties, Profiles, DocumentCategorySubmissionTypes, Documents, Consents, InputData);
function CreateFullCase(OrgID, LinkedAccountId, Reference, Name, State, AuthorType, Verdict, ProductId, DisclaimerAccepted, CustomerReferences, Properties, Profiles, DocumentCategorySubmissionTypes, Documents, Consents, InputData);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
LinkedAccountId
Type: System Guid
Linked account that the case if for, optional
Reference
Type: System String
Case Reference
Name
Type: System String
Name of the case
State
Type: System Int32
State of the case
AuthorType
Type: System Int32
AuthorType of the case
Verdict
Type: System Nullable Int32
The overall verdict of the application
ProductId
Type: System Guid
The Product the case relates to
DisclaimerAccepted
Type: System Nullable Boolean
Indicates of the disclaimer has been accepted
CustomerReferences
Type: System.Collections.Generic List GlobalCaseReference
List of CustomerReferences, optional
Properties
Type: System.Collections.Generic List GlobalKeyValuePair  String, String
List of case properties, optional
Profiles
Type: System.Collections.Generic List GlobalProfileIDVersion
A list of Profiles to associate with the case.
DocumentCategorySubmissionTypes
Type: System.Collections.Generic List GlobalDocumentCategorySubmissionType
A list of DocumentCategorySubmissionTypes to associate with the case.
Documents
Type: System.Collections.Generic List GlobalCaseDocument
A list of Documents to associate with the case.
Consents
Type: System.Collections.Generic List GlobalCaseConsent
A list of Consents to associate with the case.
InputData
Type: GlobalCheck.DataLib GlobalInputData
Input data to store against the case
Return Value
Type: Guid

            The case id of the newly created case

See Also
IGlobalCaseManagement Interface
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement.DispatchCase Method

IGlobalCaseManagement DispatchCase Method GBG Web Service Developers Guide
Dispatches a case to an external checking service

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void DispatchCase(
    Guid OrgID,
    Guid CaseID,
    GlobalCaseDispatchParameters Params
)
void DispatchCase(
    Guid OrgID,
    Guid CaseID,
    GlobalCaseDispatchParameters Params
)
JavaScript
View Colorized Copy to Clipboard Print
function DispatchCase(OrgID, CaseID, Params);
function DispatchCase(OrgID, CaseID, Params);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
CaseID
Type: System Guid
Unique identifier of the Case
Params
Type: GlobalCheck.DataLib GlobalCaseDispatchParameters
The dispatch parametersGlobalCaseDispatchParameters
See Also
IGlobalCaseManagement Interface
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement.GetCaseDetails Method

IGlobalCaseManagement GetCaseDetails Method GBG Web Service Developers Guide
Get CaseDetails for a given Case

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalCaseDetails GetCaseDetails(
    Guid OrgID,
    Guid CaseID
)
GlobalCaseDetails GetCaseDetails(
    Guid OrgID,
    Guid CaseID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetCaseDetails(OrgID, CaseID);
function GetCaseDetails(OrgID, CaseID);
Parameters
OrgID
Type: System Guid
Unique identifier of the organisation user
CaseID
Type: System Guid
Unique identifier of the Case
Return Value
Type: GlobalCaseDetails
GlobalCaseDetails
See Also
IGlobalCaseManagement Interface
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement.GetCaseInputData Method

IGlobalCaseManagement GetCaseInputData Method GBG Web Service Developers Guide
Gets the input data of a case

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalInputData GetCaseInputData(
    Guid OrgID,
    Guid CaseID
)
GlobalInputData GetCaseInputData(
    Guid OrgID,
    Guid CaseID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetCaseInputData(OrgID, CaseID);
function GetCaseInputData(OrgID, CaseID);
Parameters
OrgID
Type: System Guid
Unique identifier of organisation to retrieve Cases from
CaseID
Type: System Guid
Case to retrieve
Return Value
Type: GlobalInputData
GlobalCaseDetails
See Also
IGlobalCaseManagement Interface
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement.GetCases Method

IGlobalCaseManagement GetCases Method GBG Web Service Developers Guide
Gets list of Data Case

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalCases GetCases(
    Guid OrgID,
    uint Page,
    uint PageSize,
    string Name,
    uint State,
    uint Verdict
)
GlobalCases GetCases(
    Guid OrgID,
    uint Page,
    uint PageSize,
    string Name,
    uint State,
    uint Verdict
)
JavaScript
View Colorized Copy to Clipboard Print
function GetCases(OrgID, Page, PageSize, Name, State, Verdict);
function GetCases(OrgID, Page, PageSize, Name, State, Verdict);
Parameters
OrgID
Type: System Guid
Unique identifier of Case
Page
Type: System UInt32
Index of page (first page has index of 1)
PageSize
Type: System UInt32
Number of Data Case to return in a page (max 100)
Name
Type: System String
Search filter for Data Case - filters on Name
State
Type: System UInt32
Search filter for State
Verdict
Type: System UInt32
Search filter for Verdict
Return Value
Type: GlobalCases
List of Data Case
See Also
IGlobalCaseManagement Interface
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement.RaiseChargingPoint Method

IGlobalCaseManagement RaiseChargingPoint Method GBG Web Service Developers Guide
Raise a charging point on a case

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalCaseDetails RaiseChargingPoint(
    Guid OrgID,
    Guid CaseID,
    Guid ProfileID,
    Guid AuthenticationID
)
GlobalCaseDetails RaiseChargingPoint(
    Guid OrgID,
    Guid CaseID,
    Guid ProfileID,
    Guid AuthenticationID
)
JavaScript
View Colorized Copy to Clipboard Print
function RaiseChargingPoint(OrgID, CaseID, ProfileID, AuthenticationID);
function RaiseChargingPoint(OrgID, CaseID, ProfileID, AuthenticationID);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
CaseID
Type: System Guid
Unique identifier of the Case
ProfileID
Type: System Guid
The id of the profile associated with the charging point
AuthenticationID
Type: System Guid
The id of the authentication associated with the charging point
Return Value
Type: GlobalCaseDetails
[Missing <returns> documentation for "M:GlobalCheck.ID3gLib.IGlobalCaseManagement.RaiseChargingPoint(System.Guid,System.Guid,System.Guid,System.Guid)"]
See Also
IGlobalCaseManagement Interface
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement.SaveCaseDocuments Method

IGlobalCaseManagement SaveCaseDocuments Method GBG Web Service Developers Guide
Saves the documents of a case

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SaveCaseDocuments(
    Guid OrgID,
    Guid CaseID,
    List<GlobalCaseDocument> Documents
)
void SaveCaseDocuments(
    Guid OrgID,
    Guid CaseID,
    List<GlobalCaseDocument> Documents
)
JavaScript
View Colorized Copy to Clipboard Print
function SaveCaseDocuments(OrgID, CaseID, Documents);
function SaveCaseDocuments(OrgID, CaseID, Documents);
Parameters
OrgID
Type: System Guid
Unique identifier of the organisation
CaseID
Type: System Guid
Unique identifier of the Case
Documents
Type: System.Collections.Generic List GlobalCaseDocument
The documents to update
See Also
IGlobalCaseManagement Interface
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement.SaveDocumentResult Method

IGlobalCaseManagement SaveDocumentResult Method GBG Web Service Developers Guide
Saves the validation and authentication result of a document

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalCaseDetails SaveDocumentResult(
    Guid OrgID,
    Guid CaseID,
    List<GlobalCaseDocumentResult> Results,
    GlobalCaseDocumentResultParameters Param
)
GlobalCaseDetails SaveDocumentResult(
    Guid OrgID,
    Guid CaseID,
    List<GlobalCaseDocumentResult> Results,
    GlobalCaseDocumentResultParameters Param
)
JavaScript
View Colorized Copy to Clipboard Print
function SaveDocumentResult(OrgID, CaseID, Results, Param);
function SaveDocumentResult(OrgID, CaseID, Results, Param);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
CaseID
Type: System Guid
Unique identifier of the Case
Results
Type: System.Collections.Generic List GlobalCaseDocumentResult
The results
Param
Type: GlobalCheck.DataLib GlobalCaseDocumentResultParameters
The selected data parameters
Return Value
Type: GlobalCaseDetails
[Missing <returns> documentation for "M:GlobalCheck.ID3gLib.IGlobalCaseManagement.SaveDocumentResult(System.Guid,System.Guid,System.Collections.Generic.List{GlobalCheck.DataLib.GlobalCaseDocumentResult},GlobalCheck.DataLib.GlobalCaseDocumentResultParameters)"]
See Also
IGlobalCaseManagement Interface
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement.SaveExternalDataResult Method

IGlobalCaseManagement SaveExternalDataResult Method GBG Web Service Developers Guide
Saves the selected external data matches such as PEP and Sanctions matches

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalCaseDetails SaveExternalDataResult(
    Guid OrgID,
    Guid CaseID,
    GlobalExternalDataResultParameters Param
)
GlobalCaseDetails SaveExternalDataResult(
    Guid OrgID,
    Guid CaseID,
    GlobalExternalDataResultParameters Param
)
JavaScript
View Colorized Copy to Clipboard Print
function SaveExternalDataResult(OrgID, CaseID, Param);
function SaveExternalDataResult(OrgID, CaseID, Param);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
CaseID
Type: System Guid
Unique identifier of the Case
Param
Type: GlobalExternalDataResultParameters
The selected data parameters
Return Value
Type: GlobalCaseDetails
[Missing <returns> documentation for "M:GlobalCheck.ID3gLib.IGlobalCaseManagement.SaveExternalDataResult(System.Guid,System.Guid,GlobalCheck.DataLib.GlobalExternalDataResultParameters)"]
See Also
IGlobalCaseManagement Interface
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement.SaveManualDispatchResult Method

IGlobalCaseManagement SaveManualDispatchResult Method GBG Web Service Developers Guide
Saves a manually processed dispatch result

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalCaseDetails SaveManualDispatchResult(
    Guid OrgID,
    Guid CaseID,
    GlobalCaseDispatchParameters Param,
    GlobalDispatchResult Result
)
GlobalCaseDetails SaveManualDispatchResult(
    Guid OrgID,
    Guid CaseID,
    GlobalCaseDispatchParameters Param,
    GlobalDispatchResult Result
)
JavaScript
View Colorized Copy to Clipboard Print
function SaveManualDispatchResult(OrgID, CaseID, Param, Result);
function SaveManualDispatchResult(OrgID, CaseID, Param, Result);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
CaseID
Type: System Guid
Unique identifier of the Case
Param
Type: GlobalCheck.DataLib GlobalCaseDispatchParameters
The dispatch parameters
Result
Type: GlobalCheck.DataLib GlobalDispatchResult
The results to update
Return Value
Type: GlobalCaseDetails
The updated GlobalCaseDetails object
See Also
IGlobalCaseManagement Interface
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement.SaveResult Method

IGlobalCaseManagement SaveResult Method GBG Web Service Developers Guide
Saves a case result

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalCaseDetails SaveResult(
    Guid OrgID,
    Guid CaseID,
    List<GlobalResultData> Results,
    GlobalCaseResultParameters Param
)
GlobalCaseDetails SaveResult(
    Guid OrgID,
    Guid CaseID,
    List<GlobalResultData> Results,
    GlobalCaseResultParameters Param
)
JavaScript
View Colorized Copy to Clipboard Print
function SaveResult(OrgID, CaseID, Results, Param);
function SaveResult(OrgID, CaseID, Results, Param);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
CaseID
Type: System Guid
Unique identifier of the Case
Results
Type: System.Collections.Generic List GlobalResultData
The authentication results
Param
Type: GlobalCheck.DataLib GlobalCaseResultParameters
The result parameters
Return Value
Type: GlobalCaseDetails
[Missing <returns> documentation for "M:GlobalCheck.ID3gLib.IGlobalCaseManagement.SaveResult(System.Guid,System.Guid,System.Collections.Generic.List{GlobalCheck.DataLib.GlobalResultData},GlobalCheck.DataLib.GlobalCaseResultParameters)"]
See Also
IGlobalCaseManagement Interface
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement.UpdateCase Method

IGlobalCaseManagement UpdateCase Method GBG Web Service Developers Guide
Updates a Case

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UpdateCase(
    Guid OrgID,
    Guid CaseID,
    string Name,
    Guid LinkedAccountId,
    int State,
    int AuthorType,
    Nullable<int> Verdict,
    Nullable<bool> DisclaimerAccepted,
    List<GlobalCaseReference> CustomerReferences,
    List<GlobalKeyValuePair<string, string>> Properties,
    List<GlobalProfileIDVersion> Profiles,
    List<GlobalDocumentCategorySubmissionType> DocumentCategorySubmissionTypes,
    List<GlobalCaseDocument> Documents,
    List<GlobalCaseConsent> Consents,
    GlobalInputData InputData
)
void UpdateCase(
    Guid OrgID,
    Guid CaseID,
    string Name,
    Guid LinkedAccountId,
    int State,
    int AuthorType,
    Nullable<int> Verdict,
    Nullable<bool> DisclaimerAccepted,
    List<GlobalCaseReference> CustomerReferences,
    List<GlobalKeyValuePair<string, string>> Properties,
    List<GlobalProfileIDVersion> Profiles,
    List<GlobalDocumentCategorySubmissionType> DocumentCategorySubmissionTypes,
    List<GlobalCaseDocument> Documents,
    List<GlobalCaseConsent> Consents,
    GlobalInputData InputData
)
JavaScript
View Colorized Copy to Clipboard Print
function UpdateCase(OrgID, CaseID, Name, LinkedAccountId, State, AuthorType, Verdict, DisclaimerAccepted, CustomerReferences, Properties, Profiles, DocumentCategorySubmissionTypes, Documents, Consents, InputData);
function UpdateCase(OrgID, CaseID, Name, LinkedAccountId, State, AuthorType, Verdict, DisclaimerAccepted, CustomerReferences, Properties, Profiles, DocumentCategorySubmissionTypes, Documents, Consents, InputData);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
CaseID
Type: System Guid
Unique identifier of the Case
Name
Type: System String
Name of the case
LinkedAccountId
Type: System Guid
Linked account that the case if for, optional
State
Type: System Int32
State of the case
AuthorType
Type: System Int32
The AuthorType of the case
Verdict
Type: System Nullable Int32
The overall verdict of the case
DisclaimerAccepted
Type: System Nullable Boolean
Indicates of the disclaimer has been accepted
CustomerReferences
Type: System.Collections.Generic List GlobalCaseReference
List of CustomerReferences, optional
Properties
Type: System.Collections.Generic List GlobalKeyValuePair  String, String
List of case properties, optional
Profiles
Type: System.Collections.Generic List GlobalProfileIDVersion
A list of Profiles to associate with the case.
DocumentCategorySubmissionTypes
Type: System.Collections.Generic List GlobalDocumentCategorySubmissionType
A list of DocumentCategorySubmissionTypes to associate with the case.
Documents
Type: System.Collections.Generic List GlobalCaseDocument
A list of Documents to associate with the case.
Consents
Type: System.Collections.Generic List GlobalCaseConsent
A list of Consents to associate with the case.
InputData
Type: GlobalCheck.DataLib GlobalInputData
Input data to store against the case
See Also
IGlobalCaseManagement Interface
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalCaseManagement.UpdateState Method

IGlobalCaseManagement UpdateState Method GBG Web Service Developers Guide
Updates the state of a case

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UpdateState(
    Guid OrgID,
    Guid CaseID,
    uint State
)
void UpdateState(
    Guid OrgID,
    Guid CaseID,
    uint State
)
JavaScript
View Colorized Copy to Clipboard Print
function UpdateState(OrgID, CaseID, State);
function UpdateState(OrgID, CaseID, State);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
CaseID
Type: System Guid
Unique identifier of the Case
State
Type: System UInt32
The state to update
See Also
IGlobalCaseManagement Interface
IGlobalCaseManagement Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig Interface

IGlobalConfig Interface GBG Web Service Developers Guide
Interface for uploading document images

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGlobalConfig
public interface IGlobalConfig
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.ID3gLib.IGlobalConfig = function();
GlobalCheck.ID3gLib.IGlobalConfig.createInterface('GlobalCheck.ID3gLib.IGlobalConfig');
GlobalCheck.ID3gLib.IGlobalConfig = function();
GlobalCheck.ID3gLib.IGlobalConfig.createInterface('GlobalCheck.ID3gLib.IGlobalConfig');
See Also
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig Members

IGlobalConfig Members GBG Web Service Developers Guide
The IGlobalConfig type exposes the following members.
Methods
 | Name | Description
Public method | GetCardName | This method return a card types name
Public method | GetDocImageMaxSizeKBytes | Returns the maximum supported image size.
Public method | GetDocImageMinSizeKBytes | Returns the minimum supported image size.
Public method | GetDocImageSupportedFileTypes | Returns the supported files types
Public method | GetDocumentTypes | Get a list of supported document types
Public method | GetExtractFormats | Get a list of supported formats for Data Extract
Public method | GetExtractVersions | Get a list of supported versions for Data Extract
Public method | GetIdentityCardIssuingCountries | This method retrieve's the list of Countries supported for 'Country of Issue' for the European National Identity Card Item Check
Public method | GetIdentityCardNationalityCountries | This method retrieve's the list of Countries supported for 'Country of Nationality' for the European National Identity Card Item Check
Public method | GetItalyProvinceOfBirth | This method retrieve's the list of Provinces supported for the Italy Item check
Public method | GetItemCheckResultCodes | This method returns the list of Result codes for a given item check
Public method | GetLocationCountries | This method retrieve's the list of Countries supported by the Online Location Item Check
Public method | GetLocationStates | This method retrieve's the list of US States supported for the IP Verification Item check
Public method | GetPassportCountries | This method retrieve's the list of Countries supported by the International Passport Item Check
Public method | GetSanctionsIssuers | This method returns the list of Issuers supported by the Sanctions item checks
Back to Top
See Also
IGlobalConfig Interface
GlobalCheck.ID3gLib Namespace


IGlobalConfig Methods

IGlobalConfig Methods GBG Web Service Developers Guide
The IGlobalConfig type exposes the following members.
Methods
 | Name | Description
Public method | GetCardName | This method return a card types name
Public method | GetDocImageMaxSizeKBytes | Returns the maximum supported image size.
Public method | GetDocImageMinSizeKBytes | Returns the minimum supported image size.
Public method | GetDocImageSupportedFileTypes | Returns the supported files types
Public method | GetDocumentTypes | Get a list of supported document types
Public method | GetExtractFormats | Get a list of supported formats for Data Extract
Public method | GetExtractVersions | Get a list of supported versions for Data Extract
Public method | GetIdentityCardIssuingCountries | This method retrieve's the list of Countries supported for 'Country of Issue' for the European National Identity Card Item Check
Public method | GetIdentityCardNationalityCountries | This method retrieve's the list of Countries supported for 'Country of Nationality' for the European National Identity Card Item Check
Public method | GetItalyProvinceOfBirth | This method retrieve's the list of Provinces supported for the Italy Item check
Public method | GetItemCheckResultCodes | This method returns the list of Result codes for a given item check
Public method | GetLocationCountries | This method retrieve's the list of Countries supported by the Online Location Item Check
Public method | GetLocationStates | This method retrieve's the list of US States supported for the IP Verification Item check
Public method | GetPassportCountries | This method retrieve's the list of Countries supported by the International Passport Item Check
Public method | GetSanctionsIssuers | This method returns the list of Issuers supported by the Sanctions item checks
Back to Top
See Also
IGlobalConfig Interface
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetCardName Method

IGlobalConfig GetCardName Method GBG Web Service Developers Guide
This method return a card types name

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetCardName(
    GlobalCardType CardType
)
string GetCardName(
    GlobalCardType CardType
)
JavaScript
View Colorized Copy to Clipboard Print
function GetCardName(CardType);
function GetCardName(CardType);
Parameters
CardType
Type: GlobalCheck.DataLib GlobalCardType
[Missing <param name="CardType"/> documentation for "M:GlobalCheck.ID3gLib.IGlobalConfig.GetCardName(GlobalCheck.DataLib.GlobalCardType)"]
Return Value
Type: String
string the card type name
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetDocImageMaxSizeKBytes Method

IGlobalConfig GetDocImageMaxSizeKBytes Method GBG Web Service Developers Guide
Returns the maximum supported image size.

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
uint GetDocImageMaxSizeKBytes()
uint GetDocImageMaxSizeKBytes()
JavaScript
View Colorized Copy to Clipboard Print
function GetDocImageMaxSizeKBytes();
function GetDocImageMaxSizeKBytes();
Return Value
Type: UInt32
Maximum image size in KBytes
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetDocImageMinSizeKBytes Method

IGlobalConfig GetDocImageMinSizeKBytes Method GBG Web Service Developers Guide
Returns the minimum supported image size.

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
uint GetDocImageMinSizeKBytes()
uint GetDocImageMinSizeKBytes()
JavaScript
View Colorized Copy to Clipboard Print
function GetDocImageMinSizeKBytes();
function GetDocImageMinSizeKBytes();
Return Value
Type: UInt32
Minimum image size in KBytes
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetDocImageSupportedFileTypes Method

IGlobalConfig GetDocImageSupportedFileTypes Method GBG Web Service Developers Guide
Returns the supported files types

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<string> GetDocImageSupportedFileTypes()
List<string> GetDocImageSupportedFileTypes()
JavaScript
View Colorized Copy to Clipboard Print
function GetDocImageSupportedFileTypes();
function GetDocImageSupportedFileTypes();
Return Value
Type: List String
List of supported file extensions
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetDocumentTypes Method

IGlobalConfig GetDocumentTypes Method GBG Web Service Developers Guide
Get a list of supported document types

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<string> GetDocumentTypes()
List<string> GetDocumentTypes()
JavaScript
View Colorized Copy to Clipboard Print
function GetDocumentTypes();
function GetDocumentTypes();
Return Value
Type: List String
List of strings containing the supported types
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetExtractFormats Method

IGlobalConfig GetExtractFormats Method GBG Web Service Developers Guide
Get a list of supported formats for Data Extract

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<string> GetExtractFormats()
List<string> GetExtractFormats()
JavaScript
View Colorized Copy to Clipboard Print
function GetExtractFormats();
function GetExtractFormats();
Return Value
Type: List String
List of strings containing the supported formats
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetExtractVersions Method

IGlobalConfig GetExtractVersions Method GBG Web Service Developers Guide
Get a list of supported versions for Data Extract

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<string> GetExtractVersions()
List<string> GetExtractVersions()
JavaScript
View Colorized Copy to Clipboard Print
function GetExtractVersions();
function GetExtractVersions();
Return Value
Type: List String
List of strings containing the supported versions
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetIdentityCardIssuingCountries Method

IGlobalConfig GetIdentityCardIssuingCountries Method GBG Web Service Developers Guide
This method retrieve's the list of Countries supported for 'Country of Issue' for the European National Identity Card Item Check

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalCountry> GetIdentityCardIssuingCountries()
List<GlobalCountry> GetIdentityCardIssuingCountries()
JavaScript
View Colorized Copy to Clipboard Print
function GetIdentityCardIssuingCountries();
function GetIdentityCardIssuingCountries();
Return Value
Type: List GlobalCountry
An array of GlobalCountry objects
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetIdentityCardNationalityCountries Method

IGlobalConfig GetIdentityCardNationalityCountries Method GBG Web Service Developers Guide
This method retrieve's the list of Countries supported for 'Country of Nationality' for the European National Identity Card Item Check

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalCountry> GetIdentityCardNationalityCountries()
List<GlobalCountry> GetIdentityCardNationalityCountries()
JavaScript
View Colorized Copy to Clipboard Print
function GetIdentityCardNationalityCountries();
function GetIdentityCardNationalityCountries();
Return Value
Type: List GlobalCountry
An array of GlobalCountry objects
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetItalyProvinceOfBirth Method

IGlobalConfig GetItalyProvinceOfBirth Method GBG Web Service Developers Guide
This method retrieve's the list of Provinces supported for the Italy Item check

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalProvince> GetItalyProvinceOfBirth()
List<GlobalProvince> GetItalyProvinceOfBirth()
JavaScript
View Colorized Copy to Clipboard Print
function GetItalyProvinceOfBirth();
function GetItalyProvinceOfBirth();
Return Value
Type: List GlobalProvince
An array of GlobalProvince objects
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetItemCheckResultCodes Method

IGlobalConfig GetItemCheckResultCodes Method GBG Web Service Developers Guide
This method returns the list of Result codes for a given item check

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalItemCheckResultCodes GetItemCheckResultCodes(
    uint ID
)
GlobalItemCheckResultCodes GetItemCheckResultCodes(
    uint ID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetItemCheckResultCodes(ID);
function GetItemCheckResultCodes(ID);
Parameters
ID
Type: System UInt32
item check ID
Return Value
Type: GlobalItemCheckResultCodes
GlobalItemCheckResultCodes object
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetLocationCountries Method

IGlobalConfig GetLocationCountries Method GBG Web Service Developers Guide
This method retrieve's the list of Countries supported by the Online Location Item Check

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalCountry> GetLocationCountries()
List<GlobalCountry> GetLocationCountries()
JavaScript
View Colorized Copy to Clipboard Print
function GetLocationCountries();
function GetLocationCountries();
Return Value
Type: List GlobalCountry
An array of GlobalCountry objects
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetLocationStates Method

IGlobalConfig GetLocationStates Method GBG Web Service Developers Guide
This method retrieve's the list of US States supported for the IP Verification Item check

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalProvince> GetLocationStates()
List<GlobalProvince> GetLocationStates()
JavaScript
View Colorized Copy to Clipboard Print
function GetLocationStates();
function GetLocationStates();
Return Value
Type: List GlobalProvince
An array of GlobalProvince objects
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetPassportCountries Method

IGlobalConfig GetPassportCountries Method GBG Web Service Developers Guide
This method retrieve's the list of Countries supported by the International Passport Item Check

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalCountry> GetPassportCountries()
List<GlobalCountry> GetPassportCountries()
JavaScript
View Colorized Copy to Clipboard Print
function GetPassportCountries();
function GetPassportCountries();
Return Value
Type: List GlobalCountry
An array of GlobalCountry objects
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalConfig.GetSanctionsIssuers Method

IGlobalConfig GetSanctionsIssuers Method GBG Web Service Developers Guide
This method returns the list of Issuers supported by the Sanctions item checks

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalSanctionsIssuer> GetSanctionsIssuers()
List<GlobalSanctionsIssuer> GetSanctionsIssuers()
JavaScript
View Colorized Copy to Clipboard Print
function GetSanctionsIssuers();
function GetSanctionsIssuers();
Return Value
Type: List GlobalSanctionsIssuer
An array of GlobalSanctionsIssuer objects
See Also
IGlobalConfig Interface
IGlobalConfig Members
GlobalCheck.ID3gLib Namespace


IGlobalCredentials Interface

IGlobalCredentials Interface GBG Web Service Developers Guide
Interface for credential checking

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGlobalCredentials
public interface IGlobalCredentials
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.ID3gLib.IGlobalCredentials = function();
GlobalCheck.ID3gLib.IGlobalCredentials.createInterface('GlobalCheck.ID3gLib.IGlobalCredentials');
GlobalCheck.ID3gLib.IGlobalCredentials = function();
GlobalCheck.ID3gLib.IGlobalCredentials.createInterface('GlobalCheck.ID3gLib.IGlobalCredentials');
See Also
IGlobalCredentials Members
GlobalCheck.ID3gLib Namespace


IGlobalCredentials Members

IGlobalCredentials Members GBG Web Service Developers Guide
The IGlobalCredentials type exposes the following members.
Methods
 | Name | Description
Public method | ChangePassword | Change Password
Public method | ChangePIN | Change PIN associated with an account
Public method | CheckCredentials | Checks the ID3global credentials.
Public method | CheckCredentialsWithPIN | Checks the ID3global credentials including PIN sequence.
Public method | ForgotAccount | Send Account name reminder to registered email address
Public method | ForgotPassword | Forgot Password - Creates a temporary password and sends to registered email address of account holder
Public method | GetPINSequence | Retrieve PIN Sequence
Back to Top
See Also
IGlobalCredentials Interface
GlobalCheck.ID3gLib Namespace


IGlobalCredentials Methods

IGlobalCredentials Methods GBG Web Service Developers Guide
The IGlobalCredentials type exposes the following members.
Methods
 | Name | Description
Public method | ChangePassword | Change Password
Public method | ChangePIN | Change PIN associated with an account
Public method | CheckCredentials | Checks the ID3global credentials.
Public method | CheckCredentialsWithPIN | Checks the ID3global credentials including PIN sequence.
Public method | ForgotAccount | Send Account name reminder to registered email address
Public method | ForgotPassword | Forgot Password - Creates a temporary password and sends to registered email address of account holder
Public method | GetPINSequence | Retrieve PIN Sequence
Back to Top
See Also
IGlobalCredentials Interface
GlobalCheck.ID3gLib Namespace


IGlobalCredentials.ChangePassword Method

IGlobalCredentials ChangePassword Method GBG Web Service Developers Guide
Change Password

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ChangePassword(
    string AccountName,
    string Password,
    string PINSequence,
    string NewPassword
)
void ChangePassword(
    string AccountName,
    string Password,
    string PINSequence,
    string NewPassword
)
JavaScript
View Colorized Copy to Clipboard Print
function ChangePassword(AccountName, Password, PINSequence, NewPassword);
function ChangePassword(AccountName, Password, PINSequence, NewPassword);
Parameters
AccountName
Type: System String
Account name of the caller in form of user@domain.com
Password
Type: System String
Current password
PINSequence
Type: System String
PIN sequence from the users PIN specified by a call to GetPINSequence
NewPassword
Type: System String
New password to be associated with the login
See Also
IGlobalCredentials Interface
IGlobalCredentials Members
GlobalCheck.ID3gLib Namespace


IGlobalCredentials.ChangePIN Method

IGlobalCredentials ChangePIN Method GBG Web Service Developers Guide
Change PIN associated with an account

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ChangePIN(
    string AccountName,
    string Password,
    string PINSequence,
    string NewPIN
)
void ChangePIN(
    string AccountName,
    string Password,
    string PINSequence,
    string NewPIN
)
JavaScript
View Colorized Copy to Clipboard Print
function ChangePIN(AccountName, Password, PINSequence, NewPIN);
function ChangePIN(AccountName, Password, PINSequence, NewPIN);
Parameters
AccountName
Type: System String
Account name of the caller in form of user@domain.com
Password
Type: System String
Password associated with AccountName
PINSequence
Type: System String
Sequence of digits from current PIN
NewPIN
Type: System String
New PIN to assign to the account
See Also
IGlobalCredentials Interface
IGlobalCredentials Members
GlobalCheck.ID3gLib Namespace


IGlobalCredentials.CheckCredentials Method

IGlobalCredentials CheckCredentials Method GBG Web Service Developers Guide
Checks the ID3global credentials.

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalAccount CheckCredentials(
    string AccountName,
    string Password
)
GlobalAccount CheckCredentials(
    string AccountName,
    string Password
)
JavaScript
View Colorized Copy to Clipboard Print
function CheckCredentials(AccountName, Password);
function CheckCredentials(AccountName, Password);
Parameters
AccountName
Type: System String
Account name of the caller in form of username@domainname
Password
Type: System String
Password associated with AccountName
Return Value
Type: GlobalAccount
GlobalAccount object
See Also
IGlobalCredentials Interface
IGlobalCredentials Members
GlobalCheck.ID3gLib Namespace


IGlobalCredentials.CheckCredentialsWithPIN Method

IGlobalCredentials CheckCredentialsWithPIN Method GBG Web Service Developers Guide
Checks the ID3global credentials including PIN sequence.

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalAccount CheckCredentialsWithPIN(
    string AccountName,
    string Password,
    string PINSequence
)
GlobalAccount CheckCredentialsWithPIN(
    string AccountName,
    string Password,
    string PINSequence
)
JavaScript
View Colorized Copy to Clipboard Print
function CheckCredentialsWithPIN(AccountName, Password, PINSequence);
function CheckCredentialsWithPIN(AccountName, Password, PINSequence);
Parameters
AccountName
Type: System String
Account name of the caller in form of username@domainname
Password
Type: System String
Password associated with AccountName
PINSequence
Type: System String
Sequence of digits from current PIN
Return Value
Type: GlobalAccount
GlobalAccount object
See Also
IGlobalCredentials Interface
IGlobalCredentials Members
GlobalCheck.ID3gLib Namespace


IGlobalCredentials.ForgotAccount Method

IGlobalCredentials ForgotAccount Method GBG Web Service Developers Guide
Send Account name reminder to registered email address

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ForgotAccount(
    string Email
)
void ForgotAccount(
    string Email
)
JavaScript
View Colorized Copy to Clipboard Print
function ForgotAccount(Email);
function ForgotAccount(Email);
Parameters
Email
Type: System String
Registered email linked to the account
See Also
IGlobalCredentials Interface
IGlobalCredentials Members
GlobalCheck.ID3gLib Namespace


IGlobalCredentials.ForgotPassword Method

IGlobalCredentials ForgotPassword Method GBG Web Service Developers Guide
Forgot Password - Creates a temporary password and sends to registered email address of account holder

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ForgotPassword(
    string AccountName
)
void ForgotPassword(
    string AccountName
)
JavaScript
View Colorized Copy to Clipboard Print
function ForgotPassword(AccountName);
function ForgotPassword(AccountName);
Parameters
AccountName
Type: System String
Account name of the caller in form of user@domain.com
See Also
IGlobalCredentials Interface
IGlobalCredentials Members
GlobalCheck.ID3gLib Namespace


IGlobalCredentials.GetPINSequence Method

IGlobalCredentials GetPINSequence Method GBG Web Service Developers Guide
Retrieve PIN Sequence

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetPINSequence(
    string AccountName,
    string Password
)
string GetPINSequence(
    string AccountName,
    string Password
)
JavaScript
View Colorized Copy to Clipboard Print
function GetPINSequence(AccountName, Password);
function GetPINSequence(AccountName, Password);
Parameters
AccountName
Type: System String
Account name in form user@domain
Password
Type: System String
Password
Return Value
Type: String
PIN sequence
See Also
IGlobalCredentials Interface
IGlobalCredentials Members
GlobalCheck.ID3gLib Namespace


IGlobalDocImage Interface

IGlobalDocImage Interface GBG Web Service Developers Guide
Interface for uploading document images

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGlobalDocImage
public interface IGlobalDocImage
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.ID3gLib.IGlobalDocImage = function();
GlobalCheck.ID3gLib.IGlobalDocImage.createInterface('GlobalCheck.ID3gLib.IGlobalDocImage');
GlobalCheck.ID3gLib.IGlobalDocImage = function();
GlobalCheck.ID3gLib.IGlobalDocImage.createInterface('GlobalCheck.ID3gLib.IGlobalDocImage');
See Also
IGlobalDocImage Members
GlobalCheck.ID3gLib Namespace


IGlobalDocImage Members

IGlobalDocImage Members GBG Web Service Developers Guide
The IGlobalDocImage type exposes the following members.
Methods
 | Name | Description
Public method | Download | Download a Document Image
Public method | DownloadStoredImage | Download a Stored Document, this should take a specific ImageGuid not a DIV image Guid
Public method | GetImageResults | Get Image processing results for specified ImageID
Public method | ProcessStoredImage | Process a stored image
Public method | StoreDocumentImage | Upload a Document Image to be stored
Public method | Upload | Upload a Document Image
Public method | UploadAndProcess | Upload a Document Image and process synchronously
Back to Top
See Also
IGlobalDocImage Interface
GlobalCheck.ID3gLib Namespace


IGlobalDocImage Methods

IGlobalDocImage Methods GBG Web Service Developers Guide
The IGlobalDocImage type exposes the following members.
Methods
 | Name | Description
Public method | Download | Download a Document Image
Public method | DownloadStoredImage | Download a Stored Document, this should take a specific ImageGuid not a DIV image Guid
Public method | GetImageResults | Get Image processing results for specified ImageID
Public method | ProcessStoredImage | Process a stored image
Public method | StoreDocumentImage | Upload a Document Image to be stored
Public method | Upload | Upload a Document Image
Public method | UploadAndProcess | Upload a Document Image and process synchronously
Back to Top
See Also
IGlobalDocImage Interface
GlobalCheck.ID3gLib Namespace


IGlobalDocImage.Download Method

IGlobalDocImage Download Method GBG Web Service Developers Guide
Download a Document Image

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Stream Download(
    Guid OrgID,
    Guid AuthenticationID
)
Stream Download(
    Guid OrgID,
    Guid AuthenticationID
)
JavaScript
View Colorized Copy to Clipboard Print
function Download(OrgID, AuthenticationID);
function Download(OrgID, AuthenticationID);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation the image was originally uploaded by
AuthenticationID
Type: System Guid
Unique identifier for the Document Image
Return Value
Type: Stream
Document Image as a stream
See Also
IGlobalDocImage Interface
IGlobalDocImage Members
GlobalCheck.ID3gLib Namespace


IGlobalDocImage.DownloadStoredImage Method

IGlobalDocImage DownloadStoredImage Method GBG Web Service Developers Guide
Download a Stored Document, this should take a specific ImageGuid not a DIV image Guid

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Stream DownloadStoredImage(
    Guid OrgID,
    Guid ImageID
)
Stream DownloadStoredImage(
    Guid OrgID,
    Guid ImageID
)
JavaScript
View Colorized Copy to Clipboard Print
function DownloadStoredImage(OrgID, ImageID);
function DownloadStoredImage(OrgID, ImageID);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation the image was originally uploaded by
ImageID
Type: System Guid
Unique identifier for the Document Image
Return Value
Type: Stream
Document Image as a stream
See Also
IGlobalDocImage Interface
IGlobalDocImage Members
GlobalCheck.ID3gLib Namespace


IGlobalDocImage.GetImageResults Method

IGlobalDocImage GetImageResults Method GBG Web Service Developers Guide
Get Image processing results for specified ImageID

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalDIVData GetImageResults(
    Guid OrgID,
    Guid AuthenticationID
)
GlobalDIVData GetImageResults(
    Guid OrgID,
    Guid AuthenticationID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetImageResults(OrgID, AuthenticationID);
function GetImageResults(OrgID, AuthenticationID);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation the image was originally uploaded by
AuthenticationID
Type: System Guid
Unique identifier for the Document Image
Return Value
Type: GlobalDIVData
GlobalDIVData object, containing the result of the image processing
See Also
IGlobalDocImage Interface
IGlobalDocImage Members
GlobalCheck.ID3gLib Namespace


IGlobalDocImage.ProcessStoredImage Method

IGlobalDocImage ProcessStoredImage Method GBG Web Service Developers Guide
Process a stored image

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalDIVData ProcessStoredImage(
    Guid OrgID,
    Guid ImageID,
    bool Synchronous
)
GlobalDIVData ProcessStoredImage(
    Guid OrgID,
    Guid ImageID,
    bool Synchronous
)
JavaScript
View Colorized Copy to Clipboard Print
function ProcessStoredImage(OrgID, ImageID, Synchronous);
function ProcessStoredImage(OrgID, ImageID, Synchronous);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation the image was originally uploaded by
ImageID
Type: System Guid
Unique identifier for the File Image
Synchronous
Type: System Boolean
If the processing should be synchronous
Return Value
Type: GlobalDIVData
GlobalDIVData object, containing the result of the image processing
See Also
IGlobalDocImage Interface
IGlobalDocImage Members
GlobalCheck.ID3gLib Namespace


IGlobalDocImage.StoreDocumentImage Method

IGlobalDocImage StoreDocumentImage Method GBG Web Service Developers Guide
Upload a Document Image to be stored

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Guid StoreDocumentImage(
    Stream DocImage
)
Guid StoreDocumentImage(
    Stream DocImage
)
JavaScript
View Colorized Copy to Clipboard Print
function StoreDocumentImage(DocImage);
function StoreDocumentImage(DocImage);
Parameters
DocImage
Type: System.IO Stream
Document Image
Return Value
Type: Guid
Guid as a document storage ID
See Also
IGlobalDocImage Interface
IGlobalDocImage Members
GlobalCheck.ID3gLib Namespace


IGlobalDocImage.Upload Method

IGlobalDocImage Upload Method GBG Web Service Developers Guide
Upload a Document Image

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalDIVData Upload(
    Stream DocImage
)
GlobalDIVData Upload(
    Stream DocImage
)
JavaScript
View Colorized Copy to Clipboard Print
function Upload(DocImage);
function Upload(DocImage);
Parameters
DocImage
Type: System.IO Stream
Document Image
Return Value
Type: GlobalDIVData
GlobalDIVData object, containing the result of the image processing
See Also
IGlobalDocImage Interface
IGlobalDocImage Members
GlobalCheck.ID3gLib Namespace


IGlobalDocImage.UploadAndProcess Method

IGlobalDocImage UploadAndProcess Method GBG Web Service Developers Guide
Upload a Document Image and process synchronously

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalDIVData UploadAndProcess(
    Stream DocImage
)
GlobalDIVData UploadAndProcess(
    Stream DocImage
)
JavaScript
View Colorized Copy to Clipboard Print
function UploadAndProcess(DocImage);
function UploadAndProcess(DocImage);
Parameters
DocImage
Type: System.IO Stream
Document Image
Return Value
Type: GlobalDIVData
GlobalDIVData object, containing the result of the image processing
See Also
IGlobalDocImage Interface
IGlobalDocImage Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership Interface

IGlobalMembership Interface GBG Web Service Developers Guide
Interface for managing accounts

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGlobalMembership
public interface IGlobalMembership
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.ID3gLib.IGlobalMembership = function();
GlobalCheck.ID3gLib.IGlobalMembership.createInterface('GlobalCheck.ID3gLib.IGlobalMembership');
GlobalCheck.ID3gLib.IGlobalMembership = function();
GlobalCheck.ID3gLib.IGlobalMembership.createInterface('GlobalCheck.ID3gLib.IGlobalMembership');
See Also
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership Members

IGlobalMembership Members GBG Web Service Developers Guide
The IGlobalMembership type exposes the following members.
Methods
 | Name | Description
Public method | CreateAccount | Create Account
Public method | CreateRole | Create Role
Public method | GetAccountDetails | Gets the Account details the specified Account
Public method | GetAccountPermission | Gets the Permission the account has on a resource
Public method | GetAccountRoles | Gets the Roles an account is a member of
Public method | GetAccounts | Get summary details of child Organisations
Public method | GetPermissions | Gets Role Permissions on specified resource identifier
Public method | GetRoleMembers | Gets Accounts that are a member of the specified Role
Public method | GetRolePermissions | Gets the Permissions granted to Resources for specified Role
Public method | GetRoles | Gets all Roles for the specified organisation
Public method | ResetPassword | Reset Password - only applicable if self-care password reset is disabled in licence
Public method | UpdateAccountDetails | Update Account
Public method | UpdatePermissions | Adds and/or Removes Role Permissions to/from Resource specified by unique identifier
Public method | UpdateRole | Update Role
Public method | UpdateRoleMembers | Adds and/or removes one or more Accounts to/from the specified Role
Back to Top
See Also
IGlobalMembership Interface
GlobalCheck.ID3gLib Namespace


IGlobalMembership Methods

IGlobalMembership Methods GBG Web Service Developers Guide
The IGlobalMembership type exposes the following members.
Methods
 | Name | Description
Public method | CreateAccount | Create Account
Public method | CreateRole | Create Role
Public method | GetAccountDetails | Gets the Account details the specified Account
Public method | GetAccountPermission | Gets the Permission the account has on a resource
Public method | GetAccountRoles | Gets the Roles an account is a member of
Public method | GetAccounts | Get summary details of child Organisations
Public method | GetPermissions | Gets Role Permissions on specified resource identifier
Public method | GetRoleMembers | Gets Accounts that are a member of the specified Role
Public method | GetRolePermissions | Gets the Permissions granted to Resources for specified Role
Public method | GetRoles | Gets all Roles for the specified organisation
Public method | ResetPassword | Reset Password - only applicable if self-care password reset is disabled in licence
Public method | UpdateAccountDetails | Update Account
Public method | UpdatePermissions | Adds and/or Removes Role Permissions to/from Resource specified by unique identifier
Public method | UpdateRole | Update Role
Public method | UpdateRoleMembers | Adds and/or removes one or more Accounts to/from the specified Role
Back to Top
See Also
IGlobalMembership Interface
GlobalCheck.ID3gLib Namespace


IGlobalMembership.CreateAccount Method

IGlobalMembership CreateAccount Method GBG Web Service Developers Guide
Create Account

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalAccount CreateAccount(
    Guid OrgID,
    string Name,
    string Username,
    string Email,
    string Password,
    string PIN,
    bool PasswordNeverExpires,
    List<Guid> RoleIDs
)
GlobalAccount CreateAccount(
    Guid OrgID,
    string Name,
    string Username,
    string Email,
    string Password,
    string PIN,
    bool PasswordNeverExpires,
    List<Guid> RoleIDs
)
JavaScript
View Colorized Copy to Clipboard Print
function CreateAccount(OrgID, Name, Username, Email, Password, PIN, PasswordNeverExpires, RoleIDs);
function CreateAccount(OrgID, Name, Username, Email, Password, PIN, PasswordNeverExpires, RoleIDs);
Parameters
OrgID
Type: System Guid
Unique identifier of Organisation in which to create the account
Name
Type: System String
Display name of the new user
Username
Type: System String
Username for the new account
Email
Type: System String
Email address of the new user
Password
Type: System String
Password for the new users first sign in - this parameter is ignored when Self-care Password Resets are enabled
PIN
Type: System String
PIN for the new users first sign in
PasswordNeverExpires
Type: System Boolean
True if the accounts password should never expire, overriding the policy setting on the Password Policy that is applied to the account
RoleIDs
Type: System.Collections.Generic List Guid
List of Role IDs the account should be added to
Return Value
Type: GlobalAccount
Created GlobalAccount object
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership.CreateRole Method

IGlobalMembership CreateRole Method GBG Web Service Developers Guide
Create Role

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalRole CreateRole(
    Guid OrgID,
    string Name,
    string Description,
    bool IsAdminPolicy
)
GlobalRole CreateRole(
    Guid OrgID,
    string Name,
    string Description,
    bool IsAdminPolicy
)
JavaScript
View Colorized Copy to Clipboard Print
function CreateRole(OrgID, Name, Description, IsAdminPolicy);
function CreateRole(OrgID, Name, Description, IsAdminPolicy);
Parameters
OrgID
Type: System Guid
Unique identifier of Organisation in which to create the account
Name
Type: System String
Name of the new role
Description
Type: System String
Description of the new role
IsAdminPolicy
Type: System Boolean
True if role required users to have administrator password policy applied, false otherwise
Return Value
Type: GlobalRole
GlobalRole object
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership.GetAccountDetails Method

IGlobalMembership GetAccountDetails Method GBG Web Service Developers Guide
Gets the Account details the specified Account

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalAccountDetails GetAccountDetails(
    Guid OrgID,
    Guid AccountID
)
GlobalAccountDetails GetAccountDetails(
    Guid OrgID,
    Guid AccountID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetAccountDetails(OrgID, AccountID);
function GetAccountDetails(OrgID, AccountID);
Parameters
OrgID
Type: System Guid
Unique identifier of Organisation
AccountID
Type: System Guid
Unique identifier of account to retrieve
Return Value
Type: GlobalAccountDetails
GlobalAccountDetails object for requested account
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership.GetAccountPermission Method

IGlobalMembership GetAccountPermission Method GBG Web Service Developers Guide
Gets the Permission the account has on a resource

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalPermission GetAccountPermission(
    Guid OrgID,
    Guid ResourceID
)
GlobalPermission GetAccountPermission(
    Guid OrgID,
    Guid ResourceID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetAccountPermission(OrgID, ResourceID);
function GetAccountPermission(OrgID, ResourceID);
Parameters
OrgID
Type: System Guid
Unique identifier of Organisation
ResourceID
Type: System Guid
Unique identifier of Resource
Return Value
Type: GlobalPermission
GlobalPermission object
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership.GetAccountRoles Method

IGlobalMembership GetAccountRoles Method GBG Web Service Developers Guide
Gets the Roles an account is a member of

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalRoles GetAccountRoles(
    Guid OrgID,
    Guid AccountID,
    uint Page,
    uint PageSize,
    string Search,
    uint Filter
)
GlobalRoles GetAccountRoles(
    Guid OrgID,
    Guid AccountID,
    uint Page,
    uint PageSize,
    string Search,
    uint Filter
)
JavaScript
View Colorized Copy to Clipboard Print
function GetAccountRoles(OrgID, AccountID, Page, PageSize, Search, Filter);
function GetAccountRoles(OrgID, AccountID, Page, PageSize, Search, Filter);
Parameters
OrgID
Type: System Guid
Unique identifier of Organisation
AccountID
Type: System Guid
Unique identifier of account
Page
Type: System UInt32
Index of page (first page has index of 1)
PageSize
Type: System UInt32
Number of accounts to return in a page (max 100)
Search
Type: System String
Search filter for accounts - filters on Name, Username, Email
Filter
Type: System UInt32
Filter organisations by type. 0 - no filter, 1 - active users, 2 - expired users
Return Value
Type: GlobalRoles
GlobalRoles object
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership.GetAccounts Method

IGlobalMembership GetAccounts Method GBG Web Service Developers Guide
Get summary details of child Organisations

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalAccounts GetAccounts(
    Guid OrgID,
    uint Page,
    uint PageSize,
    string Search,
    uint Filter
)
GlobalAccounts GetAccounts(
    Guid OrgID,
    uint Page,
    uint PageSize,
    string Search,
    uint Filter
)
JavaScript
View Colorized Copy to Clipboard Print
function GetAccounts(OrgID, Page, PageSize, Search, Filter);
function GetAccounts(OrgID, Page, PageSize, Search, Filter);
Parameters
OrgID
Type: System Guid
Unique identifier of Organisation
Page
Type: System UInt32
Index of page (first page has index of 1)
PageSize
Type: System UInt32
Number of accounts to return in a page (max 100)
Search
Type: System String
Search filter for accounts - filters on Name, Username, Email
Filter
Type: System UInt32
Filter organisations by type. 0 - no filter, 1 - active users, 2 - expired users
Return Value
Type: GlobalAccounts
GlobalAccounts object with response from the request
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership.GetPermissions Method

IGlobalMembership GetPermissions Method GBG Web Service Developers Guide
Gets Role Permissions on specified resource identifier

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalRolePermission> GetPermissions(
    Guid OrgID,
    Guid ResourceID
)
List<GlobalRolePermission> GetPermissions(
    Guid OrgID,
    Guid ResourceID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetPermissions(OrgID, ResourceID);
function GetPermissions(OrgID, ResourceID);
Parameters
OrgID
Type: System Guid
Unique identifier of Organisation
ResourceID
Type: System Guid
Unique identifier of Resource
Return Value
Type: List GlobalRolePermission
Role Permissions
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership.GetRoleMembers Method

IGlobalMembership GetRoleMembers Method GBG Web Service Developers Guide
Gets Accounts that are a member of the specified Role

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalRoleMembers GetRoleMembers(
    Guid OrgID,
    Guid RoleID,
    uint Page,
    uint PageSize,
    string Search,
    uint Filter
)
GlobalRoleMembers GetRoleMembers(
    Guid OrgID,
    Guid RoleID,
    uint Page,
    uint PageSize,
    string Search,
    uint Filter
)
JavaScript
View Colorized Copy to Clipboard Print
function GetRoleMembers(OrgID, RoleID, Page, PageSize, Search, Filter);
function GetRoleMembers(OrgID, RoleID, Page, PageSize, Search, Filter);
Parameters
OrgID
Type: System Guid
Unique identifier of Organisation
RoleID
Type: System Guid
Unique identifier of Role
Page
Type: System UInt32
Index of page (first page has index of 1)
PageSize
Type: System UInt32
Number of accounts to return in a page (max 100)
Search
Type: System String
Search filter for accounts - filters on Name, Username, Email
Filter
Type: System UInt32
Filter role members by type. 0 - no filter, 1 - members of role, 2 - not members of role
Return Value
Type: GlobalRoleMembers
GlobalRoleMembers object with response from the request
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership.GetRolePermissions Method

IGlobalMembership GetRolePermissions Method GBG Web Service Developers Guide
Gets the Permissions granted to Resources for specified Role

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalResource> GetRolePermissions(
    Guid OrgID,
    Guid RoleID
)
List<GlobalResource> GetRolePermissions(
    Guid OrgID,
    Guid RoleID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetRolePermissions(OrgID, RoleID);
function GetRolePermissions(OrgID, RoleID);
Parameters
OrgID
Type: System Guid
Unique identifier of Organisation
RoleID
Type: System Guid
Unique identifier of Role
Return Value
Type: List GlobalResource
GlobalPermission object
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership.GetRoles Method

IGlobalMembership GetRoles Method GBG Web Service Developers Guide
Gets all Roles for the specified organisation

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalRoles GetRoles(
    Guid OrgID,
    uint Page,
    uint PageSize,
    string Search,
    uint Filter
)
GlobalRoles GetRoles(
    Guid OrgID,
    uint Page,
    uint PageSize,
    string Search,
    uint Filter
)
JavaScript
View Colorized Copy to Clipboard Print
function GetRoles(OrgID, Page, PageSize, Search, Filter);
function GetRoles(OrgID, Page, PageSize, Search, Filter);
Parameters
OrgID
Type: System Guid
Unique identifier of Organisation
Page
Type: System UInt32
Index of page (first page has index of 1)
PageSize
Type: System UInt32
Number of accounts to return in a page (max 100)
Search
Type: System String
Search filter for accounts - filters on Name, Username, Email
Filter
Type: System UInt32
Filter organisations by type. 0 - no filter, 1 - active users, 2 - expired users
Return Value
Type: GlobalRoles
GlobalRoles object
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership.ResetPassword Method

IGlobalMembership ResetPassword Method GBG Web Service Developers Guide
Reset Password - only applicable if self-care password reset is disabled in licence

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ResetPassword(
    Guid OrgID,
    Guid AccountID,
    string Password
)
void ResetPassword(
    Guid OrgID,
    Guid AccountID,
    string Password
)
JavaScript
View Colorized Copy to Clipboard Print
function ResetPassword(OrgID, AccountID, Password);
function ResetPassword(OrgID, AccountID, Password);
Parameters
OrgID
Type: System Guid
Unique identifier of Organisation
AccountID
Type: System Guid
Unique identifier of account to retrieve
Password
Type: System String
Unique identifier of account to retrieve
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership.UpdateAccountDetails Method

IGlobalMembership UpdateAccountDetails Method GBG Web Service Developers Guide
Update Account

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UpdateAccountDetails(
    GlobalAccountDetails Account
)
void UpdateAccountDetails(
    GlobalAccountDetails Account
)
JavaScript
View Colorized Copy to Clipboard Print
function UpdateAccountDetails(Account);
function UpdateAccountDetails(Account);
Parameters
Account
Type: GlobalCheck.DataLib GlobalAccountDetails
Account to update
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership.UpdatePermissions Method

IGlobalMembership UpdatePermissions Method GBG Web Service Developers Guide
Adds and/or Removes Role Permissions to/from Resource specified by unique identifier

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UpdatePermissions(
    Guid OrgID,
    Guid ResourceID,
    List<GlobalRolePermission> AddRolePermissions,
    List<GlobalRolePermission> RemoveRolePermissions
)
void UpdatePermissions(
    Guid OrgID,
    Guid ResourceID,
    List<GlobalRolePermission> AddRolePermissions,
    List<GlobalRolePermission> RemoveRolePermissions
)
JavaScript
View Colorized Copy to Clipboard Print
function UpdatePermissions(OrgID, ResourceID, AddRolePermissions, RemoveRolePermissions);
function UpdatePermissions(OrgID, ResourceID, AddRolePermissions, RemoveRolePermissions);
Parameters
OrgID
Type: System Guid
Unique identifier of Organisation
ResourceID
Type: System Guid
Unique identifier of Profile or Authentication Record
AddRolePermissions
Type: System.Collections.Generic List GlobalRolePermission
Role Permissions to add
RemoveRolePermissions
Type: System.Collections.Generic List GlobalRolePermission
Role Permissions to remove
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership.UpdateRole Method

IGlobalMembership UpdateRole Method GBG Web Service Developers Guide
Update Role

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UpdateRole(
    Guid OrgID,
    GlobalRole Role
)
void UpdateRole(
    Guid OrgID,
    GlobalRole Role
)
JavaScript
View Colorized Copy to Clipboard Print
function UpdateRole(OrgID, Role);
function UpdateRole(OrgID, Role);
Parameters
OrgID
Type: System Guid
Unique identifier of Organisation in which to create the account
Role
Type: GlobalCheck.DataLib GlobalRole
Role to update
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalMembership.UpdateRoleMembers Method

IGlobalMembership UpdateRoleMembers Method GBG Web Service Developers Guide
Adds and/or removes one or more Accounts to/from the specified Role

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UpdateRoleMembers(
    Guid OrgID,
    Guid RoleID,
    List<Guid> AddAccountIDs,
    List<Guid> RemoveAccountIDs
)
void UpdateRoleMembers(
    Guid OrgID,
    Guid RoleID,
    List<Guid> AddAccountIDs,
    List<Guid> RemoveAccountIDs
)
JavaScript
View Colorized Copy to Clipboard Print
function UpdateRoleMembers(OrgID, RoleID, AddAccountIDs, RemoveAccountIDs);
function UpdateRoleMembers(OrgID, RoleID, AddAccountIDs, RemoveAccountIDs);
Parameters
OrgID
Type: System Guid
Unique identifier of Organisation
RoleID
Type: System Guid
Unique identifier of Role
AddAccountIDs
Type: System.Collections.Generic List Guid
Unique identifier of Accounts to add
RemoveAccountIDs
Type: System.Collections.Generic List Guid
Unique identifier of Accounts to remove
See Also
IGlobalMembership Interface
IGlobalMembership Members
GlobalCheck.ID3gLib Namespace


IGlobalOrganisation Interface

IGlobalOrganisation Interface GBG Web Service Developers Guide
Interface for managing organisations

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGlobalOrganisation
public interface IGlobalOrganisation
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.ID3gLib.IGlobalOrganisation = function();
GlobalCheck.ID3gLib.IGlobalOrganisation.createInterface('GlobalCheck.ID3gLib.IGlobalOrganisation');
GlobalCheck.ID3gLib.IGlobalOrganisation = function();
GlobalCheck.ID3gLib.IGlobalOrganisation.createInterface('GlobalCheck.ID3gLib.IGlobalOrganisation');
See Also
IGlobalOrganisation Members
GlobalCheck.ID3gLib Namespace


IGlobalOrganisation Members

IGlobalOrganisation Members GBG Web Service Developers Guide
The IGlobalOrganisation type exposes the following members.
Methods
 | Name | Description
Public method | CreateOrganisation | Creates an Organisation
Public method | GetHome | Get summary details for home screen
Public method | GetOrganisationDetails | Retrieves details of an organisation
Public method | GetOrganisations | Get summary details of Organisations
Public method | UpdateOrganisationDetails | Update an Organisation
Back to Top
See Also
IGlobalOrganisation Interface
GlobalCheck.ID3gLib Namespace


IGlobalOrganisation Methods

IGlobalOrganisation Methods GBG Web Service Developers Guide
The IGlobalOrganisation type exposes the following members.
Methods
 | Name | Description
Public method | CreateOrganisation | Creates an Organisation
Public method | GetHome | Get summary details for home screen
Public method | GetOrganisationDetails | Retrieves details of an organisation
Public method | GetOrganisations | Get summary details of Organisations
Public method | UpdateOrganisationDetails | Update an Organisation
Back to Top
See Also
IGlobalOrganisation Interface
GlobalCheck.ID3gLib Namespace


IGlobalOrganisation.CreateOrganisation Method

IGlobalOrganisation CreateOrganisation Method GBG Web Service Developers Guide
Creates an Organisation

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalOrganisation CreateOrganisation(
    Guid ParentOrgID,
    GlobalOrganisationDetails OrganisationDetails,
    string AdminName,
    string AdminUsername,
    string AdminEmail,
    string AdminPassword,
    string AdminPIN
)
GlobalOrganisation CreateOrganisation(
    Guid ParentOrgID,
    GlobalOrganisationDetails OrganisationDetails,
    string AdminName,
    string AdminUsername,
    string AdminEmail,
    string AdminPassword,
    string AdminPIN
)
JavaScript
View Colorized Copy to Clipboard Print
function CreateOrganisation(ParentOrgID, OrganisationDetails, AdminName, AdminUsername, AdminEmail, AdminPassword, AdminPIN);
function CreateOrganisation(ParentOrgID, OrganisationDetails, AdminName, AdminUsername, AdminEmail, AdminPassword, AdminPIN);
Parameters
ParentOrgID
Type: System Guid
Unique identifier of Parent Organisation
OrganisationDetails
Type: GlobalCheck.DataLib GlobalOrganisationDetails
Organisation to create
AdminName
Type: System String
Name of administrator account for child organisation
AdminUsername
Type: System String
Username of administrator account for child organisation
AdminEmail
Type: System String
Email of administrator account for child organisation
AdminPassword
Type: System String
Password of administrator account for child organisation - this parameter is ignored when Self-care Password Resets are enabled
AdminPIN
Type: System String
PIN for password resets and 2nd level sign in
Return Value
Type: GlobalOrganisation
Newly created Organisation
See Also
IGlobalOrganisation Interface
IGlobalOrganisation Members
GlobalCheck.ID3gLib Namespace


IGlobalOrganisation.GetHome Method

IGlobalOrganisation GetHome Method GBG Web Service Developers Guide
Get summary details for home screen

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalHome GetHome(
    Guid OrgID
)
GlobalHome GetHome(
    Guid OrgID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetHome(OrgID);
function GetHome(OrgID);
Parameters
OrgID
Type: System Guid
organisation UID
Return Value
Type: GlobalHome
GlobalHome object with response from the request
See Also
IGlobalOrganisation Interface
IGlobalOrganisation Members
GlobalCheck.ID3gLib Namespace


IGlobalOrganisation.GetOrganisationDetails Method

IGlobalOrganisation GetOrganisationDetails Method GBG Web Service Developers Guide
Retrieves details of an organisation

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalOrganisationDetails GetOrganisationDetails(
    Guid OrgID
)
GlobalOrganisationDetails GetOrganisationDetails(
    Guid OrgID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetOrganisationDetails(OrgID);
function GetOrganisationDetails(OrgID);
Parameters
OrgID
Type: System Guid
Unique identifier for organisation to retrieve details from
Return Value
Type: GlobalOrganisationDetails
Details of organisation
See Also
IGlobalOrganisation Interface
IGlobalOrganisation Members
GlobalCheck.ID3gLib Namespace


IGlobalOrganisation.GetOrganisations Method

IGlobalOrganisation GetOrganisations Method GBG Web Service Developers Guide
Get summary details of Organisations

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalOrganisations GetOrganisations(
    Guid ParentOrgID,
    uint Page,
    uint PageSize,
    string Search,
    uint Filter
)
GlobalOrganisations GetOrganisations(
    Guid ParentOrgID,
    uint Page,
    uint PageSize,
    string Search,
    uint Filter
)
JavaScript
View Colorized Copy to Clipboard Print
function GetOrganisations(ParentOrgID, Page, PageSize, Search, Filter);
function GetOrganisations(ParentOrgID, Page, PageSize, Search, Filter);
Parameters
ParentOrgID
Type: System Guid
Parent organisation
Page
Type: System UInt32
Index of page (first page has index of 1)
PageSize
Type: System UInt32
Number of organisation to return in a page (max 100)
Search
Type: System String
Search filter for organisations - filters on Name, DomainName, Legal Name and Alias
Filter
Type: System UInt32
Filter organisations by type. 0 - no filter, 1 - active organisations, 2 - expired organisations
Return Value
Type: GlobalOrganisations
GlobalOrganisations object with response from the request
See Also
IGlobalOrganisation Interface
IGlobalOrganisation Members
GlobalCheck.ID3gLib Namespace


IGlobalOrganisation.UpdateOrganisationDetails Method

IGlobalOrganisation UpdateOrganisationDetails Method GBG Web Service Developers Guide
Update an Organisation

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UpdateOrganisationDetails(
    GlobalOrganisationDetails OrganisationDetails
)
void UpdateOrganisationDetails(
    GlobalOrganisationDetails OrganisationDetails
)
JavaScript
View Colorized Copy to Clipboard Print
function UpdateOrganisationDetails(OrganisationDetails);
function UpdateOrganisationDetails(OrganisationDetails);
Parameters
OrganisationDetails
Type: GlobalCheck.DataLib GlobalOrganisationDetails
Updated details
See Also
IGlobalOrganisation Interface
IGlobalOrganisation Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile Interface

IGlobalProfile Interface GBG Web Service Developers Guide
Interface for managing Profiles and Licence

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGlobalProfile
public interface IGlobalProfile
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.ID3gLib.IGlobalProfile = function();
GlobalCheck.ID3gLib.IGlobalProfile.createInterface('GlobalCheck.ID3gLib.IGlobalProfile');
GlobalCheck.ID3gLib.IGlobalProfile = function();
GlobalCheck.ID3gLib.IGlobalProfile.createInterface('GlobalCheck.ID3gLib.IGlobalProfile');
See Also
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile Members

IGlobalProfile Members GBG Web Service Developers Guide
The IGlobalProfile type exposes the following members.
Methods
 | Name | Description
Public method | CopyProfile | Copies an existing Profile
Public method | CreateProfile | Create a new Profile
Public method | GetCardTypes | Gets the list of Credit/Debit Card Type supported by Credit/Debit Card Item Checks within the specified Profile
Public method | GetCardTypesMP | Gets the list of Credit/Debit Card Type supported by Credit/Debit Card Item Checks within the specified Profile
Public method | GetItemCheckProperties | Returns valid set of property names and values (if restricted) for specified Item Check
Public method | GetLicence | Get Licence for an Organisation
Public method | GetProfileChain | Gets list of Profile Versions within a Profile chain, specified by ProfileID and filtered by Profile State
Public method | GetProfileDetails | Get full Profile details
Public method | GetProfiles | Gets list of Profiles for specified organisation, filtered by specified states
Public method | GetProfileVersionItemIDs | Gets the list of Item IDs for the specified Organisation and Profile
Public method | GetProfileVersions | Gets Profile Versions for specified organisation
Public method | UpdateLicence | Updates Items within a Licence
Public method | UpdateProfile | Update a Profile
Public method | UpdateProfileDetails | Update a Profile
Public method | UpdateProfileState | Update a Profile State
Back to Top
See Also
IGlobalProfile Interface
GlobalCheck.ID3gLib Namespace


IGlobalProfile Methods

IGlobalProfile Methods GBG Web Service Developers Guide
The IGlobalProfile type exposes the following members.
Methods
 | Name | Description
Public method | CopyProfile | Copies an existing Profile
Public method | CreateProfile | Create a new Profile
Public method | GetCardTypes | Gets the list of Credit/Debit Card Type supported by Credit/Debit Card Item Checks within the specified Profile
Public method | GetCardTypesMP | Gets the list of Credit/Debit Card Type supported by Credit/Debit Card Item Checks within the specified Profile
Public method | GetItemCheckProperties | Returns valid set of property names and values (if restricted) for specified Item Check
Public method | GetLicence | Get Licence for an Organisation
Public method | GetProfileChain | Gets list of Profile Versions within a Profile chain, specified by ProfileID and filtered by Profile State
Public method | GetProfileDetails | Get full Profile details
Public method | GetProfiles | Gets list of Profiles for specified organisation, filtered by specified states
Public method | GetProfileVersionItemIDs | Gets the list of Item IDs for the specified Organisation and Profile
Public method | GetProfileVersions | Gets Profile Versions for specified organisation
Public method | UpdateLicence | Updates Items within a Licence
Public method | UpdateProfile | Update a Profile
Public method | UpdateProfileDetails | Update a Profile
Public method | UpdateProfileState | Update a Profile State
Back to Top
See Also
IGlobalProfile Interface
GlobalCheck.ID3gLib Namespace


IGlobalProfile.CopyProfile Method

IGlobalProfile CopyProfile Method GBG Web Service Developers Guide
Copies an existing Profile

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalProfileDetails CopyProfile(
    Guid OrgID,
    GlobalProfileIDVersion ProfileIDVersion,
    string Name,
    string Description
)
GlobalProfileDetails CopyProfile(
    Guid OrgID,
    GlobalProfileIDVersion ProfileIDVersion,
    string Name,
    string Description
)
JavaScript
View Colorized Copy to Clipboard Print
function CopyProfile(OrgID, ProfileIDVersion, Name, Description);
function CopyProfile(OrgID, ProfileIDVersion, Name, Description);
Parameters
OrgID
Type: System Guid
Unique identifier of organisation
ProfileIDVersion
Type: GlobalCheck.DataLib GlobalProfileIDVersion
Profile to copy
Name
Type: System String
New for the new Profile
Description
Type: System String
Description for the new Profile
Return Value
Type: GlobalProfileDetails
The newly created Profile
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile.CreateProfile Method

IGlobalProfile CreateProfile Method GBG Web Service Developers Guide
Create a new Profile

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalProfileDetails CreateProfile(
    Guid OrgID,
    string Name,
    string Description,
    List<uint> ItemIDs
)
GlobalProfileDetails CreateProfile(
    Guid OrgID,
    string Name,
    string Description,
    List<uint> ItemIDs
)
JavaScript
View Colorized Copy to Clipboard Print
function CreateProfile(OrgID, Name, Description, ItemIDs);
function CreateProfile(OrgID, Name, Description, ItemIDs);
Parameters
OrgID
Type: System Guid
Unique identifier of organisation
Name
Type: System String
Profile name
Description
Type: System String
Profile description
ItemIDs
Type: System.Collections.Generic List UInt32
Items to populate Profile with
Return Value
Type: GlobalProfileDetails
The newly created Profile
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile.GetCardTypes Method

IGlobalProfile GetCardTypes Method GBG Web Service Developers Guide
Gets the list of Credit/Debit Card Type supported by Credit/Debit Card Item Checks within the specified Profile

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalCardType> GetCardTypes(
    Guid OrgID,
    GlobalProfileIDVersion ProfileIDVersion
)
List<GlobalCardType> GetCardTypes(
    Guid OrgID,
    GlobalProfileIDVersion ProfileIDVersion
)
JavaScript
View Colorized Copy to Clipboard Print
function GetCardTypes(OrgID, ProfileIDVersion);
function GetCardTypes(OrgID, ProfileIDVersion);
Parameters
OrgID
Type: System Guid
Unique identifier of organisation
ProfileIDVersion
Type: GlobalCheck.DataLib GlobalProfileIDVersion
The ID and Version of the profile
Return Value
Type: List GlobalCardType
List of GlobalCardType object
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile.GetCardTypesMP Method

IGlobalProfile GetCardTypesMP Method GBG Web Service Developers Guide
Gets the list of Credit/Debit Card Type supported by Credit/Debit Card Item Checks within the specified Profile

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalCardType> GetCardTypesMP(
    Guid OrgID,
    List<GlobalProfileIDVersion> ProfileIDVersions
)
List<GlobalCardType> GetCardTypesMP(
    Guid OrgID,
    List<GlobalProfileIDVersion> ProfileIDVersions
)
JavaScript
View Colorized Copy to Clipboard Print
function GetCardTypesMP(OrgID, ProfileIDVersions);
function GetCardTypesMP(OrgID, ProfileIDVersions);
Parameters
OrgID
Type: System Guid
Unique identifier of organisation
ProfileIDVersions
Type: System.Collections.Generic List GlobalProfileIDVersion
List of ProfileIDVersions objects
Return Value
Type: List GlobalCardType
List of GlobalCardType object
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile.GetItemCheckProperties Method

IGlobalProfile GetItemCheckProperties Method GBG Web Service Developers Guide
Returns valid set of property names and values (if restricted) for specified Item Check

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalProperty> GetItemCheckProperties(
    Guid OrgID,
    uint ItemCheckID
)
List<GlobalProperty> GetItemCheckProperties(
    Guid OrgID,
    uint ItemCheckID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetItemCheckProperties(OrgID, ItemCheckID);
function GetItemCheckProperties(OrgID, ItemCheckID);
Parameters
OrgID
Type: System Guid
Unique identifier of organisation to retrieve Profiles from
ItemCheckID
Type: System UInt32
Item check identifier
Return Value
Type: List GlobalProperty
List of GlobalProperty objects
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile.GetLicence Method

IGlobalProfile GetLicence Method GBG Web Service Developers Guide
Get Licence for an Organisation

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalLicence GetLicence(
    Guid OrgID
)
GlobalLicence GetLicence(
    Guid OrgID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetLicence(OrgID);
function GetLicence(OrgID);
Parameters
OrgID
Type: System Guid
Unique identifier of organisation
Return Value
Type: GlobalLicence
GlobalLicence object
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile.GetProfileChain Method

IGlobalProfile GetProfileChain Method GBG Web Service Developers Guide
Gets list of Profile Versions within a Profile chain, specified by ProfileID and filtered by Profile State

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalProfileVersion> GetProfileChain(
    Guid OrgID,
    Guid ProfileID,
    bool IncludeTest,
    bool IncludePreEffective,
    bool IncludeEffective,
    bool IncludeRetired
)
List<GlobalProfileVersion> GetProfileChain(
    Guid OrgID,
    Guid ProfileID,
    bool IncludeTest,
    bool IncludePreEffective,
    bool IncludeEffective,
    bool IncludeRetired
)
JavaScript
View Colorized Copy to Clipboard Print
function GetProfileChain(OrgID, ProfileID, IncludeTest, IncludePreEffective, IncludeEffective, IncludeRetired);
function GetProfileChain(OrgID, ProfileID, IncludeTest, IncludePreEffective, IncludeEffective, IncludeRetired);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
ProfileID
Type: System Guid
Unique identifier of the Profile chain to return
IncludeTest
Type: System Boolean
If True then Profiles with at least one version in Test state are returned
IncludePreEffective
Type: System Boolean
If True then Profiles with at least one version in Pre-effective state are returned
IncludeEffective
Type: System Boolean
If True then Profiles with at least one version in Effective state are returned
IncludeRetired
Type: System Boolean
If True then Profiles with at least one version in Retired state are returned
Return Value
Type: List GlobalProfileVersion
List of GlobalProfileVersion objects
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile.GetProfileDetails Method

IGlobalProfile GetProfileDetails Method GBG Web Service Developers Guide
Get full Profile details

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalProfileDetails GetProfileDetails(
    Guid OrgID,
    Guid ProfileID,
    uint Version,
    uint Revision
)
GlobalProfileDetails GetProfileDetails(
    Guid OrgID,
    Guid ProfileID,
    uint Version,
    uint Revision
)
JavaScript
View Colorized Copy to Clipboard Print
function GetProfileDetails(OrgID, ProfileID, Version, Revision);
function GetProfileDetails(OrgID, ProfileID, Version, Revision);
Parameters
OrgID
Type: System Guid
Unique identifier of organisation
ProfileID
Type: System Guid
Unique identifier of Profile
Version
Type: System UInt32
Profile Version
Revision
Type: System UInt32
Profile Revision
Return Value
Type: GlobalProfileDetails
ID3gProfileDetails object
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile.GetProfiles Method

IGlobalProfile GetProfiles Method GBG Web Service Developers Guide
Gets list of Profiles for specified organisation, filtered by specified states

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalProfile> GetProfiles(
    Guid OrgID,
    bool IncludeTest,
    bool IncludePreEffective,
    bool IncludeEffective,
    bool IncludeRetired
)
List<GlobalProfile> GetProfiles(
    Guid OrgID,
    bool IncludeTest,
    bool IncludePreEffective,
    bool IncludeEffective,
    bool IncludeRetired
)
JavaScript
View Colorized Copy to Clipboard Print
function GetProfiles(OrgID, IncludeTest, IncludePreEffective, IncludeEffective, IncludeRetired);
function GetProfiles(OrgID, IncludeTest, IncludePreEffective, IncludeEffective, IncludeRetired);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
IncludeTest
Type: System Boolean
If True then Profiles with at least one version in Test state are returned
IncludePreEffective
Type: System Boolean
If True then Profiles with at least one version in Pre-effective state are returned
IncludeEffective
Type: System Boolean
If True then Profiles with at least one version in Effective state are returned
IncludeRetired
Type: System Boolean
If True then Profiles with at least one version in Retired state are returned
Return Value
Type: List GlobalProfile
List of GlobalProfile objects
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile.GetProfileVersionItemIDs Method

IGlobalProfile GetProfileVersionItemIDs Method GBG Web Service Developers Guide
Gets the list of Item IDs for the specified Organisation and Profile

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<uint> GetProfileVersionItemIDs(
    Guid OrgID,
    GlobalProfileIDVersion ProfileIdVersion
)
List<uint> GetProfileVersionItemIDs(
    Guid OrgID,
    GlobalProfileIDVersion ProfileIdVersion
)
JavaScript
View Colorized Copy to Clipboard Print
function GetProfileVersionItemIDs(OrgID, ProfileIdVersion);
function GetProfileVersionItemIDs(OrgID, ProfileIdVersion);
Parameters
OrgID
Type: System Guid
Unique identifier of organisation
ProfileIdVersion
Type: GlobalCheck.DataLib GlobalProfileIDVersion
[Missing <param name="ProfileIdVersion"/> documentation for "M:GlobalCheck.ID3gLib.IGlobalProfile.GetProfileVersionItemIDs(System.Guid,GlobalCheck.DataLib.GlobalProfileIDVersion)"]
Return Value
Type: List UInt32
List of Item IDs
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile.GetProfileVersions Method

IGlobalProfile GetProfileVersions Method GBG Web Service Developers Guide
Gets Profile Versions for specified organisation

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalProfileVersion> GetProfileVersions(
    Guid OrgID
)
List<GlobalProfileVersion> GetProfileVersions(
    Guid OrgID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetProfileVersions(OrgID);
function GetProfileVersions(OrgID);
Parameters
OrgID
Type: System Guid
Unique identifier of organisation
Return Value
Type: List GlobalProfileVersion
List of GlobalProfileVersion objects
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile.UpdateLicence Method

IGlobalProfile UpdateLicence Method GBG Web Service Developers Guide
Updates Items within a Licence

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UpdateLicence(
    Guid OrgID,
    GlobalLicence Licence
)
void UpdateLicence(
    Guid OrgID,
    GlobalLicence Licence
)
JavaScript
View Colorized Copy to Clipboard Print
function UpdateLicence(OrgID, Licence);
function UpdateLicence(OrgID, Licence);
Parameters
OrgID
Type: System Guid
Unique identifier of organisation
Licence
Type: GlobalCheck.DataLib GlobalLicence
Updated Licence
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile.UpdateProfile Method

IGlobalProfile UpdateProfile Method GBG Web Service Developers Guide
Update a Profile

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UpdateProfile(
    Guid OrgID,
    GlobalProfile Profile
)
void UpdateProfile(
    Guid OrgID,
    GlobalProfile Profile
)
JavaScript
View Colorized Copy to Clipboard Print
function UpdateProfile(OrgID, Profile);
function UpdateProfile(OrgID, Profile);
Parameters
OrgID
Type: System Guid
Unique identifier of organisation
Profile
Type: GlobalCheck.DataLib GlobalProfile
Updated Profile
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile.UpdateProfileDetails Method

IGlobalProfile UpdateProfileDetails Method GBG Web Service Developers Guide
Update a Profile

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UpdateProfileDetails(
    Guid OrgID,
    GlobalProfileDetails ProfileFull,
    bool NewVersion
)
void UpdateProfileDetails(
    Guid OrgID,
    GlobalProfileDetails ProfileFull,
    bool NewVersion
)
JavaScript
View Colorized Copy to Clipboard Print
function UpdateProfileDetails(OrgID, ProfileFull, NewVersion);
function UpdateProfileDetails(OrgID, ProfileFull, NewVersion);
Parameters
OrgID
Type: System Guid
Unique identifier of organisation
ProfileFull
Type: GlobalCheck.DataLib GlobalProfileDetails
Profile to update
NewVersion
Type: System Boolean
True if a new Profile Version should be created, false if a new Revision should be created
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalProfile.UpdateProfileState Method

IGlobalProfile UpdateProfileState Method GBG Web Service Developers Guide
Update a Profile State

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UpdateProfileState(
    Guid OrgID,
    GlobalProfileIDVersion ProfileIDVersion,
    Nullable<DateTime> StartDate,
    Nullable<DateTime> EndDate
)
void UpdateProfileState(
    Guid OrgID,
    GlobalProfileIDVersion ProfileIDVersion,
    Nullable<DateTime> StartDate,
    Nullable<DateTime> EndDate
)
JavaScript
View Colorized Copy to Clipboard Print
function UpdateProfileState(OrgID, ProfileIDVersion, StartDate, EndDate);
function UpdateProfileState(OrgID, ProfileIDVersion, StartDate, EndDate);
Parameters
OrgID
Type: System Guid
Unique identifier of organisation
ProfileIDVersion
Type: GlobalCheck.DataLib GlobalProfileIDVersion
Unique identifier and Version of Profile to update
StartDate
Type: System Nullable DateTime
Start Date for a Profile, or null if Profile should remain in Test State
EndDate
Type: System Nullable DateTime
End Date (or Retirement Date) for a Profile, or null if Profile should not be set to retire
See Also
IGlobalProfile Interface
IGlobalProfile Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch Interface

IGlobalSearch Interface GBG Web Service Developers Guide
Interface for processing Authentications and Address Lookups

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGlobalSearch
public interface IGlobalSearch
JavaScript
View Colorized Copy to Clipboard Print
GlobalCheck.ID3gLib.IGlobalSearch = function();
GlobalCheck.ID3gLib.IGlobalSearch.createInterface('GlobalCheck.ID3gLib.IGlobalSearch');
GlobalCheck.ID3gLib.IGlobalSearch = function();
GlobalCheck.ID3gLib.IGlobalSearch.createInterface('GlobalCheck.ID3gLib.IGlobalSearch');
See Also
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch Members

IGlobalSearch Members GBG Web Service Developers Guide
The IGlobalSearch type exposes the following members.
Methods
 | Name | Description
Public method | CancelDataExtract | Cancel Data Extract
Public method | CreateDataExtract | Creates a new Data Extract
Public method | DownloadDataExtract | Download Data Extract
Public method | GetAuthenticationDetails | This method returns full authentication details including input data and result codes.
Public method | GetAuthentications | This method returns a log of all authentications between a date range.
Public method | GetDataExtract | This method returns the data extract as a byte[]
Public method | GetDataExtractHistory | Get the Data Extract download history
Public method | GetDataExtracts | Get Data Extracts for a given organisation
Public method | GetLatestAuthenticationDetails | This method returns full authentication details including input data and result codes for the latest Authentication in a chain.
Public method | GetPEPIntelligenceData | This method returns PEP Intelligence data for the specified Sanction ID
Public method | GetReport | Renders a report for the given Path and in the given format
Public method | GetReportImage | Renders a stream associated with a given imageID
Public method | GetReportParameters | Gets the parameters for specified Report
Public method | GetReports | Get Reports
Public method | GetSanctionsEnforcementsData | This method returns Sanctions & Enforcements data for the specified Sanction ID
Public method | UpdateAuthenticationHelpdeskAccess | This method returns enables or disables Helpdesk access to an authentication record. Helpdesk access is automatically revoked after 7 days.
Back to Top
See Also
IGlobalSearch Interface
GlobalCheck.ID3gLib Namespace


IGlobalSearch Methods

IGlobalSearch Methods GBG Web Service Developers Guide
The IGlobalSearch type exposes the following members.
Methods
 | Name | Description
Public method | CancelDataExtract | Cancel Data Extract
Public method | CreateDataExtract | Creates a new Data Extract
Public method | DownloadDataExtract | Download Data Extract
Public method | GetAuthenticationDetails | This method returns full authentication details including input data and result codes.
Public method | GetAuthentications | This method returns a log of all authentications between a date range.
Public method | GetDataExtract | This method returns the data extract as a byte[]
Public method | GetDataExtractHistory | Get the Data Extract download history
Public method | GetDataExtracts | Get Data Extracts for a given organisation
Public method | GetLatestAuthenticationDetails | This method returns full authentication details including input data and result codes for the latest Authentication in a chain.
Public method | GetPEPIntelligenceData | This method returns PEP Intelligence data for the specified Sanction ID
Public method | GetReport | Renders a report for the given Path and in the given format
Public method | GetReportImage | Renders a stream associated with a given imageID
Public method | GetReportParameters | Gets the parameters for specified Report
Public method | GetReports | Get Reports
Public method | GetSanctionsEnforcementsData | This method returns Sanctions & Enforcements data for the specified Sanction ID
Public method | UpdateAuthenticationHelpdeskAccess | This method returns enables or disables Helpdesk access to an authentication record. Helpdesk access is automatically revoked after 7 days.
Back to Top
See Also
IGlobalSearch Interface
GlobalCheck.ID3gLib Namespace


IGlobalSearch.CancelDataExtract Method

IGlobalSearch CancelDataExtract Method GBG Web Service Developers Guide
Cancel Data Extract

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void CancelDataExtract(
    Guid OrgID,
    Guid DataExtractID
)
void CancelDataExtract(
    Guid OrgID,
    Guid DataExtractID
)
JavaScript
View Colorized Copy to Clipboard Print
function CancelDataExtract(OrgID, DataExtractID);
function CancelDataExtract(OrgID, DataExtractID);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
DataExtractID
Type: System Guid
Unique identifier of DataExtract
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.CreateDataExtract Method

IGlobalSearch CreateDataExtract Method GBG Web Service Developers Guide
Creates a new Data Extract

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void CreateDataExtract(
    Guid OrgID,
    string Name,
    GlobalDataExtractType Type,
    DateTime Start,
    Nullable<DateTime> End,
    GlobalDataExtractFormat Format,
    string Version,
    bool Repeat
)
void CreateDataExtract(
    Guid OrgID,
    string Name,
    GlobalDataExtractType Type,
    DateTime Start,
    Nullable<DateTime> End,
    GlobalDataExtractFormat Format,
    string Version,
    bool Repeat
)
JavaScript
View Colorized Copy to Clipboard Print
function CreateDataExtract(OrgID, Name, Type, Start, End, Format, Version, Repeat);
function CreateDataExtract(OrgID, Name, Type, Start, End, Format, Version, Repeat);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
Name
Type: System String
Name of the data extract
Type
Type: GlobalCheck.DataLib GlobalDataExtractType
The type of extract
Start
Type: System DateTime
Start date of the extract
End
Type: System Nullable DateTime
Optional end date
Format
Type: GlobalCheck.DataLib GlobalDataExtractFormat
Format of the extract
Version
Type: System String
Web service version to return data in.
Repeat
Type: System Boolean
True if to repeat the extract
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.DownloadDataExtract Method

IGlobalSearch DownloadDataExtract Method GBG Web Service Developers Guide
Download Data Extract

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Stream DownloadDataExtract(
    Guid OrgID,
    Guid DataExtractID
)
Stream DownloadDataExtract(
    Guid OrgID,
    Guid DataExtractID
)
JavaScript
View Colorized Copy to Clipboard Print
function DownloadDataExtract(OrgID, DataExtractID);
function DownloadDataExtract(OrgID, DataExtractID);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
DataExtractID
Type: System Guid
Unique identifier of DataExtract
Return Value
Type: Stream
[Missing <returns> documentation for "M:GlobalCheck.ID3gLib.IGlobalSearch.DownloadDataExtract(System.Guid,System.Guid)"]
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.GetAuthenticationDetails Method

IGlobalSearch GetAuthenticationDetails Method GBG Web Service Developers Guide
This method returns full authentication details including input data and result codes.

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalAuthenticationDetails GetAuthenticationDetails(
    Guid OrgID,
    Guid AuthenticationID
)
GlobalAuthenticationDetails GetAuthenticationDetails(
    Guid OrgID,
    Guid AuthenticationID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetAuthenticationDetails(OrgID, AuthenticationID);
function GetAuthenticationDetails(OrgID, AuthenticationID);
Parameters
OrgID
Type: System Guid
Unique identifier of the organisation
AuthenticationID
Type: System Guid
Unique identifier of the authentication
Return Value
Type: GlobalAuthenticationDetails
GlobalAuthenticationFull object
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.GetAuthentications Method

IGlobalSearch GetAuthentications Method GBG Web Service Developers Guide
This method returns a log of all authentications between a date range.

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalAuthentications GetAuthentications(
    Guid OrgID,
    DateTime StartDate,
    DateTime EndDate,
    uint SearchType,
    string SearchValue,
    uint Page,
    uint PageSize,
    uint SortType,
    bool DescendingOrder
)
GlobalAuthentications GetAuthentications(
    Guid OrgID,
    DateTime StartDate,
    DateTime EndDate,
    uint SearchType,
    string SearchValue,
    uint Page,
    uint PageSize,
    uint SortType,
    bool DescendingOrder
)
JavaScript
View Colorized Copy to Clipboard Print
function GetAuthentications(OrgID, StartDate, EndDate, SearchType, SearchValue, Page, PageSize, SortType, DescendingOrder);
function GetAuthentications(OrgID, StartDate, EndDate, SearchType, SearchValue, Page, PageSize, SortType, DescendingOrder);
Parameters
OrgID
Type: System Guid
Unique identifier of the organisation
StartDate
Type: System DateTime
start date of the search
EndDate
Type: System DateTime
end date of the search
SearchType
Type: System UInt32

            1 = Authentication ID

            2 = Customer Reference

            3 = (first 40 characters of) Decision Band

            4 = Profile ID

            5 = Profile Name

            6 = Profile State

            7 = Chain ID

            8 = Username

            9 = Account ID

            10 = Helpdesk Access

            11 = Device ID

            12 = First Initial Forename + Surname + Postcode (delimited with |)

            13 = Forename + Surname + Postcode (delimited with |)

            14 = Credit/Debit Card (matches first 6 and last 4 digits only)

            15 = Telephone Number

            16 = Driving Licence Number

            17 = UK Passport Number

            18 = International Passport Number

            19 = Date of Birth (DDMMYYYY) + Postcode

            20 = Surname

            21 = Forename + Surname (delimited with |)

            22 = First Initial of Forename + Surname (delimited with |)

            23 = Forename + First Initial of Surname (delimited with |)

            24 = Identity Card Number
SearchValue
Type: System String
search value (exact match, case insensitive)
Page
Type: System UInt32
the page number requested
PageSize
Type: System UInt32
the number of records to return per page
SortType
Type: System UInt32
1 = Customer Reference, 2 = Timestamp, 3 = Profile Name, 4 = Decision Band, 5 = Score
DescendingOrder
Type: System Boolean
True if results should be returned in descending search order
Return Value
Type: GlobalAuthentications
GlobalAuthentications object
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.GetDataExtract Method

IGlobalSearch GetDataExtract Method GBG Web Service Developers Guide
This method returns the data extract as a byte[]

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Stream GetDataExtract(
    Guid OrgID,
    DateTime StartDate,
    DateTime EndDate,
    uint SearchType,
    string SearchValue,
    uint Format,
    string Version
)
Stream GetDataExtract(
    Guid OrgID,
    DateTime StartDate,
    DateTime EndDate,
    uint SearchType,
    string SearchValue,
    uint Format,
    string Version
)
JavaScript
View Colorized Copy to Clipboard Print
function GetDataExtract(OrgID, StartDate, EndDate, SearchType, SearchValue, Format, Version);
function GetDataExtract(OrgID, StartDate, EndDate, SearchType, SearchValue, Format, Version);
Parameters
OrgID
Type: System Guid
Unique identifier of the organisation to perform extract on
StartDate
Type: System DateTime
start date of the search
EndDate
Type: System DateTime
end date of the search
SearchType
Type: System UInt32

            1 = Authentication ID

            2 = Customer Reference

            3 = (first 40 characters of) Decision Band

            4 = Profile ID

            5 = Profile Name

            6 = Profile State

            7 = Chain ID

            8 = Username

            9 = Account ID

            10 = Helpdesk Access

            11 = Device ID

            12 = First Initial Forename + Surname + Postcode (delimited with |)

            13 = Forename + Surname + Postcode (delimited with |)

            14 = Credit/Debit Card (matches first 6 and last 4 digits only)

            15 = Telephone Number

            16 = Driving Licence Number

            17 = UK Passport Number

            18 = International Passport Number

            19 = Date of Birth (DDMMYYYY) + Postcode

            20 = Surname

            21 = Forename + Surname (delimited with |)

            22 = First Initial of Forename + Surname (delimited with |)

            23 = Forename + First Initial of Surname (delimited with |)

            24 = Identity Card Number
SearchValue
Type: System String
search value (exact match, case insensitive)
Format
Type: System UInt32
Format of data extract - supported values: 0 = Zipped TSV
Version
Type: System String
Data Extract version - supported values: ID3g201304, will default to ID3g201304 if no value is supplied
Return Value
Type: Stream
Zipped TSV file containing data extract
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.GetDataExtractHistory Method

IGlobalSearch GetDataExtractHistory Method GBG Web Service Developers Guide
Get the Data Extract download history

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalDataExtractDownloadHistory> GetDataExtractHistory(
    Guid OrgID,
    Guid DataExtractID
)
List<GlobalDataExtractDownloadHistory> GetDataExtractHistory(
    Guid OrgID,
    Guid DataExtractID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetDataExtractHistory(OrgID, DataExtractID);
function GetDataExtractHistory(OrgID, DataExtractID);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
DataExtractID
Type: System Guid
Unique identifier of DataExtract
Return Value
Type: List GlobalDataExtractDownloadHistory
List of GlobalDataExtractDownloadHistory objects
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.GetDataExtracts Method

IGlobalSearch GetDataExtracts Method GBG Web Service Developers Guide
Get Data Extracts for a given organisation

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalDataExtracts GetDataExtracts(
    Guid OrgID,
    uint Page,
    uint PageSize,
    string Search,
    uint Filter
)
GlobalDataExtracts GetDataExtracts(
    Guid OrgID,
    uint Page,
    uint PageSize,
    string Search,
    uint Filter
)
JavaScript
View Colorized Copy to Clipboard Print
function GetDataExtracts(OrgID, Page, PageSize, Search, Filter);
function GetDataExtracts(OrgID, Page, PageSize, Search, Filter);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
Page
Type: System UInt32
Index of page (first page has index of 1)
PageSize
Type: System UInt32
Number of Data Extract to return in a page (max 100)
Search
Type: System String
Search filter for Data Extract - filters on Name, DomainName, Legal Name and Alias
Filter
Type: System UInt32
Filter organisations by type. 0 - no filter, 1 - ready Data Extract, 2 - pending Data Extract
Return Value
Type: GlobalDataExtracts
List of GlobalDataExtract objects
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.GetLatestAuthenticationDetails Method

IGlobalSearch GetLatestAuthenticationDetails Method GBG Web Service Developers Guide
This method returns full authentication details including input data and result codes for the latest Authentication in a chain.

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalAuthenticationDetails GetLatestAuthenticationDetails(
    Guid OrgID,
    Guid AuthenticationID
)
GlobalAuthenticationDetails GetLatestAuthenticationDetails(
    Guid OrgID,
    Guid AuthenticationID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetLatestAuthenticationDetails(OrgID, AuthenticationID);
function GetLatestAuthenticationDetails(OrgID, AuthenticationID);
Parameters
OrgID
Type: System Guid
Unique identifier of the organisation
AuthenticationID
Type: System Guid
Unique identifier of the authentication
Return Value
Type: GlobalAuthenticationDetails
GlobalAuthenticationFull object
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.GetPEPIntelligenceData Method

IGlobalSearch GetPEPIntelligenceData Method GBG Web Service Developers Guide
This method returns PEP Intelligence data for the specified Sanction ID

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalPEPIntelligenceData GetPEPIntelligenceData(
    Guid OrgID,
    string SanctionID
)
GlobalPEPIntelligenceData GetPEPIntelligenceData(
    Guid OrgID,
    string SanctionID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetPEPIntelligenceData(OrgID, SanctionID);
function GetPEPIntelligenceData(OrgID, SanctionID);
Parameters
OrgID
Type: System Guid
Unique identifier of the organisation
SanctionID
Type: System String
Identifier of the record to find.
            This identifier is returned with the results of an Authentication in the GlobalSanctionsMatch class when a match is found using the
            PEP Intelligence item check
Return Value
Type: GlobalPEPIntelligenceData
GlobalPEPIntelligenceData
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.GetReport Method

IGlobalSearch GetReport Method GBG Web Service Developers Guide
Renders a report for the given Path and in the given format

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Stream GetReport(
    Guid OrgID,
    string Path,
    string Format,
    string StreamRoot,
    string PageRoot,
    List<GlobalReportParameter> Parameters,
    int PageNumber
)
Stream GetReport(
    Guid OrgID,
    string Path,
    string Format,
    string StreamRoot,
    string PageRoot,
    List<GlobalReportParameter> Parameters,
    int PageNumber
)
JavaScript
View Colorized Copy to Clipboard Print
function GetReport(OrgID, Path, Format, StreamRoot, PageRoot, Parameters, PageNumber);
function GetReport(OrgID, Path, Format, StreamRoot, PageRoot, Parameters, PageNumber);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
Path
Type: System String
Path, including name, of the report to render
Format
Type: System String
Format to render the report: 'HTML4.0', 'PDF' or 'EXCEL'
StreamRoot
Type: System String
Page to pull back the images
PageRoot
Type: System String
Page that is hosting the report and is linked for sub reports
Parameters
Type: System.Collections.Generic List GlobalReportParameter
Report Parameter values
PageNumber
Type: System Int32
The page number of the report to render
Return Value
Type: Stream
Streamed Report
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.GetReportImage Method

IGlobalSearch GetReportImage Method GBG Web Service Developers Guide
Renders a stream associated with a given imageID

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Stream GetReportImage(
    Guid OrgID,
    string RequestID,
    string ImageID
)
Stream GetReportImage(
    Guid OrgID,
    string RequestID,
    string ImageID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetReportImage(OrgID, RequestID, ImageID);
function GetReportImage(OrgID, RequestID, ImageID);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
RequestID
Type: System String
Request ID associated with GetReport
ImageID
Type: System String
Image ID to render
Return Value
Type: Stream
Streamed image
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.GetReportParameters Method

IGlobalSearch GetReportParameters Method GBG Web Service Developers Guide
Gets the parameters for specified Report

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalReportParameter> GetReportParameters(
    Guid OrgID,
    string Path
)
List<GlobalReportParameter> GetReportParameters(
    Guid OrgID,
    string Path
)
JavaScript
View Colorized Copy to Clipboard Print
function GetReportParameters(OrgID, Path);
function GetReportParameters(OrgID, Path);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
Path
Type: System String
Full path to the report
Return Value
Type: List GlobalReportParameter
Report Parameters
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.GetReports Method

IGlobalSearch GetReports Method GBG Web Service Developers Guide
Get Reports

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<GlobalReportDetails> GetReports(
    Guid OrgID,
    string ReportFolder
)
List<GlobalReportDetails> GetReports(
    Guid OrgID,
    string ReportFolder
)
JavaScript
View Colorized Copy to Clipboard Print
function GetReports(OrgID, ReportFolder);
function GetReports(OrgID, ReportFolder);
Parameters
OrgID
Type: System Guid
Unique identifier of the Organisation
ReportFolder
Type: System String
Report Folder
Return Value
Type: List GlobalReportDetails
List of Reports that can be run against the specified organisation
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.GetSanctionsEnforcementsData Method

IGlobalSearch GetSanctionsEnforcementsData Method GBG Web Service Developers Guide
This method returns Sanctions & Enforcements data for the specified Sanction ID

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GlobalSanctionsEnforcementData GetSanctionsEnforcementsData(
    Guid OrgID,
    string SanctionID
)
GlobalSanctionsEnforcementData GetSanctionsEnforcementsData(
    Guid OrgID,
    string SanctionID
)
JavaScript
View Colorized Copy to Clipboard Print
function GetSanctionsEnforcementsData(OrgID, SanctionID);
function GetSanctionsEnforcementsData(OrgID, SanctionID);
Parameters
OrgID
Type: System Guid
Unique identifier of the organisation
SanctionID
Type: System String
Identifier of the record to find.
            This identifier is returned with the results of an Authentication in the GlobalSanctionsMatch class when a match is found using the
            Sanctions & Enforcements item check
Return Value
Type: GlobalSanctionsEnforcementData
GlobalSanctionsEnforcementData
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace


IGlobalSearch.UpdateAuthenticationHelpdeskAccess Method

IGlobalSearch UpdateAuthenticationHelpdeskAccess Method GBG Web Service Developers Guide
This method returns enables or disables Helpdesk access to an authentication record. Helpdesk access is automatically revoked after 7 days.

Namespace: GlobalCheck.ID3gLib
Assembly: GlobalCheck.ID3gLib (in GlobalCheck.ID3gLib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UpdateAuthenticationHelpdeskAccess(
    Guid OrgID,
    Guid AuthenticationID,
    bool Enable
)
void UpdateAuthenticationHelpdeskAccess(
    Guid OrgID,
    Guid AuthenticationID,
    bool Enable
)
JavaScript
View Colorized Copy to Clipboard Print
function UpdateAuthenticationHelpdeskAccess(OrgID, AuthenticationID, Enable);
function UpdateAuthenticationHelpdeskAccess(OrgID, AuthenticationID, Enable);
Parameters
OrgID
Type: System Guid
Unique identifier of the organisation
AuthenticationID
Type: System Guid
Unique identifier of the authentication
Enable
Type: System Boolean
True if Helpdesk access should be enabled, False if it should be disabled
See Also
IGlobalSearch Interface
IGlobalSearch Members
GlobalCheck.ID3gLib Namespace